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READ ME FIRST 

Welcome to Take Control of iWeb: iLife ’08 Edition, version 1.1, 
published in February 2009 by TidBITS Publishing Inc.  

This book puts you in control of creating and publishing professional-
looking Web sites using iWeb, Web design software from Apple Inc. 
This book was written by Steve Sande, edited by Karen Anderson and 
Tonya Engst, and published by TidBITS Publishing Inc. 

Copyright © 2009, Steve Sande. All rights reserved. 

If you have the PDF version of this title, please note that if you want 
to share it with a friend, we ask that you do so as you would a physical 
book: “lend” it for a quick look, but ask your friend to buy a new copy 
to read it more carefully or to keep it for reference. You can click here 
to give your friend a discount coupon. Discounted classroom and Mac 
user group copies are also available. 

Updates 
We may offer free minor updates to this book. To read any available 
new information, click the Check for Updates link on the cover, or 
click here. On the resulting Web page, you can also sign up to be noti-
fied of major updates via email. If you have a version of this book 
where the Check for Updates link doesn’t work, contact us at tc-
comments@tidbits.com to obtain the PDF. 

Basics 
In reading this book, you may get stuck if you don’t know certain 
basic facts about iWeb or if you don’t understand Take Control syntax 
for things like working with menus or finding items in the Finder. 
Please note the following: 

• Path syntax: I occasionally use a path to show the location of a 
file or folder in your file system. Path text is formatted in special 
type. For example, iLife ’08 installs its component applications, 
such as iWeb, in the Applications folder. The path to iWeb is: 
/Applications/iWeb. 

The slash at the start of the path tells you to start from the root 
level of the disk. You will also see paths that begin with ~ (tilde), 
which is a shortcut for any user’s home directory. For example, if 

http://www.takecontrolbooks.com/class-copies.html
http://www.takecontrolbooks.com/class-copies.html
mailto:tc-comments@tidbits.com
mailto:tc-comments@tidbits.com
http://emperor.tidbits.com/webx?checkReferral@@.3c4415d4/!bt=0061
http://emperor.tidbits.com/webx?checkUpdate@@.3c4415d4/!mw=weberle&bt=0061&bv=1.1
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a person with the user name andrea wants to create a new iWeb 
domain file in a folder called Web Sites in her Documents folder, 
she would create the domain file in her ~/Documents/Web Sites 
folder, which is another way of writing /Users/andrea/ 
Documents/Web Sites. 

• Menus: When I describe choosing a command from a menu 
in the menu bar, I use an abbreviated description. For example, 
the abbreviated description for the menu command that saves 
a file from iWeb is “File > Save.” 

• Toolbar: I refer to the iWeb toolbar (shown below this para-
graph), throughout this book. You can find it at the bottom of 
the iWeb window, or—if you prefer to use menus or keyboard 
shortcuts, check out Table 1, next page, which maps the toolbar 
buttons to menu commands and keyboard shortcuts. 

 

What’s New in Version 1.1 
Whether you’re a new reader or have been along for the iWeb ride 
since the first edition of this book, some recent changes to the world 
of Apple and the Internet are discussed in detail in this new version: 

• .Mac becomes MobileMe: As part of the overall effort to 
support wireless synchronization of calendars, contacts, and 
other information, Apple has changed the name and features 
of .Mac. The new online product, designed to be attractive to 
owners of Windows and Linux PCs as well, is called MobileMe. 

Like .Mac, MobileMe is available for $99 per year. The subscrip-
tion now provides 20 GB (twice the previous amount) of combined 
email and file storage and 200 GB of monthly data transfer, 
meaning that it’s now feasible to host podcasts, video, and large 
photo libraries on your iWeb site. 

• Add a Twitter feed to your iWeb site: Twitter is the new 
social networking phenomenon that you use by writing 140-
character (or less) “tweets” about what you’re currently doing. 
In Appendix B: Add a Twitter Feed (p. 134), you can learn how 
to add a Twitter feed to your iWeb site showing your most recent 
tweets.  
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Table 1: Menu and Keyboard Equivalents for the Toolbar 

Toolbar Icon Menu Equivalent Keyboard Equivalent 

 

File > New Site Shift-Command-N 

 

Insert > Text Box None 

 

Insert > Shape > [list of shapes] None 

 

Insert menu None 

 

Arrange > Bring Forward Option-Shift-Command-F 

 

Arrange > Send Backward Option-Shift-Command-B 

 

Format > Unmask Shift-Command-M 

 

Arrange > Rotate Counter 
Clockwise 

Command-R 

 

View > Show / Hide Media 
Browser 

None 

 

View > Show / Hide Adjust 
Image 

None 

 

View > Show / Hide Inspector Option-Command-I 

 

View > Show / Hide Colors Shift-Command-C 

 

Format > Font > Show / Hide 
Fonts 

Command-T 
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INTRODUCTION 

In January 2006, Apple CEO Steve Jobs announced iWeb, a new 
Web site design and publishing tool in iLife ’06. I know all too 
well how difficult it is to make a great-looking Web site and create 
a blog, because I’ve struggled with the complexities of RSS feeds and 
searched to find a way to easily publish photo galleries and podcasts. 
Watching Jobs simply click and drag his way through the creation 
of a professional-looking Web site in a few minutes during a keynote 
address was certainly an eye-opener, so I purchased iLife ’06 and 
began playing with iWeb. The result of my play was the first edition 
of this book. 

Fast-forward to August 2007 and another announcement from Steve 
Jobs—the release of iLife ’08, including a new version of iWeb. What 
impresses me most about iWeb 2 is how Apple’s developers improved 
on the original by adding capabilities that previously required exten-
sive workarounds—see What’s New in iWeb 2 (p. 10) for more details 
on the new features.  

In this book, I take you on a journey of discovery. I briefly explore 
the past so you can see what a powerful tool iWeb is, and then you 
can follow me as I build a Web site step by step. You can visit my 
iWeb site at http://www.tcoiweb.com/, and then read about how 
I used iWeb to create what you’re viewing. 

If you’ve never made a Web site before, you’ll be thrilled with how 
easily you can organize your thoughts and have iWeb turn them into 
a beautiful work of art. Experienced Web designers will be happy with 
how iWeb works with the rest of the iLife suite to create vibrant Web 
sites full of text, sound, video, and photography.  

Let’s get started! 

http://www.tcoiweb.com/
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QUICK START TO MAKING A SITE IN iWEB 

Although you can read this book sequentially, you may wish to use 
this page to set a custom path through the topics that I cover. You 
can click the blue links to jump quickly to a particular section. 

Learn what’s new in iWeb 2: 
• Find out how the changes in iWeb 2 and the capabilities of 

MobileMe combine to help you create Web sites that are more 
compelling and powerful that those you could create in iWeb 1; 
see What’s New in iWeb 2 (p. 10). 

Start your site: 
• For historical context, read A Brief History of Web Sites (p. 11). 

Then, if you haven’t already, Install iWeb (p. 15). 

• Start a new site! Learn how to Create Your First Site (p. 18).  

• Get the scoop on Editing One Site on Two Macs (p. 40). 

• Ready to take your site live? In Publish Your Site (p. 41), you’ll find 
out how to publish to MobileMe and to other servers. Appendix A: 
Web Hosting (p. 130) provides more detail about hosting your site 
on a server that is not MobileMe.  

Add links & media: 
• Learn about making links in Create Web Hyperlinks (p. 57) and 

Create Other Link Types (p. 60).  

• If image-based links are more your fancy, find more info in Create 
Picture Hyperlinks (p. 105) and Make an Image Map (p. 106). 

• Turn your thoughts into bits with Publish a Blog (p. 72). 

• Take your radio or TV show online with Publish a Podcast (p. 78). 

• Add Photos to your site, and learn about Photo pages, My Albums 
pages, and Web galleries (p. 89).  

• Use iWeb to Create an Online Movie Theater (p. 107). 

Go beyond the limits: 
• Learn how to Make Text Sparkle (p. 50) and discover the fabulous 

effects you can create with Shapes, Layers & Masks (p. 63). 
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• Add Special Elements (p. 36) to count visitors and provide 
information. 

• See Enhance Photos (p. 98) to add cool effects—like Instant Alpha 
(p. 101)—to your photos, plus get advice on how to Accelerate 
Picture Downloads (p. 102). 

• Add Google Maps to give your readers directions with the Google 
Map Web Widget (p. 114). 

• Get an example of adding HTML code to your Web page in Add a 
Video from YouTube (p. 109). 

• Get social with your iWeb site. Read Appendix B: Add a Twitter 
Feed (p. 134). 

• Looking for extra income? Add Google AdSense Ads (p. 111), get 
ideas for how to Run an Online Store (p. 115), and Increase Traffic 
to your site (p. 126). 

• Add a Form to your site in order to capture information from 
visitors (p. 121). 

• Manage Multiple iWeb Sites using separate domain files (p. 127). 
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WHAT’S NEW IN iWEB 2 

Let’s start by looking at what’s new or different in iWeb 2: 

• MobileMe improvements: Apple has updated the MobileMe 
service to make it more useful to iWeb users. For instance, you 
can now Publish to a Personal Domain on MobileMe (p. 44).  

Apple has also increased the amount of disk storage and the 
monthly bandwidth allowance, so even large and heavily visited 
Web sites can exist on a MobileMe account. However, the Mobile-
Me terms and conditions still prohibit the use of MobileMe-hosted 
sites for ecommerce. Note that MobileMe was renamed MobileMe 
on July 9, 2008 (it was formerly called .Mac). 

• Web widgets: With a new feature called HTML Snippets, you 
can add things like news headlines, live webcam feeds, YouTube 
videos, and stock tickers to your Web site. For examples, see Add 
a Video from YouTube (p. 109), Add a Form (p. 121), and Appendix 
B: Add a Twitter Feed (p. 134). 

• Google integration: Apple and Google have been getting cozy 
lately, and the integration of Google AdSense and Google Maps 
into iWeb 2 is a perfect example of the level of cooperation 
between the two companies: 

◊ The Google AdSense widget enables you to Add Google AdSense 
Ads to your Web pages (p. 111).  

◊ The Google Maps widget provides a way to Add Google Maps 
to your Web content with one click (p. 114). 

• New templates and theme switching: Apple has created 8 
new themes for iWeb 2, bringing the total to 26. When you Choose 
a Template for your Web site, consider a new iWeb theme to give 
your site a makeover (p. 20).  

• Instant Alpha: A powerful new photo editing tool, Instant Alpha, 
removes background clutter from photos you use in iWeb sites, 
giving the images a more professional appearance (p. 101). 

• Improved integration with iPhoto: Through enhanced Photo 
pages, Web galleries, and My Album pages, iWeb 2 makes it easier 
than ever to Add Photos (p. 89) to a Web site.  
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A BRIEF HISTORY OF WEB SITES 

Like many long-time Mac geeks, I started using the Internet prior 
to the introduction of the World Wide Web (in my case, thanks to 
Adam Engst’s Internet Starter Kit for Macintosh). For the most part, 
early Internet applications provided a text-based way to interact on 
the Internet. Some of the early Internet applications were confusing 
to use (Gopher, for example) and have disappeared, but other tools, 
like clients for FTP (File Transfer Protocol), are still used.  

Beginning in 1991, the Web made the Internet vastly more useful 
and exciting for many people. Anyone with access to a Web server 
could put Web pages on the Internet, and anyone with a Web browser 
could look at them. Unlike earlier Internet applications, the Web 
wasn’t just straight text—Web pages could have colors, pictures, 
and other visual elements.  

The language of the Web is HTML (Hypertext Markup Language). 
Created by Tim Berners-Lee as part of his original specification for 
the World Wide Web, HTML is a set of text instructions designed 
to tell a Web browser, like Safari or Firefox, where to place text, pic-
tures, links, and other features on a Web page. (Find out more about 
Tim Berners-Lee at http://en.wikipedia.org/wiki/Tim_berners-lee.) 

I was so excited by the invention of the World Wide Web and 
HTML, that I almost immediately downloaded the original NCSA 
Mosaic Web browser, visited the few sites that were available, and 
made my own Web site. What tool did I use to set up my original 
site? SimpleText. That’s right—the same tool we still use to read 
those ubiquitous Read Me files that seem to come with every new 
piece of software, although it’s now called TextEdit.  

SimpleText was a good tool for developing Web sites in those days. 
Most sites consisted of a lot of text, hyperlinks to other sites, and had 
only a few graphics since most of us were using slow, dial-up modems 
to access the Internet. We would type the HTML into a text document 
and then view the more graphical result in a Web browser.  

http://en.wikipedia.org/wiki/Tim_berners-lee
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Here’s a simplified example of the HTML behind a basic Web page: 

<html> 
<title>This is an example Web page</title> 
<p><b>Welcome to my example Web page.</b><br> 
Pretty boring, huh? This is what the World Wide Web was like for 
quite a few years. Lots of text, a few tiny graphics, and links to other 
lame Web sites.</p> 
<p><a href="http://www.tcoiweb.com/">A link to the example 
Web site for this book</a><hr> 
<img src="http://www.gizmoranch.com/cover.jpg"></p> 
</html> 

When a Web browser receives the HTML shown above, it responds by 
showing a Web page that looks like the one in Figure 1. 

FIGURE 1 
 

 
 In the old days, Web pages often looked like this one. In compar-

ison to the rich visual options we have today, it’s a wonder that the 
Web took off like it did. 

  The items in the HTML that are surrounded by angle brackets (such 
as <html>) are called tags. Once you know the meaning of a few tags, 
you can see how they create a formatted Web page: 

• <html>: The <html> tag defines the rest of the text as being 
readable by a Web browser. Notice that a closing tag, </html>, 
ends the text. 
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• <title>: The opening and closing <title> tags create the title at 
the top of the Web page. 

• <p>: The <p> (paragraph) tag creates a paragraph. I could jazz 
up the text with a different font, italics, or bold-faced text, but for 
this example I left it plain vanilla. 

• <a>: The <a> (anchor) tag has an attribute—a bit of text that 
clarifies what the tag should do. In this case, the attribute tells 
it what Web page to link to. 

• <img>: The <img> (image) tag has an src attribute that gives 
the path to a graphic that I want to display on the page. 

For the first few years, nearly everyone typed HTML by hand, 
though by late 1995 simple graphical editors, such as Adobe’s 
PageMill (originally by Ceneca Communications), appeared on 
the scene. In their infancy, these WYSIWYG editors (What You See 
Is What You Get editors) were considered a godsend to those who 
didn’t want to think in HTML. On the other hand, they often gen-
erated HTML with oddities or bugs, and didn’t provide as much 
flexibility as hand-coding the HTML did. 

At first HTML had only a few tags, so it was easy to learn. But, the 
W3C (World Wide Web Consortium) began adding new features to 
HTML based on input from Web designers and browser developers: 
they wanted better graphics, beautiful and functional forms, better 
typography, and security. The W3C even developed CSS (Cascading 
Style Sheets) to provide additional flexibility in Web page layout.  

In the last few years, RSS (Really Simple Syndication) has made it 
possible for readers to subscribe to blogs (also known as weblogs), 
which are Web sites with frequent updates, usually in the form of 
diaries or daily commentary. And, now podcasts and video podcasts 
(vodcasts) take RSS even further by letting people subscribe to audio 
and video feeds.  
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As the capabilities of the Web increased, the ease of creating good-
looking and full-featured Web sites deteriorated. A professional 
Web designer needed expensive and difficult applications like 
Dreamweaver or a conglomeration of special applications, and 
amateurs and hobbyists found it increasingly frustrating to use 
Web design tools. It wasn’t surprising to find a person using a low-
end Web design application like Macromedia Contribute to develop 
basic pages; linking them to a blog created with Blogger, WordPress, 
or MovableType; and adding podcast RSS feed files created in 
Podcast Maker or Feeder.  

iWeb 2 is one of several next-generation Web development tools 
(others are RapidWeaver, http://www.realmacsoftware.com/; 
Sandvox, http://www.karelia.com/sandvox/; and Freeway, 
http://www.softpress.com/) that bring high-end Web features into 
the reach of everyday users. In many ways, iWeb 2 is similar to Apple’s 
Pages application (part of the iWork suite). Pages has a number of 
professionally designed templates for page layout, giving you a leg 
up on creating brochures, posters, newsletters, and so on. And, it 
is integrated with iPhoto so you can add a photo to a document with 
a simple drag-and-drop from iPhoto. 

Taking the cue from Pages, iWeb’s programmers provided themes 
that serve as a starting point for designing a full-featured Web site. 
Integration with iPhoto, iMovie, iTunes, and even GarageBand extend 
the drag-and-drop options and let you add many types of media to 
enhance your Web site and enchant your visitors.  

What you’ll find by the time you reach the end of this book is that 
you can use iWeb 2 to design attractive Web sites full of photos, 
blogs, podcasts, and many special features—all without writing a line 
of HTML. I think you’ll also have a smile on your face when you see 
the results and realize you’ve spent only $79 on iLife ’08, instead of 
hundreds or even thousands of dollars for high-end Web design tools. 

Enough of the history lesson—let’s get started. 

http://www.realmacsoftware.com/
http://www.karelia.com/sandvox/
http://www.softpress.com/
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INSTALL iWEB 

To install iLife ’08, your Macintosh must meet or exceed the following 
minimum requirements: 

• A Mac with a Power PC G4, PowerPC G5, or Intel processor, and 
at least 512 MB of memory (1 GB or higher is recommended). iWeb 
is a Universal application (so it runs on Power PC- and Intel-based 
Macs), and it operates much faster on the Intel-based machines. 

• DVD drive (SuperDrive or Combo Drive). 

• At least 3 GB of available disk space if you want to install all of the 
iLife ’08 software. 

• Mac OS X Tiger 10.4.9 or later, including Mac OS X Leopard 10.5.  

• QuickTime 7.2 or later. iLife ’08 installs this on your Macintosh 
if it’s not currently installed. 

If your Mac does meet the requirements, grab your iLife ’08 disc and 
follow the directions in this section to install the software, make sure 
you have the latest version, and launch the software. 

Run the Installer 
Before you install iWeb (or any software), I recommend that you 
quit any applications that are already running. Also, I suggest that 
you temporarily disable antivirus software like McAfee, Norton 
Antivirus, or ClamXav to avoid possible conflicts with the installer. 
Remember to practice safe computing and turn your antivirus 
protection back on once the installation is completed. 

If you’ve installed other Mac software, you already know how to 
install iLife ’08: Open the box, remove the installation DVD, and 
place it in the Combo Drive or SuperDrive in your Macintosh. Soon 
the drive begins to whir and the DVD contents appear on the screen 
(Figure 2). Double-click the iLife ’08 icon to launch the installer. 
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FIGURE 2 
 

 
 

See that icon that looks like an open cardboard box with “iLife ’08” 
beneath it? Double-click it to start installing. 

  
Follow the prompts and enter the administrator password for your 
Mac when asked. When the installer reaches the Installation Type 
pane, you can choose whether you want to customize the installation: 

• To customize the installation, click Customize. This is useful if 
your disk space is limited—from the Customize screen you can 
choose which programs you’d like to install. If you are limited 
by space, consider not installing iDVD and GarageBand. 

• To install the entire iLife suite, click Install (or click Upgrade if 
you don’t have an Install button). 

When the installation is complete, the icon for iWeb (Figure 3) 
appears in the Dock, along with (if you installed them) icons for 
the other iLife applications.  
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FIGURE 3 

 

The iWeb icon looks like a cork bulletin board 
with some text and a photo pinned to it, 
representing how you can use a Web site to post 
bulletins about your life for the world to see. 

   
Make Sure You Have the Latest Version 
Before you start doing serious work in iWeb, run Check for Updates 
to be certain you have the latest version of iWeb installed: 

1. Launch iWeb by clicking once on the Dock icon or twice on the 
iWeb icon in the Applications folder. 

2. In iWeb, choose iWeb > Check for Updates.  

If the most recent version is installed, a small dialog appears 
noting that you have the most recent version. If not, you receive 
notification that an update is available and Software Update 
launches to install the update. 

3. If you are notified of an update, make sure the update is selected 
for installation by checking its Install box, and then click the install 
button at the lower right of the Software Update window. 

4. When asked, enter the administrator name and password for the 
Mac receiving the update, and click the OK button.  

5. You are asked to agree to a License Agreement for each program 
you install. Read the legalese if you are so inclined, and then click 
the Agree button to continue.  

Software Update downloads the latest version of the iWeb software 
and installs it. 

  
TIP You can keep iWeb updated by choosing iWeb > Preferences 

and checking the “Check for iWeb updates automatically” box.  
Or, if you don’t want to use Software Update or have iWeb 
download its own updates, you can get iWeb updates, and other 
updates, from http://www.apple.com/support/downloads/. 
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CREATE YOUR FIRST SITE 

In this section, I walk you through the basic steps for doing Web 
publishing in iWeb. You can follow along as I create a site, which I’ve 
put on the Web—at http://www.tcoiweb.com/—so you can see it in 
action. You may wish to create a similar sample site, so you can get 
some practice. Alternately, you can skim this section to quickly find 
information about a particular topic. 

Create a Domain File 
What’s a domain? Generally, a domain name identifies a computer 
or computers on the Internet. For instance tidbits.com is the domain 
name used for the Mac news site TidBITS. However, the relationship 
between iWeb Domains and Internet domains is tenuous, and it’s 
probably best not to try to think of them as being analogous. 

An iWeb Domain file contains the materials that make up an iWeb 
site—the HTML code, Cascading Style Sheets, images, sound files, 
and movies.  

  
TIP MORE ABOUT DOMAIN FILES 

You can find out how to work with one Domain file on multiple 
Macs in the sidebar Editing One Site on Two Macs, at the end of 
this section. And, if you want to make more than one Web site 
in iWeb and thus to have multiple Domain files, see Manage 
Multiple iWeb Sites (near the end of the book). 

  
When you first launch iWeb, it may automatically create a new 
Domain file or it may ask you to locate one or create a new one. 
Let’s look at each of those scenarios: 

• First launch ever: When you first launch iWeb on your Mac, 
iWeb creates a new Domain file for you and it greets you with 
a Welcome to iWeb ’08 dialog (Figure 4). Click the OK button, 
and you’ll be asked to Choose a Template. 

http://www.tcoiweb.com/
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FIGURE 4 
 

 
 

The Welcome to iWeb ’08 dialog links to the Getting Started PDF 
document and to online video tutorials on the Apple Web site. Both 
are useful and I recommend them as a supplement to this book. 

  
• Missing Domain file: If, however, you have worked with iWeb 

on a Mac and the Domain file has been moved from its default 
location or deleted, iWeb asks you to either create a Domain file 
or choose an existing Domain file (Figure 5).  

FIGURE 5 
 

 
 If you want to create a new iWeb Domain file, click the Create 

Domain button. If you want to work on an existing iWeb Domain 
file, then use Choose Domain. If you really wanted to start up 
iTunes, not iWeb, click Quit. 

  You already have at least one Domain file if you’ve been using 
the earlier version of iWeb. Click the Choose Domain button and 
navigate to your Domain file. The default location for the Domain 
file is ~/Library/Application Support/iWeb/. 

Should you wish to create a new Domain file, follow these 
instructions instead:  

1. Click the Create Domain button.  

An Open/Save dialog appears (Figure 6). 
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FIGURE 6 
 

 
 Your iWeb domain file can be saved in almost any directory or folder 

on your Mac. I save mine in a folder called Websites. 

  2. Navigate to the folder on your Mac where you want to save your 
Domain file, then click Choose.  

Since I tend to use more than one iWeb Domain file, I’ve 
created a folder called Websites and I save the separate iWeb 
Domain files in their own subdirectories. (You can find more 
information about using multiple Domain files in Manage 
Multiple iWeb Sites.)  

Choose a Template 
As soon as you have chosen the location of your Domain file or if you 
decide to add a new Web site to an existing Domain, iWeb asks you to 
choose a template for your Web site (Figure 7).  

Generally speaking, a template is a canned document that you use 
as a starting point. It typically contains standardized text and design 
elements, which you then customize or expand. In iWeb, the tem-
plates help you maintain a consistent look and consistent navigation 
links throughout a site. They also help you create a great looking site 
in short order. Apple and third-party developers also refer to tem-
plates as themes, so I use both terms interchangeably in this book. 
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FIGURE 7 
 

 

iWeb has 26 different 
templates for you to 
choose from.  
Each template has eight 
available page types 
(Welcome, About Me, 
Photos, My Albums, 
Movie, Blog, Podcast, 
and Blank). 

   
Apple wants to make your Web site look like it was designed by a 
professional without forcing you to make the tough decisions faced 
by the pros. A Web designer follows certain guidelines to produce a 
unique look for a Web site, and you can follow similar ones when you 
choose a template, either to use in its default state, or as a starting 
point for further customization: 

• Look for templates that use fonts that add to the feel of the site. 
For example, Portagol, a bold, stencil-like font used in the Free-
style template, would look ridiculous and out of place on a Web 
site celebrating a wedding, while an elegant font like Cochin would 
be equally absurd on a skateboarding site (Figure 8). 
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FIGURE 8 
 

 

 

Unless you have an 
extremely warped sense 
of humor, match the 
look of your site with 
the feeling you want 
to convey.  
Stencil fonts, spray 
paint backgrounds, 
and bright colors 
don’t put across the 
romance of a society 
wedding (top), and 
a formal design and 
flowery fonts are 
out of place on a 
skateboarding Web 
site (bottom). 

   
• Pick colors that match the mood you’re trying to achieve. Bright 

colors make people feel happy, while dark colors such as brown 
or black can be considered dark and foreboding. For example, 
Baby is a happy template with plenty of light blue and white, while 
the Black template and its default dark font colors can be used to 
great effect if you want an ominous or scary site. 

• Make your Web pages easy to read by using text colors and 
backgrounds that don’t clash, but have enough contrast to make 
the text stand out. Think of light green on a pink background as 
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an example of clashing colors, while carnation on the same pink 
background is difficult to read because the colors are too much 
alike (Figure 9). If you’re not sure about how your text colors 
and backgrounds will work, use the default template colors.  

FIGURE 9 
 

  
 Don’t nauseate your readers with clashing colors (left) or make them 

feel as if they’re having eye problems by making the text color too 
close to the background color (right). 

  • Don’t go overboard with fonts. With an almost infinite choice of 
typefaces, many beginners use too many on a page. It’s better to 
use only one or two typefaces per page and to vary the style (bold, 
italic, and so on) and size sparingly (Figure 10). 

FIGURE 10 

 

Using every font you can 
find might have been 
fine on a rock concert 
poster in the 1960s, but 
it looks annoying and 
confusing on a Web 
page. 

   • Web page designs, like fashions, change over time. In the early 
days of Web design, background music and scrolling text were 
considered high fashion, to the enjoyment of some and the horror 
of discerning critics. Now they’re the nightmare of Web design, 
somewhat akin to lime green leisure suits. Keep an eye on what the  
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most popular Web sites are doing and then use your own judgment 
on whether they’re forerunners of Web designs of the future or 
quickly dated designs we’ll all be snickering about in a few years.  

Later, I describe how you can customize these templates with fonts, 
colors, masks, shapes, and other tools. If a template doesn’t seem 
perfect to you, you may easily be able to tweak it to your liking. 

  
NOTE FINDING MORE TEMPLATES 

There have always been people developing themes for Apple 
software, and iWeb is no exception. If you want to use a 
different template with iWeb, try these sites: 
• iPresentee has a constantly-growing set of iWeb themes 

for business and pleasure: http://www.ipresentee.com/ 
iPresentee/iPresentee_-_iWeb_Themes.html. 

• Jumsoft is producing a line of iWeb themes that span 
a number of interests, from children’s sites to business-
oriented: http://www.jumsoft.com/iweb-themes/. 

• 11Mystics has info about making templates and is selling 
many themes: http://11mystics.com/. 

• Lamiavia’s easily installed templates are now available 
through Miamiou: http://miamiou.com/. 

• iWeb fan Max Karreth is developing free and commercial 
templates for iWeb: http://guimkie.com/projects/iweb/ 
templates/. 

  

http://www.ipresentee.com/iPresentee/iPresentee_-_iWeb_Themes.html
http://www.ipresentee.com/iPresentee/iPresentee_-_iWeb_Themes.html
http://www.jumsoft.com/iweb-themes/
http://11mystics.com/
http://miamiou.com/
http://guimkie.com/projects/iweb/%0Btemplates/
http://guimkie.com/projects/iweb/%0Btemplates/
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TIP HOW TO LEARN THE RULES OF WEB SITE DESIGN 
The best way to learn the rules of good Web design is to study 
other sites, good and bad. I like to visit Vincent Flanders’s 
Web Pages That Suck (http://www.webpagesthatsuck.com/), 
a tongue-in-cheek site that critiques Web pages that have been 
nominated by readers for their unbelievable badness.  
Other design resources include: 
• How to Make a Web Site of Your Own: Excellent guidelines 

for creating your own Web site. 
http://www.mardiros.net/design-guidelines.html 

• Rent to Own Real Estate: An example of many things that 
can go wrong with Web page design. 
http://www.renttoownrealestate.com/ 

• Web Design From Scratch: This site is billed as “a complete 
guide to designing Web sites that work”, and it lives up to the 
billing for both beginners and more advanced Web designers. 
http://www.webdesignfromscratch.com/ 

Learn More & Do More, near the end of this book, notes more 
useful resources for learning Web design. 

   

Choose a Page Type 
Once you’ve chosen a site template from the left side of the dialog, 
stay in the dialog, because you still need to pick a page type from the 
right side. iWeb has eight page types: 

• Welcome: The Welcome page is a virtual welcome mat for your 
site. Use it describe your site and link to the other pages. For my 
example site—http://www.tcoiweb.com/, I start with a Welcome 
page (keep reading just ahead) and then show you the unique 
features of each page type. 

• About Me: About Me is the page type you can use to introduce 
yourself or your organization to the world. The default About Me 
page has space for personal or company attributes, links to photo 
albums you have published, a list of favorite songs and Web sites, 
plus a spot for a picture. (See Make Your About Me Page, p. 37.) 

http://www.webpagesthatsuck.com/
http://www.mardiros.net/design-guidelines.html
http://www.renttoownrealestate.com/
http://www.webdesignfromscratch.com/
http://www.tcoiweb.com/
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• Photo: iWeb’s integration with iPhoto makes it easy to display 
your favorite photos or create a portal to a Web-based slideshow. 
(See Create a Photo Page, p. 89.) 

• My Albums: Photos and movies can be organized into albums, 
but how do you organize a large group of albums? The My Albums 
page type gives your readers a way to navigate through your media 
collections (See Set Up a My Albums Page, p. 94.)  

• Movie: Think of the Movie page type as an online theater for 
your QuickTime movies. Create your movies in iMovie 7 and 
publish them online with iWeb. (See Create an Online Movie 
Theater, p. 107.)  

• Blog: This page is for an online journal, also known as a weblog 
or blog. iWeb generates an RSS feed so readers can subscribe to 
your blog. (See Publish a Blog, p. 72.) 

• Podcast: Podcasts and vodcasts are the audio and video equiv-
alents of blogs. The Podcast page lists the latest episodes of your 
podcast and creates an RSS feed that works with the iTunes Store 
podcast directory. (See Publish a Podcast, p. 78.) 

• Blank: If none of the other page types are what you need, try 
the Blank page, which provides a blank page with navigation links 
to other pages in your site. I suggest using the other page types 
as much as possible until you have experience with customizing 
iWeb pages.  

After highlighting your choice of template and initial page type 
(if you are following this section tutorial style, select Modern Frame 
for the template and Welcome for the page), click the Choose button.  

iWeb responds by generating the skeleton of your site and opening 
it in the main iWeb window. As you can see in Figure 11, I chose 
the Modern Frame theme and the Welcome page. 
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FIGURE 11 
 

 
 iWeb creates a new site, called Site, and it shows my first page 

(Welcome) in the Webpage canvas, along with the Sidebar at the left 
and the toolbar below. The site icons now appear as blue (published) 
or red MobileMe cloud icons.  
My next step will be to change the name from Site (as shown in the 
Sidebar) to a more descriptive title.  
Notice that I already have another Web site (TCiWeb08) listed in the 
Sidebar. 

  The iWeb application window now has three main areas:  

• Sidebar: Situated at the left, the Sidebar helps you switch to 
different pages in a site and to rename your pages. If you have 
more than one site in a Domain file, the site titles appear in the 
top level (leftmost) of Sidebar with the individual pages indented 
below.  

If a site has been published to MobileMe, the red dot icons turn 
blue. A red icon means the site is unpublished. Making a change 
to a page, even adding or deleting a single character, turns the 
icon red. The next time you publish the site to MobileMe, the icon 
turns blue again. If you publish to a folder, the icon remains red 
as this function works only when you publish to MobileMe 
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• Webpage canvas: Taking up most of the window, the Webpage 
canvas is where you create and arrange your content. 

• Toolbar: The toolbar sits at the bottom of the window. Click 
buttons on the toolbar for easy access to some iWeb commands, 
and see Table 1 (p. 6) for a handy reference to the menu com-
mands and keyboard shortcuts that map to the toolbar buttons. 

Name Your Site 
Notice, by looking in the Sidebar, that iWeb has named your site, 
Site. If you publish your site on MobileMe, this name will appear in 
the URL of the Web site like this: http://web.me.com/username/Site/. 

So, if your MobileMe username is stevensande and your site is named 
Site, the URL will be: http://web.me.com/stevensande/Site/. (Point-
ing a Web browser at: http://web.me.com/stevensande/ has the same 
effect as typing the longer URL.) 

  
NOTE WHAT’S A URL? 

A URL (Uniform Resource Location) is a sequence of characters 
that gives the exact scheme and path to a Web page or other 
Internet resource. (The scheme relates to the type of Internet 
service being used, such as Web, FTP, or email.) URL can be 
pronounced as “U–R–L” or (less commonly) “Earl.”  
In the case of a Web URL, the URL appears as a sequence of 
characters in the address bar at the top of the browser, and 
the scheme is http. 

  
I recommend that you change the name to something short and 
descriptive, so that you end up with a better URL. Here are some 
important naming tips: 

• Typability: Keep the name fairly short so visitors needn’t type 
a long address. For example, instead of Steve and Barb Sande’s 
July, 2007 Vacation to Seattle for the SABR Convention and an 
Alaska Cruise, I’d use Vacation 07-2007 or, even better, July-07-
Trip. Descriptive information that doesn’t fit in the title can go 
on the site’s pages. 

• Spaces: Avoid using spaces in your Web site name, as people 
may inadvertently add a second space between words when they 
type a site’s URL. Spaces are replaced with underscores when 
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the URL appears in a Web browser. For instance, if I had named 
my example Web site House of Steve, the URL would be 
http://web.me.com/stevensande/House of Steve/, and it would 
appear in the address field of a Web browser with the URL 
http://web.me.com/stevensande/House_of_Steve/.  

Current best practices for avoiding spaces in a site name include: 

• Run the site name words together (e.g., HouseofSteve).  

• Replace spaces with hyphens (e.g., House-of-Steve). 

• Replace spaces with underscores (e.g., House_of_Steve). 

Any of these naming conventions can prevent confusion with 
spaces in Web site names.  

• Limitations: Another good reason to keep your name short is 
that some older servers, particularly those using outdated versions 
of the Windows operating system, may not be able to handle a 
long directory name. For instance, the maximum path length for 
Windows 95 and later versions of Windows is 76 characters, so 
if the path to your Web server directory is long, you’ll have only 
a few characters left for the name.  

Here’s how to change the name from Site to something else: 

1. In the Sidebar, double-click the default site name Site to open the 
edit field for the name. 

2. Enter the new name and press Return. I named my example Web 
site TCiWeb2. 

Name Your Home Page 
The first page listed after the site name in the Sidebar is always the 
page that a reader sees first, after typing the URL to your site. Its 
name is especially important since the name will appear in the navi-
gation links on your site, and in the title bar of visitors’ Web browsers. 
This page is what a visitor to your site would think of as the home 
page, because it’s the page that appears first. 

In Web parlance, the home page is often called the index page since 
many Web page design tools name the file index.html. However you 
can name the page anything you like. If you don’t know much about 
Web publishing, you might think that this is perfectly reasonable, and 



30 

not worry about it. But, if you do know about the mechanics of Web 
publishing, this may trouble you, because you know that usually only 
pages with certain names (such as index.html or default.html) will 
show up if a visitor types the site’s URL without specifying a page at 
the end. 

When you publish to MobileMe, iWeb generates an index.html 
page for you! This page contains a redirect (think of a redirect as a 
forwarding address) from the index.html page to the page that’s listed 
first after the Web site name in the Sidebar. 

 Warning! Do not give any page the name index as iWeb saves 
it with the name index.html. This can conflict with the default 
index.html file and result in your site not displaying properly.  

  
In case you are curious, here’s some of the HTML used by an iWeb-
generated index.html page: 

<head> 
<title></title> 
<meta http-equiv=“refresh” 
content=“0;url=TCiWeb2/Home.html”/> 
</head> 

So, with this index.html page in place, a visitor who enters 
http://web.me.com/stevensande/ in a Web browser will go to the 
same page as a visitor who enters the longer http://web.me.com/ 
stevensande/TCiWeb2/Home.html.  

For my example site, I want to call the first page Home. To change 
the page name: 

1. In the Sidebar, double-click the default page, named Welcome, 
to open its edit field. 

2. Decide what to name the page. Since the name will be used in the 
navigation links on your site, it’s smart to keep it short. I suggest 
ten characters or less, including spaces. You can make the name 
mixed-case (Home), lowercase (home), or uppercase (HOME), but 
you should be consistent with your casing in all your page names. 
Casing does make a difference when a user types your URL, so you 
may wish to play it safe by staying with all lowercase letters. 
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3. Enter the new page name and press Return. I’m typing Home for 
the name in Figure 12.  

FIGURE 12 
 

 
 Here, I am changing the name of the Welcome page to Home. As 

soon I press Return, the navigation link at the top of the page (out of 
sight on the right of this screenshot) changes from Welcome to Home. 

  
Edit the Headline 
The default headline in the example site is the gray text near the top 
that says “Matt’s Photography.” You can change this text placeholder 
to whatever you want to say to your guests. To edit the headline: 

1. Triple-click Matt’s Photography to highlight them for editing. 

2. Type the new headline. For this example, I’ve changed the name to 
Take Control of iWeb ’08. 

3. Click anywhere else on the page to deselect the title. 

Change the Picture 
Although the photo placeholders on the Home page are striking, 
you’ll likely want to update the default placeholder pictures with your 
own. You can drag a photo in from the Desktop, but this is where 
iWeb’s integration with other applications in iLife ’08 works nicely. 

To find a photo in iPhoto and insert it, follow these steps: 

1. Click the Media button on the iWeb toolbar.  

The Media Browser appears (Figure 13). 
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FIGURE 13 

 

The Media Browser—from this 
single dialog you can choose 
music and playlists from the 
Audio tab, pictures from the 
Photos tab, and Movies 
you’ve created from the 
Movies tab.  
The Media Browser is now a 
common feature in many iLife 
and iWork applications. 

   
 

 No photos? If you’ve just installed iLife for the first time and you 
don’t have any pictures in iPhoto, the Media Browser will be empty.  

  
2. Click the Photos button.  

All albums, your complete library, and iPhoto events appear in the 
Media Browser. Clicking one of the listed items, such as an event, 
lets you view the photos. 

3. Browse through the pictures until you find the ones you’d like 
to use. For the example Web site, I chose a self-portrait I took 
with PhotoBooth, a picture of an airplane wing that I shot with 
my iPhone, and a photo of a printed copy of Take Control of Your 
iPod: Beyond the Music.  

Don’t be concerned if your photo is in a portrait (vertical) orien-
tation but the photo placeholder is landscape (horizontal). iWeb 
will automatically mask the image. By mask, I mean that iWeb 
will hide part of the picture so it fits in the placeholder. (If you’re 
worried about the size of your photo file, see Accelerate Picture 
Downloads.) 

4. Drag a photo from the Media Browser to the iWeb page and drop 
it on the placeholder. Your picture is pasted into the placeholder.  
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5. If the photo appears upside down or reversed, you can correct that 
problem by clicking the photo to select it, then choosing Arrange > 
Flip Vertically or Arrange > Flip Horizontally. You can also rotate 
any photo by holding down the Command key while dragging one 
of the eight handles that appear around the edges of the photo. 
You can also use the Rotate button on the toolbar to rotate a 
selected photo 90º counterclockwise each time it is clicked. 

6. If the picture doesn’t look good where it has been placed, you can 
drag it to a different location. On occasion, thin, blue alignment 
guides appear when you drag a picture. You can use these lines as 
a visual aid to help you center and align page elements for a more 
professional look (iWeb’s preferences allow you to set whether 
alignment guides show at an object’s center or edges). 

7. If a photo appears to be too dark or light, or the color tint isn’t 
what you’d expect, you can click the Adjust button on the toolbar 
to gain access to controls for enhancing the picture. 

  
NOTE ALTERNATE TEXT FOR WEB GRAPHICS 

iWeb still can’t add an alt attribute to an image. An alt attribute 
is typically coded into the HTML to tell Web browsers what text 
to display in place of an image while the image is loading or if 
the image does not load.  
An alt attribute is a necessity for assistive technology like text 
readers for sight-impaired visitors to your site and useful for 
text-only mobile browsers. It is considered good Web etiquette 
to include an alt attribute, and I hope that a future version of 
iWeb will include this capability. 

   

  
TIP Do you need help figuring out how to use an item on an 

iWeb template page? Put your pointer over any item and a 
small yellow help tip (called a Help tag in iWeb) appears with 
a description of how to use that page design element. 
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My Web page is starting to look much better (Figure 14). 

FIGURE 14 

 

Changing 
the 
headline 
text and 
adding new 
pictures 
gives this 
page an 
entirely 
different 
look.  

   Notice the reflection below the book’s photo? That’s a feature of iWeb 
that adds a professional look to your pages without adding a lot of 
work. The reflection gradually fades into the background color of your 
page, acting as a smooth transition between the photo and the text. 
Learn more about reflections, and about other aspects of applying 
effects to photos, in The Fine Points of Formatting Photos. 

Edit the Heading & Body Text 
The final step in customizing the default Welcome page is changing 
the heading and body text. Just as you customized the headline and 
photo placeholders, you customize the heading and body text place-
holder with your prose.  

To change the default body text: 

1. Select the heading by double-clicking it.  

2. Type a new heading. (I changed the dummy text “Welcome to my 
site” to “About this site”). 

3. To edit the body text, double-click on it.  

4. Start typing your body text. It will replace the dummy text.  
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You may wish to change the font, size, or style of the text that you 
entered, and you may wish to make a link. I cover those topics in Work 
with Text, later. For now, let’s take a look at the updated home page 
(Figure 15) before we move on to adding a few special elements. 

FIGURE 15 
 

 
 The page is ready to publish. Its icon in the Sidebar is red because 

the page hasn’t been published yet. 

  
 
 

 

 

 
NOTE WHAT IS LOREM IPSUM? 

New pages in iWeb have text placeholders filled with dummy 
text, usually beginning with “Lorem ipsum dolor sit amet 
consectetuer adipiscing elit, sed diam nonummy nibh euismod 
tincidunt ut laoreet dolore magna aliquam erat volutpat.”  
Printers and typesetters have used this as dummy text since 
the 1500s. For a long time, page designers have understood 
that someone looking at a layout will be distracted by the 
readable content on the page. Instead of filling the page with 
something readable, they’ve used lorem ipsum instead. Lorem 
ipsum looks like real text, rather than text that has been typed 
in, copied, and then pasted a number of times.  
The text comes from sections 1.10.32 and 1.10.33 of de Finibus 
Bonorum et Malorum (The Extremes of Good and Evil) written 
in 45 BC by Marcus Tullius Cicero. You can read the Wikipedia 
translation at http://en.wikipedia.org/wiki/Lorem_ipsum.  

  

http://en.wikipedia.org/wiki/Lorem_ipsum
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Add Special Elements 
iWeb includes a number of special elements that add functionality 
and fun to your Web pages.  

The first element, the Made on a Mac button, helps you show your 
pride in owning a Mac and links readers to the MobileMe Web site, 
where they can get more info about MobileMe, the Macintosh, and 
other Apple products and services. By default, all iWeb pages have 
a Made on a Mac button. You can delete it from a page by clicking it 
to select it and pressing Delete. To add the button to a page, choose 
Insert > Button > Made on a Mac.  

Do you want to know how many people visit your Web pages? The Hit 
Counter element adds a small odometer-like counter that increments 
every time someone visits the Web page. The counter works only if 
you publish your Web site on MobileMe. If you want to include a Hit 
Counter on your Web page, choose Insert > Button > Hit Counter.  

Are you a MobileMe subscriber? If you are, you have a MobileMe 
email address, and adding an Email Me button to your Web page 
automatically creates a link that people can use to send you email. I 
don’t recommend using this, since spammers can gather your email 
address from your Web page, but if you’re letting only friends and 
relatives know about your Web site it may not be a problem. Add 
an Email Me button by choosing Insert > Button > Email Me. 

 New in iWeb 2: To add content created by others to your Web 
pages, iWeb 2 provides more special elements. These include Google 
Maps and Google AdSense Ads.  
Another new feature in iWeb 2, HTML snippets, lets you add pieces 
of HTML code to your Web page. I give examples of adding HTML 
snippets in Add a Video from YouTube and Add a Form. 
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Change the Page Size & Background Color 
Depending on the look of your page, you might want to change its size 
and background color. For example, if a Web browser is open to full-
screen size, a white margin (iWeb calls it the background) on a white 
page can look strange, as the text is overwhelmed by the wide-open 
spaces.  

Here’s how to solve this problem:  

1. Click the Inspector icon, and then click the Page Inspector icon 
( ).  

2. Click the Layout button. 

3. Adjust the page size by setting the padding at the top and bottom 
of the page, the height and width of the page, and the height of the 
header and footer. All these measurements are in pixels. 

4. Click the Page Background and Browser Background color wells to 
adjust those colors. Use the Browser Background color to create a 
frame for your page content. 

Note that iWeb doesn’t apply these changes globally, so you have to 
make them for every page. That can create a lot of work if you want to 
have a consistent look on each page and don’t want to use the default 
browser background color.  

Make Your About Me Page 
Now that you know how to choose a template, and you know the 
basics of how to personalize elements of a page, it’s time to create the 
About Me page. Let’s get started: 

1. Add the About Me page: Choose File > New Page (Command-
N) or click the  button below the Sidebar. Select the About Me 
page type for the template you’re using, then click Choose.  

The About Me page, with its placeholders, appears (Figure 16). 
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FIGURE 16 

 

Everything I’ve 
ever wanted to 
know about Matt’s 
Photography, and 
more! It’s time for 
me to fill in the 
details of my life. 
Sorry, Matt. 

   2. Customize the headline, photo, and body text: You already 
know how to change these elements (see Edit the Headline, 
Change the Picture, and Edit the Heading & Body Text if not).  

3. Edit the list of stats:  

• To change an item’s label, highlight the label by clicking it once, 
and then type your new text. (I wanted to replace Subjects with 
Hobbies, so I highlighted Subjects, and then typed Hobbies.) 

• To edit an item’s text, select the text and type over it (Trenz 
Pruca lives in Seattle, Washington, but I live in Highlands 
Ranch, Colorado. I double-clicked Seattle, Washington and 
typed Highlands Ranch, Colorado).  

• To remove an item, select it and press Delete. 

 Quick-select: In some iWeb templates, you can quickly 
select an item by triple-clicking it. 

  
• To add a new item, select an existing item, copy it by choosing 

Edit > Copy (Command-C), place your pointer at the location 
where you want the new item, and then paste the item by choos-
ing Edit > Paste (Command-V). Then, customize the new item. 
I added my age to the list. 

• To turn an item into a link, see Create Web Hyperlinks. 

• For info about including a photo, see Change the Picture.  

4. Customize the “My favorite songs” list: This list doesn’t 
appear in all templates, but you can add it by using the tip that 
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follows this section. If a songs list is included in the template 
you’re using, you can simply type the names of your favorite songs, 
or you can get fancy by creating links to songs in the iTunes Store 
so that visitors to your site can click over to the store and listen to 
a short sample of each song, and then purchase the music if they 
like it. It’s easy to do: 

a. Delete the name of the first placeholder song. (In some 
templates, these songs are numbered—if you delete carefully, 
the number 1 will remain. If not, press Return to start a new 
line in the list). 

b. In the iTunes Store, search for a song you’d like to list as a 
favorite. 

c. Drag the song from the iTunes Store to the right spot in the 
list. After you drop it, iWeb will add a link to the song’s listing 
in the iTunes Store (Figure 17). You may have to change the 
link’s font size (see Make Text Sparkle) or move the link slightly 
to make it look good. 

d. Add more songs to the list—to get a new list entry, place your 
pointer at the end of an existing entry and press Return. 

FIGURE 17 

 

My favorite songs are all by 
Steely Dan. Click one of those 
song titles and you can hear 
or purchase it in the iTunes 
Store. 

   
 

  
TIP Want an even easier way to add your favorite songs to your 

Web page? Simply drop an iTunes playlist on your Web page 
where you want the list of favorites to appear. iWeb adds 
formatting and links, the latter giving your readers a chance 
to hear your favorites in iTunes. 

   

http://itunes.apple.com/WebObjects/MZStore.woa/wa/viewAlbum?i=308565&id=308631&s=143441
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 Editing One Site on Two Macs 
Let’s say you normally work on your iWeb site on your office Mac 
Pro, but would like to work on the site on your MacBook Air while 
you’re on vacation in Italy. To make this work, first make sure that 
you have iWeb installed and have launched it at least once on both 
Macs. Second, you need to transfer a large file. Follow these steps: 

1. On the source Mac, locate the file called Domain in your user 
folder, in ~/Library/Application Support/iWeb/. This is the file 
that you’ll be copying. 
Usually, iWeb saves all your Web sites in a single file called 
Domain. Of course, if you follow the steps in Manage Multiple 
iWeb Sites, this won’t be true—you will want to use whatever 
Domain file matches the Web site that you want to work with. 

2. Open a network connection to the destination computer (or you 
can use a different transfer method, such as a CD or a MobileMe 
iDisk).  

3. Copy Domain to the user folder ~/Library/Application 
Support/iWeb/ on the destination computer. If a Domain file 
already exists in that location, you should either rename it or, 
if it doesn’t contain any Web sites, overwrite it.  

Now when you open iWeb on the destination Mac, you’ll see all 
your Web sites. Edit your sites on the other Mac, and then reverse 
the process when you want to resume editing your Web sites on 
the original Macintosh. 

Can you put Domain in a shared folder or on a server and work on 
it over a network? Yes, but be aware that this may be much slower 
than working on a local file and that file permissions may become 
an issue. 
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PUBLISH YOUR SITE 

In this section, I help you figure out where to publish your site 
(MobileMe or somewhere else) and give you the necessary steps. 

Decide Where to Publish Your Site  
A Web site is nothing if the rest of the world can’t see it. To publish 
your site so others can view it, you must copy its files to a Web server, 
a computer running Web-serving software that knows how to commu-
nicate with Web browsers. Usually, a Web server has an always-on 
connection to the Internet and—ideally—it is situated in a place where 
power outages, drive failures, and other problems are unlikely to 
occur. A service that provides you with space on a Web server, and 
takes care of all the maintenance and technical details of running 
a Web server is called a Web host. 

From the perspective of an iWeb user, you have three main choices 
for your Web host, which I present here in what I consider the most 
likely option to the least likely: 

• Use MobileMe: Apple has made Web publishing easy by 
integrating iWeb with MobileMe. A site published to MobileMe 
can be open for the world to see, or it can be password protected 
for privacy. The URL to your Web site can either begin with 
www.mac.com, or you can host a personal domain (a registered 
domain name that you control) on MobileMe. One downside of 
publishing to MobileMe is that Apple doesn’t allow commercial 
activity on Web sites hosted there (see the Warning in Run an 
Online Store to read the rules about commercial activity). 

Available for $99.95 per year, MobileMe provides 10 GB of disk 
storage, an email address, and many other features. To join, visit 
your local Apple Store or see http://www.me.com/. (Joe Kissell’s 
Take Control of MobileMe is a valuable source of information on 
how to make the most of MobileMe.) 

• Use a third-party Web host: Many iWeb users already have 
Web hosting as part of the service from their Internet Service 
Provider (ISP), and some may own or share a Web server. You 

  
NOTE Amazon often sells MobileMe packages at a substantial discount. 

  

http://www.me.com/
http://www.takecontrolbooks.com/mobileme?pt=INTERNAL
http://tinyurl.com/jrvod/


42 

can use iWeb to publish a site on any server, but instead of using 
iWeb to quickly upload the files to Apple’s MobileMe servers, you 
must move the files to your server manually, typically with FTP 
software. To find out more, jump ahead to Publish to Other 
Servers. For more on using your own domain name on a third-
party Web host service, read Appendix A: Web Hosting. 

 Warning! According to Apple, iWeb’s hit counter, enhanced 
slideshow, blog and podcast comments, and password protec-
tion options will not work unless you publish to MobileMe.  

  
• Be your own host: Although every Mac OS X computer has 

a built-in Web server, allowing you to be your own Web host, for 
your typical iWeb user, it’s probably not the best choice. Your Mac 
is probably not turned on 24 hours per day and connected to the 
Internet, and, even if it is, the built-in Web server is difficult to 
learn how to use well and not aimed at the same type of person 
who loves the graphical interface and simplicity of iWeb. You 
may also run into problems with firewalls, broadband providers, 
and dynamic network addresses. 

Publish to MobileMe 
To publish your site to MobileMe, follow these steps: 

1. Verify that your Macintosh is set up to work properly with 
MobileMe: 

a. If everything is set up properly, you see the name of your 
MobileMe account at the bottom of the iWeb window, preceded 
by a small green light (Figure 18). That green light means 
you’re ready to publish your site and you should skip to Step 2. 

FIGURE 18 
 

 
 

We are “go” for launch! Your copy of iWeb won’t show my MobileMe 
account name as seen in this screenshot, but if you see the green 
light next to your MobileMe name, you can publish to MobileMe 
immediately. 
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b. If you don’t see the green light, it means there’s some minor 
configuration work to do. Open System Preferences (click the 
icon in your Dock or choose it from the  menu) and open the 
MobileMe pane: 

• If you are not signed in to MobileMe, enter your MobileMe 
member name and password in the appropriate fields, and 
then click the Sign In button. 

• If you are signed in, you’re ready to go to Step 1c, next.  

c. Verify that your Mac is communicating with the MobileMe 
server. In the Finder, choose Go > iDisk > My iDisk (Shift-
Command-I). If your iDisk icon appears on your Mac Desktop 
or Finder window sidebar, you are ready to publish. (If it 
doesn’t appear, verify that Connected Servers is checked in 
the General pane of the Finder’s Preferences.) 

2. In iWeb, choose File > Publish to MobileMe or click the Publish 
button in the lower left of the iWeb window. (If you’re wondering 
about the Publish All to MobileMe option in the File menu, see 
the note on the next page, Publish vs. Publish All.) 

A small dialog appears, and it shows the status as your Mac 
connects to MobileMe and uploads the various files that iWeb has 
created. Once the site has been published, a new dialog appears 
(Figure 19). 

FIGURE 19 
 

 
 

Your Web site is now ready for visitors. From this dialog you can 
send email to your friends and colleagues, visit the site, or start 
making more pages. This screenshot shows the result of publishing 
using a personal domain; a similar dialog appears when you publish 
to a MobileMe address. 
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3. In the dialog, click a button: 

• Click Announce to automatically generate a customizable email 
that you can send to people who you’d like to invite to your Web 
site. The email features links to the site and pages you have 
created or updated. 

• Click Visit Site Now to make sure that the pages look the way 
they should. (You can visit your published site at any time after 
you exit this dialog by choosing File > Visit Published Site or 
clicking the Visit button at the bottom of the iWeb window.) 

• Click OK to get back into iWeb’s editing tools.  

  
NOTE PUBLISH VS. PUBLISH ALL 

You can either Publish to MobileMe, which submits only the 
pages or sites that have been changed, or Publish All to 
MobileMe. Which should you choose? 
If you’ve made minor changes to your site, such as adding a 
post to a blog, use File > Publish to MobileMe. That way, iWeb 
sends MobileMe only pages that have been changed. This saves 
a lot of time. 
At times, though, you should publish all your pages and sites 
again. For example, if you’re publishing your Web sites on 
MobileMe and accidentally deleted your sites from your iDisk, 
use File > Publish All to MobileMe to make sure that all site 
components are uploaded again, not just those that have 
changed. Publish All is also useful if you change MobileMe 
accounts and want to send your iWeb work to the new account, 
or if you find missing pages or links in your site. 
When you republish your site using either of these methods, you 
may need to refresh your Web browser to see the changes. 

  

Publish to a Personal Domain on MobileMe 
Beginning with iWeb 2, you can now host your own domain name 
on MobileMe. If you have your own registered domain name (i.e., 
www.myowndomain.com) and you’re a MobileMe subscriber, 
MobileMe and iWeb provide a process to forward browsers looking 
for that domain to the space on MobileMe.  
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While writing this book, I registered the domain name tcoiweb.com 
so I could try this out for my readers. (There’s more information 
about registering domain names in Appendix A: Web Hosting.) Now 
watch as I set up a personal domain on MobileMe: 

1. Choose File > Set Up Personal Domain. (You must be connected 
to the Internet for the Set Up Personal Domain menu item to be 
visible.) Your default Mac Web browser opens your MobileMe 
account to a login page.  

2. Log into MobileMe. You’re directed to the MobileMe Account 
Settings page.  

3. Click the Personal Domain button on the right side of the 
MobileMe Account Settings page. 

4 MobileMe displays a page describing the requirements to set up 
a personal domain—a registered domain name that you own and 
iWeb 2. Click the Add Domain button. 

5. Enter your domain name twice in the edit fields on the page that 
appears (Figure 20), then press the Continue button. 

FIGURE 20 
 

 
 Here I’m letting MobileMe know what my registered domain name is. 

In this example, I’m using the tcoiweb.com domain. 

  6. The second page displayed (Figure 21) informs you that you need 
to contact your domain registrar (the company that you registered 
your domain name with), change the www CNAME (abbreviation 
of “canonical name”) to web.me.com, and then return to the page 
and click the Done button. 
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FIGURE 21 
 

 
 MobileMe now asks me to change the www CNAME (alias) for my 

domain to point to web.me.com. 

  Once you have made this change, browsers that are pointing 
to your personal domain name are forwarded to the MobileMe 
servers, which then recognize the incoming requests and route 
them to the correct folder in your MobileMe account.  

If you are unfamiliar with what a CNAME is or how to change the 
settings, give your domain registrar a call—they are usually glad to 
help. Once you’ve changed the CNAME address, you need to wait 
for up to 48 hours for the domain name servers throughout the 
Internet to reflect the change, though you can click the Done but-
ton right away—you don’t need to wait for the change to spread 
through the Internet. 

The final page displayed informs you that MobileMe is now con-
figured to host your personal domain. Be patient! It can take up 
to 48 hours for the changes to filter through the Internet. 

7. Quit iWeb and then start it up again.  

Your personal domain is now listed at the bottom of the iWeb window 
next to your MobileMe account name. When you publish your Web 
site, it is now visible to you and the world at your personal domain 
name. 
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Publish to Other Servers 
Before you can publish to a Web server that is not MobileMe, you 
must figure out how you’ll transfer the files to the correct directory 
on the server. In most cases, you’ll use File Transfer Protocol (FTP) 
to upload your files to a server that you connect to over the Internet. 

Pick an FTP client 
Fortunately for Mac users, we can choose among several excellent 
and simple FTP clients. (A client is software that helps you work with 
a server. In this case, you run the FTP client on your computer, and 
it transfers files to a server.)  

Table 2 rounds up a number of FTP clients used by myself or other 
Take Control authors; they all have free trial versions. As an iWeb 
user, you’ll especially value an FTP client that can synchronize a 
folder on a server with a folder on your hard disk so that you can 
easily upload only the files from your iWeb site that have changed.  

 
Table 2: FTP Client Software  

Program Price Notes 

Captain FTP, from Xnet 
Communications 
http://captainftp.xdsnet.de/ 

$29 Has synchronization, 
Universal Binary for Intel 
Macs 

Cyberduck, by David V. Kocher 
http://cyberduck.ch/ 

Free Open-source FTP client, 
Universal binary, 
Dashboard widget, 
synchronization. 

Fetch, from Fetch Softworks 
http://www.fetchsoftworks.com/ 

$25 Has synchronization, 
Universal Binary, 
scriptable 

Interarchy, from Nolobe 
http://interarchy.com/ 

$59 Has synchronization, 
Universal Binary, 
scriptable 

Transmit, from Panic 
http://www.panic.com/transmit/ 

$29.95 Includes special instruc-
tions for iWeb users 

   

http://captainftp.xdsnet.de/
http://cyberduck.ch/
http://www.fetchsoftworks.com/
http://www.panic.com/transmit/
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If you haven’t used your FTP client before, I recommend installing 
the software and practicing the upload and download procedures, 
before trying to publish your iWeb site. 

 Warning! To stop character garbling during upload, set the FTP 
client preference for character encoding to UTF-8. In Cyberduck’s 
preferences, for example, this setting is in the Browser preference 
pane, in the Character Encoding pop-up menu. If any of your page 
names contain accented letters, non-Latin script, or “smart/curly” 
quotes, I suggest using Cyberduck as it fixes problems that may 
prevent your pages from being displayed by some servers 

  
Publish from iWeb 
Once you’re familiar with your FTP software, you can publish your 
Web site to your server: 

1. Choose File > Publish to a Folder. 

A dialog appears (Figure 22). 

FIGURE 22 
 

 
 In this dialog, you must enter the URL for your site if you’re using 

iWeb to publish a blog or podcast. iWeb uses the URL to generate an 
RSS feed for your podcast or blog so that others can subscribe to it. 
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2. Choose an existing folder to store the iWeb files in, or click 
New Folder to create a new folder in which to save the files. In 
Figure 22 (previous page), I’m saving the site in a folder named 
TCOiWeb08. 

3. If your site has a blog or podcast, enter the URL for your site in 
the field provided. iWeb will use this URL to generate the RSS 
feed for your blog or podcast. For example, a Web site saved 
on www.stevesandethemovie.com would have the URL 
http://www.stevesandethemovie.com/, while a Web site saved 
on a virtual server account from an ISP at www.incrediblybig 
ispcorp.net/~username might have one of these URLs:  

• http://www.incrediblybigispcorp.net/~username 

• http://username.incrediblybigispcorp.net/.  
If you’re not sure of your URL, ask your ISP. 

4. Click the Choose button.  

iWeb generates files from all the sites listed in the Sidebar and 
saves them in the folder you specified. A dialog appears, confirm-
ing that the site was published. 

5. Click Cancel, or Click Visit Site Now to see what your site looks 
like in a Web browser (your Web browser, running on your Mac, 
is pointed to the index.html file stored on your hard drive). 

6. In your FTP application, using the FTP user name and password 
supplied to you by your ISP or Web host, log in to the appropriate 
directory on the Web server. 

7. If you’ve never had a Web site before, the folder should be empty. 
In some cases there may be a placeholder or Under Construction 
Web page stored in the directory. In that case, delete the existing 
file, but note that, generally, it’s a good idea to check with your 
Web host or ISP before deleting files.  

8. Upload the contents of the folder that you saved in Step 4 to your 
Web server. Make sure that you upload all the folders created by 
iWeb that have the same names as the sites you created in iWeb, 
as well as the index.html file generated by iWeb as it creates the 
folders. Just uploading the contents of the site folders results in 
breaking the functionality of any RSS Subscribe buttons you’ve 
added to your site. 
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WORK WITH TEXT 

Even if you include fancy graphics or podcasts on your Web site, 
the text is the heart of your site and is worthy of your attention. In 
this section, I cover a grab bag of techniques that all relate to working 
with text: improving its look, avoiding issues with high-ASCII char-
acters, and creating hyperlinks.  

Make Text Sparkle 
iWeb’s professionally developed templates are nice, but you may 
want to customize the look of your text, perhaps in order to make 
your page stand out more. Although I don’t want to overdo it, I’d 
like to add pizzazz to my example pages by modifying text colors 
and styles, and applying effects such as opacity and rotation. 

Fonts 
If you have a special headline 
that needs to stand out, 
consider using a different 
font. Yes, I know I told you earlier not to use too many different fonts, 
and that basic rule still applies. However, judicious use of a special 
font can definitely change the way your Web page looks. As an exam-
ple, I decided to change the title text “About this site” to make it look 
friendlier and stand out a bit. I selected the text by double-clicking 
it, and then clicked the Fonts button on the toolbar. Playing with 
the Font panel for a while, I found a font (Bernard MT Condensed) 
that gave me the look I wanted. 

Size 
Size matters when it comes to text on Web pages. Headlines and titles 
should be larger than body text. To change text size without using the 
Font panel, select the text and press Command-Minus to make the 
text smaller or Command-Plus to make the text larger. There’s also 
a slider in the Font panel you can use to resize text on the fly.  

Color 
Adding color is an easy and usually unobtrusive way to customize 
the text on your Web site. I recommend using a consistent color 
theme throughout your site—choose colors that go well together 
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 and that make the text easy to read. On my site, I added a dash of 
color by changing some titles and headlines to the same burnt sienna 
color found elsewhere in the theme.  

To change the color of text, select it and then bring up the Colors 
panel by clicking the Colors button on the toolbar. You can choose 
a color in several different ways, and then adjust the brightness and 
opacity of the color as well. 

Styles 
You have a number of text styles at your disposal as well. When I refer 
to styles, I’m talking about the usual things you do with text from the 
Format menu—bold, italicize, underline, or outline. iWeb allows 
you to go beyond those simple styles with additional functions in the 
Font panel.  

To bring up the Font panel, click the Fonts button on the toolbar. 
The buttons at the top of the Font panel (Figure 23) are powerful 
tools. With them, you can double underline, strikethrough, or double 
strikethrough text. These styles can’t be coded for in HTML, so iWeb 
overlays the text with a transparent graphic to create special under-
line and strikethrough effects. 

FIGURE 23 
 

 Use the toolbar at the top of the Font panel to apply different types 
of (from left to right) underlines, strikethroughs, colors, backgrounds, 
and shadows. 

  You can also apply a shadow to selected text by clicking the Shadow 
button. The three sliders to the right of the shadow button control 
the opacity, blur, and offset of the shadow, while the dial controls 
the direction of the shadow. Take a minute to play with these controls 
in order to gain mastery of them; I suggest working on text that is at 
least 24 points so that you can see the effects more easily. 

Alignment & spacing 
The alignment and spacing of text can make a remarkable difference 
in the way that your Web page looks. You control both types of for-
matting in the Text Inspector (Figure 24). 
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FIGURE 24 

 

The Text Inspector provides 
another location to change the 
color of text, in addition to its 
alignment and spacing controls.  
Typographers reading this book 
will be pleased to know that 
iWeb provides tools for leading 
and kerning. If you’re not 
a typographer, you may be 
interested to know that leading 
is the space between lines of 
text and kerning is the space 
between characters. 

   When I talk about alignment, I’m referring to how the text lines up 
with the borders of the text box that surrounds it. Text can be: 

Left aligned, 
center aligned, 

or right aligned 

Text can also be justified, which means that it is neatly aligned with 
both the left and right borders, similar to the way that this paragraph 
has been formatted. In contrast to the “ragged right” margins in the 
rest of this book (set that way to enhance legibility), this paragraph 
has a smooth right margin. Notice how some spaces between the 
words in this paragraph are wider than others—the computer does 
the spacing automatically in order to make the text justify.  

I like the smooth, professional look of justified text, since it aligns 
both sides of the paragraph and leaves no ragged edges. For an 
example of justified text in iWeb, see Figure 25. 
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FIGURE 25 
 

 
 The example site Home page has justified text. Ragged text is 

easier to read as it keeps character spacing equal throughout your 
site, while justified text gives a smoother look to page designs. 

  Spacing of text can make a difference in the look of your pages too: 

• Character spacing: Known in the typographical world as kern-
ing, character spacing defines how far apart individual characters 
are. Drag the Character slider in the Text Inspector to adjust this 
distance. I tend to keep this setting at the default 0%, although 
I occasionally increase the percentage to force text to fill a line. 

• Line spacing: This type of formatting is also called leading 
(pronounced “ledding”) after the pieces of lead that traditional 
typesetters place between lines of physical type to adjust the space 
between lines. To adjust your line spacing, click in a paragraph 
that you want to adjust; then drag the Line slider in the Text 
Inspector (the space between lines increases as you slide it right).  

• Space before/after paragraph: Use the Before Paragraph 
Spacing and After Paragraph Spacing sliders to define how much 
space will appear before and after paragraphs. This tool is useful 
for long Web pages containing a lot of text arranged in paragraphs. 

• Margin: Finally, you can inset the margin using the Inset Margin 
slider. Inset refers to the number of points of space between the 
edges of the text box and the characters.  

Background fill 
Background fill is color or an image that fills the space behind text. 
Background fills, when done right, make the text stand out and draw 
a reader’s attention to important information. Background fills in 
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iWeb pertain to a specific text object. In other words, you can’t high-
light a few words and apply a background fill to them—if you want to 
do that, you must break those words out into a separate text object. 

To apply a background fill, select the text block, click the Inspector 
button, and click the button ( ). Let’s look at the types of fills 
provided by the Fill pop-up menu in the Graphic Inspector: 

• Color fill: As you might guess, this fills the background of a text 
object with color. To change the color, click the color well to bring 
up the Colors panel. If you pick a solid color, the well takes on 
a solid color. If you change the opacity of your color to make it 
slightly transparent (look for an Opacity slider in the Colors 
panel), the color well has two tones, like the one in Figure 26. 

FIGURE 26 

 

The Fill pop-up menu is a gate-
way to all sorts of fill effects. The 
color well, located beneath the 
menu, acts as a button you can 
click to access the Color panel. 

   • Gradient fill: A gradient fill creates a smooth transition between 
two colors and places it behind your text. Choosing Gradient Fill 
from the Fill pop-up menu (Figure 27), adds two new color wells 
to the Fill area of the Graphic Inspector, one for the color at the 
beginning of the color gradient and one for the color at the end. 

FIGURE 27 

 

Applying a gradient fill to the 
background of a text box.  

   In the figure above, both colors have some transparency (hence the 
semaphore-looking rectangles). You can switch which color will be 
at the top or left of the gradient by clicking the double-ended arrow 
next to the color wells. Or, you can fiddle with the Angle dial to 
determine the direction of the gradient, or click one of the two 
small arrows to quickly set a vertical or horizontal gradient.  
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• Image fill: This fill puts a picture behind the text. I suggest using 
it sparingly. An image fill works well in a button where a picture 
serves as a background and large, bold text labels the button. After 
you choose Image Fill from the pop-up menu, the Fill area of the 
Graphic Inspector changes slightly (Figure 28): The second pop-
up menu lets you set how the image behaves as a background fill, 
and the Choose button lets you select the image. 

FIGURE 28 

 

The multifaceted Fill area of the 
Graphic Inspector changes again 
when you choose an Image Fill. 

   • Tinted image fill: Similar to an image fill, a tinted image fill 
adds a color well so you can choose the tint color and opacity. For 
example, you can use a black-and-white photograph and a brown 
tint to create a mock sepia-tint picture (Figure 29). 

FIGURE 29 

 

Using a brown tint on a black and white 
photograph makes a fine faux sepia-tint 
picture. (This is a picture of my first girlfriend 
and me riding our trikes in 1962). 

   Text rotation 
Your text needn’t be horizontal. Using Text Rotation, you can place 
your text at any angle—even upside down! Although I don’t suggest 
topsy-turvy text for most Web sites, putting your titles or headlines 
at a slight angle can add drama to an otherwise dull page. 

To rotate a block of text: 

1. Select the text object by clicking it.  

Handles appear around the edge. 

2. Hold down the Command key and move your pointer over a 
handle.  
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The pointer takes on a double-ended arrow badge to indicate that 
you can rotate the text. 

3. Continue holding down Command as you drag the handle to rotate 
the text. A help tip will float nearby, displaying the angle of the text 
box in degrees. 

You can apply other text effects to rotated text for extra impact. 
Figure 30 shows how I used rotated text and a shadow to label 
my video podcast page. 

  
NOTE When is text not text? When it’s a graphic! Whenever you use 

rotation, shadowing, layering, or any font that isn’t a standard Web 
font, your text object is converted to a portable network graphics 
(.png) file. You can still change it in iWeb, but when the page is 
published to the Web, the text becomes an image. 

  
Layering 
You have another layout tool at your fingertips with iWeb: layering. 
Figure 30 shows a side-by-side example of layering in action.  

FIGURE 30 
 

     
 In the left image, I’ve dragged a text box with a color fill over a piece 

of rotated and shadowed text. Using the Forward and Back buttons 
on the toolbar, I can either move the text box back or move the 
rotated text forward. 

  Text and graphics can be moved in virtual 3D with some items being 
higher or lower with respect to the bottom layer. Think of your Web 
page as a layer cake. The bottom layer can be a picture, while the top 
layer can be text or another image. The top layer can be opaque, in 
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which case it blocks part of the view of the bottom layer, or it can 
be transparent and allow an uninterrupted view of the layer below.  

Figure 31 shows an interesting effect that I created for my Podcast 
page. To make it, I started with the large Podcast in back, which was 
in its own text object. I made it slightly transparent using the opacity 
slider on the Colors panel. The next step was to copy and paste the 
text object, and in the copy I made the font size slightly smaller and 
the transparency slightly less, and then I layered the copy in front of 
the previous text. I repeated this four times. 

FIGURE 31 
 

 
 Creating this dynamic headline for my Podcast page didn’t take a 

special graphics tool like Photoshop. I did it with layers in iWeb. 

  
 

  
NOTE Most current Apple software is Unicode-savvy, meaning that it 

accepts text in any of the dozens of languages supported by Mac 
OS X. iWeb is a perfect example of this. It encodes Web pages 
in such a way that most modern browsers display non-English 
and non-Latin text properly. 
Keyboard input of right-to-left text in languages like Arabic or 
Hebrew is difficult for practical use in iWeb, although you may 
get satisfactory results if you copy text from another application 
and paste it into iWeb. 

  

Create Web Hyperlinks 
Say, for instance, that you’re working on your About Me page, and 
you want to add a link to your favorite restaurant’s Web site. (I linked 
to the site for a local pizza place.) Here’s what to do: 

1. Figure out the URL to the location you want to link to. If you don’t 
want to type it in later in these steps, go to that location with your 
Web browser and then copy the URL from the address field.  
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2. Select a graphic or bit of text that will serve as the source of your 
link. (I selected Big Bill’s NY Pizza.) If you are selecting text, to 
make a more professional-looking link, be sure to not select any 
spaces or punctuation before or after the text.  

4. Choose Insert > Hyperlink > Webpage. (Or, if that option is 
dimmed, click the Inspector button and open the Link Inspector.) 

iWeb opens the Link Inspector (Figure 32). 

FIGURE 32 

 

In the Link Inspector, I’ve 
changed a few things to make 
my link work the way I want it 
to: 
• The first checkbox shows that 

I’m setting the highlighted 
text as the source of a 
hyperlink. 

• The pop-up menu indicates 
that the link goes to a page 
outside of my own Web site. 

• The correct URL to the link’s 
destination is in the URL field. 

• The checkbox below the URL 
field is enabled, because I 
want the link destination to 
open in a new browser 
window.  

   5. Tell iWeb what to link to: 

• To link to another Web site, enter the URL in the URL field.  

• To link to a page on your own site, choose One of My Pages 
from the Link To pop-up menu and then choose the page from 
the Page pop-up menu. 

iWeb now establishes the link. If you were linking from text, the 
text gains an underline, and if you were linking from a graphic, a 
small icon that looks like the Link Inspector button ( ) appears 
in the lower right of the picture to indicate that the picture is now 
a clickable hyperlink. This icon won’t appear on your published 
Web page, but people reading your site will see whatever cues their  
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browsers offer for graphical links, such as the pointer changing to 
a hand when it moves over the image or a yellow help tip popping 
up and showing the linked URL. 

6. Test the link either by publishing your site or clicking it in iWeb. 

  
TIP FASTER LINK MAKING 

Once you’ve mastered the basics of making links, you can 
make a link faster by dragging its favicon from Safari to iWeb. 
(A favicon, also known as a Favorites icon or page icon, is a 
small icon that represents a Web site, typically seen at the left 
of the address field in a Web browser.) The resulting link text 
will be the page’s title (Figure 33). If you drag the favicon from 
another browser like FireFox, the URL appears instead of the 
page title. 
 

FIGURE 33 

 

I dragged the 
favicons for the 
home pages of my 
three favorite Web 
sites from Safari to 
iWeb. Now, iWeb 
shows the title of 
each home page, 
and iWeb has auto-
matically entered 
each URL in the 
Link Inspector. 

   
 

   

 Image maps: If you’d like to make an image map, where different 
portions of an image link to different URLs, see Make an Image 
Map. 
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NOTE CAN I LINK TO A POINT ON THE SAME PAGE? 

Anchor or internal links have been around since the early days 
of HTML. They provide a way linking to text or a picture on the 
same page. A common use of this feature is to create links from 
a list of alphabetical letters (A to Z) to words listed in an alpha-
betical glossary on a long Web page. Clicking the letter T, for 
example, moves you down the page to the start of the glossary 
entries beginning with T. 
Unfortunately, iWeb can’t create anchor links. If you have 
experience in editing raw HTML, you can add anchor links man-
ually by editing your published iWeb page. However, the next 
time you publish the page, the information will be overwritten 
and you’ll need to add it back in. 
If your Web site needs anchor links, you should either prepare 
to do a lot of HTML editing or use a different Web design tool 
to create pages that use anchor links. 

  

Create Other Link Types 
I’ve only shown you how to link to external Web sites. iWeb provides 
you with a way to link to an email address (called a mailto link), other 
pages of your Web site, or to files. Let’s learn more about these types 
of links: 

• Mailto links: Links to an email address solve two problems— 
first, they get your email address off the Web page, making it 
slightly less vulnerable to spammers harvesting them, though not 
much less vulnerable—see the warning ahead—and second, they 
make it easier for visitors to send email to the address in question. 
Add mailto links by choosing An Email Message from the Link To 
pop-up menu in the Link Inspector, then adding an email address 
and a subject (Figure 34). 
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FIGURE 34 

 

For personal Web sites, mailto 
links are a great way to 
encourage feedback from 
your friends.  

   iWeb also offers the opportunity to add an Email Me button to any 
page by choosing Insert > Button > Email Me. This automatically sets 
up a mailto link to your MobileMe email address.  

 Warning! Mailto links can make you a target for spammers, who 
use software to automatically glean email addresses from mailto 
links in Web sites. One way to decrease the chances that you’ll 
become a spam target is to camouflage your email address. For 
example, steve@me.com can be camouflaged as steve@medotcom. 
Many senders realize that it’s not a “real” email address and will 
replace dot with . before pressing the send button. iWeb 
unfortunately won’t let you replace @ with at. 
You can also provide an email addresses without a mailto link. 
Just writing the email address into your text as something like 
myname (at) me (dot) com will get the point across to your 
readers while eliminating harvesting by spammers. 

  
• File links: Do you have files that you want your Web site visitors 

to download? An example would be a PDF file containing your 
family’s annual holiday letter—it’s too long to turn it into a Web 
page, but you want to enable visitors to download it easily. A file 
link lets a visitor click a link to download a file.  
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Add a file link by choosing A File from the Link To pop-up menu 
in the Link Inspector, then clicking the Choose button to select the 
file you want to make available for downloading (Figure 35).  

FIGURE 35 

 

File links are helpful if you have 
information that you’d like to 
make available to the public.  
Be sure that you have created 
the file or are the copyright 
owner, and don’t allow down-
loads of other copyrighted 
material. 
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SHAPES, LAYERS & MASKS 

In this section, I talk about three powerful iWeb features—Shapes, 
Layers, and Masks. I touched on the topic of layers with respect to 
text objects in Work with Text, but there’s more to the story.  

Shapes 
In iWeb, shapes are exactly what the name implies, pre-drawn shapes 
that you use to add excitement to your Web site. These include lines, 
arrows, circles, stars, rectangles, polygons, and even a comic speech 
balloon. Shapes can behave in three different ways on your page: 

• Inline: If you insert a shape just after clicking in a text block, 
when a text cursor is flashing, the shape goes in the text as an 
inline graphic, meaning it behaves just like a regular character. 

• Wrapped: You can change an inline graphic so that text in its 
paragraph wraps around it. 

• Fixed-object: You can drag the object around freely on the page 
and place it where you like. Text does not wrap around it. (See 
Fixed-object shapes, ahead two pages.) 

Inline & wrapped shapes 
Follow along with me as I add an inline shape: First, I set the inser-
tion point by clicking in the text where I want the shape to go. Next, 
I choose a circle from the Shapes pop-up menu on the toolbar. A 
circle surrounded by handles appears (Figure 36).  

FIGURE 36 

 

Inserting this shape 
changed the spacing 
between two paragraphs 
of my text and, frankly, I 
don’t like the way it looks. 
That can be fixed with 
word wrapping. 

   I don’t like the way the shape looks, since it’s creating too much 
space above my paragraph. So, I keep the shape selected, open the 
Inspector, click the Text button, and click the Wrap button. I check 
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the “Object causes wrap” box and fill in the other options in the 
Inspector. My page now looks like Figure 37. 

FIGURE 37 

 

Text is now wrapped 
to the left of the circle 
shape. Now it’s time to 
do something with that 
shape. 

   
 

 Caveat! iWeb doesn’t provide full text wrap, which would allow 
iWeb users to move the shape anywhere in the text and have the 
text literally wrap around it, following the outline of the shape. 

  
Just having a circle next to the text doesn’t make sense, but I have a 
plan: I want to put a picture of a cat in the circle. To do this, I: 

1. Make sure the shape is selected and open the Graphic Inspector. 

2. Choose Image Fill from the Fill pop-up menu. 

iWeb opens an Open dialog. 

3. Locate and open the image. I opened a picture of Frodo the cat. 

4. Choose Scale to Fill (this may vary depending on the picture you’re 
placing into the shape). 

Frodo the cat is now immortalized in his own circular frame on my 
Web page. To finish the job, in the Graphic Inspector, I removed the 
line around the shape by setting the stroke to none—stroke refers to 
the type (solid, dotted, or dashed) and the thickness of the line. I also 
added a shadow. Figure 38 (next page) shows the final product. 

  
TIP To resize a shape proportionally, press Shift while you drag one 

of the shape’s handles. 
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FIGURE 38 

 

This small medallion, 
created by adding a shape 
with an image fill, highlights 
the text nicely and compli-
ments the blog posting. 

   Fixed-object shapes 
A fixed-object shape is movable anywhere on a page. While the name 
appears to be an oxymoron, it means that the object stays wherever 
you move it. To insert a fixed-object shape, make sure you do not 
have a typing cursor active in a text block and then choose the shape 
from the Shapes pop-up menu on the toolbar.  

When a plain vanilla photo just doesn’t do it for me, I like to call up 
a shape, do an image fill, and then move the resulting photo anywhere 
on the page I please. As an example, take a look at Figure 39. 

FIGURE 39 

 

I’m a star! I didn’t use a 
graphics program to create 
this image, only a fixed object 
shape, a picture, a few set-
tings, and some imagination.  

   What I did here was create a new star shape, increase the size from 
the default by dragging one of the handles, perform an image fill 
(as described on the previous page), rotate using the Command-click 
mouse action described earlier in Text rotation, and then add a shad-
ow using the tools described in Styles. How long did it take me to 
complete this image? About a minute. 
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Shapes that change 
While all shapes can be resized by dragging a handle, some shapes 
have multiple settings: 

• Stars and polygons: When you create a star shape, a small 
slider appears under the star, allowing you to change the number 
of points from as low as 3 to as high as 20. The same slider appears 
with the polygon shape (3 to 11 sides).  

• Arrows: You can change the width of the tail and the length of 
the head by dragging the circular control (inside the red circle in 
Figure 40). It’s called a circular control because of its shape and 
to differentiate it from a square handle. 

FIGURE 40 

 

Dragging the circular control changes 
the width and length of the tail, and 
the length of the arrowhead.  

   • Round rectangles: The circular control also has an effect on 
the rounded rectangle shape, where dragging the control can 
straighten or curve the corners. 

Text in shapes 
There’s one more thing you can do with shapes—fill them with text. 
This is particularly useful for placing text in a confined area so that 
it can be moved to a specific spot on a page, perhaps to serve as a 
caption for a photo. Here’s how to do it: 

1. Create a fixed-object shape (see Fixed-object shapes). For my 
example, I’m using the comic speech balloon.  

2. Drag the shape to the location where you want it. I decided to put 
the balloon near a picture of me as a kid on my Video page.  

3. Resize the shape if you want it to be larger or smaller. 

4. Double-click the shape. A text cursor appears inside the shape. 
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5. Start typing your text. If you type more text into a shape than can 
fit, a clipping indicator will appear (Figure 41). To see all your 
text, either remove some words or enlarge the shape. 

FIGURE 41 

 

The clipping indicator is the small 
plus sign at the bottom of the 
shape. It’s there to tell you that 
you have too many letters and 
too little space. (The red dotted 
underline beneath the word “trike” 
is from the Mac spelling checker.) 

   6. You can change the shape’s background, opacity, border color, and 
thickness, and you can also apply formatting or links to the text in 
a shape. The final version of my speech balloon is on the example 
Web site (http://www.tcoiweb.com/). 

Layers 
I touched on the concept of layers earlier in this book (Make Text 
Sparkle). However, layers can be used for more than just making text 
look good. Layering graphic and text blocks is a wonderful way to 
create an interesting looking Web page.  

The theory of layers is that you can stack different objects upon each 
other. By selecting one object and using the Forward and Backward 
buttons on the toolbar, you can move it in front of or behind other 
objects. To effectively use layers with graphics and text, you need to 
think about your page design in three dimensions–the height and 
width of your page, as well as the depth of the layers. 

The use of layers to make your Web pages more exciting is limited 
only by your imagination. To demonstrate the power of layers, we’re 
going create a special effect by using a picture as a backdrop to some 
text. Placing text directly on a picture can sometimes make the text 
unreadable, so putting a text-filled shape with a slight amount of 
opacity over the picture is a better way to create the effect.  

http://www.tcoiweb.com/
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We’ll begin by creating a new page and placing a large picture on it. 
Then we’ll create the effect: 

1. Create a rounded rectangle shape over the darker portion of the 
photo. The shape is filled with the default white color at this point, 
blocking the picture.  

2. Type your text. Don’t worry about the color of the text right now. 
At this point the picture and shape look like Figure 42. 

FIGURE 42 

 
 I can’t see the forest for the text in this picture. Since I don’t want 

the text to block the beautiful scenery, I need to make the rounded 
rectangle transparent. 

  3. Select the shape by clicking it.  

Eight handles appear around the perimeter of the shape.  

4. Open the Graphic Inspector and then adjust the opacity of the 
shape. In my case, 20% worked well to give the appearance of a 
slightly lighter text frame embedded in the picture.  

5. Changing the opacity of the shape also changed the opacity of the 
text so it’s almost impossible to read. Select and cut the text, then 
click the picture and paste the text to create a separate text layer.  
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6. Move the text layer on top of the rounded rectangle and resize it 
so it fits within the boundaries of the shape.  

7. Change the color of the text to a readable and pleasant-looking 
hue. In my example, I grabbed the color of one of the sunlit peaks 
by using the magnifying glass icon in the Colors window to create 
a text color that contrasted with the dark blue of the mountains 
(Figure 43).  

FIGURE 43 
 

 
 The completed example page. You can now see the lower part of 

the mountain, the trees and the lake, and the text is readable. I 
also used the Adjust tool on the toolbar to enhance the photo. 

  In this example, I inserted the lower layer (the photo), created a 
middle layer (the rounded rectangle shape), and placed a text layer 
on top. Experiment with moving layers around using the Forward 
and Backward buttons and you can find some surprising and 
wonderful effects. 

Masks 
A mask allows you to change what parts of a fixed or inline object 
are visible. A photographer would call this “cropping,” but there is 
a slight difference—cropping changes the original image by removing 
parts of it, while a mask retains the original image but hides portions 
of it behind an opaque cover. 
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You may have already experienced masks without knowing what was 
going on. Many of the image placeholders in iWeb templates have 
masks applied, so when you drag a photo to a placeholder and drop 
it, certain areas of your original photo aren’t visible.  

Masks can be useful in cropping out distracting material in a photo, 
removing ex-husbands or ex-wives, and framing a photo so that it fits 
a space on your Web page. To demonstrate the mask tool, I’ve built 
a new entry for my blog. The text is written, I’ve made my formatting 
changes, and I’ve inserted a picture. I’d like to crop the picture so that 
I focus on the two Swiss Guards on the left (Figure 44). 

FIGURE 44 

 

The picture before 
masking. I’d like to see 
as much as possible of 
the two guards on the 
left and try to crop out 
the woman who is talking 
to them. 

   Here’s how to use a mask to crop out the right side of the picture: 

1. I select the image and click the Mask button on the toolbar.  

A mask is applied (Figure 45) to the image, and the button 
changes to Unmask. (If I decide to bring back the original image 
at some point, I can click the Unmask button.) 
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FIGURE 45 

 

The mask applied to the 
image cuts off too much 
and makes my picture 
too small, so I adjust the 
size of the mask. The 
Edit Mask slider at the 
bottom lets me increase 
or decrease the size of 
the picture on the page. 

   2. To resize the mask, I drag the mask’s handles until the mask covers 
only the portions of the image I don’t want to see (Figure 46). 
The darker part of the image is what will be visible to me.  

FIGURE 46 

 

The image is now framed 
the way I want it, with 
the two guards nicely 
framed. 

   3. Since the image is now masked the way I like it, I click anywhere 
on the Web page to accept the mask. I can resize and even reposi-
tion the image with the mask in place. If I want to be fancy, I can 
rotate the image by pressing Command while dragging a handle.  

To see how the final image looks after masking, visit the example 
Web site and look at the Examples page at http://www.tcoiweb.com/ 
TCiWeb2/Examples.html. 

http://www.tcoiweb.com/TCiWeb2/Examples.html
http://www.tcoiweb.com/TCiWeb2/Examples.html
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PUBLISH A BLOG 

Blog is a contraction of Web log, describing a Web site on which a 
writer, or group of writers, posts items on a regular basis focusing on 
a specific subject. The items typically include text, images, and links 
to other Web sites or Internet resources. Blogs display content in 
reverse chronological order, with the latest entries at the top.  

Although we didn’t call them blogs in the early days, blogs have been 
on the Web all along. Blogging took off in 2001 with the emergence 
of Blogger and other free Web-based blogging services that made it 
easy to add new blog entries and keep old entries organized. Blogging 
has become a popular means of communication and has been 
adopted by the mainstream media, although it is primarily known 
as an alternative media capable of affecting worldwide opinion. 

iWeb’s Blog page type provides most of the elements of a classic blog: 

• An overview page, with excerpts of the most recent posts listed in 
reverse chronological order 

• Detailed blog entries on their own pages 

• An archive of past entries that your readers can visit 

• Comments with attachments (when the Web site is published to 
MobileMe) 

• A tool for searching iWeb blogs (MobileMe only) 

In this section, I show you how to be an iWeb blogger. I’m a bloggy 
kind of guy, so I want to add a blog to the example Web site: 

1. Add the Blog pages: Choose File > New Page (Command-N) or 
click the  button below the Sidebar. Select the Blog page type for 
the template you’re using, and then click Choose.  

A Blog item appears in the Sidebar, heading a category that 
includes Entries and Archive. The Entries item opens in the 
Webpage canvas area (Figure 47), in case you want to make 
a new entry right away. 
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FIGURE 47 
 

 
 This figure shows a new blog entry in the Modern Frame template.  

Entries is selected in the Sidebar, and buttons are available for 
adding or deleting an entry.  
Starting a new blog also creates a Blog summary page (called Blog 
in the Sidebar), and an Archive page that automatically collects older 
entries. 

  2. Update the Blog summary page: iWeb initially shows you the 
Entries item, but since your readers see the Blog summary page 
when they click the Blog button, you should update that page first: 

a. Change the summary page name: If, for instance, you 
would rather call your blog a journal, you can change the sum-
mary page name and the corresponding label on the button. 
Double-click Blog in the Sidebar to select it, and then type a 
new page name following the naming suggestions I made earlier 
in Name Your Site. 

b. Customize the title: Sure, Matt’s Photography is descriptive, 
but I’d like a headline that matches my witty personality. 
Double-click the headline in the Webpage canvas to select it, 
and type a new headline. I chose Feelin’ Bloggy as the name of 
my blog. 
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c. Replace the blog description: Few people want to read the 
lorem ipsum, so double-click it to select it, and then type a short 
paragraph or two about what you plan to accomplish with the 
blog and why the reader should take the time to read it. 

d. Change the picture: The placeholder photo for the Modern 
Frame theme is a picture of good ol’ Matt. Since I’ve never been 
Matt and don’t intend to be, I want to show a photo of my own 
grizzled visage. To change the photo, drag a photo from the 
Desktop or the Media Browser to the placeholder (see Change 
the Picture for help with the Media Browser).  

e. Set the number of entries on the Blog summary page: 
It’s considered good etiquette to restrict the number of recent 
entries on the Blog summary page so that readers don’t feel 
compelled to scroll down a long list of entries. In the Inspector, 
click the Blog & Podcast button (the blue RSS button) and 
change the number of excerpts if you like—iWeb defaults to ten, 
which may be a good number to start with (Figure 48). 

FIGURE 48 

 

You make five important 
decisions in the Inspector:  
• How many excerpts 

to show on the Blog 
summary page. 

• The length of each blog 
excerpt. 

• Whether to allow 
comments. 

• Whether to allow files to 
be attached to comments. 

• If your Blog page should 
offer a search field. 

   f. Set the length of each blog excerpt: With the Blog view 
of the Blog & Podcast Inspector still open, adjust the excerpt 
length by moving the slider left or right. At the leftmost setting, 
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each blog entry appears as a headline, date, and “read more” 
link. With the slider all the way to the right, each blog entry 
will appear on the Blog summary page in its entirety, but with-
out any associated images. I prefer to show about five lines 
of each excerpt, enough to whet my readers’ appetites so that 
they’ll click the “read more” link. 

g. Set the formatting for each blog excerpt: Click once on 
the sample blog excerpt to display the Blog Summary window 
(Figure 49). You can use this tool to choose the placement 
of the text for all entries in relation to the picture, get rid of 
unwanted image placeholders, change the size of the photos, 
add extra space between multiple photos in a blog posting, 
and change the proportions of the photo. 

FIGURE 49 
 

 

The Blog Summary 
window, new to iWeb 2, 
provides a way to fine-
tune the look of entry 
excerpts on the Blog 
Summary page. 

   
h. Allow comments: If you wish to allow readers to comment 

on your Blog posts, check the “Allow comments” box. Although 
comments add interactivity to blogs, they can also provide a 
target for spammers who seek out and destroy blog sites with 
unwanted advertisements. 

 Comment compatibility: Comments set up in iWeb 
work only if you publish to a MobileMe account. If you 
publish to another Web host, be sure to read Add Special 
Elements, later in this book. 

  
i. Allow attachments: If you’ve allowed comments, you should 

also decide if you want to let people attach files to their written  
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comments. In my opinion, this is a bad idea unless you’re 
running a private Web site and know who will be sending files 
to your Web server. 

Now that the Blog summary page is ready to go (Figure 50), you 
can replace the placeholder text with an actual entry. 

FIGURE 50 
 

 
 The main Blog page is ready to go. With a new picture, my own title, 

and a description of what I’ll be writing about in the blog, I can start 
typing blog entries. I’ve entered a post titled “Go Rockies” already, 
as you can see in this screenshot.  

  3. Add a blog entry: In the Sidebar, click the Entries item. Now, 
above the Webpage canvas, you’ll see a list of entries containing 
a default, new blog entry, and at the bottom you see a placeholder 
page for the new blog entry (if you don’t see a new placeholder 
page, click the Add Entry button, located below the list of blog 
entries). Let’s edit the placeholder page: 

a. Edit the title of the blog entry: Double-click the title to 
select it, and then type a new title. The title does not appear 
in the URL for the entry page, so you don’t have to worry about 
technical considerations when you choose your title. My first 
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entry is called “Does this guy feel bloggy,” describing the look 
on the face of an architectural detail in Florence. 

b. Delete or change the headline: The template that I’m using 
has a big headline at the top of the page as well as a title for 
each entry. If you feel that the headline is a redundant feature, 
you can delete it or you can change it to something different.  

c. Delete or customize the picture: When you do a lot of 
blogging, you don’t always have a photo to go with your text. 
If this is the case with your blog entry, delete the picture to save 
space and make the page load faster. To delete the picture, click 
it to select it, and then press Delete. You can also replace the 
photo with one of your own, as described in Change the Picture. 

d. Write your blog entry: Now it’s time to play Ernest 
Hemingway and sweat over a hot keyboard. Triple-click the 
lorem ipsum of the text placeholder and begin typing your 
masterpiece. Concentrate on your writing and not on how the 
text looks. (In Make Text Sparkle, I show you how to perform 
tricks with your text to make your blog entries stand out.) 

4. Add an RSS button: Most iWeb blog pages include a Subscribe 
to RSS Feed button. This button lets your readers subscribe to your 
blog and receive the latest updates as they occur. If the button is 
not included on your page, or if you have inadvertently deleted it, 
choose Insert > Button > Subscribe to RSS Feed. 

5. Save: At this point, you should save your Web site (choose File > 
Save), and then publish it to MobileMe or another Web server, as 
I described in Publish Your Site.  

If your blog or any of the other pages you’ve created aren’t exactly 
what you had in mind, don’t worry, unless you don’t like the look of 
your Blog summary page—try a different template if that’s the case, 
since it’s difficult to modify that page and have your changes stick. 
You’ll have plenty of opportunities to fine-tune your Web site and 
add new features as we continue. 
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PUBLISH A PODCAST 

What’s the fastest-growing new media on the planet? Podcasts. Pod-
casts, online radio shows, are consumed whenever, wherever, and 
however the listener desires. A typical podcast has three features: 

• It has a number of episodes, all dealing with a particular subject. 

• Listeners can subscribe to a podcast using podcatcher software 
like iTunes or Juice. By subscribing to a podcast, listeners will 
receive the latest episode automatically. 

• Listeners can enjoy a podcast on a mobile device, such as an iPod, 
iPhone or other MP3 player.  

Hundreds of thousands of podcasts are available today on almost 
any conceivable topic from “A Bluegrass and Old Time Radio Show” 
to “Zolfo Springs, Florida Weather.”  

Podcasts can go beyond the audio to include video, at which point, 
we call them video podcasts, or vodcasts. Video podcasts won’t neces-
sarily appeal to people who like to listen while they do something else, 
but they do have advantages: 

• It’s easier to demonstrate devices or processes when you can show 
your audience what you’re talking about instead of describing it. 

• The combination of sight and sound is much more engaging than 
audio alone. Would you rather see bright blue water, sparkling 
sand, and swaying palm trees in a travel podcast, or only hear the 
podcaster describing them? 

As an owner of iLife ’08, you have three powerful integrated tools 
at your disposal for recording, editing, and publishing podcasts— 
GarageBand, iMovie 7, and iWeb 2. GarageBand has special podcast 
tools, including automatic ducking (turning down the volume of 
music when narration begins) and adding iTunes enhancements 
(such as chapters). iMovie 7 is the video podcast equivalent of 
GarageBand, and it can transfer your video masterpiece into a Web-
friendly, low-bandwidth version that plays nicely in a Web browser 
or on an iPod. 
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Create a Podcast Section 
Although you can use your blog area to host podcasts, you will prob-
ably want to add a podcast section to your Web site. For instance, on 
my example site, I created not one, but two, podcast sections, one for 
my audio podcast called Listen, and another for my video podcast 
called Watch.  

Here’s what to do: 

1. Add a podcast section: Choose File > New Page (Command-N) 
or click the plus ( ) button below the Sidebar. Select the Podcast 
page type for your template, and then click Choose.  

The Sidebar shows a new Podcast item, a new Entries item, and an 
Archive page. Initially, iWeb selects Entries, showing you a default 
layout for a new episode in the Webpage canvas, and an episode 
list above the Webpage canvas. 

2. Click Podcast in the Sidebar to view your new Podcast summary 
page (Figure 51). 

FIGURE 51 
 

 
 Here is the Podcast summary page in the Modern Frame template.  

iWeb also creates a podcast entries page (called Entries in the 
Sidebar) and an Archive page that organizes older podcasts. 
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3. Customize the Podcast summary page: 

a. Change the page name: Your Podcast summary page has 
the default name Podcast and that name appears in the navig-
ation links. If you prefer a different name, double-click Podcast 
in the Sidebar to select it and type a new name following the 
naming suggestions I made earlier in Name Your Site. For 
my sample site, I used Listen as the Podcast page name. 

b. Customize the title: In the Webpage canvas, double-click 
the title to select it and type a new one. I chose Take Control 
of Steve’s Podcast for my podcast. 

c. Replace the podcast description: Double-click the descrip-
tion text to select it, and replace it with a persuasive reason why 
people should take the time to listen to your podcast. 

d. Change the picture: Drag a photo from the Desktop or the 
Media Browser to the placeholder (see Change the Picture for 
help with the Media Browser).  

e. Set how many entries to show: It’s good to keep the 
Podcast summary page short, so it will load quickly. In the 
Inspector, click the Blog & Podcast button (RSS) and, in the 
Blog view, set the number of excerpts (in this case, “excerpt” 
means “episode descriptions”). 

f. Set the length of each episode description: With the 
Inspector still open, adjust the excerpt length by moving the 
slider left or right. Show at least five lines so your description 
is long enough to encourage visitors to click the “listen” link. 

g. Set the podcast details: In the Blog & Podcast Inspector, 
click the Podcast button. In the Podcast view (Figure 52), 
enter the name or names of the people who are the podcast 
hosts in the Series Artist field. Also be sure to enter a contact 
email address. The address does not show up in iTunes, but is 
used by the iTunes Store for contact purposes. Is your podcast 
something that would be considered adults-only? If so, please 
choose Explicit from the Parental Advisory pop-up menu. 
Finally, check whether or not you want to have the podcast 
appear in the iTunes Store listings.  
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FIGURE 52 
 

 

There’s a difference between 
a Podcast Series and a 
Podcast Episode: 
• The “Podcast Series” 

section at the top of this 
Podcast view provides 
the iTunes Store with 
information about your 
podcast that appears in 
the directory listing.  

• The “Podcast Episode” 
controls at the bottom 
are dimmed here because 
an episode is not selected. 
These details can vary 
by episode. If a particular 
episode needs different 
details than the series, 
you should come back 
here later and change 
the information for that 
episode. 

   
5. Most iWeb podcast pages include a Subscribe button. This button 

lets your readers subscribe to your podcast in an application like 
iTunes. If the button is not included on your page, or if you have 
inadvertently deleted it, choose Insert > Button > Subscribe to 
Podcast to place this important button on the page. 

That’s it—you’ve customized your Podcast summary page. Now, it’s 
time to add an episode. 
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Add an Episode  
You can add an episode from GarageBand or iMovie 7. If you’ve 
already taken care of the encoding and don’t want to use GarageBand, 
or if you’re using other software to create your podcasts, you can add 
episodes from the Finder or Media Browser. I provide the steps for 
each possibility here. 

Add an episode from GarageBand  
If you created your episode in GarageBand and wish to add it to your 
Web site in AAC MPEG 4 or MP3 format, you can accomplish that 
with only a few clicks: 

1. With your podcast file open in GarageBand, choose Share > Send 
Podcast to iWeb. 

2. Choose the type of compression (AAC or MP3) and the Audio 
Settings (Good, High or Higher Quality).  

GarageBand launches iWeb, creates a mixdown (mix of the dif-
ferent channels you’ve recorded) of the podcast, and converts the 
recording from GarageBand format to your chosen audio format. 
Patience is a virtue during this process—it took my 2 GHz Intel 
Core Duo iMac almost 6 minutes to process a 24-minute podcast. 

3. Choose the “blog” to send the podcast to (iWeb considers a podcast 
to be another type of blog), and click OK. If you have only a single 
blog or podcast page rather than both pages, you don’t get a choice— 
the podcast is sent to the blog or podcast page that exists already. 

Your podcast episode is added to the episode list. If you added 
pictures to your podcast while editing it in GarageBand, the first 
picture in the podcast track appears in the picture placeholder 
(I used an iPhone podcast for my example, as you can see in 
Figure 53). If you don’t add any pictures to your podcast, iWeb 
uses a generic podcast icon.  

 Warning! If you try to drag-and-drop your own image into 
the picture placeholder, you’ll lose your picture and podcast 
episode as well. Use GarageBand’s podcast track to add the 
picture, or use the generic podcast icon added by iWeb as your 
picture. 
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FIGURE 53 

 

The first pic-
ture in your 
GarageBand 
podcast track 
appears in the 
picture place-
holder.  
iWeb uses 
the name of 
your Garage-
Band podcast 
as the title 
description. 

   4. Edit the episode title—you may have given your episode a name in 
GarageBand that doesn’t make sense for it on the Web. If you want 
to change the name, triple-click the title and type the new name. 

5. Edit the headline. To delete it, click the headline and press Delete. 
To change the headline, triple-click it and type your new headline. 

Your podcast is now added to your iWeb site. Save your iWeb site and 
publish it using the instructions in Publish Your Site.  

 Podcast won’t play: You may run into a situation where you’ve 
exported a podcast directly from GarageBand to iWeb as an AAC 
file, then found that it won’t play in a Web browser. Instead, you 
see a QuickTime logo with a question mark on it and when you 
click that logo, it takes you to a download page for the latest ver-
sion of QuickTime.  
If this happens to you, share the podcast with GarageBand and 
convert the file to MP3 format instead of AAC.  

  
Add an episode from iMovie 
You can easily add video podcast episodes made in iMovie 7 to your 
iWeb site:  

1. With your episode file open in iMovie, choose Share > iWeb. 
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2. iMovie 7 prompts you to choose between two types of Web movie 
file settings. Select “Share for Video Podcast,” and then click Share.  

iMovie processes the video clips, transitions, and effects you’ve 
added, and compresses the video into M4V format. The processing 
can take some time. My example video is slightly over a minute 
long, yet it took 3.5 minutes to complete this step. 

  
NOTE If you select “Share for Web,” iMovie 7 assumes that the video 

will be watched from a Web site, while the “Share for Video 
Podcast” option creates video for watching directly on an iPod 
or other mobile device. There is a quality difference: “Share for 
Web” creates a 320 x 240 pixel movie at 12 frames per second 
with medium-quality stereo sound, while “Share for Video 
Podcast” movies are 30 frames per second with H.264 video 
and 44.1 kHz AAC stereo sound.  
My example video podcast is a little over a minute long and the 
difference in size between the two settings wasn’t much—5 MB 
for “Share for Web” versus 6.4 MB for “Share for Video Podcast.” 

  
3. When prompted, choose any blog or podcast on your site as the 

location for your episode.  

Your episode is added to the episode list in the section you chose. 
iWeb shows the first frame of the video on the episode page.  

  
TIP I began my first video podcast with a black title screen that 

shows an animated title. Unfortunately, the first frame is com-
pletely black so the picture in iWeb was a black box. To avoid 
this in your video podcasts, either add a still photo at the start 
of your video podcast or overlay titles right onto the video. 

  
4. If you gave your video podcast episode a name in iMovie that 

doesn’t make sense for it on the Web, change it now by triple-
clicking the title and typing the new name. 

5. Delete or change the headline. To delete it, click the headline and 
press Delete. To change it, triple-click it and type a new headline. 

Your video podcast is now ready to go live! Save your iWeb site and 
publish it using the instructions in Publish Your Site. 
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Add an episode from the Finder 
If you’d prefer not to use the encoding options in GarageBand or 
iMovie, or if you already created the file in another program, follow 
these steps to add your episode (in MP3, M4A, or M4V format) to 
your iWeb site:  

1. In iWeb’s Sidebar, under the name of your podcast, select Entries 
to show the episode list and Webpage canvas.  

2. Click the Add Entry button below the episode list to open a new 
episode page in the Webpage canvas.  

3. Drag your podcast file from the Finder and drop it on the podcast 
placeholder, which looks like a picture with audio/video player 
controls below it (Figure 54). 

FIGURE 54 
 

 

The podcast placeholder 
consists of a picture 
with audio/video player 
controls just beneath it.  
You should replace 
the lorem ipsum below 
the placeholder with 
descriptive text about 
your podcast. 

   
4. Set up the picture: 

• In the case of an audio podcast, if you added any pictures to it, 
the first picture appears in place of the placeholder picture and 
you are all set. Otherwise, a new placeholder appears with the 
words “Drag Image Here.” Drag a picture in from the Finder or 
the Media Browser and drop it on the placeholder.  

• In the case of a video podcast, iWeb uses the first frame of your 
video file as the podcast picture. 

Your podcast is now ready to go live on the Internet. Save your Web 
site, and then publish it using the instructions in Publish Your Site. 
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Submit a Podcast to the iTunes Store 
Doing all this work to publish a podcast to your Web site is a waste of 
time if nobody listens to or watches your work. If you are a MobileMe 
subscriber, iWeb 2 provides a quick way to add a podcast listing to the 
iTunes Store. The iTunes Store is the largest podcast directory, so you 
can rest assured that if someone is looking for a podcast about your 
area of expertise, they’ll find your work in their search results. Follow 
along as I submit my podcast to the iTunes Store: 

1. Choose File > Submit Podcast to iTunes.  

A dialog appears (Figure 55). Notice that iWeb has pre-populated 
a lot of information. The podcast description and photo that you 
entered earlier are already formatted and ready to send to iTunes. 

FIGURE 55 
 

 
 

The violet background, the photo, and the description of the podcast 
are in the iTunes Store podcast directory.  

  
2. Enter copyright information, if applicable to your podcast. Choose 

the Category and Sub-category (if applicable) for your podcast, and 
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then the language in which it is recorded. Finally, be sure to enter 
parental advisory information. You have your choice of none, clean 
(for podcasts that are acceptable for any age group), or explicit 
(podcasts that contain subject matter appropriate only for adults). 

3. Click the Publish and Submit button. 

iWeb begins the process by publishing your Web site. Once that 
is completed, iWeb opens iTunes and begins the submission by fill-
ing in the URL to the RSS feed file (a file used by iTunes and other 
podcasting applications to subscribe to your podcast).  

Figure 56 shows what I saw when I submitted my podcast to the 
iTunes Store. 

FIGURE 56 
 

 
 

You needn’t wonder what your feed file Web address is—iWeb 
provides that information to the iTunes Directory automatically.  

  
4. Click Continue. At this point you must sign in using your Apple 

ID and password. You have a final chance to check your podcast 
description in the Review Podcast screen that appears. If every-
thing is acceptable to you, click the Submit button.  
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iTunes responds with a short message telling you that any corre-
spondence regarding your podcast will be sent to the email address 
you provided in the Blog and Podcast Inspector. In a few minutes, 
you’ll receive an email message notifying you that your podcast feed 
was successfully added and is under review. If everything is fine, 
another message follows within a day or two with code that you 
can use to add a link that lets listeners subscribe to your podcast 
with a single click. 

Now that you’re a successful podcaster, be sure to keep both your 
podcast and your site updated.  
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ADD PHOTOS 

Digital photos are great! It’s so easy to take pictures with your digital 
camera and transfer them to your Mac, then retouch and categorize 
them in iPhoto. With iWeb, it’s straightforward to add a gallery to 
your Web site so visitors can read about a vacation trip and then view 
pictures from the trip in an animated slideshow.  

Of course, you can insert a single photograph anywhere in your site, 
but iWeb also provides a few special options: 

• Photo pages: These pages are set up to display as many as 300 
photos on a page. If you publish to MobileMe, they also offer a nice 
slideshow option. 

• My Album pages: New in iWeb 2, these Web pages organize 
multiple iPhoto albums on a single page. Once you Set Up a My 
Albums Page, viewers of the page can click an iPhoto album’s 
thumbnail-style cover image to open a Photo page showing its 
contents.  

• Web galleries: New in iLife ’08, you can Work with Web 
Galleries in iPhoto and publish them to your MobileMe account. 
Web galleries have a number of nice features for fun and easy 
viewing of photos, and you can put an animated, clickable, 
thumbnail-style image leading to a gallery on any page in iWeb. 

  
TIP MORE INFO ON PHOTOS AHEAD 

For advice on making your photos faster to download for people 
viewing your site, enhancing their appearance using tools in 
iWeb, or for details on making them into clickable links, see the 
next section, Enhance Photos. 

  

Create a Photo Page 
iWeb has a special, attractive page type—the Photo page—specifically 
for publishing your pictures on your Web site. iWeb even provides a 
slideshow feature to show your pictures in sequential order.  
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Let’s create a Photo page: 

1. If you want to export photos from iPhoto to iWeb, you can 
continue with these steps, but if you’d prefer to work in iPhoto 
immediately before the export, perhaps to double-check photo 
names, or to make sure an album is properly set up, skip ahead 
to Export Photos from iPhoto to iWeb. 

2. Add a Photo page to your Web site by choosing File > New Page 
(Command-N) or pressing the plus ( ) button below the Sidebar. 
Click the Photo template, and then click Choose.  

A Photo page with placeholders appears (Figure 57). 

FIGURE 57 

 
 The headline (Matt’s Photography), text, and photos are all place-

holders for your custom content.  

  3. If you plan to have more than one Photo page or don’t like the 
name Photos, you can change the name. Double-click Photos in 
the Sidebar to select it, type the new name, and press Return. Since 
my example site only has one photo album, I’m going to continue 
calling the page Photos. 

4. The headline on the page, “Matt’s Photography,” may work well 
for Matt, but not for you. Double-click the headline placeholder 
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and type a new title. For my example Photo page, I changed the 
headline to Random Pictures.  

5. That paragraph of lorem ipsum needs to go. Double-click it, and 
then type a description of the pictures you’re adding to the Photo 
page. 

6. A Photo page can hold up to 300 pictures. There are three ways 
you can add photos to your Photo page: 

• You can drag an individual picture from the Media Browser and 
drop it on a photo placeholder. 

• You can drag a complete photo album from the Media Browser 
onto a photo placeholder.  

• You can drag the photo from the Finder and drop it on a Photo 
page. 

7. You may decide that a photo looks better in a different location 
on the Photo page. To move a photo, drag it. The other photos will 
shift as you do this.  

8. What if you have unnecessary duplicates? Select any photos you 
want to delete by clicking them, and then press Delete. You can 
select multiple photos for deletion by Command-clicking them, 
or highlight a range of photos by Shift-clicking.  

9. Photos that you bring into iWeb may have a short default caption, 
perhaps something like 2008Photo(113), 105-0501_IMG, or equal 
nonsense. To edit a caption, click it to select it, and then type your 
new text. You can type longer captions than those that appear on 
the Photo page, but they will be visible only in the slideshow. 

10. By default, iWeb shows only two lines of your photo captions. 
To change the number of lines, click on one of the photos to 
display the Photo Grid window (Figure 58) and adjust the 
Caption lines option by clicking its up or down arrow. 
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FIGURE 58 
 

 

Use the Photo Grid window 
to change the number of 
columns and lines in the 
caption, frame your pic-
tures, and set the number 
of photos on each page.  

   
11. In most iWeb templates, pictures are initially placed in three 

columns. To make photos appear larger or smaller, you can change 
the layout by selecting the number of columns (from one to six) in 
the Photo Grid (Figure 58, above).  

12. Wouldn’t your photos look nice with picture frames around 
them? Scroll through the available frames under Album Style 
on the Photo Grid window, then click one to apply it.  

  
NOTE There’s an alternative to frames that looks just fine on many 

Web sites. You can add a color border to all your photos by 
selecting a plain frame style, then using the Stroke controls in 
the Graphic Inspector to add a solid line: choose a color for the 
border from the color well, then increase the line thickness by 
adjusting the points in the un-labeled field. 

  
13. You can add even more depth to your photos by adding a shadow. 

From the Graphic Inspector, check the Shadow box; then adjust 
the color, angle, offset, blur, and opacity of the shadow to your 
liking. I used a frame that makes it look like I printed my pictures 
on photo paper and then taped them to the page (Figure 59). 
The shadow gives a feeling of depth to the page. 

You have now created a Photo page. After you next publish your site, 
you can send email to your friends, relatives, and co-workers and brag 
about your Photo page. Also, you may wish to link to your new Photo 
page from the About Me page. 
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FIGURE 59 
 

 
 My customized Photo page looks different than the template page, 

and it took little work to change the format and frame style.  
Play Slideshow and Subscribe buttons are automatically added to a 
Photo page. When clicked, the Play Slideshow button opens a new 
window that displays your pictures one at a time, while the Subscribe 
button allows subscribers to use a Web browser to view the RSS feed 
of your page. They can view your latest photos whenever you update 
the site. 

  
Enhanced vs. Regular Slideshows 
Visitors to your Web site can view a slideshow of your photos by 
clicking the Start Slideshow button on your Photo page. When you 
publish your site to MobileMe, the slideshow is enhanced. The photos 
appear on a black background with a reflection at the bottom, the 
slideshow plays without further clicks from the viewer, and a filmstrip 
appears at the top of the current slide when the mouse hovers there, 
which allows the viewer to select other slides in the slideshow. 
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I was concerned that some of my friends who use Windows might 
not be able to view the enhanced slideshows, but testing shows that 
the slideshows work well in Windows Web browsers. 

If you use Publish to Folder and host your site on another server, 
you won’t get the enhancements in your slideshow, and, in fact, it 
won’t be a slideshow. It will appear on a white background with a 
brushed steel border, viewers must click a forward or back button to 
move to the next or previous slide, and there is no filmstrip available 
for quick navigation to another slide. 

Set Up a My Albums Page 
A new feature in iWeb 2 is the My Albums page type, which features 
photo albums from iPhoto instead of individual photos. By clicking 
an album cover, guests to your Web site can then see the individual 
photos that make up the album or view a slideshow. Let’s go step-by-
step through this process: 

1. Add a My Albums page. Choose File > New Page (Command-N) 
or press the plus ( ) button below the Sidebar. Select a theme, 
click the My Albums template, and then click the Choose button. 
A blank My Albums page is added to your iWeb site (Figure 60). 

FIGURE 60 
 

 

Our mystery friend Matt 
is back, this time with 
albums full of his photo-
graphy. Of course, all of 
these are placeholders 
you need to change to 
customize your iWeb 
site. 
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2. Customize the page headline and title. Double-click the page 
headline and type in your headline, and then double-click the title 
to edit it. 

3. That black and gray spiral-bound photo album in the theme I 
chose (Figure 60, previous page) is a bit boring. iWeb provides 
a way for you to change the style to one of 17 types. Click the album 
and a transparent black dialog appears (Figure 61). 

FIGURE 61 
 

 

Use the Media Index 
dialog to change the 
look and features of 
your photo albums. 

   
4. Click the Index style button and a pop-up menu appears showing 

all 17 styles of photo albums. Click on one of the album buttons to 
apply the style to the album on your page. 

5. Since the Media Index dialog is still visible, you can use it to 
change several other features of your My Albums page: 

• To disable the title that appears below each album, uncheck the 
“Show title” box. 

• iWeb shows the number of photos in an album just below the 
album. To turn off the numbering, uncheck “Show number.” 

• How many columns of albums would you like to see on you’re 
my Albums page? From the Columns pop-up menu, choose 
from 1 to 4 columns.  

• The Spacing slider adjusts the amount of blank space between 
the albums. 

• Someone viewing the My Albums page can see the contents of 
each album without opening it by hovering the mouse pointer 
on the album cover. The Album animation pop-up menu gives 
you the choice of no animation or a variety of transitions 
between the pictures when someone hovers the pointer. 
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• If you’d like your visitors to be able to subscribe to an album 
in iPhoto, make sure the “Allow subscribe” checkbox is checked. 

6. Once you’ve changed the settings for the My Albums page, close 
the Media Index dialog by clicking the X in the upper left-hand 
corner of the box.  

7. Now add your albums. You can drag them one at a time, or as a 
group, from the Media Browser and drop them on the page. An 
album appears on the My Albums page for each album you drag 
and drop. 

8. If you don’t like the name of an album as shown in the Sidebar, 
you can change it by double-clicking it and editing the name.  

9. Each album you dropped onto the My Albums page has a Photo 
page associated with it. Readers who click an album are taken to 
that Photo page. Since iWeb creates these Photo pages with stan-
dard placeholder text, you need to customize each of the pages. 
(For help, see the previous subsection, Create A Photo Page.) 

To see an example of how the My Albums page works, visit 
http://www.tcoiweb.com/TCiWeb2/My_Albums/My_Albums.html. 
It’s an excellent way to organize a lot of photos. 

Export Photos from iPhoto to iWeb 
Dragging individual photos or albums from the Media Browser to 
an iWeb page isn’t the only way to copy photos to iWeb. In many 
cases, you may be working in iPhoto when the desire to publish 
your photographs strikes you. Here’s what to do: 

1. First edit the names of the photos in iPhoto, since the names will 
serve as captions in iWeb. 

2. Select the items you want to share, and click the iWeb button in 
the iPhoto toolbar to pop up two choices—Photo Page and Blog:  

• Photo page: Choose Photo Page to export the photos to a new 
iWeb Photo page. (If you had an album selected when you chose 
Photo Page, the page will have the same name as the album.)  

• Blog: Choose Blog to share photos with one of your iWeb 
blogs. iWeb adds one new entry for each photo.  

http://www.tcoiweb.com/TCiWeb2/My_Albums/My_Albums.html
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Once you’ve exported photos from iPhoto to iWeb, be sure to edit 
your new iWeb Photo page or blog to match the style and content 
of the rest of your site.  

Work with Web Galleries 
iPhoto 7 adds the Web Gallery, a new feature that replaces the 
photocasts available in some previous versions of iPhoto. A Web 
Gallery is a page displaying photo albums that you publish to a 
MobileMe account. Each album is viewable by others, and you can 
choose to make individual albums available to everyone or only to 
people you’ve provided passwords to. You can also choose to allow 
viewers to download your photos or upload additional photos to 
the album.  

What I personally like about Web Galleries is how good they look! 
Visitors to the My Gallery page see each of your published albums, 
and they can quickly review the contents of the albums simply by 
moving their pointer left and right over the album. This motion 
allows the visitor to scroll quickly through all of the photos in an 
album without having to open it. 

When visitors decide to open an album, they initially see the photos 
in a grid, but from the bottom of the page, they can access more view-
ing options. For instance, there’s a carousel view that works like the 
Cover Flow effect in iTunes. And there’s a slideshow option. 

You can add an album from an iPhoto 7 Web Gallery to your iWeb 
page by choosing Insert > MobileMe Gallery. From here, pick an 
album, and iWeb will put a small, animated photo onto your iWeb 
page. What I mean by “animated” is that it automatically shows the 
album as a slideshow. It also provides the same functionality of a Web 
Gallery in MobileMe: Moving the mouse pointer left and right over 
the photo scrolls through all of the photos included in the album. 

Your visitors can click on the photo to open a new browser window 
featuring the album in your iPhoto 7 Web Gallery, complete with the 
usual Web Gallery viewing controls like the carousel view. 

With all of this talk about photos, let’s move on to a discussion about 
making those photos look great on your Web page. 
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ENHANCE PHOTOS 

iWeb 2 gives you the power to do more with your online photos. In 
this section, I describe how to create interesting effects, frames, and 
shadows, and even how to use my favorite new iWeb 2 tool—Instant 
Alpha, which eliminates cluttered backgrounds in photos. I also cover 
editing photos so that they load faster (see Accelerate Picture Down-
loads), how to turn almost any picture into a clickable hyperlink (see 
Create Picture Hyperlinks), and how to Make an Image Map. 

The Fine Points of Formatting Photos 
Here are my favorite tips for formatting photos in iWeb: 

• Removing, adding, or changing reflections: Some iWeb 
templates automatically place a reflection under large pictures 
on certain pages. You can add, remove, or change reflections on 
almost any picture through the Graphic Inspector: select the pic-
ture, open the Graphic Inspector, and configure the “Reflection” 
checkbox and slider. Reflections cannot be added to photos that 
represent iPhoto Web galleries. 

Reflections aren’t always appropriate. I like them under large 
single photos on a page, but they seem distracting and unnecessary 
on pages with a lot of text or multiple photos. I tried reflections 
under the photos on the Examples page of my Web site and didn’t 
like them (Figure 62). 

FIGURE 62 
 

     
 Photos on a Web page without (left) and with (right) a reflection. 

Should you use a reflection? You make the call. In this case, I found 
the reflection distracting, so I removed it. 

  • Adding, removing, or changing shadows: You can make 
photos appear to float over a Web page by adding a shadow. I find 
shadows less distracting than reflections, and they can add depth 
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to an otherwise flat and uninteresting page. As with reflections, 
shadows can’t be applied to a photo that represents an iPhoto 
Web gallery. To add a shadow, select a photo, open the Graphic 
Inspector, and set the Shadow checkbox and other controls: 

◊ Color: I usually don’t adjust this, since most shadows are 
shades of gray in nature. However, you can click the color well 
to pick a new tone.  

◊ Angle: I recommend the default, which is 315°. That places the 
“sun” above and to the left of your Web page.  

◊ Offset: The offset is the apparent depth of the shadow—a small 
number makes the picture appear to float above the Web page, 
while the highest offset (50) gives the illusion that the photo is 
about three-quarters of an inch above the page.  

◊ Blur: The blur defines whether the shadow is sharp or fuzzy. 
Smaller numbers make the edge of the shadow sharper, and the 
shadow edge becomes more diffuse as the number gets higher 
(the highest setting is 100). I prefer slightly more diffuse edges 
for higher offset numbers.  

◊ Opacity: Smaller opacity numbers create a light shadow, while 
larger numbers (the maximum is 100) make a dark shadow. I 
prefer to make the shadow slightly less opaque as the offset 
increases (Figure 63). 
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FIGURE 63 
 

     
 Shadowing pictures (right) brings the illusion of a third dimension to 

your Web page and adds an interesting touch to your photos. 

  • Changing the opacity of photos: In the Graphic Inspector, 
move the Opacity slider left to decrease the opacity and make the 
selected picture appear more transparent. Use this effect to make 
a photo appear hazy, as in a distant memory.  

• Using photos as page backgrounds: Open a page and then 
open the Page Inspector. Choose Tinted Image Fill from the Page 
Background pop-up menu, and then click Choose to select the 
picture you wish to use as the background. Once you’ve selected 
a picture, choose Scale to Fill from the middle pop-up menu.  

Finally, click the color well to tint the picture, if desired. I don’t 
tint my pictures, but I adjust the Opacity slider so that only a hint 
of the picture shows in the page background (Figure 64).  
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FIGURE 64 
 

 
 To jazz up a blog entry about my beloved Colorado Rockies, I used 

a game photo as the page background, reducing its opacity to serve 
as a non-disruptive backdrop.  
I used shadowing to make the blog photo appear to float over the 
background.  

  
Instant Alpha 
No, it’s not a new fast-cooking oatmeal, nor is it anything like Instant 
Karma. iWeb 2’s Instant Alpha is a fun and useful effect that lets you 
turn a color or colors transparent. It works best when the item you 
wish to highlight (a person, for example) is surrounded by the color 
you want to make transparent. 

For the Examples page of my Web site, I want to highlight a small 
bronze sculpture of a raven. When I took a picture of the sculpture, 
it was against a yellowish background that detracted from the Web 
page. What I need is to have the sculpture and its shadow without 
the background color. Here’s where Instant Alpha really shines: 

1. After placing the picture on the Web page, click on it to select it. 

2. Choose Format > Instant Alpha. 
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An informational dialog appears on the screen (Figure 65). 

FIGURE 65 
 

 
 

Is this the first time you’ve used Instant Alpha? Have you used it 
before, but forgotten how it works? iWeb provides succinct help each 
time you invoke Instant Alpha. 

  
3. As noted in the dialog, just click on the color you want to make 

transparent and then drag the mouse. A brown highlight grows 
over the area you’re making transparent, indicating the region 
that will become transparent. 

4. If not all the color surrounding the image becomes transparent, 
click and drag in several areas around the image.  

5. When you’re satisfied, press Return and the color disappears, 
leaving only the sculpture and its shadow (Figure 66). If I was 
really daring, I could remove the shadow as well. 

FIGURE 66 
 

               
 

The Jim Eppler raven sculpture before (left), during (center), and 
after (right) applying Instant Alpha. You can see a short movie of this 
process at http://www.tcoiweb.com/TCiWeb2/Video.html. 

  

Accelerate Picture Downloads 
A big complains about the first version of iWeb was how long it 
took for a Web browser to render pictures on an iWeb page. I’m 
happy to say that iWeb 2 does a much better job of optimizing photos 
than its predecessor. However, you can help your readers enjoy their 
Web browsing even more by doing manual optimization. It’s easy 
to optimize your photos for Web viewing. To learn how, follow 

http://www.tcoiweb.com/TCiWeb2/Video.html
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along with me as I fix a photo. First, download and install 
GraphicConverter, a nifty shareware utility from Lemke Software 
(http://www.lemkesoft.com/, €29.95 or $34.95). 

 Important iPhoto info! If you are working in iPhoto, follow 
these steps before editing photos in GraphicConverter: 
1. Create an album for photos you intend to optimize, and put 

duplicates of your photos in it, so edits you make to those copies 
won’t change your originals: Choose File > New Album 
(Command-N) to make the album. Now, select the desired 
photos and choose Photos > Duplicate (Command-D). Finally, 
drag the photos with “copy” in the title to your new album.  

2. In iPhoto’s General preference pane, from the Edit Photo pop-up 
menu, choose In Application and then choose GraphicConverter 
to tell iPhoto that GraphicConverter should be an editing choice. 

3. If you want to usually use GraphicConverter to edit photos, 
leave the Edit Photo pop-up menu set to GraphicConverter. But, 
if you want to usually edit photos in iPhoto, change the Edit 
Photo menu to another option.  

Now, to edit a photo in the new album in GraphicConverter, 
double-click it or Control-click (or right click) it and choose 
GraphicConverter from the menu that appears. 

 

Now, I’ll open a photo in GraphicConverter, and then open the 
Information panel by choosing Window > Show Information 
(Control-Command-I). Here’s what it says about my photo: 

Size: 2,048 x 1536 pixels 

Resolution: 180 x 180 ppi 

Colors: 16.7 million (32-bit) 

File Length: 931.7 KB 

This explains why it takes so long for that picture to load. My iWeb 
page is only 700 pixels wide, so the image is being scaled down to fit. 
And since most monitors display graphics at about 72 pixels per inch, 
the resolution is overkill. And must I show the picture in 16.7 million 
colors?  

Clearly, there is room to shrink this photo: 

http://www.lemkesoft.com/
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• Decrease the bit depth (number of available colors): I 
start manipulating the picture in GraphicConverter by changing 
the bit depth (number of colors available) to 16-bit (32,768 colors) 
by choosing Picture > Colors > Change to 32768 colors (16-bit) 
(Control-Command-5). This didn’t change the look of the photo 
noticeably, but it did reduce the file size (called file length in the 
Information panel).  

• Reduce the resolution: Next, I reduce the resolution to 72 x 72 
ppi by choosing Picture > Resolution (Command-Option-R) and 
entering 72 in both fields. This decreases the size of the image to 
819 x 614 pixels, decreasing the file size as well.  

• Scale: Finally, I scale the picture down to 700 pixels wide while 
keeping the proportions of the original photo. I choose Picture > 
Size > Scale (Control-Command-Y), make sure the “Keep 
Proportions” and “Scale Picture” boxes are checked, and then 
enter a width of 700 pixels. 

Now the Information panel shows the following statistics: 

Size: 700 x 525 pixels 

Resolution: 72 x 72 ppi 

Colors: 32,768 (16-bit) 

File Length: 294.1 KB 

The new file size is less than a third of the original, meaning it should 
load about three times faster than the original picture.  

 Watch out for masking! Even if you optimize your images, the 
automatic masking that iWeb performs on images that are dropped 
into certain placeholders will still slow rendering of those pictures 
in Web browsers. To avoid this, use iWeb’s predefined graphic 
placeholders sparingly, and turn off masking if you do use them.  
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NOTE GraphicConverter isn’t the only software you can use to optimize 

your photos for use in iWeb, but I recommend it because it’s 
inexpensive and powerful. Some other applications are: 
• Adobe Photoshop Elements: 

http://www.adobe.com/products/photoshopelmac/, $89 
• Adobe Photoshop CS3: 

http://www.adobe.com/products/photoshop/, $649 
• Apple Aperture: http://www.apple.com/aperture/, $199 
• ArcSoft PhotoStudio: 

http://www.arcsoft.com/products/photostudio/, $79 

  

Create Picture Hyperlinks 
Earlier, in Create Web Hyperlinks, you saw the power of using text-
based hyperlinks to connect Web pages to other Internet locations. 
Picture-based hyperlinks let you turn any image into the source of 
a link, so that readers can click the picture to follow the link. 

To turn an image into the source of a link, follow these steps: 

1. Click the image to select it.  

2. In the Link Inspector, check the “Enable as a hyperlink” box. 

3. Enter the link: 

• If you are linking to another Web site, enter (or paste) the URL 
in the URL field.  

• If you are linking to another page on your site, choose One of 
My Pages from the Link To pop-up menu and then choose a 
page from the Page pop-up menu. 

A small icon that looks like the Link Inspector button appears 
in the lower right corner of the picture to indicate that the picture 
is now a clickable hyperlink. This icon won’t appear on your pub-
lished Web page, but people reading your site will see whatever 
cues their browsers offer for graphical links, such as the pointer 
changing to a hand when it moves over the image or a yellow 
help tip popping up and showing the linked URL. 

4. Test the link by clicking it in iWeb. 

http://www.adobe.com/products/photoshopelmac/
http://www.adobe.com/products/photoshop/
http://www.apple.com/aperture/
http://www.arcsoft.com/products/photostudio/
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Make an Image Map 
Image maps link certain areas of an image to different URLs. 
Designers use graphical tools to create pictures with striking or 
unusual buttons and images, and then use an image map to define 
which area links to which URL. To make an image map in iWeb:  

1. Create your base image and place it on your iWeb page.  

2. Create shapes that cover the areas you wish to turn into clickable 
regions.  

3. Link each shape to the appropriate Web page using the Link 
Inspector (see Create Picture Hyperlinks, just previously). 

4. Set the fill for each shape to None in the Graphic Inspector. 

5. Also in the Graphic Inspector, set the stroke for each shape to a 
dotted line with a width of .25 pt.  

This creates virtually invisible links that your visitors can click. Note 
that you must set the stroke to something other than None for this to 
work.  

I recently completed a Web page that used an image map to good 
effect. A client created an organization chart with pictures of the 
principal partners and the company’s consultant employees. I used 
layering with invisible shapes to create an image map. Now readers 
can view biographies of each consultant by clicking the org chart in 
different locations. 

  
TIP For more information about options for different types of links 

available in the Link To pop-up menu of the Link Inspector, see 
Create Other Link Types, earlier. 
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CREATE AN ONLINE MOVIE THEATER 

Digital video is becoming much easier to produce, thanks to better 
camcorders and software like iMovie 7. You can share your digital 
videos with your Web site visitors by converting the videos to a Web-
friendly, low-bandwidth format, then exporting them to iWeb. The 
process is extremely easy, once you’ve created the digital video. You 
can also embed a YouTube video right on your Web page; iWeb’s new 
HTML Snippet command makes it easy. 

Add a Video from iMovie 
Once you’ve shared a movie from iMovie to Apple’s Media Browser, 
you can easily import it into other applications that use the Medial 
Browser, including iWeb.  

Here’s how to put your movie in the Media Browser and include it on 
an iWeb page: 

1. With your edited movie selected in iMovie 7, choose Share > Media 
Browser.  

A dialog appears, asking you to select the format(s) for exporting 
your movies (Figure 67). 

FIGURE 67 
 

 
 

Sharing to the Media Browser makes your movie available to any 
application that uses the Media Browser. In this example, I chose 
to export to a file viewable on iPhones and computers, as well as 
compatible with MobileMe and YouTube. 
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 Warning—first frames count! The first frame of your movie 
will show on your iWeb movie page, so be sure to use an image 
for the first frame and not a blank black. 

  
2. Select a format for your movie:  

• For most videos, the mobile setting produces a small, easily 
downloaded video file.  

• If you know your viewers have no issues with bandwidth, select 
the medium or large settings to create videos that are easier on 
the eyes. 

When you’ve chosen a format, click Publish.  

iMovie compresses and formats your movie with the proper size, 
frame rate, and audio quality. This process can be very time-
consuming. On a fast Intel-based Mac I found that it took about 
twice as long as the length of the video to finish the processing 
(i.e., a 30-second video would take about a minute to process). 

Once the conversion is complete, your movie is available in the 
Media Browser for placement on an iWeb page. The movie can be 
placed on any page, or you can use iWeb’s Movie page template to 
showcase your cinematic masterpiece. It’s a good idea to remain 
consistent with the rest of the pages used on your Web site.  

3. If you want to use a new Movie page in iWeb, click the plus ( ) 
button below the Sidebar and then pick a template and its corre-
sponding Movie page template, and, finally, click Choose.  

iWeb creates the page for you with movie and text placeholders. 

4. To place the movie on your page, in iWeb, open the Media Browser 
and click the Movies button. Drag your movie choice from the 
Media Browser and drop it on the movie placeholder. If your 
movie isn’t in the Media Browser, you can drag it from the Finder 
and drop it on your iWeb page. Movies can reside on any iWeb 
page, not just on the Movie page template. 

A warning is displayed if the movie is over 10 MB in size: 

• If your viewers are on high-bandwidth Internet connections, 
you can ignore the warning.  
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• If you’re concerned about the file size, republish the movie in 
iMovie using a smaller size or lower quality format. 

5. Select and edit the headline and the descriptive text for the Movie 
page. You can also add a shadow or frame to the picture on the 
movie page using the Graphic Inspector (see The Fine Points of 
Formatting Photos).  

You’ve now successfully added a movie to your iWeb site. 

  
NOTE VIDEO FOR WINDOWS USERS 

iMovie 7 usually creates video with H.264 encoding technology. 
Many Windows users have upgraded to QuickTime 7 or similar 
software that can decode H.264 video, but if they haven’t they 
won’t be able to view your movies. 
To make sure they can view your movies, consider linking to 
the latest version of Windows QuickTime from your Movie page—
http://www.apple.com/quicktime/download/standalone.html. 
If Windows users can’t upgrade to the latest version of Quick-
Time or another player application that can decode H.264 video, 
you should choose a different method of encoding your video, 
such as MPEG-4. Depending on what application you’re using 
to encode your video, you should be able to find settings for the 
codec (software used to encode and decode video) by choosing 
a Save As, Share, or Export menu item. 

  

Add a Video from YouTube 
YouTube is a cultural phenomenon, with the most popular user-
submitted videos having tens of millions of viewers. In addition 
to adding your own videos to your Web pages, you can also insert 
YouTube content into your site. This is done using the Web Widget 
called HTML Snippet, which allows you to insert raw HTML code 
into an iWeb page.  

Follow along as I add an episode of “Will It Blend?” to my example 
Web site: 

1. Start by visiting YouTube and choosing the video you wish to 
insert. Just to the right of the video screen is an informational 

http://www.apple.com/quicktime/download/standalone.html
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section that includes HTML code for embedding the video into 
your Web page (Figure 68). Select and copy the embed code. 

FIGURE 68 
 

 
 

YouTube videos include HTML code that can be used to include 
the video on a Web page. The Embed code at the bottom of this 
screenshot is what we’re interested in. 

  
2. With your Web page open in iWeb, click the Web Widgets button 

on the toolbar and choose HTML Snippet. You can also choose 
Insert > HTML Snippet from the menu bar.  

3. A small box marked <HTML> appears, in addition to a floating 
transparent black dialog titled HTML Snippet. In the large edit 
field on this dialog, paste the Embed code that you just copied 
from the YouTube site, then click the Apply button. 

4. Click the X icon in the upper left of the HTML Snippet dialog to 
close it. 

Since the embed code includes the necessary video size infor-
mation, iWeb automatically resizes the HTML Snippet box to 
perfectly fit a YouTube video.  

5. Save and publish your iWeb site. 

Your readers can now enjoy the video. 
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MAKE MONEY, ADD FORMS & MORE 

A Web site can be a drain on your wallet, especially if it grows so 
popular that you’re charged for bandwidth and space usage overages. 
Wouldn’t it be nice if you could at least recoup part of the cost of 
running your Web site? Perhaps you have a great new product or 
service that you want to sell online. With iWeb and a little ingenuity, 
you can start selling your goods to the world.  

Perhaps you’d like to add a form to your site, either to gather names 
or to conduct a survey. Or, maybe you’d like to add a map? I cover 
these options and more in this section. 

Add Google AdSense Ads 
In the previous edition of this book I described how you could join 
an affiliate program (Amazon Associates) that lets you put ads on 
your Web pages. There was only one problem with this; you couldn’t 
use the affiliate links if you were using MobileMe (.Mac). Since that 
time, Apple has become a close partner with Google and added the 
capability to place Google AdSense ads on any Web site you create 
with iWeb, including those hosted on MobileMe. What’s even better 
is how easy it is to insert AdSense advertisements on your Web pages. 

To begin choose File > Set Up Google AdSense. Now enter your email 
address to create a new account (Figure 69), and click Submit to 
begin the process. (Of course, if you already are a member, click the 
I Already Have an Account button.) 



112 

FIGURE 69 
 

 
 

Type the email address you want to use for your AdSense account; 
then click Submit.  

  
A dialog appears, asking for the account email address and your zip 
code or the last 5 digits of your phone number (Figure 70). Click the 
Submit button to continue the process of linking iWeb to Google 
AdSense. 

FIGURE 70 
 

 
 

Already using Google AdSense? Enter your account email address 
and a piece of supporting information, and then click Submit.  

  
Next, you should receive an email message with additional infor-
mation. Those who are already using AdSense receive a special email 
with a Web link that takes you to a page asking for permission to 
allow Apple to access your AdSense account for statistical purposes.  
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Adding an AdSense advertisement couldn’t be easier: 

1. In iWeb, open the Web page on which you wish to add the 
advertisement. 

2. Choose Insert > Google AdSense Ad. Two items appear on your 
Web page—a small 125 x 125 pixel AdSense button and a floating 
dialog (Figure 71). 

FIGURE 71 
 

 
 

One menu selection is all it takes to put an AdSense ad on your Web 
page. The dialog (right, above) is used to change the look and size of 
the advertisement. 

  
3. From the Select ad format pop-up menu, choose the type and 

size of the advertisement. You can choose from text links, text 
ads, or text-and-image ads, all in a variety of sizes.  

4. Use the Select ad color pop-up menu to choose a color scheme 
for your ad. It’s best to use something that doesn’t detract from 
the overall theme of your Web page. On my example Photos page, 
I used the Brown ad color to match the wooden frames around 
my pictures. 

5. Move the ad to the appropriate location on your Web page, then 
save and publish the page.  

6. View the published page in your Web browser to see what the ad 
looks like.  

It may take a day or two for Google AdSense to determine what 
kind of content you have on your Web page and begin inserting 
appropriate ads. Your patience will be rewarded when you start 
making money on the click-throughs for those ads. 
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Add Google Maps 
One of the more widely used features of Google is Google Maps, 
an online map and business search engine. While it won’t make you 
money directly, having a map showing where your business is located 
can help potential customers find you and may drive business to your 
“brick and mortar” store. 

iWeb 2 makes it easy to add Google Maps to a Web page with the 
Google Map Web Widget. A Web Widget provides a way for you to 
add someone else’s content to your site. Here’s how I used the Google 
Map Web Widget to add a map showing the location of a favorite 
pizzeria and providing driving directions:  

1. With my Examples Web page open in iWeb, I choose Insert > 
Google Map.  

A sample map appears, along with a floating dialog (Figure 72). 

FIGURE 72 
 

 
 

The default map shows Apple headquarters in Cupertino, CA. Use 
“Get Directions To Here” to get directions so you can visit Steve Jobs. 

  
2. In the dialog, I type the address I wish to show on the map.  

3. I can also select whether or not to show zoom controls or the 
address bubble on my map: 
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• The zoom control is the ladder-like graphic on the left of the 
map shown in Figure 72 (previous page). Clicking the plus  
(  ) button zooms you in for additional detail, while clicking 
the minus (  ) button zooms you out to show a larger area. You 
can also drag the zoom slider up and down to zoom in or out.  

• The address bubble is the white “cartoon balloon” pointing at 
the destination address. You can click the appropriate link to 
get directions to or from the destination address. 

4. I click the Apply button.  

The actual map appears in iWeb, and I can now save and publish my 
Web page. 

  
TIP The Google Map Web Widget is rather picky about the address 

that you enter, so you may not see your map appear. If this 
happens, try entering the address a bit differently. For example, 
instead of Quail Place or Quail Road, enter Quail. The Web Widget 
uses a different map database than the usual Google Map data-
base, so addresses that may be recognized in Google Maps 
might not appear in the Widget. 

  

Run an Online Store 
If you make your own products, wouldn’t it be nice to sell them in 
your own online store? Although you won’t be able to host a store 
on .Mac, if your site is located elsewhere the sky is the limit for your 
ecommerce ambitions. 

In this section I describe three different methods of creating a store: 

• If you’d like to sell t-shirts, clothing, or other items that you’ve 
designed, I walk you through using CafePress to build your store. 

• To sell other goods and services, try using Google Checkout.  

• Finally, I briefly describe how you can create a truly professional 
store using open source ecommerce software called Zen Cart. 
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 Warning! If you want to create an online store on your iWeb site, 
then you should host your site somewhere other than on MobileMe. 
The MobileMe terms and conditions state: 
“The Service is designed for personal use and not intended to be 
used for commercial business purposes, including, but not limited 
to, transacting online sales or software distribution via an e-
commerce site.” 
 This does not apply to Google AdSense advertisements. 

  
CafePress 
CafePress (http://www.cafepress.com/) can make you a shop owner 
immediately, and you don’t have to worry about having a minimum 
quantity order, keeping items in stock, or shipping merchandise to 
buyers. CafePress specializes in printing clothing, home decor items, 
posters, calendars, and even print-on-demand books and CDs, all 
based on content you provide. (For an example of a non-iWeb site 
that sells goodies on CafePress, visit http://www.tidbits.com/store/.) 

I won’t go through the process of signing up with CafePress (it’s free, 
by the way) or creating your store, since CafePress provides easy 
instructions. I’ve created some clothing items featuring my custom 
license plate.  

Follow along as I add a sales page for those items to my iWeb site: 

1. Log into your CafePress account and click the “Visit” link for your 
store. A list of your merchandise appears, categorized by type.  

2. Choose an item to add to your iWeb store, and click the CafePress 
link for that item to bring up the description. For my example, I’m 
choosing the IM4MACS Long Sleeve T-Shirt.  

3. Switch to iWeb, and add a new Blank page for your store.  

4. Change the name of your store page in the Sidebar. I changed the 
name of mine to Gear. 
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5. Change the headline at the top of the page by double-clicking it 
and typing your new headline.  

6. Replace the placeholder title and descriptive text with your own 
writing. Describe the store you’re running and include any special 
notes about your products.  

7. Now we’re ready to get to work. Switch back to your CafePress 
store and the item you want to sell on your own Web site. Using 
Grab (found in your /Applications/Utilities folder) or a similar 
screen-capture utility, capture a screen shot of the item you want 
to sell and copy it.  

8. Switch back to iWeb and paste the screen shot onto your store 
Web page. If you want to make the image larger or smaller, click 
it to select it, then drag one of the corner handles. 

9. Add a text box to the store Web page and use it to add text that 
describes the product. I typed a short description with the price, 
made it bold, and wrote a longer description beneath. 

10. Last but not least, use the tricks you’ve learned earlier in this book 
to link to the appropriate page in your CafePress store (see Create 
Web Hyperlinks and Create Picture Hyperlinks). When you link 
to a product listing in the CafePress store, copy the URL from 
the CafePress site and paste it in the URL field in iWeb’s Link 
Inspector.  

For one of the custom t-shirts I’ve designed, the CafePress URL 
is http://www.cafepress.com/sandestuff.177927251. In the URL, 
sandestuff indicates the CafePress store that the item is located 
in, while 17792751 is the specific item number for the T-shirt 
with the special artwork I’ve created.  

Once the links have been created, your store is open for business 
(Figure 73). 
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FIGURE 73 
 

 
 My store is open for business after only a few minutes of work in 

iWeb. With CafePress, you supply the artwork and they supply the 
products. You needn’t deal with processing credit cards, keeping an 
inventory on hand, or shipping to customers. 

  CafePress is great when you want to make a limited range of items, 
but what if you want to sell a product that isn’t in their catalog? That’s 
where Google Checkout can come in handy. 

Google Checkout 
If you want to sell single items, provide a payment option for a 
service, or collect donations, then iWeb 2 and Google Checkout 
(http://checkout.google.com/) are the answer to your online retail 
questions.  

I won’t go through the mechanics of getting an account set up with 
Google Checkout. This example assumes that you have already signed 
up for Google Checkout and have an approved account. To open an 
iWeb shop backed by Google Checkout: 

1. Visit http://checkout.google.com/, and log in to your account. 
You’re taken to your account management portal page. Click the 
Settings tab, and then click the “Buy Now buttons” link in the left 
sidebar.  

http://checkout.google.com/
http://checkout.google.com/
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The “Create a Buy Now button” page appears (Figure 74). 

FIGURE 74 
 

 
 Just three steps is all it takes to create a Google Buy Now button. 

  
2. Select the type of button you want to use. If you are selling a single 

item (no different sizes or colors), the Basic button is probably 
sufficient. Select “Button with options” if your customers should 
choose from multiple options for each item. 

3. Choose the button style. At publication time, your choices were 
large or small buttons on a white or colored background.  

4. Now describe your item, listing its name, price, and so on. If you 
selected “Button with options,” you can add descriptions for each 
option by clicking the “Add another item” link.  

5. When your choices are complete, click the “Create button code” 
button. Just below the button, an edit field containing HTML code 
for the Buy Now button appears. Click in this field to select all the 
code, and then copy it. 
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6. Now switch to iWeb. Choose Insert > HTML Snippet or press 
the Web Widget toolbar button and select HTML Snippet. When 
the floating dialog appears, paste the HTML code you just copied 
from the Google Checkout page into the edit field. Press the Apply 
button. 

7. Now you have a button, but no product description. Using the 
techniques I’ve discussed elsewhere in this book, add text and 
photos to entice your readers to buy your product or service.  

8. Test the payment button. Since you’re going to use an outside 
payment processor, it’s a good idea to make sure everything 
works before turning the store loose on an unsuspecting world. 
Your buyers will be able to pay you with a variety of methods, 
including credit cards. 

 Keep it under cover! You should hide the store until you’re sure 
it works properly by disabling or hiding any links to it. 

  
I wouldn’t be entirely surprised if Apple added a Store page type 
to a future version of iWeb, to be used only when the site is hosted 
away from MobileMe. Until then, you can use link-based services 
such as CafePress and Google Checkout to sell a variety of goods 
and services. 

Zen Cart 
Zen Cart (http://www.zen-cart.com/) is a full-featured open-source 
Web store application with thousands of installations around the 
world. Although installing and configuring Zen Cart is beyond the 
scope of this book, the HTML Snippet Web Widget lets you embed 
a Zen Cart store into an iWeb site hosted on a Web host that allows 
ecommerce (i.e., not MobileMe).  

The key is to set up your Zen Cart store the way you want it, sepa-
rately from your Web site. For example, you may locate the files for 
your Web site on your Web server at http://mywebstore.com/ and 
have the store accessible at http://mywebstore.com/store/. Then, 
add the store to your Web site: 

1. Create a new blank page in iWeb, and edit the page to match the 
rest of your site. Use the Layout button in the Page Inspector to set 
the width of your page so it is about 20 pixels wider than the width 

http://www.zen-cart.com/
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of your Zen Cart store. The default store page is 900 pixels wide, so 
setting the page width to 920 pixels will frame the store perfectly. 

2. Using the Web Widgets button on the toolbar or the Insert > 
HTML Snippet command, add a new HTML Snippet. 

3. In the edit field, add the following code: 

<iframe src="http://mywebstore.com/store/" height="1800" 
width="905"></iframe> 

replacing the italic URL—shown in green for those of you viewing 
this in color—with your actual store URL. 

4. Press Apply. In a few moments the Zen Cart store appears in the 
iWeb page. 

If you’re looking for a way to sell products online and individual 
links just aren’t going to cut it, give Zen Cart a try. Now that we can 
integrate Zen Cart with iWeb, a whole new world is opening up for 
Mac users interested in ecommerce. 

Add a Form 
If you’re using your iWeb site for business, or for a volunteer 
endeavor, chances are good that you need to capture information 
of one type or another. This can include such things as the names 
and addresses of potential customers and Web surveys to capture 
feedback or marketing information.  

The common way to create a form on a Web site is to tie an HTML-
based form to a database application like MySQL or FileMaker Pro. 
iWeb doesn’t currently have a built-in forms module to let you create 
the HTML, but you can create the code in another program and then 
use the HTML Snippet command to insert the necessary HTML on 
your Web page. 

  
TIP If you store your data in a MySQL, Oracle, or SQL Server 

database, server-based form-generation and data-collection 
software like the $70 Form Maker Pro (http://www.form-
maker.com/) can be useful for creating the HTML code that 
you embed in your iWeb pages. 

  

http://mywebstore.com/store/
http://www.form-maker.com/
http://www.form-maker.com/
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However, you can easily capture information with your iWeb site, 
without coding a traditional HTML form or learning about MySQL 
or a similar database management system. Just ahead, I show you 
how to use the form capability in Google Docs spreadsheets to create 
a form that you can use for a nifty online survey or to collect customer 
data, available right within your Web site. When visitors fill out the 
form, the data is transferred to a Google Docs spreadsheet where you 
can retrieve the results at any time. 

You get an idea of what this could look like in the example site 
that I created for this book; look near the bottom of the page at 
http://www.tcoiweb.com/TCiWeb2/Examples.html. 

Create the form 
To make a form for your site using Google Docs, you need a Google 
Docs account, which you can get at http://docs.google.com/. Click the 
Get Started button to be escorted through the new account process.  

Once you have set up your account, sign in to Google Docs. Google 
Docs will open to a startup page showing any documents that you’ve 
already created and saved. From that page, follow these steps to 
create a form: 

1. Choose New > Spreadsheet (Figure 75). 

FIGURE 75 
 

 

Google Docs uses 
spreadsheets to create 
forms, store all the 
information gathered, 
and allow processing 
of the results.  
Here, I’m choosing 
Spreadsheet from the 
New menu to make 
a new, empty spread-
sheet. 

   

http://docs.google.com/
http://www.tcoiweb.com/TCiWeb2/Examples.html
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2. In the first row of the spreadsheet (that’s row 1, the row above 
the gray bar), enter questions for the form data you wish to collect 
with one question or piece of data (some database folks would call 
this a field label; Google Docs calls it a question title) per column 
(Figure 76).  

For example, enter Name in column A, Address in column B, City 
in column C, State in column D, Zip or Postal Code in column E, 
and a survey question (“Do you use iWeb?”) in column F. 

FIGURE 76 
 

 
 

A view of the Google Docs spreadsheet. Row 1 contains the names of 
the data fields we want to capture with our form.  

  
3. Choose File > Save to save the spreadsheet. Google Docs requires 

that you give the spreadsheet a unique name.  

4. Now click the Share tab near the top right of the Google Docs page.  

5. Google Docs asks if you wish to invite people as collaborators, as 
viewers, or to fill out a form. Select the last item—fill out a form.  

6. Click the “Start editing your form” button. 

A new window appears containing your form. 

7. You may want to edit the way the questions in your form can 
be answered. For example, the answer to the “Do you use iWeb?” 
question should have only two choices—yes or no. To edit those 
choices for a particular question: 

a. Click the corresponding Edit link (you must hover your mouse 
over the question in order to see the link).  
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Google Docs highlights the question with a yellow background 
and shows customization controls for it.  

b. Use the controls to further edit the way your question can be 
answered (Figure 77). 

FIGURE 77 
 

 

When editing Google 
Docs form fields, you 
can add help text and 
configure the answer 
so that it is in the form 
of a short text field, a 
longer paragraph box, 
multiple choice, check-
boxes, or choices from 
a list.  
When you’re done, click 
Save. 

   
c. Click the Save button to save the information in the form. 

d. Configure another question, or when you finish configuring, 
click the “Next, choose recipients” button. 

A Preview and Send a Form page appears. You can use this page 
to send email to people letting them know that you want them to 
fill out your form, but since this form is going into your iWeb site, 
don’t worry about sending email. 

8. Click the “Go to live form” link. 

A new Web page opens, showing your form. Keep that page open as 
you proceed with the next task, embedding your form. 

Embed the form 
Now that you’ve made the form, you can embed it on an iWeb page. 
You’ll be using a special technique, called an iframe, or an inline 
frame. Keep your Web browser open, since you will need to copy 
the URL of the new Web page into the iframe’s HTML code. 
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To embed your form in a Web page in iWeb:  

1. In iWeb, click in the location where you want to embed your form.  

2. From the Web Widgets button on the toolbar, choose HTML 
Snippet. 

3. Click in the resulting black HTML Snippet dialog so that the 
insertion point is near the upper left of the box. 

4. Enter (or paste) the following HTML into the HTML Snippet 
dialog: 

(The italicized URL shown here—in green for those of you reading 
in color—is a placeholder; substitute your own URL from the end 
of the previous set of steps.) 

<iframe src="http://spreadsheets.google.com/viewform 
?key=pkXWKw4_R-6sZfykeKFMpAA" width="600" 
height="600"></iframe> 

  
NOTE The opening iframe tag above has three attributes: 

• The URL of the embedded page 
• The width of the “frame” that will hold the embedded page. 
• The height of the “frame” that will hold the embedded page. 
For more information, see http://en.wikipedia.org/wiki/Iframe. 

  
5. Click the Apply button, and then click the X at the upper left to 

close the HTML Snippet dialog. 

A rectangle representing the shape of your form appears on the 
iWeb page. You can tweak the width and height to make the form 
fit the page. 

6. Save and publish your Web site  

7. To view the data that is entered in the form, log in to Google Docs 
and view your spreadsheet. You’ll even see a time/date stamp that 
lets you know when visitors filled out the form. 

Congratulations! You’ve now set up a form. You can easily view the 
results in the Google Docs spreadsheet. 



126 

Increase Traffic 
Whether you’ve added some moneymaking opportunities to your 
Web site using the ideas earlier in this section, or you are trying to 
get the word out on something like a hot political topic, how do you 
get people to visit your site? There are many methods, including pay-
per-click Web advertising and Web rings, but I mention only one 
here—listing your Web site on search engines. 

By listing your Web site on a search engine like Google or Yahoo, 
you’re making sure that people who are looking for information have 
a way of finding your site. Here’s how to list your site on the major 
search engines: 

• Google: You needn’t do anything to submit your site to Google, 
since Google’s software “spiders” “crawl” the Web, find new Web 
sites, and then index the sites by words and phrases used on the 
site pages. Google suggests that you increase the chance of your 
site being crawled by making sure other locations link to your site. 
For more information, visit http://www.google.com/support/ 
webmasters/. 

• Yahoo: Use the form at https://siteexplorer.search.yahoo.com/ 
submit to submit the URL to your home page and the rest of your 
site will be added by the Yahoo crawler. You can also add the RSS 
feed to your blog or podcast. 

• Windows Live Search: Show your support for the Mac 
by submitting your iWeb site to Microsoft’s search engine at 
http://search.msn.com/docs/submit.aspx?FORM=WSDD2. 

• Ask.com: Ask uses a similar method to Google for adding Web 
sites to its index, so you needn’t submit your URL to them.  

You can increase the chances that Google and Ask.com will crawl 
your Web site by submitting your URL to Yahoo and Windows Live 
Search. If another Webmaster finds your site through one of these 
two search engines and likes it, chances are good that they’ll link 
to your site, which will increase your visibility to the spiders and 
crawlers. 

 

https://siteexplorer.search.yahoo.com/submit
https://siteexplorer.search.yahoo.com/submit
http://www.google.com/support/webmasters/
http://search.msn.com/docs/submit.aspx?FORM=WSDD2
http://www.google.com/support/webmasters/
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MANAGE MULTIPLE iWEB SITES 

Once you’re familiar with iWeb, you may want to have multiple sites. 
For example, perhaps you want to have your own site and a Web site 
for a school or church group, or for different clients. You can create 
multiple Web sites in iWeb and publish them to your MobileMe 
account all at once, but if you’re not using MobileMe or wish to have 
the second site on another Web server, you need to create separate 
Domain files, a feature that Apple added in iWeb 1.1. 

If you currently have all your Web sites in a single Domain file and 
want to split them out to separate Domain files, follow these steps: 

1. In the Finder, create a separate folder for each of your Web sites.  

For example, I created a folder in my Documents folder and 
named it Websites, and then made six new folders within it 
(Figure 78). 

FIGURE 78 

 

Finally, I can 
store my Web 
sites in my 
Documents 
folder, which 
is where I 
think they 
should be. 
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2. Place a copy of your Domain file (found in your user’s folder in 
~/Library/Application Support/iWeb/) in each of the folders 
created in Step 1. 

 Warning! Since you will be deleting Web sites from a Domain 
file in Step 4, make certain that this file is a copy of your orig-
inal Domain file. In this step, to make a copy, Option-drag the 
file out of your user Library and drop it into your new folder. 
This insures that you are working on a copy. 
I also recommend making a backup of your original Domain 
file before proceeding. 

  
3. From one of the folders, double-click Domain to open it in iWeb.  

4. In the iWeb Sidebar, highlight one of the other Web sites, then 
choose Edit > Delete Site. Repeat until you’re down to the one Web 
site that you want to store in the folder.  

5. Choose File > Save to save the individual Web site in its folder. 

6. Repeat Steps 3–5 until each folder has one Web site Domain file 
in it, each file containing only one Web site. 

Now that you’ve successfully created a Domain file for each Web 
site, when you want to edit one of these Web sites, double-click the 
appropriate Domain file. The original Domain file is still in your 
Library folder and can be opened for editing by launching iWeb. 
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LEARN MORE & DO MORE 

Continue your journey with iWeb by learning more about MobileMe, 
podcasting, and Web design. The publications, Web sites, and prod-
ucts listed here are some of my favorites. 

Take Control ebooks: 
• Take Control of MobileMe by Joe Kissell (TidBITS Publishing, 

$10) 

• Take Control of Podcasting on the Mac, by Andy Affleck (TidBITS 
Publishing, $10) 

• Take Control of Your Domain Names, by Glenn Fleishman 
(TidBITS Publishing, $10) 

Books: 
• The Non-Designers Web Book, by Robin Williams & John Tollett, 

(Peachpit Press, $34.99) 

• Learning Web Design: A Beginner’s Guide to HTML, Graphics, 
and Beyond, by Jennifer Niederst Robbins (O’Reilly, $39.95) 

• Web Design Garage, by Marc Campbell (Prentice Hall, $34.99) 

Web sites: 
• Apple’s iWeb Forum 

http://discussions.apple.com/forum.jspa?forumID=1193 

• Vincent Flanders’s Web Pages That Suck 
http://www.webpagesthatsuck.com/ 

http://www.takecontrolbooks.com/mobileme?pt=INTERNAL
http://www.takecontrolbooks.com/podcasting-mac?pt=INTERNAL
http://www.takecontrolbooks.com/domain-names?pt=INTERNAL
http://tinyurl.com/oabw5
http://tinyurl.com/mymdo
http://tinyurl.com/mymdo
http://tinyurl.com/q6eu6
http://discussions.apple.com/forum.jspa?forumID=1193
http://www.webpagesthatsuck.com/
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APPENDIX A: WEB HOSTING 

The topic of hosting an iWeb site on a server that isn’t run by 
MobileMe could rightfully fill another book. However, it wouldn’t be 
fair to you to talk about setting up your own Web site without at least 
touching on the subject, so this appendix gives an overview of how to 
host your site someplace other than MobileMe. 

To host your Web site elsewhere than MobileMe, follow these steps: 

1. Decide at what Web location your site will be reachable. Web-
hosting companies typically offer you one or more of the following 
choices for the start of a URL: 

• A special path at the hosting company from a domain 
they control: This is common because it requires the least 
effort by the hosting company. The pattern is usually 
http://www.example.com/username/ or 
http://www.example.com/~username/.  

• A subdomain at the hosting company: A subdomain 
prepends a name to the front of a domain name; for instance, 
I host Web sites on my Podbus.com hosting service with URLs 
like http://mytestsite.podbus.com/.  

If you go with either of the above two options, skip to Step 5. 

• Your own domain: Many hosting companies are happy 
to create a virtual Web server for you at a domain name you 
choose and register through them or a third party. A virtual 
Web server resides on the same computer as dozens or even 
tens of thousands of other Web sites, but only responds when 
its name is “called” by a browser. For example, my Podbus.com 
servers host a Web site whose URL is http://stmatthew-
elca.org/. This type of hosting is usually slightly more expensive 
than using a path or a subdomain. 

 Allow for transfer time! If you already own a domain 
you want to use, but you don’t want to work with the existing 
firms that handle your domain and Web hosting, allow a few 
days to transfer your files or registration to new hosts. 
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2. Check if your desired domain name is available by searching for 
it on a domain name registrar’s Web site or a hosting company’s 
site, if they also handle domain registration. I suggest you search 
at GoDaddy.com (http://www.godaddy.com/) and easyDNS 
(http://www.easydns.com/), two well-regarded domain registrars. 
(It’s becoming more and more difficult to find domain names that 
someone doesn’t already own. I tried to register stevensande.com 
a while back, only to find that someone else with my name already 
owned it.) 

Enter your proposed domain name in one of the domain search 
fields to see if it’s available. If your primary choice is already taken, 
GoDaddy.com provides you with a truly baroque list of alterna-
tives. Some of the alternatives include variations of your proposed 
name and different TLDs (top-level domains, or the far-right part 
of a domain name), such as .org, .net, and .biz, as well as country 
codes like .cn or .nu. It’s often better to get a .com name to ensure 
that someone typing the name in a Web browser doesn’t forget 
the TLD and wind up at the wrong location. 

3. Now that you’ve decided on a domain name, it’s time to put three 
pieces together: your domain name registration, domain server, 
and Web host. Some services can sell you all three pieces in one 
package, meaning you can avoid thinking about these parts as 
different steps, but it’s also common to end up working with two 
services in order to get all three pieces: 

• Register your domain name: Expect to spend anywhere 
from $1.95 to $35.00 per year for a domain registration, with 
the lower pricing going to bulk buyers. I prefer GoDaddy for the 
speed of registration and control they offer of my domain. 

• Serve your domain: Registering a domain gives you a lease 
on that name, but it doesn’t tell other computers on the Internet 
how to find your Web site or deliver email. For that, you need 
a domain host, technically called a DNS (domain name system) 
server. DNS maps human-readable names to machine-friendly 
Internet protocol addresses, like takecontrolbooks.com to 
216.168.61.78. Your Web host typically provides details so that 
you can either host your DNS at your registrar (entering one set 
of information) or at the Web host itself (entering a different set 
of information at the registrar). 

http://www.godaddy.com/
http://www.easydns.com/
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• Sign up for a Web-hosting account: You’ll upload your 
Web site files to the Web server via FTP. 

4. Using information provided by your Web host, configure your 
domain depending on one of three scenarios: 

• Your registrar, DNS host, and Web host are the same 
company: You should be able to use one dashboard or control 
interface to set everything up. Or, simply by paying for the 
accounts, you may already be active. 

• Your registrar hosts your DNS, and your Web host is 
separate: Set your domain name’s main address and www 
plus dot address to IP address values provided by your Web 
host. For instance, you would use the DNS host settings to have 
example.com and www.example.com point to 192.168.1.1 
if that’s the value provided by your Web host. 

• Your registrar is separate from your combined DNS 
and Web host: Your Web host will provide the details on how 
to delegate DNS hosting by entering values at your registrar for 
their nameservers, which handle DNS requests.  

5. Determine where to upload your files. This information usually 
comes from your Web host in the form of an FTP address, a user 
name used to log in to the FTP server, and a password for the FTP 
server. Your provider may tell you to upload files directly in to your 
FTP directory or may give you a different path to the directory. 

 Warning! FTP is an insecure protocol; your user name and 
password are sent without any protection over all the networks 
between your computer and the destination server. If you’re on 
a home network, you may be fine, but if you’re at a Wi-Fi hot 
spot other users could intercept your information. Find a Web 
host that offers Secure FTP (SFTP) which) uses strong encryp-
tion to scramble the data between most FTP client software 
available on the Mac and their FTP server. 

  
6. Upload your files as outlined in Publish to Other Servers. If your 

first attempt at viewing your Web site results in a “404: File Not 
Found” error, contact your Web host and make sure that they 
have set your directory index to index.html. The directory index  
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is a pointer that sends visitors to the home page without requiring 
them to type the index.html part of the URL. All they need to type 
is www.whateveryourdomainis.com, not 
www.whateveryourdomainis.com/index.html. 

Your Web site is now online for the world to see. Congratulations! 

  
NOTE Don’t get frustrated if you can’t get your Web site up and run-

ning immediately. It can take some time (usually less than a 
day) for your new domain name to make it to all of the domain 
name servers in the world, you might not get information from 
your Web host in a timely manner, or there may be issues in 
uploading your files via FTP. Be patient, work with your Web 
host, and before you know it, your beautiful iWeb site will be 
ready for the world to see. 

 

  
TIP Want to know more about the steps discussed in this Appendix? 

Need some handholding? Check out Glenn Fleishman’s Take 
Control of Your Domain Names. 

   

  
TIP Backing up important files is always a good idea. After you’ve 

put a lot of time and effort into creating your Web site, the last 
thing you’ll want to do is start all over again if your hard drive 
fails or a file is corrupted. Using Mac OS X 10.5 (Leopard) and 
an external hard disk, you can back up your files without any 
effort with the built-in Time Machine application. You may also 
wish to read Joe Kissell’s Take Control of Mac OS X Backups, 
which is an excellent resource for any Mac owner. 

  

 

http://www.takecontrolbooks.com/domain-names?pt=INTERNAL
http://www.takecontrolbooks.com/domain-names?pt=INTERNAL
http://www.takecontrolbooks.com/backup-macosx?pt=INTERNAL
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APPENDIX B: ADD A TWITTER FEED 

Do you tweet? No, I’m not asking if you think you’re a bird, but if you 
are a member of Twitter.  

Twitter (http://www.twitter.com/) is a social networking service 
based on the idea of answering the question “What are you doing?” 
with frequent 140-or-less character posts to the world at large and 
your followers in particular. It has become wildly popular, with many 
Web sites, news organizations, celebrities, and even the Take Control 
series (http://www.twitter.com/takecontrol/) having Twitter 
accounts that you can follow. 

If your friends or Web site visitors don’t have Twitter accounts, they 
can still follow your daily antics if you add a Twitter feed to your iWeb 
site. What’s a Twitter feed? It’s a listing of your most recent tweets in 
reverse chronological order—kind of a mini-blog. Figure 79 shows a 
Twitter feed on an iWeb page. 

FIGURE 79 
 

 
 

The Twitter feed JavaScript adds your latest tweets in reverse chron-
ological order, along with when they were posted. A small addition 
to the script posts a message if Twitter is slow in responding, so your 
readers know that the tweets are loading, albeit slowly.  

  
To add the Twitter feed, use the HTML Snippet Web Widget to add 
to your iWeb page a script written in JavaScript—a programming 
language popular with Web developers—by developer Remy Sharp 
(http://remysharp.com/) and made available under an MIT License.  

http://www.twitter.com/
http://www.twitter.com/takecontrol
http://remysharp.com/


135 

 Redirecting or forwarding a domain name for MobileMe? 
If so, you may not be able to show Twitter feeds using this method. 
For example, if you registered the domain mypersonaldomain.com 
and set up domain forwarding with your domain registrar to point 
that domain to your MobileMe Web site, then the Twitter feed 
JavaScript probably won’t work.  
Instead, you should follow the instructions in Publish to a Personal 
Domain on MobileMe to add the personal domain to MobileMe. 
With the personal domain hosted by MobileMe, the Twitter feed 
JavaScript should work properly. 

  
If the thought of having a list of tweets on an iWeb page has you all 
atwitter, follow along as I add a Twitter feed to the examples page at 
http://www.tcoiweb.com/TCiWeb08/Examples.html: 

1. To start, you need three files: 

• The JavaScript file 

• A special Cascading Style Sheet (CSS) file for formatting the 
output of the script 

• An animated GIF image that shows a progress bar while the 
tweets are loading 

I’ve made this easy for you by providing all three of the necessary 
files in one zip archive. You can download it here: 
http://idisk.mac.com/stevensande-Public/TweetFeed.zip. 

2. Double-click the TweetFeed.zip file to open the archive and access 
the individual files. 

3. Upload these three files to the root (top) level of your iWeb site: 

• If MobileMe hosts your site:  

a. In the Finder, choose Go > iDisk > My iDisk. You may be 
asked to enter your MobileMe user name and password.  

b. Once the iDisk mounts, on the iDisk, double-click the Web 
folder, and then from within the Web folder, open the Sites 
folder. 

c. Drag the three files—ajax-loader.gif, twitter.js, and 
twitter.css—to the Sites folder. 

http://www.tcoiweb.com/TCiWeb08/Examples.html
http://idisk.mac.com/stevensande-Public/TweetFeed.zip
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• If MobileMe doesn’t host your site: Copy the files to the root 
level of your site, that is, the level that holds the page files 
(index.html, About_Me.html, and so on) and folders. 

4. Open your Web site in iWeb. You may want to put the Twitter 
feed on an empty page, in which case you should add a new page 
to your site using the page type of your choice.  

5. Create a text box for a title. In Figure 79 (previous page), 
that’s the “Tweets from Steve” header above the list of tweets. 
The JavaScript doesn’t create that for us, so we need to add a title 
of our own. 

6. Make sure you know your iWeb URL. If you aren’t sure, publish 
your site and then copy the URL from the dialog that iWeb pops 
up to announce that the site has been successfully published.  

7. Now comes the fun part! Choose HTML Snippet from the Web 
Widgets in the toolbar, and then copy the following code and paste 
it into the HTML Snippet container: 

<link rel="stylesheet" type="text/css" media="screen,print" 
href="http://yourwebsiteURL/twitter.css" /> 
<script src="http://yourwebsiteURL/twitter.js" 
type="text/javascript" charset="utf-8"></script> 
<script type="text/javascript" charset="utf-8"> 
getTwitters('tweet', { 
  id: 'yourtwitterID', 
  count: 5, 
  enableLinks: true, 
  ignoreReplies: true, 
  clearContents: true, 
  template: '"%text%" <a 
href="http://twitter.com/%user_screen_name%/statuses/%id%
/">%time%</a>' 
}); 
</script> 
<div id="tweet"> 
<p>Please wait while my tweets load. <img 
src="http://yourwebsiteURL/ajax-loader.gif" /></p> 
<p><a href="http://twitter.com/yourtwitterID">If you can't 
wait, check out what I've been twittering.</a></p> 
</div> 

Do not click Apply yet! 
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8. There, that wasn’t too bad, was it? Now you just need to do a little 
editing to the code in the HTML Snippet container: 

a. Replace the three instance of yourwebsiteURL with the 
actual address of your Web site. For instance, my URL is 
www.tcoiweb.com, so that’s what I substituted. 

b. Next, for the two instances of yourtwitterID, replace each one 
with your Twitter user name, the name that you use to log in to 
Twitter. 

c. Think about how many tweets you want to show on your Web 
page, and type that number beside count, replacing the 5 that’s 
there now. Or, you can show five tweets and leave the 5 alone. 

d. Click Apply. 

Your most recent tweets should appear on your iWeb page 

If your tweets don’t show, make sure that you’ve posted some 
tweets, and if you have, recheck the location of the files that you 
copied in Step 3. Also, make sure that you are connected to the 
Internet. You can double-check or further edit the HTML by 
double-clicking Twitter feed (or failed Twitter feed) on your 
iWeb page. 

9. When everything is updated to your satisfaction, publish the Web 
page. Be sure to check that your tweets are showing up.  

 Warning! If your site is not hosted on MobileMe, you may need 
to upload or add the files back to your site whenever you republish. 
Keep this in mind if your tweets suddenly disappear after you add 
content to your site. 

   
  

TIP CHANGING THE LOOK OF YOUR TWEETS 
If you don’t like the color or text size of the tweets on your 
Web page, you can change the CSS file to alter those attributes. 
I leave this as an exercise for the reader. Check Remy’s Web 
page about his JavaScript for details: http://remysharp.com/ 
2007/03/20/how-to-add-twitter-to-your-blog-without-it-
hanging-your-site/. 

  

http://remysharp.com/2007/03/20/how-to-add-twitter-to-your-blog-without-it-hanging-your-site/
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ABOUT THIS BOOK 

Thank you for purchasing this Take Control book. We hope you find 
it both useful and enjoyable to read. We welcome your comments at 
tc-comments@tidbits.com. Keep reading in this section to learn more 
about the author, the Take Control series, and the publisher. 

About the Author 
Steve Sande embraces change. After 
gathering his Bachelor of Science in Civil 
Engineering and MBA from the University 
of Colorado, he worked as an engineer until 
falling in love with the Mac in late 1984. He 
started a new life as an IT manager and 
unofficial Mac evangelist, at one point 
managing a team supporting over 1,200 Macs. 

In late 2004, Steve embarked on a new career as a certified Mac 
consultant. When he’s not haunting the local Apple Stores, working 
with clients, or writing ebooks, he loves to cook, go geocaching, sing, 
ride his recumbent bicycle, collect and create art, and attend classical 
music concerts (despite the picture, Steve doesn’t like most country 
music). He’s also an instructor for ASPE Technology facilitating 
Business Analysis classes (http://www.aspetech.com/). Since the 
spring of 2008, he’s been blogging professionally on The Unofficial 
Apple Weblog (http://tuaw.com/). You can follow Steve on Twitter 
(http://www.twitter.com/stevensande/). 

Steve lives in Highlands Ranch, Colorado, with Barb—his wife of 29 
years, who really is a rocket scientist—and his tortoiseshell cat, Ruby.  

Author’s Acknowledgements 
I’d like to thank several people for their support during the creation 
of this book: 

• Barb Sande, my wonderful wife, for putting up with me typing 
away on my computer at all hours of the day.  

• Tonya Engst, for being such an unbelievably patient, hard 
working, and understanding editor-in-chief.  
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• Karen Anderson, for taking on the daunting task of editing this 
book and being patient with a person who is notoriously slow at 
creating updates. 

• Remy Sharp, for his wonderful Twitter feed JavaScript. 

• Tom Gewecke, for his outstanding work in the iWeb Forum on 
the Apple Support Web site and assistance with previous versions 
of this book. 

Shameless Plugs 
If you’re a Mac user who lives nowhere near an Apple Store, and you 
need some help or training, my Mac consulting firm, Raven Solutions, 
LLC, offers remote online support services. When I’m not available, 
one of my team of Apple certified consultants can help out.  

I also run a Web and podcast hosting company called Podbus.com. 
Our rates are low, our service is great, and we offer a money-back 
satisfaction guarantee (http://www.podbus.com/). 

About the Publisher 
Publishers Adam and Tonya Engst have been 
creating Mac-related content since they started 
the online newsletter TidBITS, in 1990. In 
TidBITS, you can find the latest Macintosh 
news, plus read reviews, opinions, and more 
(http://www.tidbits.com/). 

Adam and Tonya are known in the Mac world as 
writers, editors, and speakers. They are also 
parents to Tristan, who thinks ebooks about 
clipper ships and castles would be cool. 

Production Credits 
Link-making AppleScript: Matt Neuburg 
List macros: Sharon Zardetto 
Take Control logo: Jeff Tolbert 
Editor: Karen Anderson 
Editor in Chief: Tonya Engst 
Publisher: Adam Engst 
Twitter feed test assistant: Amelia Sauter 
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