
Power Tools Conference:
InDesign CS4 for the Practical User
Session Description

Adobe’s 18 month turn around schedule has caught many of us by surprise. Couldn’t we just have 

another 6 months please? We were just getting into our flow with CS3, and here we are, being nudged 

from our comfort zone right out into the big bad future again. This two day session will first work on 

what’s new in Indesign CS4, introducing the newest features that Adobe is touting.  Then on day two 

we’ll go into a real world pragmatic workflow just to see how we’ll make those new features work for 

us. In so doing, we’ll find out which ones are important, and which we can dismiss.

What’s New in CS4

1.  New workspace interface:
We’re going to start this whole shebang with a quick look at the new 

interface features in the InDesign application window. 

The first thing I want to show you is a feature that we Mac users will find 

new, but Windows users have had since they first ripped off, uh,I mean 

came up with their GUI. It’s called the Application Frame. You’ll find it 

under Window>Application Frame. It lets you keep the whole 

application together in one single framework, or window. So if you work 

on multiple monitors, or you just want to keep things contained, you can 

select this option and your whole workspace will be self-contained.
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Application Bar

You might consider the Application Bar a small feature, but it’s also one of those things that once you 

get used to, will save you cumulative time over a week’s work.  The Application Bar lets you do several 

things. You can launch Adobe Bridge (more about Bridge later), you can adjust the magnification of 

your document, show or hide guides and rulers, and even arrange how documents are viewed. 

Fig1: 

That last part, about arranging how documents are viewed leads us right to the next new feature, what 

we will call tabbed viewing (the tool option in Application Bar calls it “consolidate all” — how 

unimaginative don’t you think?).

Tabbed viewing 
Across the CS4 suite of apps, you’ll find this is the new look. When you have more than one document 

open, in order to keep an orderly workspace (as much as you could hope, I guess) instead of having 

them higgledy piggledy (I take every opportunity to use that term), InDesign provides you a single 

uniform window with tabs.
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Fig 2:

 

Switching from one document to the next is as easy as clicking on a tab.  If you’re not comfortable with 

that type of arrangement it’s also just as easy to change to a more traditional workspace.  Select the 

Arrangement pull down icon in the Application Bar, and choose one of the three icons to the right of 

the  “Consolidate All” icon. You have a choice of tiling in a grid, tiling vertically, or tiling horizontally. The 

choice is all yours, dependent no doubt on your monitor size, your mood, or what hemisphere you 

happen to be working in.

Fig 3:

The other layout icons describe other preset choices for arranging your document workspace. The 

truly traditional set up is the Float All in Windows selection.
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Panels not Palettes
In a further bid to convince us that this really is a new improved interface model Adobe has in all it 

documentation decided to change the name of certain aspects of the workspace. We are therefore no 

longer working with palettes, when we use tools and features. These are now known as panels.  

By default, the panels are docked at the right side of the workspace. As in all CS versions of InDesign, 

your workspace can be modified, and saved, called up as a preset. CS4 has several preset workspaces 

already named for certain types of work. Each named preset workspace makes certain tool panels 

available to you depending on which type of work you find you’ll be doing. You’ll find the workspace 

presets on the right hand side of the Application Bar. 

Fig 4:

As you can see from the figure above, you can also set up your own workspace, or if you’re not 

comfortable with that, you easily go back to the preset’s default (in the case of the figure’s example, 

you’d select Reset Typography to have all the panels docked neatly on the right).

There’s one particular preset we’ll check out at the end of this section, that being the What’s New 

preset. But before we do, let’s get a handle on some of the basic functionality of panels.
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Panels can be collapsed or expanded, docked or floated.  While none of this might seem surprising or 

new, let’s go over it once just for clarity.

Select the Essentials preset from the Application Bar. If you need to, choose Reset Essentials. That will 

put everything back in its default position.

Click + Drag the  Pages panel from its resting place at the side of the workspace by selecting its icon 

into the open workspace.

Fig 5:

To collapse/expand the floating panel, double click on the dark gray area at its top, or click once on the 

Expand/Collapse panel button (the double arrows).  

Dock the panel at the side of the screen by dragging to the left side or the right of the workspace. The 

side will light up with a blue highlight signifying that your panel will magnetically dock there.

Cluster your panel with other panels in the same way. Drag it to a group of panel, and when you see 

the blue highlight, release. 
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Smart Cursors, Smart Guides
Any veteran Illustrator users can tell you that Smart Cursors and Smart Guides aren’t new ideas. They’re 

just new to InDesign. While I’ve often found so called Smart Guides in Illustrator to be somewhat 

annoying, I find the opposite to be true here. They’re a great tool and a useful improvement. 

Smart Cursors show live positioning and transformation values as you select and move, resize and 

rotate objects.  By default InDesign enables Smart Cursors. To check, Choose InDesign  > Preferences > 

Interface. Then make sure that under Cursor Options, you have Show Transformation Values checked.  

When you select an object, say a graphic frame, or a text frame, and resize that object, the Smart Cursor 

will dynamically show Width and Height values of that object. So you can be very precise about the 

size without having to take your eyes off the object, to check in the control panel at the top of the 

screen. 

Fig 6:

When you click+drag to move that object, the Smart Cursor will dynamically show the X/Y positions 

relative to the document ruler. 
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Fig 7:

Again, these are also reflected on the control panel, but the Smart Cursor allows you to move objects 

around while keeping a precise sense of its position without ever taking your eyes off it. While that 

may seem like a minor feature, it adds up in a cumulative way to speeding your whole workflow. 

Finally, when you choose to rotate an object, the Smart Cursor dynamically informs you of the angle of 

rotation in relation to the orientation point from which you are doing that rotation.

Fig 8:
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Earlier I said that this sort of thing gets annoying in Illustrator, but not so much here. Let me explain 

myself. In a normal workflow, I am using Illustrator to create an individual element, a logo, or 

illustration, that I plan on using as an element within an InDesign document. In that respect, the 

relative sizes and positions on a page don’t matter so much to me within the Illustrator doc. But when I 

do place that object on a page in InDesign, I’m very concerned with its relative placement on my 

layout. So while in Illustrator, these values may seem to intrude on my, for lack of a better word, creative 

process, those values are extremely helpful to me in my layout process. 

Now let’s take one step back and two steps forward. First the step back. When we move an object, the 

Smart Cursor, as we see, gives us an X/Y value in relation to the ruler. But as you drag the object 

around, you may also notice other guides appear and disappear depending on where you drag the 

object in relation to other objects or positions on the document layout. 

As the object passes over the center point or topmost edge or bottom most edge of another object, a 

guideline appears to let you know where that center point, or top point or bottom edge lies. This isn’t a 

function of the Smart Cursor, but rather the next subject promised in this section, the Smart Guide.

Fig 9:
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Note the Smart Guide center point in the image above.

Smart Guides will help you create precise relative positioning in much the same way the Smart Cursor 

helps you with accurate sizes and positions relative to the document page.

Here’s where Smart Guides really come into play.

1. Open a new document in InDesign. Whatever the default settings are, it doesn’t really 

matter. Make it a Letter sized image.

2. Select the Rectangle Frame tool and draw a square frame on the page, near to the left 

margin, but not necessarily abutting it.

3. Next, select the square you just created, and Option+Shift+Drag to the right. As you do so, 

you’re new object will stutter over the center point of the existing square (the Smart Guide’s 

snap to function). Continue on dragging so that there is a good space between your original 

square and your new one.  The Smart Guides will show you your alignment on top, center 

and bottom. 

4. Finally, repeat that process, this time taking the second square and duplicating it in the same 

fashion. As your new object reaches the same space as that which you created between the 

first two, your Smart Guides will let you know that you now have an equal gutter between all 

three objects. So spacing out objects on a page has now become one of the easiest 

functions in InDesign. 

Fig’s 10, 11, 12:
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10.   A simple square.

11.    The tops, center and bottom are aligned.

12.   The Gutters are equal. 

Now that we have our frames equidistant from each other, let’s look at one more 

enhancement that follows directly from this innovation.
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Automatic Placed Image Resizing
In the last part, we dragged out our frames first, defining their sizes before we actually have images to 

fill them. This isn’t always the way we work, since there are times when we place our images and then 

drag out our frames to fit those images. In earlier versions, this was a bit tedious, because the frame 

and the proportions of the image we were about to place didn’t often match. 

We would have to resort to resizing either frame or image, using the Fitting command (Object > 

Fitting>…). But this new version has a great enhanced method of placing images so that they’re at 

their original proportions at placement. 

We’ll use some images that are on everyone’s computer, by using the Desktop Pictures that come with 

every Mac, so that we can be sure we’re using the same assets. And for this little demonstration, we’ll 

use the multiple place feature that was introduced in CS3 to show you this newest enhancement.

1. Place four images from the Desktop Pictures folder found in your Macintosh HD > Library > 

Desktop Pictures folder. 

2. Choose Macintosh HD > Library > Desktop Pictures > Nature, then Command+Click on four 

non-contiguous files. Choose  Clown Fish.jpg, Earth Horizon.jpg, Ladybug.jpg and Zebra.jpg.
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3. Now use your arrow keys to cycle through which image you want to place first. The preview 

in the place cursor will show you your choice. Note also that is shows you how many images 

you’ve chosen to place. 

Fig 14:

4. Drag your frame out now and you’ll see that no matter how expansive you drag the frame 

out, it remains at the same proportions.  Click to place, and then move on to place the next 

image. As ready to place the second image, keep a close eye on the cursor. As it nears the 

edge of the existing image, it will become hollow, signifying that you’re in alignment with 

that image as well. Now that’s smart.

Fig 15:

5. Place the other two images one to the right of the other two, and the final image drag out 

below the other three, aligned with all three above it as a group.
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Fig 16:

All four images are laid out in a balanced and equally distant fashion.  But let’s try one more 

adjustment.  

6. Crop the center picture by selecting it with the Selection tool and dragging the frame over 

to the left. 
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Fig 17:

7. Now select the Zebra on the right, and drag it over to the left. You’ll know when to stop, 

when the Smart Guides let you know that the gutter between the images is equidistant.

Fig 18:
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8. Finally, let’s crop the bottom image to meet the right edge of the zebra image. Again, the 

Smart Guides will let us know when we’re aligned.

Fig 19:

If we’d have tried that in any earlier versions of InDesign, we’d have had a tedious process of 

drawing guides, dragging, resizing content to fit, and generally having a drag of a time (pun 

intended). The Smart Guides, Smart Cursor and Multiple place command combine to save us 

time and hassle. End of commercial. 

What’s New Preset
Let’s take a quick step back and go up to the Workspace presets in the Application Bar.  From the list of 

preset Workspaces, choose What’s New. 

The What’s New Panel is broken up into three segments. The topmost segment contains Links and 

Preflight. Select Preflight. 

Power Tools Conference:
InDesign for the Practical User  Andrew Shalat

 Page 15 of 22



Continuous Live  Preflighting of your document as you work.
Preflighting is one of those aspects of digital prepress and design whose value becomes apparent 

when something goes wrong. Just like preflighting an airplane, you want to make sure that everything 

is in working order, and up to spec before you take off. InDesign users are like pilots. It’s our 

responsibility to make sure that our documents are flightworthy. 

Flightworthy means all your fonts are in order, all your images are in the 

correct color space and format, and that they have substantial enough 

resolution that they will look right when printed. Flightworthy means all 

the links to your images, logos and such are robust and unbroken. 

Flightworthy means the document will print without any problems, and 

your printer will love you, and your client will pay you, and you’ll be 

happier in life for having produced a project done well.

You can always buy a third-party preflighting software package, but 

InDesign has included its own built-in for several generations now. The 

only thing was, you had to remember to run the preflight check before you output or packaged your 

piece. 

InDesign CS4 now provides an integrated and continuous preflighting function, so you don’t have to 

wait until the last minute to see if something is amiss. The trick is to let InDesign know what kind of 

output you’re intending, so that it can make sure your assets are in line with the require spec’s. 

In order to do that, you need to open the Preflight panel, and under the control menu (upper right of 

the panel) select Define Profiles.
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Fig 21:

In the instance I have here, I’m defining a generic CMYK profile for output. So I need to go through 

each preflighting aspect that will have a bearing on my intentions and my document. If you’re not sure 

about the specifications you’ll need to be aware of, the best thing is to call a printer and ask. It might 

be a good idea to call the printer you are hoping to use for the job. Keep this panel open while you do, 

and you can walk your way down the list, seeing what is essential to be aware of, and what isn’t. We’ll 

walk through this in the seminar.

Embed and Unembed Profiles

As with most things in this life, you can’t be sure what the other guy/gal is bringing to the party. So you 

sometimes have to make sure that what you find necessary is going to be a part of whatever you 

happen to be cooking up. That’s where embedding a profile comes in handy. When you embed a 

profile, you make the profile part of the document. You embed a profile in cases where you’re sending 

the file to someone else, or just as a precaution for yourself. Embedding a profile will ensure that your 

preflighting agenda is consistent, even if you’re only transferring your file from your desktop to your 

laptop. 
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Just because the profile is embedded doesn’t mean you are obligated to use it. It’s merely a reference 

for your workflow.  So if you send a document with an embedded profile to your printer, or another 

colleague, they don’t have to use it. They can select a different profile to use with the document.

Let’s create a sample profile.  I’ll call it CMYK basic. In my sample document (it can be any document, 

really), I’ve opened the Preflight panel, then selected the Define Profiles. My main concern with this is 

that I don’t want RGB or LAB files in my document, since they won’t print correctly to CMYK 

separations. 

Now remember, these settings are just alarms. They aren’t automatic fixes. You’ll be required to do that 

should anything be wrong during the preflight process.

1. Scroll through the checklist for the definition. Make sure to check Links Missing or Modified. 

That’s pretty much a standard thing for any document.

2. Select Color, and make sure to check on the Color Spaces and Modes Not Allowed. This is 

where we’re going to be alerted if any of our images aren’t in the correct color format (either 

CMYK or Grayscale). 

Fig 22:
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3. Now go down to Images and Objects, and look to see that we have ample minimal settings 

for resolution. 

4. Save the profile and click OK.

That ought to take care of it for this profile.  Immediately in the Preflight panel you should see some 

information. If you’re using the same document that we used to create the automatically proportioned 

images, then you’ll see some warnings about the images. Select the Color category and drill down to 

choose Clown Fish.jpg. Then untwirl the Info at the bottom to see what is wrong.

Fig 23:

So you have a handle now on what you have to do to become aware of and fix your document for 

output. 

Before we move on to another subject, let’s embed the profile into this document. You can embed only 

one profile. The [Basic] profile cannot be embedded, since it comes as a default in every document.
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Select the profile in the Profile list, and then click the Embed icon   to the right of the Profile list. 

You can also choose to unembed a profile. To unembed a profile, choose Define Profiles from the 

Preflight panel menu, select the profile, and then choose Unembed Profile from the Preflight Profile 

Menu on the left side of the dialog box.

Don’t throw any of your profiles away. Instead, you can export them, and save them in a specific 

format. You can also load other profiles you may find online, or that are provided by your printer. The 

profiles are saved in the .idpp format.

Preflight As You Work Without the Panel Open
Once you’ve set up your profiles for preflight, you don’t have to keep the panel open. You’ll find the 

continuous preflighting available to you in the bottom left corner of your document window. 

Fig 24:

Customizable Links Panel
Now let’s examine the Links Panel, which conveniently enough is found just above Preflight in the 

What’s New workspace.  The Links panel is very similar to its CS3 predecessor, only rather than having a 

Go To link button, we can see a live page number that shows on what page the links resides, and when 

selected, takes us directly to the chosen image. 
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But wait. There’s more. Where the original CS3 LInks panel (back then it was still a palette) pretty much 

stopped there, this new version takes on a whole new customizable realm. 

Under the Link Panel’s control menu (the line icon button on the upper right) select the Panel Options.

The ensuing dialog window lets you add tons of more information that can be a part of your Links 

Panel.  Choose any or all of the information you think you’d like to see at a glance in the panel, and click 

Save. 

Fig 25:

These options are letting you see much of the preflight information you are concerned with as well. 

For instance, Effective PPI and Transparency, Color Space, and Scale are all very important bits of info. 

And it helps that you can see them all at once, in one panel. Wow.
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Fig 26:

  Now that’s some Links Panel.

Those are the basics. The next step is to put some of these new features, along with some others, to 

work for us. You may find that some aren’t as important or useful as the Public Relations material might 

want you to believe.  So in this seminar we’ll create a few documents, and see what really works and 

what we can dismiss, or at the least, put aside.
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Part 2: InDesign as Pizza
The whole model of how InDesign works I liken to making a pizza. Think of InDesign as the pizza 

dough on which we put all the ingredients and toppings of the pizza. Alone, it’s not the pizza itself, it’s 

just flat dough. It’s nothing but the delivery system for the sauce, cheese, pepperoni, onions, and black 

olives. Oh, and don’t forget the drizzle of olive oil on top.  But first it has to be cooked right. And that is 

where the design part comes in.

Creating a practical real world workflow with InDesign CS4
 Let’s start a new document. But instead of working from scratch, we’ll use an InDesign template. 

1. Select File > New > Document From Template.

2. When you chose new Template, InDesign immediately called open Adobe Bridge.  More and 

more in the CS4 workflow, whether it’s InDesign, or Illustrator or Photoshop, or any of the 

suite, you’ll find that starting of in Bridge is a good way of getting your bearings, seeing 

what’s available to you, and figuring out which direction you want to take in your design. 

Fig 2-1:

Where Bridge takes you to find those templates is a bit of a mystery. If you look at the top of the Bridge 

window, you’ll see how deep inside the bowels of your Mac you have to go to find these gems. 

To start let’s select Presentations, then choose Presentation 1.indt. This is a simple  3 page presentation 

with some interesting graphics that will let us go through a few of the newer features in terms of 

interactivity.
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Note that when you open a template, it opens automatically as Untitled.  The next thing that should 

strike you about this template is graphic on the first page.  See the masking and the vector curves that 

make up the graphic frame.

1. Start with the workspace. Select Interactivity from the workspace presets pull down.

2. Select the Direct Select Tool (the hollow arrow cursor) and click once on the bottom curvy 

edge of the middle graphic on the page. Click once on the line that defines the edge of the 

curvy frame. The bezier handles will appear from the near bezier anchor points. 

3. Just for the heck of it, or to put our own stamp on this design, let’s twist and adjust the curve 

up, using the bezier handle.

Fig 2-2:

4. Make some refinements to the curve, drag the point downward a bit. 

5. Switch to the Selection tool and select the large graphic in the center of the page.  
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6. Open the Links panel. If you correctly selected the major graphic on the first page, the Links 

panel should show already selected, that image. It’s called 110020028385.jpg. They really 

have certain romantic notions about naming, don’t they.

7. Still in the Links panel, choose the Relink button on the bottom (it looks like a chain). 

Navigate to Macintosh HD/Library/Desktop Pictures/Black & White/Sea Mist.jpg

8. Note the change on the page. While we’re at it, let’s change the text on that page too. 

9. Now let’s change some of the other graphics as well. In the Links Panel, relink the bottom 

graphic 110020024701.jpg to another of your desktop pictures. I’ve chosen ../Plants/

Dandelion.jpg. 
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10. Select the graphic 11002002470.jpg which sits one above Dandelion.jpg in the Links panel 

and relink that to the same Dandelion.jpg. Your Links panel should look like this:

11. We can change the other graphics if you like, but it’s not necessary. What we want to do now 

is look at how easy it is to change a repeating graphic from within the Links panel.

12. Select the top Dandelion.jpg (2) line, and relink that to Peony.jpg in the nature folder. 

13. Select just the bottom Peony.jpg in the Links panel. Relink just that one back to 

Dandelion.jpg.

What you have just seen is how you can change graphics singularly, or if they are repeating, all at once, 

through the Links panel. Now let’s open the Paragraph Styles panel. 

1. Select Window > Type and Tables > Paragraph Styles

2. Double click on the style named Upper Right.

3. Scroll down through the dialog window to Character Color. Select the bottom color in the 

list.

4. Save the document. Name it 3 Page Presentation.
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Creating simple flash SWF files directly from within Indesign
We have a simple 3 page presentation. Of course it could be a 50 page presentation, but for basic 

principles this will do just fine. Since it’s a presentation, let’s figure we will want to export the final 

piece in one of two ubiquitous formats. The first, and most obvious is PDF. That’s been the natural and 

native format for InDesign since it first started. But now we also have the choice of making this an SWF 

or flash file. 

Both formats are interactive. A PDF is a good way of sending someone a file that they can print out, 

and that you can send rather easily via email, or as a download from a site. The SWF is more of a web 

presentation.  The main thing we have to concern ourselves with here is how to make it possible for 

viewers of the presentation to navigate from one page to the next without too much trouble. 

Buttons.

1. Find the Sample buttons panel, and select an appropriate arrow button pointing to the 

right.

 

2. Drag the selected button directly on to the first page of the document.
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3. Place the button so that it aligns with one of the other objects on the page (using the Smart 

guides and Smart Cursor, of course). Keep it selected.

4. Select the Buttons panel. Name the button something appropriate. By default the sample 

buttons have basic functions already assigned. They also have “states” , for when you rollover 

or click on them.

5. Now repeat the whole process only with a return or back arrow. Place the arrow on the 

second page.
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6. Name the back button,  set its characteristics and functions.

7. Make sure to duplicate that back button on the final page.

8. Finally, we can apply a transition for when the viewer turns 

pages, or goes from one page to the next. Select the Page 

Transitions panel. Scroll through the various transition samples. 

We’re going to make this a SWF file, so let’s do something 

special. Choose the Page Turn transition. Then select the control 

menu and choose Apply to All Spreads.
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9. Choose File > Export  and select SWF as the format for output. 

10. After deciding on size for output, the page range, and all interactivity, make sure to have 

View SWF after Exporting selected. Click OK.
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Cooler Color Control with Kuler

You’ll find the files we need for this section in the download 

http://shalat.com/dev/mw09/illustechniques.zip

One of the best things to come down the pike in a long time started out as an experimental website 

from Adobe, called Kuler. I’m still not sure how they want us to pronounce it, whether it’s koo-ler or kuh-

ler. Obviously some developer engineers don’t have much practice with elegance in language, or how 

to make clear a homophonic pun. But be that as it may, I’ll call it Kuler. Oh, sorry. Pronounce that koo-ler. 

Kuler grew from just being an esoteric website to an integral part of the color controls inside Illustrator 

itself. But in order for us to get a good understanding of this excellent tool, we’ll start with the online 

site, and see how we can pull the color themes from the Kuler site 

(http://kuler.adobe.com) into our live illustrator workflow.

The Kuler site is pretty intuitive. It’s a good idea to get an Adobe ID (it’s free) so that you can save any 

color schemes you create, and so that you have access to all the other online assets that Adobe has to 

offer.

When you open Kuler, you’ll be greeted by a color group of five swatches, and below that a number of 

links. On the left are the navigation links. The second column has examples of color sets developed by 
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other users. The third column has more information about the selected color set, that is simultaneously 

stretched across the top.  The next column is a set of buttons that let you add color sets to favorites, 

download a set, or make adjustments. Finally, the last column is just some news and other palaver form 

Adobe. 

Let’s take a quick walkthrough the online site. 

Before you do anything else, click on the large color set at the top. It will fill the screen, letting you 

really assess the harmony of these swatches. After you’ve perused that, you can and should explore 

this site. Click on the Links, or Community. Check out the Themes, root around the various parts. 

After you’ve seen what others have done, looked at the Links and eavesdropped on the community, it’s 

time to create your own color set.

Power Tools Conference:
InDesign for the Practical User  Andrew Shalat

 Page 2 of 13



Click on Create.

The currently selected color set will be the one you first see in the Create area.  Creating a new color 

set has to do with what are called Harmony rules. We’ll see Harmony rules in a moment when we open 

up Illustrator’s Color guide palette. 

You have some choices here as to how to proceed. By default you’ll create your color set From a Color. 

The next column to the right then gives you some more choices.  These are the harmony rules in 

action. Click on Analogous, and see how the stems in the color wheel adjust. Then click your way 

through each of the subsequent rules, from  Monochromatic to Triad to Complementary, and so on. 

With each different rule, the corresponding arms on the color wheel adjust. One color in the color 

wheel is highlighted. That’s the Base color. You can at any time select a different base color by clicking 

on one of the large swatches and then choosing “Set as Base Color”. It’s pretty simple stuff really. The 

Kuler engine does all the hard work. All you have to do is point it in the direction you want to explore.
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As you go through the various adjustments available via the harmony rules, you can then start playing 

directly on the color wheel itself. Grab any of the color circles at the end of arms, and move them 

around. Drag them in or out, or around. This is the real fun part. Depending on the rule you’re working 

under, the other colors will work in a corresponding manner.  When you are satisfied (momentarily, I’m 

sure), take a look at the large swatches below the wheel. You’ll see a bit of further adjustments, and 

information.

This is one of the best utilities of Kuler. The comprehensive color information 

you get with any swatch you create opens up the world of color transfer and 

tanslation from one medium to another.  If you’re developing a logo for a 

company, for instance, and you want to have the correct formula for the 

corporate color, all you need to do is put the color into your color set on 

Kuler, and read the corresponding formulas for RGB (Red, Green, Blue), CMYK 

(Cyan, Magenta, Yellow, Black), HEX (hexadecimal values from RGB for the 

web), as well as LAB (Luminance, A and B channels)  and HSV (Hue, Saturation 

and Value or Lightness).

A second way to develop a color set is from an existing image. This new version of Kuler (updated in 

November, 2008) lets you upload your own images, or access otehr images via Flickr.

Inside the zip file package I’ve made available to you, you’ll find an image called “italiancheese.jpg”. If 

you wouldn’t mind uploading that, you’ll start to see how this works. 
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When your image comes up, you’ll find five color spots in the photo. You can move these around to 

designate a range of colors within your 

image. 

You can adjust these colors in the same 

way you did above with a color set 

derived from a color. The next step is to 

name and save your color, add tags so 

that it can be indexed on the community, 

and then finally to download it to your 

own computer.

So we have our color set, named 

italiancheese, derived, appropriately 

enough, from an image of, uh, italian 

cheese.  We’ve saved it, named it, given it 

tags, and now we want to download it. 

When you do download the set, it will be 

called italiancheese.ase. Put it somewhere 

on your computer that will be easily 

accessible. 

We now have saved our color set, (or Theme),  and we want to put it to use inside InDesign.
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Kuler inside InDesign

One of the best things about the CS4 suite (isn’t that redundant? Creative Suite 4 Suite?) is its integration 

of Kuler controls within most of the applications. So you’ll find Kuler controls in Illustrator, Photoshop, 

InDesign, Flash, even Fireworks. Of course, it’s never as easy as just opening a main menu and finding 

Kuler right there. You have to search for it. You will find it following  this path:  Windows > Extensions > 

Kuler. 

Don’t become frustrated if the Extensions menu isn’t in exactly the same place in each application. 

Take your time and you’ll find it. In one case it may be three from the top, in other cases, as in InDesign, 

it’s seven menus down (if you don’t count Arrange and Workspace). 

Select Kuler. The Kuler panel is partially dependent on you being connected to the internet. That’s 

because it’s taking a direct RSS feed from the Kuler site we discussed above. 

So the listings of color sets are live from the Kuler site. The cool (kule?) part 

of it is the button on the bottom right. If you select a color set, then click 

on the button at the bottom right, those colors will automatically appear 

in your Swatches panel. 

Of course, the Create button at the top is nagging at you, isn’t it? Using the 

same essential controls we saw in the Kuler site, the Create controls within 

this panel let us, well, create new color sets, or modify those we find in the 

listing from the site. 

The Create area will also let you adjust the brightness of each hue, change 

your base color, make their harmony rules whatever suits your particular 

needs.
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Once you’ve created your set to your satisfaction (or the satisfaction 

of your clients) you can save the set, or Theme, as they like to call it. 

Click Save Theme, name the theme and choose the Browse button 

again.
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Instead of seeing the Most Popular, or Newest, or Highest Rated, 

select Saved. Now you’ll find where your Theme or color set 

lives. From here on, it’s the same process. If you want these 

colors as a unified theme for your document, choose Add to 

Swatches. 

One important thing to note is that your new colors will be in RGB. If you’re creating a document for 

the web, as we did earlier on, that’s fine. But if you’re planning on going to print, more specifically, 

offset printing, with Process, you’ll want to be aware of that. You will want to edit your colors further 

from the Swatches palette, to make sure there aren’t too many surprises down the road.

Connections
If you’ve played around in Leopard at all, you’ll no doubt have come across the new screen sharing 

options. That’s a great feature if you want to show someone exactly what you’re doing, or if you ned to 

show someone how to do something right on their own screen. You can, with their explicit permission, 

take over their screen, and even if you’re on the other side of the world, work their Mac as if it were 

your own right in front of you. I must say, it’s a little disconcerting. Sort of like proof of the Ghost in the 

Machine. 

All CS4 applications now incorporate their own version, Adobe style of screen sharing. As with Kuler, 

you’ll need to have an Adobe ID (relax, it’s free).  Here’s the thing that makes it particularly Adobe. You’ll 

find the Share My Screen menu under File (File > Share My Screen) but you’ll also find the Adobe 

Connect (which logs you in to Adobe) where you also found Kuler. That is, buried in Window > 

Extensions > Connect. 

Power Tools Conference:
InDesign for the Practical User  Andrew Shalat

 Page 8 of 13



Be that as it may, this will allow you to show your layout an design with colleagues, or if you’re brave 

(read: crazy) with clients. 

Conditional text
The idea of multi-purpose, of being able to use one source document for several and various media 

and venues has been kicking around for some time.  But with the new Conditional Text feature, 

InDesign takes it a bit further than it’s been able to go before.  If you’ve ever worked with layers, in an 

active sense, then you’ll have some idea of how this works. 

But this is a bit more sophisticated than just turning on the visibility of layers, because this feature lets 

us rewrap text, show anchored objects, or not, and have the text flow with each scenario. 

Let’s do a simple setup. 

1.  Open a new document

2.  For this example, drag out a text frame and insert placeholder text (Type > Fill with 

Placeholder Text).

3. Now create an anchored object. Anchored objects are odd 

things. In order to do that you must select the Type tool, 

then choose Object > Anchored Object > Insert. A dialog 

window will appear with a bunch of options. We don’t want 

to go into all that here but we do want to make one specific 

option.  From the Object Options section, choose Graphic at 

the Content pull down. We can adjust the positioning some 

other time. But we’re not concerned here with the 

aesthetics. So click OK.
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4. Now with the new anchored object still selected, Place an image into the frame, just as you 

would any normal graphic. I’ve selected one of the Desktop Pictures (Macintosh HD > Library 

> Desktop Pictures > Nature…) to make things easy. But you can put anything you like. 

 Note the anchor icon. When placing the image, you may have to also use the Fit Content 

commands (Object > Fit Content…) to make it fit proportionally within the frame.

5. Open the Conditional Text panel (Window > Type & Tables > Conditional Text). The 

Conditional Text panel should show one item, Unconditional Text. By default everything you 

have starts as Unconditional text. That means it thus far has no conditions applied to it. 

6. We want to create three new conditions. As you might surmise, the process for creating a 

new condition is similar to most panel interface processes. Click on the create new icon or 
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use the Create New Condition command form the menu controls in the upper right of the 

panel. I want to have three instances of this document. The first with all the text, and the 

image, the second with just the text, and no image, and finally, one with just the first 

paragraph and no more.

7. So create one condition and call it With Image and Paragraph. Then a second condition, 

called Without Image, with Paragraph. And finally, Without Image, Without Paragraph.

8. Now for the fun part. Using the Text tool, select the second paragraph. Then while it is 

selected, select the first of our conditions in the Conditional Text panel. A check mark should 

appear next to the condition.

9. Now select the anchored object, and repeat the process from above. That is, click once again 

on the first condition, With Image and Paragraph. Again, the check mark should appear.

10. Finally, since our last condition is really just a condition of absence that is covered by the 

other two, we don’t have to do anything. It is essentially a mirror of Unconditional.  I only 
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want to have it as a separate condition, for the next step. I know it sounds confusing, but it 

will all make sense, hopefully in a moment.

With each condition, there is a corresponding visibility icon.  Alternately turn on and off each 

condition.  This is the simplest use of conditions. We’ll go into this a bit more live in seminar, using a 

slightly different example as well.

When you start using more than two conditions, it starts to get confusing. One on, one off, the others 

on and off alternately. It can start to become a bit hectic. So to alleviate that problem, the Conditional 

Text panel lets you set up Condition Sets. 

Once you’ve set up your sets, you can choose them from the Set drop down.
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The practicality of Conditional Text will become apparent as you start to consider versions of your 

documents, either for US/European pricing schedules, or just business card sets that use the same 

basic elements, but vary on titles, for instance. We’ll go over this in seminar as well. I hope this gives you 

at the very least, an idea of how to approach the new feature.
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