
Beyond Print
There is a wide array of options for creating onscreen, interactive, or eDocument:
 » HTML (Web)
 » PDF
 » EPUB
 » SWF (Flash)
 » iApps or apps

 ӹ Standalone (e.g. Interview magazine, Alice Lite, etc.)
 ӹ Content delivery apps (one app that allows multiple issues or various content to be 

downloaded; e.g. Wired, The New Yorker, Zinio, Time, DI Magazine, Publisher, iGIZMO, 
Marvel, InDesign Mag, NY Times, etc.)

In general, when creating interactive documents, choose Window > Workspaces > Interactive. 
That way you get all the proper panels. (In CS5, that includes Animation, Timing, Buttons, 
Bookmarks, Hyperlinks, Media, Object States, Transitions, and Preview.)

Best  PDF readers I’ve found for iPad: iBooks (Apple), GoodReader, and BlueFire

EPUB
 » Think of EPUB like a Word document: It’s linear! The same documents that could be flowed 

in Word are appropriate for EPUB: novels, scientific papers, articles. Most other publications 
(catalogs, magazines, newspapers, textbooks, etc.) are not good for EPUB.

 » We may see some significant changes in EPUB v3, by summer of 2011.
 » You can see some cool examples of ebooks based on different css files at: epubzengarden.com
 » EPUB is actually closer to a web page, because technically it is a set of one or more html pages, 

along with a very basic CSS, and a few other XML-type files.
 » All but the simplest InDesign files will likely require cracking open the EPUB and editing.
 » To export an EPUB, choose File > Export For > EPUB, or choose Export Book to EPUB from a 

book panel menu.

from InDesign to iPad
David Blatner, indesignsecrets.com
Macworld Expo, 2011
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 » Use File > File Info to add metadata to your InDesign documents (such as title, author, 
keywords) so that they will get added to the EPUB metadata.

 » Use your book’s isbn as the unique id if you have one. If you don’t, InDesign will add a 
hexadecimal number for you.

 » You can use the page layout for the EPUB structure flow (left to right, top to bottom) or you 
can base it on the Structure pane. There are pros and cons of both (but we still tend to like Page 
Layout more): 
indesignsecrets.com/structure-pane-versus-page-order-for-epub-export-from-indesign.php

 » Use Layout > Table of Contents Styles to create a TOC style (you don’t actually have to create a 
TOC in your document… just a style) and then choose that style when exporting the EPUB. In 
CS5, these can turn into “chapter” breaks, and therefore start on a new page.

Date Metadata in EPUB is Broken
 » You can validate EPUB files with a number of tools:

 ӹ EpubChecker is free and easy utility for Mac, Windows, and Linux:  
http://www.rainwater-soft.com/epubchecker/

 ӹ If you want to upload to a server:  
http://threepress.org/document/epub-validate

 ӹ Or you can run your own command line check:  
http://code.google.com/p/epubcheck/

 » One of the first things you’ll notice is that all of InDesign’s EPUB files fail validation because 
they’re missing the date metadata. You can add this in by cracking the EPUB (see section 
below) and editing the content.opf file. The element <dc:date /> should be  
<dc:date>1991</dc:date> (or whatever year is appropriate).
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 » Here’s more information about editing metadata in the EPUB file: 
http://electricbookworks.com/kbase/creating-epub-from-indesign/after-indesign-export-to-
epub/add-metadata

Hyperlink Forward is Also Broken
 » Many hyperlinks are also broken in InDesign’s EPUB export:

 ӹ Hyperlinks to URLs work fine, but links to other sections in the epub are broken. 
Background: when a document is broken up into sections, each one becomes a separate 
xhtml file inside the EPUB document. This happens if you use the book panel (for multple 
chapters) or if you use the Use First Level Headings as Chapter Breaks. This is important 
because each xhtml file needs to be kept small. However, hyperlinks forward from one xhtml 
file to a later xhtml file do not work. The text anchor is included properly, but the xhtml file 
name is not. Therefore, the link fails. Links back to an earlier section/xhtml file do work 
correctly.

 ӹ This is also the case for cross-references: links forward fail; links back seem to work.
 ӹ Footnotes are also created as hyperlinks. Unfortunately, the footnote is placed in the last 

section of the chapter instead of the same section as the footnote reference. So they fail, too.
 » Script by Teus da Jong fixes both the date and most of the hyperlinks problems:  

http://www.teusdejong.nl/thome/ho_body5.html 
This gives you a command called File > Export For > EPUB with corrected links and the 
correct date metadata.

 » Footnotes are still not fixed with this script. For these, you will have to either move the footnote 
to the same xhtml file as the footnote reference, or add the proper xhtml name to the link.
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How to Crack an EPUB
 » EPUB is actually a zip archive. You can change its name to .zip and decompress it to see what’s 

in it. However, it’s less obvious how to zip it up again; files have to go in the right order, etc. So 
in general, it’s better to work on the archive without unzipping if you can.

 » There are a number of tools that let you open EPUB archives more easily:
 ӹ Springy (Mac OS): http://www.springyarchiver.com/
 ӹ Oxygen XML Editor (Mac and Windows): http://www.oxygenxml.com/
 ӹ Sigil: http://code.google.com/p/sigil/
 ӹ Phone Disk (Mac or Windows): http://www.macroplant.com/phonedisk/ 

iPad File Explorer (Windows 7): http://www.easypadapps.com/ipad-file-explorer.html

Editing and Including Your CSS File
 » Once you edit your CSS file, save it somewhere on disk so you can include it in your future 

EPUB files (choose Use Existing CSS File in the export to epub dialog box).

Other EPUB Tricks
 » All images out of InDesign are GIF or JPEG — in other words, all raster. You can use PNG 

if you insert them manually, by cracking. If you want scaleable vector images, you want SVG 
(which is supported in EPUB), which you can get with a plug-in: 
http://indesignsecrets.com/svg-import-and-export-means-better-epubs.php

 » In general, you’re going to want to redo all your images in Photoshop for your EPUB version of 
your document. Cari Jansen has a good post on making images for EPUB: 
http://carijansen.com/2010/09/13/image-quality-and-epub/

Resource for learning more:

 ӹ www.adobe.com/products/indesign/epub/howto
 ӹ Straight to the Point by Liz Castro: http://elizabethcastro.com/epub/
 ӹ How to Create an eBook with Adobe InDesign CS5 by Rufus Deuchler: http://www.amazon.

com/Create-eBook-Adobe®-InDesign®-ebook/dp/B0048EK1P8
 ӹ Exporting EPUB files from Adobe InDesign: www.adobe.com/products/indesign/epub/

howto/pdfs/eBooks_exporting_epub.pdf
 ӹ Optimizing images for the EPUB file format: www.adobe.com/products/indesign/epub/

howto/pdfs/eBooks_optimizing_images.pdf
 ӹ Common questions about creating EPUB files with Adobe InDesign: www.adobe.com/

products/indesign/epub/howto/pdfs/eBooks_common_questions.pdf
 ӹ What’s new in Adobe InDesign CS5 EPUB file export: www.adobe.com/products/indesign/

pdfs/whats_new_indesign_cs5_epub.pdf 
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 » InDesign objects (lines, frames, page geometry, etc.) do not get exported to EPUB! So what do 
you do if you want an InDesign layout in your EPUB (such as a book cover)? Make the artwork 
as an InDesign document page and then import one INDD into another. Even better, you can 
use the free LayoutZone from Automatication. (You could also just export the page as PDF or 
JPG from InDesign and import that, but INDD into INDD is more flexible.)

 » You can use object styles in InDesign to create DIV classes: 
http://indesignsecrets.com/indesign-object-styles-convert-to-div-classes-in-epub-export.php

 » Text wrap inside EPUB is all based on floating divs with CSS. Once again, if you want to make 
great EPUB, you want to bone up on CSS and xHTML.

 » Unfortunately, if you include local overrides, InDesign includes all your overrides as spans 
inside the HTML. For example, even if you kern two letters in a word, it turns into a span. That 
is crazy. Better to make sure all relevant styling (all the stuff you want in the epub) is based on 
character styles and then not turn on that local overrides option when exporting the epub.

 » Bonus tip for turning important local overrides (such as italic and bold) into character styles 
throughout a whole book: Use Blatner Tools to apply the character styles automatically.

Selling in iBookstore and Elsewhere
1. Export the InDesign document to EPUB.
2. Add the EPUB file to the iBooks app on your iPad for previewing and testing.
3. Sell your EPUB publication on the iBookstore. You can get your EPUB included in the 

iBookstore in either of these ways:
 ӹ Set up an iTunes Connect account, and once you’re approved, upload your EPUB files 

directly to Apple
 ӹ Create an account with one of the third-party iBookstore aggregators approved by Apple, 

upload your files to the aggregator, and then have the aggregator submit your EPUB files to 
Apple on your behalf

 » You must supply an ISBN-13 for each EPUB file you intend to distribute in the iBookstore. You 
can purchase a single ISBN or multiple ISBNs in blocks of ten or more from Bowker: www.
myidentifiers.com. Some of the aggregators include the provisioning of ISBN numbers in their 
services.

 » publisher—The application for an iTunes Connect account is available at  
https://itunesconnect.apple.com/WebObjects/iTunesConnect.woa/wa/apply

 » Currently, Apple has seven approved iBookstore aggregators:
 ӹ BiblioCore—www.bibliocore.com
 ӹ BookBaby—www.bookbaby.com
 ӹ Constellation—www.perseusdigital.com
 ӹ INgrooves—www.ingrooves.com/digital-publishing
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 ӹ Ingram—www.ingramcontent.com/apple
 ӹ Lulu—www.lulu.com/apple-ipad-publishing
 ӹ Smashwords—www.smashwords.com/about/how_to_publish_ipad_ebooks

Creating iApps and Content Delivery Apps
 » Digital Magazine Publishing Solution from Adobe

 ӹ Details and hyperlinks in Adobe’s press release: 
http://indesignsecrets.com/pr-adobe-announces-new-digital-publishing-suite.php

 ӹ This is what Wired, New Yorker, iGizmo, and many other magazines have been using (in 
beta) over the page 6 months.

 ӹ In beta, this has been a challenging and complicated solution, but Adobe will likely make it 
far easier.

 ӹ It’s expense appears to put it out of reach for many publishers
 ӹ See the article that Terri Stone wrote in Issue 38 of InDesign Magazine about the experience 

of creating the InDesign Mag issue. for the iPad
 ӹ K4 (MEI) is basing their workflow solution on top of Adobe’s DMPS.

 » Other companies are working on InDesign-to-iPad/tablet solutions, including Woodwing and 
PIxelMags. You can see Woodwing’s workflow, working with Time Magazine, in this YouTube 
movie: http://www.youtube.com/watch?v=G_oBpaMuCvc 
and see their gallery of clients at http://woodwing.com/en/digital-magazine/ipad-gallery

 » Other options for publishing on the iPad/tablet include:
 ӹ Zinio: National Geographic, Macworld, and many other magazines. This appears to be based 

on PDF with additional interactivity added. Zinio is available on a number of devices (iPad, 
Mac OS, Windows...)

 ӹ Custom solution: Esquire magazine and Interview magazine appear to be based on custom 
solutions written by third-party developers.

 » When creating an App (or an issue for a content delivery app), you need to remember that 
many readers are not going to know how to use it. Give them instructions! The New Yorker 
made a (very funny) movie. InDesign Mag and Wired provide step-by-step technical drawing 
instructions. Teach the reader how to read and interact with your app.

 » Also don’t forget to make it really clear where the interactive content is in your publication. It’s 
often not immediately obvious whether it’s a static graphic or a dynamic element.

 » Note that these solutions all rely on you (the designer/production person) creating at least two 
layouts for each page: horizontal and vertical. That means, you may be making independent 
documents for _h, _v, epub, print, and web (and more!)
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