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Read Me First 
Welcome to Take Control of High Sierra, version 1.1, published in 
September 2017 by alt concepts inc. This book was written by Scholle 
Sawyer McFarland and edited by Kelly Turner. 

This book helps you with Apple’s macOS 10.13 High Sierra operating 
system. It focuses on the new things High Sierra makes possible, like 
taking Live Photos of a FaceTime conversation, typing instead of 
talking to Siri, and easily sharing a file through iCloud. It also covers 
the interesting changes in various Apple apps such as Safari and Mail 
while including a hand-picked selection of key tips for getting the most 
out of your Mac. 

If you want to share this ebook with a friend, we ask that you do so 
as you would with a physical book: “lend” it for a quick look, but ask 
your friend to buy a copy for careful reading or reference. 

Copyright © 2017, Sawyer McFarland Editing. All rights reserved. 

Updates and More
 

You can access extras related to this ebook on the web (use the link 
in Ebook Extras, near the end; it’s available only to purchasers). On 
the ebook’s Take Control Extras page, you can: 

•	 Download any available new version of the ebook for free, or buy 
any subsequent edition at a discount. 

•	 Download various formats, including PDF, EPUB, and Mobipocket. 
(Learn about reading on mobile devices on our Device Advice page.) 

•	 Read the ebook’s blog. You may find new tips or information, as 
well as a link to an author interview. 

If you bought this ebook from the Take Control website, it has been 
added to your account, where you can download it in other formats 
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and access any future updates. However, if you bought this ebook 
elsewhere, you can add it to your account manually; see Ebook Extras. 

Finding System Preferences
 

As you settle into High Sierra, you’ll likely be tweaking the settings in 
Apple’s System Preferences app often. When I write about working in 
System Preferences, I don’t always spell out how to efficiently open the 
app. Here are common methods of accessing it: 

• Choose Apple  > System Preferences. 

• Click the System Preferences icon on the Dock (Figure 1). 

Figure 1: A quick way to access your Mac’s settings is to click the 
System Preferences “gear” icon in the Dock (center). 

• Have Siri open a particular System Preferences pane for you. 

Force Click 
Force-clicking isn’t new, but it might be new to you since more Macs 
include it now. If you have a Force Touch trackpad (newer laptops 
and the Magic Trackpad 2 qualify), many extra tricks are available 
when you force-click—or click with extra pressure. 

Note: For help with menus, paths, and other basic topics, check out 
Read Me First: A Take Control Crash Course, available for free on the 
web or as a standalone ebook in PDF, EPUB, and the Kindle’s Mo-
bipocket format. 
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What’s New in Version 1.1
 

The first version of this book offered early access to tips and tricks 
available in High Sierra’s public beta software. Version 1.1, based on 
the shipping version of High Sierra, adds chapters about several topics: 

•	 Storage Management: High Sierra’s new file system and space-
saving improvements to apps like Mail help preserve precious 
storage space, but the macOS also includes built-in tools to wrangle 
your bytes. See Manage Your Storage. 

•	 iCloud Family Sharing: Learn how to Use iCloud Family Sharing 
to simplify sharing media and more with family members. High 
Sierra streamlines sharing with a revamped Manage Family pane 
and lets you share an iCloud storage plan with your group. 

•	 Troubleshooting: Troubleshoot Mac Problems helps you prepare 
for everyday difficulties. This chapter includes High Sierra-specific 
issues that affect Boot Camp, external drives, and Microsoft Office. 

You’ll also find the following bits of new information: 

•	 Mail includes a new Spotlight-powered feature that makes it easier 
to find relevant messages when you search, as explained in Peruse 
Mail’s Top Hits. 

•	 Apple’s digital assistant offers new and improved voices. Learn how 
to use them in Change Siri’s Voice or Language. See an updated 
technique for activating Siri with your voice in “Hey, Start Siri!” 

•	 An iTunes update right before High Sierra shipped changed how we 
find and download previously purchased iOS apps. I explain in 
Where’d My Old iOS Apps Go? 

•	 I’ve added more detail about which Macs upgrade automatically to 
use the new file system introduced in High Sierra. We also found 
out that the initial release of High Sierra does not support APFS on 
Fusion drives; if you converted any during the beta period, you’ll 
need to revert them to the old file system. See One Big Caveat. 
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•	 The feature that once let you follow an RSS feed in the Safari side-
bar is gone as of Safari 11. Learn how to cope in Bye-Bye, Safari 
Shared Links. 

•	 How you go from your Mac to an iOS device using Handoff has 
changed slightly. See Move Between Devices with Handoff. 

Features that are MIA 
Some of the features that Apple advertised as part of High Sierra 
(and that may have even appeared in earlier beta versions) haven’t 
made it into the final version. We suspect we’ll see these slipped into 
a High Sierra update sometime soon: 

✦	 Messages History in iCloud: We expected High Sierra to store 
Messages’ history in iCloud to make it possible to see old mes-
sages on any device you signed in to with your iCloud account. 
This also would have saved local drive space. 

✦ Multiple Wikipedia Results in Spotlight: Apple said High Sierra 
would make it possible to get multiple Wikipedia results when you 
used Spotlight to search for something that could mean more than 
one thing. (Think: mercury.) Nope. 

✦ New Emoji: High Sierra was expected to ship with 56 new emoji 
from Unicode 10.0, the newest standard for the tiny pictures that 
make our emails and messages so much more expressive (see 
Emojipedia for examples). When they do make it to the Mac, 
offerings will include exploding head, crazy face, sandwich, elf, 
zombie, and more (Figure 2). 

Figure 2: These sample Unicode 10.0 emoji are from Emojipedia; 
the final Mac versions’ style may differ slightly. 

✦ Siri and Apple Music: If you’re an Apple Music subscriber, Siri is 
supposed to be able to read album notes and answer questions 
about songs, albums, and artists. That feature still wasn’t avail-
able at publication time. 
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Introduction 
“If it could save a person’s life, would you find a way to shave ten 
seconds off the boot time?” As the story goes, Steve Jobs laid out the 
importance of the Mac’s performance to one early engineer like this: 
Seconds of waiting here and there, multiplied across millions of 
people, could add up to a lifetime of wasted time. 

It’s appropriate, then, that the biggest changes in macOS 10.13 High 
Sierra are about speed. From its modern file system (the first such 
update since 1998) to new video and graphics technologies to enhance-
ments folded into apps like Safari and Mail, High Sierra delivers many 
improvements that you can’t see, but you’ll definitely feel. 

As for the changes you can see, this book is here to help. I’ll make sure 
you don’t miss any of the new features—some little, some big—added 
to your Mac’s apps and system-wide tools. 

You can read the book straight through to learn about all the new 
features, or browse the topics in What’s New in High Sierra? to find the 
chapters that interest you the most. I also cover some macOS funda-
mentals and the least you need to know to prepare for and handle 
trouble, like how to run Recovery mode when your Mac is on the fritz. 

My assumption is that you’ve installed High Sierra on your system, and 
now you’re ready to go. For detailed help with upgrading, see Take 
Control of Upgrading to High Sierra. 
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What’s New in High 
Sierra? 

High Sierra builds upon and adds to the changes that macOS 10.12 
Sierra brought us. Many of its improvements affect the Mac’s funda-
mental technologies, but you’ll also find updates to key apps. Use the 
links in this chapter to jump straight to the new features you’re most 
interested in. 

Cross-device Features
 

Chances are you have more—maybe a lot more—than one Apple 
device. Apple continues to make it easier to move between them and 
sync your data using iCloud integration: 

•	 iCloud Drive Sharing: Now you can share a file with other 
iCloud users without juggling different versions in email. Learn how 
in Navigate iCloud Drive. 

•	 Universal Clipboard: Sierra made it possible to copy and paste 
text and images between iOS and macOS devices, now High Sierra 
lets us do the same between two Macs. We walk through how this 
works in Copy and Paste between Devices with Universal Clipboard. 

•	 Improved Family Sharing: If you want all your loved ones to 
share digital media and more without having to share an Apple ID, 
you’ll be happy to hear High Sierra streamlines Family Sharing by 
making its settings easily accessible in a revamped Manage Family 
pane. In addition, if you buy more storage for your iCloud account, 
now you can share it with your Family Sharing group. See Use 
iCloud Family Sharing. 
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System-wide Tools
 

High Sierra puts even the deepest recesses of your Mac (and the 
internet) within easier reach: 

•	 Siri: Apple’s digital assistant trades in its old voices for smoother, 
less robotic ones. Siri also gains Apple Music DJ powers, learning 
your preferences and tailoring playlists to your mood (Figure 3). 
You can now type questions and commands to Siri if you want to 
keep your side of the conversation quiet or you have a disability that 
limits your speaking. Learn about this and more in Say Hello to Siri. 

Figure 3: Siri is happy to tailor a playlist to your mood. 

•	 Spotlight: Use Spotlight to look up flight info, from arrival and 
departure times to where to pick up your bags. See Find Files and 
Facts with Spotlight. 

•	 Notification Center: The new Now Playing widget beefs up your 
control over media, whether it’s playing in iTunes, QuickTime, or 
Safari. Get up to speed in Keep Current with Notification Center. 

Touch Bar Tips 
Apple’s Touch Bar adds a new twist for MacBook Pro users who have 
this special touch- and context-sensitive strip along the top of their 
keyboards. Look for tips for using it throughout this book. 

9
 

https://www.apple.com/shop/buy-mac/macbook-pro


         

         
       
    

         
          

          
   

          
           

             
           
           

              
 

          
           

               
       

       

       
         

         
            

             
          

       

Apple Apps
 

Here’s a look at what’s new in your Apple apps: 

•	 Dictionary: The Mac continues to established itself as an in-
ternational polyglot, adding additional Russian and Portuguese 
dictionaries with this update. See Add New References to 
Dictionary. 

•	 FaceTime: Now you can capture special moments from FaceTime 
sessions as Live Photos—mini-movies that record a few seconds of 
life, complete with sound. I show you how in Save FaceTime Mo-
ments as Live Photos. 

•	 Mail: Home in on the right message using Mail’s new Spotlight-
powered Top Hits, as explained in Peruse Mail’s Top Hits. When 
you’re in fullscreen mode in Mail, the app now uses Split Screen to 
write a new message. Get the details in Compose New Mail Mes-
sages in Split Screen. Apple also says it has improved its compres-
sion of Mail messages so that they take up to 35 percent less space 
than before. 

•	 Notes: Notes carves out more territory as a full-fledged note-taking 
tool, this time letting you organize your information in tables and 
allowing you to pin important notes to the top of a list so you can 
find them fast. Check out Note Your Thoughts. 

•	 Photos: Photos gets a big upgrade in High Sierra: 

‣	 The Photos’ sidebar—now displayed by default—has been reorga-
nized into Library, Shared, Albums, and Projects sections. The 
Library section includes a new Imports header, which you can 
click to see what you added to your library on a certain date. 

‣	 The editing pane adds a sidebar full of controls and tabs let you 
toggle between Adjust, Filters, and Crop views. You’ll find seven 
new filters under the Filters tab (Figure 4). 
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Figure 4: You’ll find seven new filters under the Filters tab in the 
editing pane; only two from the previous version of Photos remain. 

‣	 Two new editing tools, Curves and Selective Color, give you more 
precise control. 

‣	 Edit Live Photos by choosing a keyframe photo and applying new 
effects that change the way these mini-videos play. 

‣	 Auto-generated Memories collections group images together in 
new ways, for example by pets, kids, hiking, diving, winter 
sports, nights out, and meals with friends. 

‣	 Open any photo in your library in an external image editor using 
the Image > Edit With command. 

‣	 Third-party companies, like Shutterfly, can now build Mac apps 
that link to Photos, making putting projects together easier. 

Note: Wow, that’s a lot of Photos features! Get the details about how 
to use them in Jason Snell’s upcoming Photos: A Take Control Crash 
Course. 

• Safari: Safari significantly revs up its performance while adding 
tools that make surfing more pleasant. By default, Safari stops 
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videos from auto-playing and prevents advertisers from tracking 
your behavior across sites. You can also customize your browser 
experience like never before, defining page-zoom level, location 
services, notifications, Safari Reader, and content blocking settings 
on a site-by-site basis. Get the full scoop in Update Your Safari 
Smarts. 

Fundamentals
 

A lot of work happened behind the scenes in High Sierra to rewrite or 
replace underlying technologies in order to enhance performance and 
make way for future innovations: 

•	 New File System: HFS+ has been the organizing system behind 
our files and folders since 1998, when Apple released Mac OS 8.1. 
As of High Sierra, Apple replaces it with the Apple File System 
(APFS). Optimized for solid-state drive storage, APFS promises to 
make common tasks, like duplicating files, much faster. Apple also 
touts the new file system as having stronger encryption and im-
proved crash protection for your data. This is an upgrade you’ll feel 
more than see. 

One Big Caveat 
Only Macs that use solid state drives (SSD) exclusively will be con-
verted to the new file system. The initial release of High Sierra does 
not support APFS on a Fusion drive, which contains both a hard disk 
drive (HDD) and an SSD. (That means if you converted a Fusion drive 
to APFS while using the High Sierra beta, you must revert back to 
HFS+. Learn how in this Apple Support page.) To find out what kind 
of storage your Mac uses, go to Apple  > About this Mac and click 
Storage. You’ll see a description under the drive’s icon. 

•	 Improved video support: High Sierra now supports High-
Efficiency Video Coding (HEVC or H.265), a new video codec that 
compresses video up to 40 percent more efficiently than H.264, the 
standard Apple employed previously and which is widely used 
across computers, mobile systems, and televisions. Basically, the 
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gist of this is that when you’re watching video from a source that 
uses HEVC, video will take up less space and stream more quickly 
and smoothly. Netflix currently streams some premium content that 
might be able to take advantage of this. YouTube doesn’t yet. Apple 
support could tip the scales for both online media giants. 

•	 Support for VR: Although consumers likely won’t have games in 
hand for a while, High Sierra folds in support for Valve’s SteamVR, 
the software that powers virtual reality headsets such as the HTC 
Vive. This, combined with Apple’s Metal 2 Developer Kit support for 
external graphics, means developers now have what they need to 
start making a bunch of cool stuff. This applies to the iMac with 
Retina 5K, the new iMac Pro, and Macs with external GPUs, or 
graphics processing units. (So far, external GPUs are only available 
to developers.) 

Where’d My Old iOS Apps Go? 
Mac users have long restored old iOS apps by downloading and 

syncing them through iTunes, but a new version, released right 

before High Sierra, shifts the app’s focus to media only (Figure 5).
 

Figure 5: iTunes no longer handles iOS apps. 

Now you’ll download and deal with iOS apps on your iOS device. 
Learn how in this Apple support document. 
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Discover the Little Things 
in High Sierra 

You’re bound to find a new favorite amongst High Sierra’s small 
changes, whether it’s Live Photos in FaceTime or Mail’s Top Hits. Here 
are some of the most interesting features that don’t fit into one catego-
ry or another. 

Save FaceTime Moments as Live Photos
 

Many a special moment happens in FaceTime, from talks between 
long-distance sweethearts to the hotel-room hellos of parents calling 
from work trips. Now you can capture them all with Live Photos— 
Apple’s innovative moving pictures that include the seconds just before 
and after the shot was taken to make a mini-movie, complete with 
sound (Figure 6). Think Harry Potter and moving wizard pictures. 

Figure 6: Click the new button to the left of FaceTime’s End button 
to take a Live Photo, in this case, capturing these chicks tweeting 
adorably. 
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To help avoid breaches of etiquette, FaceTime takes steps to make sure 
each person is in control of whether a photo is taken of them or not. 
The setting for your camera is on by default in High Sierra, but you can 
turn it off by choosing FaceTime > Preferences and deselecting Allow 
Live Photos to Be Captured During Video Calls. (Same goes for your 
iOS 11 device; you’ll find a FaceTime Live Photos setting at Settings > 
FaceTime.) Both people in the conservation must have this setting 
turned on to take Live Photos of each other. 

Tip: You can’t circumnavigate these protections by taking a (station-
ary) screen shot during a FaceTime session using standard macOS 
shortcuts like Command-Shift-3, but screenshot apps like Snapz Pro 
X work. 

To take a Live Photo during a FaceTime session, click the new button 
that appears to the left of the End button. When a picture is snapped, 
the target’s screen flashes and a notice appears on their FaceTime 
screen that says “A FaceTime Live Photo of you was taken.” 

You’ll also see a notice on your end (Figure 7). The shot is added to 
your Photos Library. 

Figure 7: FaceTime flashes a notice to both parties when a Live 
Photo is taken. This is what the person who takes the photo sees 
(with the phone number redacted for privacy). 

Tip: Photos now lets you choose a keyframe (the main image that 
displays) for your Live Photo and apply new effects—Loop, Bounce, 
and Long Exposure—that change the way your mini-movie plays. 
Look for Live Photo editing tools in Photos’ Editing window under the 
Adjust tab. They’re at the bottom of the window. 
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Live Photos take up more space than regular still photos. Get overly 
enthusiastic about this feature and you might find yourself running out 
of storage space, especially if you have a MacBook Air. 

In Case You Missed It: Keep Folders on Top in the Finder 
There’s never been an easy way to prioritize folders in Mac Finder 
windows, and jumbled together with files, folders can be hard to spot. 
Sierra offered a fix for this dilemma: List folders first by going to 
Finder > Preferences > Advanced and selecting the Keep Folders on 
Top When Sorting by Name box (Figure 8). 

Figure 8: Here’s what a Finder window sorted by name looks like 
before the Keep Folders on Top setting is activated (A) and after (B). 

You have a better chance of finding what you’re looking for if you 
arrange the contents of your Finder windows to fit the way you work. 

Peruse Mail’s Top Hits
 

You’ll have more help next time you’re looking for a particular email 
message, because High Sierra includes a new way to unearth the most 
relevant search results. Spotlight-powered Top Hits rise to the top of 
the message list as you type in Mail’s search field (Figure 9). 
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Figure 9: As you type in your search term, Mail’s best guesses 
appear under the Top Hits header (circled) in your message list. 

Apple says these are based on factors including your VIP contacts, who 
you reply to frequently, which messages you actually read, and more. 
Top Hits results are supposed to improve the more you search. (See 
Find Files and Facts with Spotlight for more about Spotlight.) 

Note that Top Hits are separate from the suggestions and potential 
filters shown in the drop-down menu that appears underneath the 
search field. 

Tip: Wish you could point out a particular part of a picture you’re 
emailing? You can, easily. Force Click an image or PDF attachment to 
use Markup to annotate it. (See this support document for details.) 

Compose New Mail Messages in Split 
Screen 

In Sierra, when you created a new Mail message (File > New Message) 
while using fullscreen mode, the composing window rose up from the 
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bottom of the screen, covering most of the Mail Viewer. This was a 
pain if you were trying to reference something in another message. No 
more: Now, when you’re in fullscreen mode, Mail automatically uses 
Split View to open a new message window (see Figure 10). 

Figure 10: In Sierra, new message windows covered the Message 
Viewer when you were in fullscreen mode (top). High Sierra’s Mail 
uses Split Screen to show the composing window and the Message 
Viewer side by side (bottom). 

As before, when you have more than one new message window open at 
a time, they appear as a tabs in the new message window. For an 
explanation of Split Screen, see Command the View. 

Tip: If you have a MacBook Pro with Touch Bar, use the Touch Bar 
when you’re in Mail or Messages to access emoji more easily. Tap the 
emoji button and the ones you use the most appear across the
 

bar. Tap one to insert it in your message.
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Add New References to Dictionary
 

Sierra added Italian, Danish, Dutch-English, and Traditional Chinese
 
offerings to Dictionary. High Sierra continues to cultivate the macOS 

as a true polyglot by adding dictionaries for Russian and Portuguese.
 

Tip: When you’re not sure what a word means, Force Click it to view 
its definition. 

To add a new reference, open Dictionary (in the Applications folder) 
and choose Dictionary > Preferences. Select the boxes for any refer-
ences you would like to include (Figure 11). 

Figure 11: Scroll down to see a wide variety of references and then 
check the boxes next to the ones you want to appear in Dictionary. 
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In Case You Missed It: Picture in Picture 
The Mac’s Picture in Picture feature makes it easy to watch a video 
from iTunes or Safari while you work on something else. Click the 
Picture in Picture icon on the video control bar and the video 
morphs into a little window that floats above your other apps at the 
corner of your screen—even if you switch to full-screen or Split View 
(Figure 12). To close the window, click the Exit button in its 
upper-left corner. 

Figure 12: The picture-in-picture window floats above whatever else 
you’re working on. 

One important trick: When you watch a video on YouTube, no Picture 
in Picture button appears in the video control bar. Instead, Control-
click the video twice to reveal a contextual menu with an Enter 
Picture in Picture command. (Your guess is as good as mine as to 
why Apple hasn’t fixed this one yet.) 
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Say Hello to Siri 
Want to dictate a note, create a reminder for an important event, turn 
on Bluetooth, or make a call? Doing any of these things doesn’t have to 
take more than a single click (and sometimes not even that) when you 
use Apple’s digital assistant. And unlike with your iPhone or iPad, Siri 
on the Mac makes it easier for you to multi-task. You can keep doing 
what you’re doing while Siri completes a job for you. 

High Sierra updates Siri’s voices, turns it into your personal Apple 
Music DJ, let’s you type questions and commands to Siri when you 
want to keep quiet, and more. 

Get Started
 

First things first: open System Preferences > Siri and make sure that 
the Enable Talk to Siri option is selected (Figure 13). 

Figure 13: Go to Siri’s System Preferences pane to enable Siri, 
change its voice, use a different mic, and more. 

Warning: For Siri to answer questions that require a knowledge of 
where you are (think: “Show me good sushi restaurants”), Wi-Fi 
must be on. Siri doesn’t work at all without an internet connection. 
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Activating Siri 
Once Siri is enabled, your first step is to activate it, using any of these 
methods: 

•	 Click the new-and-improved Siri icon in the Dock (Figure 14). 

Figure 14: Activate Siri from the Dock (center icon). 

•	 Click the Siri icon in the menu bar at the top of your display. 

•	 Press and hold Command-Space. Be careful: if you hold Command 
and then tap the Space bar, you’ll activate Spotlight instead. 

If you prefer a less finicky shortcut, change it by going to System 
Preferences > Siri and choosing an option from the Keyboard 
Shortcut pop-up menu, such as Hold Option Space. Or, choose 
Customize to create a shortcut of your own devising—in the field 
that appears, press the keys you want to activate Siri. 

•	 The sidebar “Hey, Start Siri!” explains how to set up a voice-activat-
ed cue. 

Tip: If you have a MacBook Pro with a Touch Bar, you can also tap 

the Siri icon to the right (by default) of the Touch Bar.
 

When you activate Siri, you hear a chime and the Siri window appears 
in the upper-right corner of your screen. When Siri is listening, a line 
pulses at the bottom of this window (Figure 15). 

Figure 15: Siri is ready to listen when you see the pulsing line. 
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If you don’t see a pulsing line, click the orb at the bottom of the win-
dow. (The orb matches the Siri icon and replaces the old microphone 
icon.) Then, ask your question or make your request. 

To ask another question, click the orb in the Siri window or reactivate 
Siri using a method above. 

“Hey, Start Siri!” 
If you’re accustomed to hailing Siri with your voice, you might be
 

disappointed that Siri on the Mac still doesn’t offer this feature. By
 

using a dictation feature to open Siri on your command, though, you
 

can make it happen:
 

1. Go to System Preferences > Keyboard > Dictation. Turn Dictation 
on and then select Use Enhanced Dictation. If you haven’t already 
downloaded Enhanced Dictation, you’ll see a warning that it’s a 1.2 
GB download; click Use Enhanced Dictation. 

2. Go to System Preferences > Accessibility. Select Dictation in
 

the left-hand column.
 

3. Select Enable the Dictation Keyword Phrase and then type Hey into 
the text field. (Feel free to substitute your own keyword, maybe 
Yoo-hoo?) 

4. Click the Dictation Commands button, select the Enable Advanced 
Commands checkbox, and then make sure the Start Siri checkbox 
is selected in the list. Click Done. 

5. If you’d like some feedback to let you know your command is 

working, select the Play Sound When Command is Recognized 

checkbox.
 

Try it out by saying “Hey, start Siri!” and your Mac should respond.
 
(“Hey, open Siri,” “Hey, launch Siri,” and “Hey, switch to Siri” will
 
work, too.)
 

New! Typing Questions to Siri 
One of Siri’s drawbacks has been that it can be embarrassing, disrup-
tive, or difficult to talk to your computer when you’re in a busy office or 
out at a noisy café. But now, if you need to talk to Siri in private, you 
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can. The Type to Siri feature lets you type in your question (Figure 
16) and then hear Siri’s reply (ideally through headphones). 

Figure 16: If you’d like some privacy, type your question to Siri 
instead of blabbing in front of the whole office. 

The Type to Siri feature was designed to help people who can use a 
keyboard or other switch-based device to type, but have limited ability 
to speak. Perhaps for that reason, Apple doesn’t make it easy to turn 
this feature off and on as needed. 

Choose System Preferences > Accessibility > Siri and select the Type to 
Siri option to turn it on. When you want to talk with Siri again, go back 
into System Preferences and deselect the checkbox. With a little 
Automator magic whipped up by our own Joe Kissell, however, this 
process can be reduced to one easy click for those of us who would like 
to be able to switch back and forth. 

Make a Workflow that Turns On Type to Siri 
Open Automator (in Applications). In the dialog that appears, click 
Application and then click Choose. (This lets you to keep the workflow 
in the Dock or on your Desktop and activate it with a click.) Choose 
Utilities in the Library column and then drag the Run Shell Script 
action onto the blank workflow space to the right. Leave the action’s 
popup menus set to the defaults and then type (or copy and paste) this 
into the script field: 

defaults write com.apple.Siri TypeToSiriEnabled -bool true 

Choose File > Save and give it a name like TypeToSiri ON (Figure 17). 
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Figure 17: Here’s the finished TypeToSiri ON workflow in 
Automator. 

When you want to type a question instead of talking, run this app, and 
then activate Siri. 

Make a Workflow that Turns Type to Siri Off 
Repeat the process for creating a workflow to turn on Type to Siri, just 
above, but replace the text in the Run Shell Script action with: 

defaults write com.apple.Siri TypeToSiriEnabled -bool false 

Choose File > Save and give it a name like TypeToSiri OFF. 

Drag this app into the Dock or Desktop next to your ON workflow and 
you’ll be able to turn Type to Siri on and off with a double click (Fig-
ure 18). 

Figure 18: Keep your TypeToSiri apps handy on your Desktop 
(shown here) or in the Dock and then double click the correct one to 
turn the Type to Siri feature on or off. 

Apple, if you’re listening, please consider adding a built-in method 
(say, a menu bar item) in the next macOS for turning this feature off 
and on. 
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Tip: To learn about the many ways you can save time automating 
common and complicated actions on your Mac, see Joe Kissell’s newly 
updated Take Control of Automating Your Mac. 

Change Siri’s Voice or Language
 

You can change Siri’s voice on your Mac, just as can on your iPhone or 
iPad. High Sierra (mostly) swaps out Siri’s old voices for new, more 
natural ones. At publication time, all English-speaking female voices 
sported improved tone and inflection, but the American male voice still 
sound...ed...ro...bo...tic. 

Go to System Preferences > Siri and browse the choices in the Siri 
Voice pop-up menu. If you’ve chosen English (for any country), you 
can pick from a number of voices, including American, Australian, and 
British. Most (but not all) come with both male and female versions. 
For instance, if you choose English (Ireland) in the Language pop-up 
menu, the only Irish option in the Siri Voice pop-up menu is female. 

Missing in Translation 
Sadly, High Sierra’s Siri doesn’t include the translation powers built 
into iOS 11. As of that update, you’ll be able to ask Siri on your 
iPhone or iPad to translate any U.S. English phrase—in writing as well 
as out loud—into Mandarin, French, German, Italian, and Spanish. 
See Take Control of iOS 11 by Josh Centers. 

Find Files with Siri
 

Siri makes it possible to hunt down files, folders, and more without 
having to type a thing. Siri recognizes natural-language requests and 
is fast and fairly accurate. 
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Asking for What You Want 
To find a file or folder, tell Siri to “Find file <name>” or “Find <name> 
folder.” Siri can find files stored in iCloud, as well as in the cloud-
storage service Dropbox. 

What’s more, you don’t have to be exact with the name. For instance, 
when asked to “Find watch pdf,” Siri found the ebook Apple Watch: A 
Take Control Crash Course. Likewise, when I made a vaguer request 
like “Find files named Graham,” Siri brought back 115 files with “Gra-
ham” in their name. The more specific you are, the better your results. 

Here are some requests to try: “Open my Documents folder.” “Show 
my Movies folder.” “Show me spreadsheets from Friday,” “Find docu-
ments I opened two Mondays ago” (Figure 19). 

Figure 19: Siri makes it easy to search for files, even very specific 
ones. 

Tip: If you see a note below your Siri result, such as Show in Finder 
or Open in System Preferences, click it to quickly perform that action. 
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Refining Your Search 
You can narrow a large list of results by adding on to your query by 
voice. For example, if I ask Siri to “Find camp receipts folder,” I can 
then say “Just the one tagged urgent.” 

Sierra’s Siri could only handle one request to refine a search, but High 
Sierra breaks past this limitation. I was able to ask Siri “Show me 
spreadsheets” and then follow up with “Just from May,” “Just from 
June,” and then “Just from October.” After each request, Siri displayed 
relevant results without giving up and triggering a web search. 

Tip: If a file has an unusual name that Siri can’t recognize or you
 

need to run a more complicated search, use Spotlight (Command-


Space) instead (see Find Files and Facts with Spotlight).
 

Getting a Little More Information 
When Siri gives you results, sometimes you need more information to 
know which file is the right one: 

•	 Peek at a file: Click once on its entry in the Siri results list to 
select it, and press the Space bar (this feature is called Quick Look). 

•	 View a file or folder icon in the Finder: Control- or right-click 
its entry in the Siri results list and choose Reveal in Folder. A Finder 
window opens, with that file selected. 

Work with System Preferences and 
Information 

Siri is lightning fast when it comes to tweaking System Preferences, 
saving you the trouble of digging through menus and dialogs. 

Here are some of the things you can ask it: “Is Bluetooth on?” (Figure 
20) “Turn Bluetooth off.” “Put my Mac to sleep.” (Note that Siri can’t 
restart your Mac; instead it will tell you how to do it.) “Show me my 
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Wi-Fi settings.” “Change my wallpaper.” “Turn up the volume.” “What 
time is it?” “What’s the date?” 

Figure 20: Siri can check—and change—system settings, for exam-
ple, whether Bluetooth is off or on, shown here. 

Likewise, Siri can answer basic questions about your Mac that other-
wise would require a trip to Apple  > About This Mac and its many 
submenus. For example: “How fast is my Mac?” “How much storage do 
I have available?” “How much RAM do I have?” “What is my Mac’s 
serial number?” 

Do Tasks with Apps
 

Just as it can find files and help you change basic settings without 
breaking a sweat, Siri on the Mac also offers access to your apps. 

Opening an App 
Say “Open <app name>,” “Launch <app name>,” or “Play <app 
name>” to get things started. (Perhaps Apple thought it would im-
prove our attitude towards work to say “Play Photoshop” just as easily 
as “Play Sims.”) Note that Siri can’t close apps. 
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Controlling iTunes 
Siri lets you search for music, TV shows, or movies, as well as play a 
song, skip a track, or pause play. Say “Play Grateful Dead playlist,” or 
“Play the top song from 1975.” 

You can play and search for podcasts, too. Say: “Search for Clockwise 
podcast.” “Play podcasts.” “Jump back 30 seconds.” 

Tip: If you can’t quite place a song on the radio, ask Siri “What’s this 
song?” It will listen for a moment and then give you the answer. 

New! Getting More from Apple Music 
If you’re an Apple Music subscriber and are signed in with your Apple 
ID (iTunes > Accounts > Sign In), High Sierra’s Siri can serve as your 
personal DJ. Want to play dance music for a spontaneous party? Just 
ask. Time for some epic breakup music? Yep, it can handle that, too. 

Whether you need music for a particular mood (happy, mellow, sad) or 
a specific activity (working out, focusing, sleeping), this is a handy way 
to get some tunes started with a minimum of fuss (Figure 21). 

Figure 21: Apple Music subscribers can use Siri to tap into a playlist 
that fits an activity or mood. 
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Apple has said that Siri’s results are based on what it’s learned about 
your Apple Music preferences, but I sometimes saw peculiar results. 
For instance, when I asked it to “Play happy music,” it began with a 
melancholy Decembrists song, “Here I Dreamt I Was an 
Architect.” (I’m not sure if that says something about Siri or about me.) 

In addition, Apple has said that Siri will be able to answer music trivia 
questions and delve into album notes to tell you more about songs, 
albums, and artists. This feature was still missing at publication time, 
but hopefully will be a part of a future High Sierra update. 

Battle of the Personal Assistants: Siri vs. Alexa vs. Google 
Might there be a reason that Siri’s Apple Music powers received such 
love with this macOS release? I’d place my bets on the soon-to-be-
released HomePod, Apple’s response to the Amazon Echo and Google 
Home devices. (This CNET article compares all three.) The HomePod 
is being marketed first and foremost as a high-quality, voice-con-
trolled center for your music. 

Keeping an Eye on the Calendar 
Siri can add, change, or tell you about events in your calendar. 

Get the gist of the day by asking “What does the rest of my day look 
like?” 

Say “Set up a meeting with Kelly for tomorrow at 3:00,” and Siri 
creates the event and even warns you of conflicts. Say “Move my 5 PM 
meeting to tomorrow at 2 PM,” and Siri shuffles things around. 

Tip: To learn more about how Siri can help whip your schedule into 
shape and make leaving yourself reminders quick and easy, read my 
book Take Control of Calendar and Reminders. 

Adding a Reminder 
A truly useful Siri feature is the capability to quickly set a reminder for 
yourself. 
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Say “Remind me to call my sister at 5 PM” and Siri makes a reminder 
for 5 PM and alerts you then. Or, say “Remind me to take out the trash 
in the morning,” and Siri creates a reminder for the next day at 7 AM. 

If you want to come back to something later, say “Remind me of this.” 
Siri makes a reminder based on what you’re viewing, for example, a 
Mail message, Maps location, or webpage. (If you don’t specify a date, 
Siri doesn’t set an alarm; it notes the item in your Reminders list.) 

Click the Remove button that appears below the item in the Siri win-
dow to delete it completely (Figure 22). Or, click the item to jump to 
the Reminders app and make adjustments there. 

Figure 22: Use Siri to leave yourself a quick reminder. 
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It’s All about Contacts 
Want to talk to Siri like it’s your pal? Tell Siri your important details, 
or make sure the information is in the Contacts app: 

✦ Your home: If you want to be able to ask Siri to “Get directions 
home,” it needs your address. Fill in the right one for home (and 
work) in your Contacts card. 

✦ Your relatives: If you’d like to be able to ask Siri to call your 
sister, tell it who she is. For example, say: “Katy Sawyer is my 
sister.” You can do this for all your relatives as well as your man-
ager. Siri will ask you to confirm the change and then display your 
edited contact card. 

✦	 Birthdays: If you’ve entered a birthday in a contact’s card, you’ll 
be able to ask Siri questions like “When is Phillip’s birthday?” 

✦ Phone numbers and more: To make a call or send an email, 
make sure that information is filled in for friends and family in 
Contacts, too. 

Looking Up a Word 
Don’t bother opening the Dictionary app or doing a Google search 
when you’re at a loss for words. Ask Siri (Figure 23). 

Figure 23: Use Siri to look up a word lightning fast. 
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Tracking Down Friends and Family 
Whether you find it creepy or convenient, Siri can tap into Find My 
Friends to help you keep tabs on your loved ones. Ask it: “Where are 
my friends?” “Where is my son?” “Let me know when Dave gets to 
work.” 

Managing Your Messages 
Siri can send, read, respond, and search for messages in the Messages 
app. Say “Send Dad a message” or “Send a message to 555-1212.” Siri 
creates a new message and waits for your words. 

To catch up on messages, say “Read my new messages.” Then use Siri 
to dash off a quick reply, for example “Tell him I’ll be there in 15 
minutes.” 

Making a Call or Using FaceTime 
To start a video chat, say “FaceTime with Riku.” If you’ve set up your 
Mac to make audio calls through your iPhone (see Turn Your Mac into 
a Speakerphone), say “Call Bob at work.” 

Teach Siri to Say Names 
If you ask Siri to write an email to Jon and you have both Jons and 
Johns in your contacts, it asks you which one you want. The same 
thing goes with unusual names—Siri usually casts a wide net and lets 
you make the choice. But what if Siri just can’t pronounce a name? 

If your own name is the problem, activate Siri and say “Learn to 
pronounce my name.” Siri will ask you to say your first and then last 
name, giving you playback options to choose from each time. If it’s 
someone else’s name that it’s been mangling, say “Learn to pro-
nounce <name>” when you’re looking at a text or email from that 
person, or are viewing their card in Contacts. You’ll follow the same 
process to get it right. 
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Dealing with Mail 
Siri offers a quick way to send, check, or search for email messages: 

•	 Say “Show email from Jason from yesterday” or “Check 
email.” (Mail must be open for Siri to have access to the newest 
messages.) 

Tip: Your favorite nickname may not have stuck with your friends, 
but Siri is happy to call you whatever you want. Just say “Siri, call me 
Slugger.” 

•	 To find a particular message, try: “Find emails I received 
yesterday.” Or, “show me emails from <name>.” 

•	 Siri will even start a new message and fill in the To and Subject 
fields. Say “Email Guadalupe about the party tomorrow.” Then, it 
waits for you to dictate the details. 

Finding Your Photos 
Siri can search your photos. Ask it to: “Show my photos from Monday,” 
“Look up my videos taken in Portland, Oregon,” or “Show me my 
favorite photos” (ones that you’ve marked in Photos by clicking the 
heart icon). 

Tip: If you ask Siri to “Take a picture” on your Mac, Photo Booth 
launches. 

One of Sierra’s coolest features was the ability to ask Siri a question 
that tied into Photos’ Advanced Computer Vision. For instance, ask Siri 
to “Show me pictures with water” and Photos opens to a collection of 
images it thinks include water. 

Photos can pick out a strange and wonderful variety of objects, includ-
ing tree types (“Show me pictures of oaks”), plants (“Show me pictures 
of roses”), dog breeds (“Show me pictures of collies”), and little ones 
(“Show me pictures of babies”)—4432 objects, according to Apple 
(Figure 24). 
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Figure 24: Siri ties into Photos’ artificial intelligence features, letting 
you search your images in amazing ways. Here I’ve asked it to 
“Show me pictures of collies.” Your Siri request appears in large type 
at the top of the Photos window. 

As of High Sierra, some of these—facial expressions, for instance—still 
don’t work in my testing. However, Photos is flexible enough to realize 
that “dog” can mean more than one thing (Figure 25). 

Figure 25: Ask Siri to “Show me pictures of dogs” and your Mac 
knows that this image fits the description just as well as boxers and 
beagles. 

Your Siri request appears at the top of the Photos window along with 
the number of matches. 
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Tip: To learn more about Photos’ capabilities, read Jason Snell’s 
Photos: A Take Control Crash Course. (The current version covers 
Sierra; an update for High Sierra is planned.) 

Get Answers to Questions
 

Just like the Siri you’ve come to know and love on your iPhone and 
iPad, Siri on the Mac is ready and willing to answer all sorts of ques-
tions. For example, ask it “Who won the game?” and Siri will ask you to 
choose which league: “Baseball, basketball, cricket, football, or 
soccer?” (If you ask “Who won the big game?” you’ll see results from 
U.C. Berkeley and Stanford’s most recent encounter on the football 
field.) 

Siri and Your Privacy 
How does Siri make the magic? Every word you say to it is sent to 
Apple where servers process your speech to return an answer. Your 
voice data is assigned a random user number—it isn't associated with 
your Apple ID or your email address. After 6 months, the data is 
disassociated from the user number and then stored for up to 18 
months more for testing. Yes, that means somewhere out there right 
now someone might be listening to you saying: “Siri, why are fire 
engines red?” (If you haven’t already, ask that question.) 

Siri also sends information about you—associating it, again, only with 
your random user number—to Apple, including names and 
relationships from your Contacts app, the names of songs in your 
iTunes library, and more. When you search for documents with Siri, 
however, Apple says the names and content of your documents stay 
local. 

To pick and choose which apps’ info Siri will learn from, go to System 
Preferences > Siri, click the Siri Suggestions & Privacy button, and 
then select, or deselect, apps from the list. 
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A few handy topics to try: 

•	 Math and conversions: Ask Siri a math or conversion question 
and, depending on its complexity, it pings either the Calculator app 
or Wolfram Alpha to find what you need. Ask it: “How many tea-
spoons are in a tablespoon?” “What’s 26.2 miles in meters?” “How 
much is a 15 percent tip for $202?” “What is 35 percent of 80?” Or, 
for laughs, ask it “What’s 0 divided by 0?” (Figure 26). 

Figure 26: Siri can answer a variety of math problems.
 
Occasionally, you’ll get a…creative answer.
 

•	 Movies: Search for movie information, find showtimes and 
theaters, read reviews, and look up award winners. Ask it: “What 
movies are playing?” “Where can I see The Dark Tower?” “Show me 
the reviews for Wonder Woman.” “Did the Sound of Music win an 
Oscar?” 

•	 Stock info: Whether the market is a bull or a bear, Siri has its 
pulse. Ask it: “What’s Coca-Cola’s stock price?” “How are the mar-
kets doing? “What did Twitter close at today? “Compare AAPL and 
the NASDAQ.” 
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Tip: If Siri isn’t sure of an answer, you might see the header “Other 
Sources” at the end of your results. Click one of the names (for 
instance, Twitter) listed to see that source’s answer. New to High 
Sierra, you might also see the header “You Can Also Try,” with 
suggestions for rewording your question. Click a suggestion (or speak 
it) to see Siri’s answer to that instead. 

•	 The weather: You can ask Siri weather questions (Figure 27). 
Try: “Should I wear a sweater today?” “Will it rain this weekend?” 
“What’s the weather for tomorrow?” Or even “When is sunrise in 
Moscow?” 

Figure 27: Siri can help you prepare for the weather. 

•	 The web: If Siri doesn’t know an answer, it typically searches the 
web, but you can direct web searches yourself, too: “Google images 
of owls.” “Bing Ursula K. Le Guin.” 

•	 Random facts: Siri’s bread and butter is the random fact. Ask it: 
“How big are great white sharks?” “How many calories are in a Big 
Mac?” “What’s the chemical symbol for selenium?” “Why are leaves 
green?” “Who invented the cotton gin?” 

Tip: Need truly random input? Ask Siri to “Flip a coin” or “Roll the 
dice.” 
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•	 Sports: Siri has answers to most sports question you throw at it. 
Ask it about scores, schedules, and standings, as well as player and 
team information (Figure 28). Ask it : “When do the Timbers play 
next?” “Show me the soccer scores from last night.” “Who won the 
world series in 1959?” “What teams are in the WNBA?” “Show me 
the roster for the Golden State Warriors.” If you stump it—say, with 
a question about <gasp> tennis—Siri searches the web. 

Figure 28: Siri can fill you in about sports schedules and more. 

Pin Results for Later 
Whether you’ve found a useful sports schedule, or just need easy 
access to a list of files, you can keep information up-to-date and at 
hand by pinning Siri search results to Notification Center. You can pin 
results whenever a plus icon appears in the upper-right corner of 
the Siri results list. Click this to add the information to the Today 
view in Notification Center. (See Keep Current with Notification 
Center.) 
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Funny Things to Ask Siri 
Need a chuckle? Siri has a bountiful supply of jokes. For starters, say 
any of the following: “Siri, tell me a joke.” “Do you like Pokémon 
Go?” “How do I look?” ”What’s your favorite animal?” “Which came 
first, the chicken or the egg?” “Do you follow the three laws 
of robotics?” “Do you have a boyfriend?” “Is Jon Snow dead?” 
“Supercalifragilisticexpialidocious.” “I see a little silloetto of a 
man” (Figure 29). 

Figure 29: Siri has no end of jokes to entertain you. 

Persistence is rewarded: Ask Siri the same question again and again 
for more witty replies. 

Ask Siri What You Can Ask
 

To learn more about what Siri can do, say “What can I ask you?” or 
“What can I ask?” It replies with a list of categories including Finder, 
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System Preferences, About this Mac, Apps, FaceTime, Messages, and
 
much more. Click a category to see sample commands (Figure 30).
 

Figure 30: Whenever you need ideas for using Siri, ask it what you 
can ask. Then, scroll through categories and click one for examples. 

When to Use Spotlight Instead 
Use Apple’s Spotlight search engine, described in the next chapter, 
when: 

✦	 You want to search for a file, but have no internet connection. 

✦ You don’t want to be overheard. (Although, Siri’s Type to Siri 
feature can hush your end of the conversation, see New! Typing 
Questions to Siri.) 

✦ You’re in a noisy location. 

✦ Despite your best efforts, Siri can’t understand a name or word. 

✦	 You want to launch an app quickly (and prefer using the 
keyboard). 

For the flip side of this debate, see When to Use Siri Instead. 
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Find Files and Facts with 
Spotlight 

More and more, you might find yourself wondering “Should I use 
Spotlight or Siri when I search?” When it comes to natural language 
searches and the acquisition of random facts, Siri rules. But if you 
prefer typing (and seeing a written response) or you want to launch an 
app or open a System Preferences pane with a few keystrokes, Spot-
light packs power. Also, unlike Siri, Spotlight also doesn’t require an 
internet connection to work with local files and apps. Learn more 
about what you can do with Spotlight and you’ll have a better idea of 
which tool to use when. 

Start a Search in Spotlight
 

To activate Spotlight, press and release Command-Space (quickly) or 
click the magnifying glass icon in the menu bar. The Spotlight 
search field appears in the middle of your screen (reposition it if you 
choose). Then, type your search term to begin (Figure 31). 

Figure 31: Click the magnifying glass icon in the menu bar (or press 
Command-Space) to activate Spotlight. Then, type in your term. 

43
 



   
         

        
       

      
 

          
      

         
    

         
       

      
           

       
 

             
             

          

          
   

              
          

           
        

           
      

             
   

Change the Spotlight Shortcut 
At some point, you’ll undoubtably trigger Siri when you meant to 
trigger Spotlight. The problem is their confusingly similar shortcuts. 
To activate Spotlight, quickly press and release Command-Space; or 
press Command and tap the Space bar. To activate Siri, press and 
hold Command-Space. 

If the subtleties are a bit too much for you, change the Spotlight 
shortcut by going to System Preferences > Keyboard. Click Shortcuts 
and then pick Spotlight in the list on the left. The default settings are 
Command-Space for Show Spotlight Search and Command-Option-
Space for Show Finder Search Window. (Click the Restore Defaults 
button here anytime to go back to these.) 

To change the shortcut, double-click the current keyboard shortcut at 
the right of the pane and then press the key combination you want. If 
another command is already using this shortcut, you’ll see a warning 

icon. 

Preview Your Results
 

As you type, Spotlight guesses what you seek. You might have to type 
only a few characters before hits appear in the left-hand list below the 
search field, divided by category. Select one with your arrow keys or 
pointer. 

Tip: You can make the Spotlight panel taller to see more results at 

once, but you can’t make it wider.
 

When you select a result, a preview appears in the pane to the right. 
How much Spotlight shows in this pane seems to change with every 
macOS version. This time around, you can preview videos right in the 
pane and scroll through multi-page PDFs, Pages documents, and 
Keynote presentations without launching the parent app. If you click a 
song, on the other hand, iTunes launches. 

When you’ve found the result you want, press Return to open the file 
in its parent app. 
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Search Using Natural Language
 

When Spotlight first began supporting natural language searches, it 
was a huge time saver compared to the effort needed to plug criteria— 
pop-up menu by pop-up menu—into a Finder search (choose File > 
Find or press Command-F). For the first time, you could do complex 
searches on the Mac by typing a query that more closely resembled the 
way you speak. Looking for an email from your buddy, Suki, that 
includes an attachment? Type email from Suki with attachment 
(Figure 32). 

Figure 32: It’s easy to find files using Spotlight, even quite specific 
ones. 

But now that Siri is well established on the Mac, the game has 
changed. Compared with the ease of using Siri, Spotlight searches can 
seem downright unnatural. Sometimes phrase-based searches work 
and sometimes they don’t. 

Ask Siri “Show me the last presentation I worked on” and it immedi-
ately replies with the file. Try the same in Spotlight—last presentation 
worked on or presentation last, or even most recent presentation— 
and you get nothing. 
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Spotlight can be similarly finicky with web-based searches. Type 
what’s the weather? and you’re likely to see your city’s 10-day forecast. 
But, type What's Apple's stock price today? (with or without the 
question mark) or even Apple stock price and you’ll get the Spotlight 
equivalent of a blank stare. If this happens to you, trying rephrasing 
your request more simply—in this case, just type Apple’s stock ticker 
symbol, AAPL—and you’re more likely to get the information you need. 

All that’s to say: Keep it simple and be prepared to experiment with 
phrasing. If that doesn’t work, try Siri. 

When to Use Siri Instead 
Here’s when Siri is the right choice: 

✦ You’re having trouble phrasing your query correctly for Spotlight. 

✦	 You can’t remember how to spell your search term. (Suchi, 

suschi, or sushi?)
 

✦ You have a general question, like “What planes are flying 
overhead?” or “How big are Ragdoll cats?” Unlike Spotlight, Siri 
taps into sources like Wolfram Alpha. 

✦ You want to search your Photos library or initiate a search that 
uses Photos’ image-recognition features (see Finding Your Photos). 

✦ You are in the mood for sassy comebacks. 

Also see When to Use Spotlight Instead. 

What Can You Find?
 

High Sierra’s Spotlight lets you find many types of information on your 
Mac and on the web. Here are some of the highlights: 

•	 Applications: Spotlight has always been able to act like a simple 
application launcher. For instance, start to type keychain and the 
app appears as the top hit after just a few letters. Press Return to 
launch it. 

This saves you from digging around in the Applications folder— 
especially if the app is nested in a folder, as are Keychain Access, 
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Disk Utility, and many other tools. This is probably my number one 
use for Spotlight. 

•	 Bookmarks and history: Bookmarked sites and webpages that 
you’ve looked at recently in Safari will also appear in Spotlight 
results. 

•	 Contacts: Spotlight finds contact information quickly and easily. 
Click an icon under the contact’s name to make a call or send an 
email message. Hover over the address and then click the pin icon 
that appears to look up an address in Maps. 

•	 Currency and unit conversions: For those times when you 
need to substitute kilometers for miles or liters for quarts, there’s no 
need to head to Google or your dog-eared copy of Joy of Cooking. 
Just type in the Spotlight search field (Figure 33)—say, 3 1/2 cups, 
55 euros, or 3,000 miles—and Spotlight shows common conver-
sions. 

Figure 33: Use Spotlight to quickly make common conversions. 

•	 Definitions: When you’re not sure you have the right word, spare 
yourself the trouble of finding and opening the Dictionary app (or 
embarrassing yourself). Type a term—for example, kerfuffle or 
schlep—into Spotlight and select the Definition header. Dictionary 
results appear in the Preview pane (Figure 34). 
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Figure 34: Use Spotlight to look up what a word means. You’ll see 
links to other dictionaries under the Suggested Websites header; 
select one and press Return to see the word’s definition there. 

•	 Files of many types: Spotlight lets you search for files on your 
startup drive and any attached drives. The preview pane helps you 
make sure you have the right one. 

Tip: Find yourself without an internet connection? You can still search 
for files with Spotlight, but Siri is a no-go. 

Once you’ve found what you want, launch it in its parent app by 
pressing Return. You can tell what the parent app is by the icon that 
appears in the top-right corner of the Spotlight window. 

Where in the World Is That File? 
Need to know where a file is located? Select it in Spotlight’s results 
and then press Command. The file’s path—for example, Macintosh 
HD/Users/username/Documents/camp chart if “camp chart” is in your 
locally-stored Documents folder—appears at the bottom of Spotlight’s 
preview pane. 

•	 Flight information (New!): When you’re wondering about a 
flight, type the airline name and flight number in the Spotlight field 
to see arrival and departure times, the flight’s status, the terminal 
and gate numbers, the flight path, and more (Figure 35). 
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Figure 35: Now you can get easy access to flight information in 
Spotlight. 

•	 iTunes and iBooks Store results: Results include music, 
movies, and TV shows matching your term in the iTunes Store as 
well as your iTunes library. You can also buy or rent movies from 
iTunes in the preview pane. (Matches in the iBooks store may 
appear, too, although this happens less frequently.) Press Return to 
open a store to that entry. 

•	 Movie showtimes: Search for Movie Showtimes to see nearby flicks 
and times under the Now Playing in Theaters header. Type in a 
movie’s name and look for hits under the Movies or Now Playing in 
Theaters header to see showtimes and its Rotten Tomatoes rating, 
as well as links to trailers. 

Note: Initially, Apple said that High Sierra’s Spotlight would be able 
to include multiple Wikipedia results when a search term meant more 
than one thing, but this is one of the Features that are MIA. 
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•	 Sports: When you’ve got questions about sports stats, schedules, 
and more, Spotlight can help, especially if the topic is men’s 
professional football, baseball, basketball, hockey, and soccer. For 
instance, type Manchester United for scores from the team’s latest 
game or look for Stephen Curry and the Golden State Warrior’s 
stats appear. 

Men’s football is the only college sport Spotlight Sports covers so 
far. You might need to experiment to get a team’s name right. For 
instance, Crimson Tide doesn’t work, but Alabama Crimson Tide 
does. As for women’s sports, the WNBA is represented—search for 
Seattle Storm and you’ll see scores. Spotlight doesn’t include any 
player stats and leaves out women’s pro soccer as well as all 
women’s college sports. 

Lovers of tennis, golf, and other noble sports will be vexed to find 
their favorites overlooked, too. 

•	 Stocks: Type in the ticker symbol (for example, AAPL for Apple) to 
see the latest stock prices. 

•	 System Preferences: A fast way to open a particular System 
Preferences pane is to start typing its name in Spotlight. For 
example, start typing Privacy and the Security & Privacy preference 
pane quickly appears as the top hit. Press Return and you’re there. 

•	 Weather: Type my weather to see forecasts based on your location. 
To see weather conditions elsewhere, type in a statement like 
weather in Sonora. 

•	 Web video: You can search for video on YouTube and Vimeo 
directly from Spotlight. Type a query like iPhone 8 and look for the 
Web Videos header in results list. 

Tip: Spotlight prioritizes local data, which means often you’ll have to 
scroll down to find results from the web. 
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Find (Just) Files Faster
 

To find a file without being distracted by web results, press Command-
Option-Space to open a regular Finder search window. If you’re in the 
Finder, you can also press Command-F instead. 

Omit Types of Results
 

It’s great that Spotlight can return so many different results, but what 
if it’s all too much? 
Go to System Preferences > Spotlight > Search Results and take a look 
at the categories. If you know you’ll never want to see a certain type of 
result—for instance, it’s likely you don’t often need to search for 
fonts—uncheck the checkbox next to that category. 

Exclude Files from Spotlight
 

You might not have a problem with Spotlight finding documents in 
general, but have a very big problem with it finding particular docu-
ments on your drive. Whether it’s super-secret files, naughty love 
letters, or the redundant contents of a backup drive, you can exclude 
these files from Spotlight altogether. 

Go to System Preferences > Spotlight > Privacy. Drag a folder or disk 
onto the window, or click the plus button and navigate to the item. 
These files will now be left out of Spotlight searches. 

Protect Your Privacy
 

Speaking of privacy, have you wondered how Spotlight gets you all that 
nifty information about local weather, movie showtimes, and nearby 
restaurants anyway? When you send a query, the query—as well as the 
location of your Mac at that time—is sent back to Apple. Apple then 
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uses that information to help generate results to match. Your Mac also
 
lets Apple know what search result you pick.
 

Note: Spotlight does not send information about local searches (like, 
for a file) back to Apple. 

If that doesn’t bother you, carry on. If you need a little more informa-
tion to decide whether it bothers you, go to System Preferences > 
Spotlight > Search Results and click the About Spotlight Suggestions & 
Privacy button. 

If you’ve got the heebie-jeebies just thinking about this, deselect the 
Allow Spotlight Suggestions in Look Up checkbox. 

Take It to the Next Level 
If Spotlight’s search and launching powers aren’t quite enough
 

for your needs, check out powerful utilities like LaunchBar or Alfred.
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Cut Clutter with App Tabs 
You probably know how to cut down clutter when you search the web: 
instead of opening every new webpage in a separate window, you keep 
them organized in tabs. With tabs, multiple windows are gathered into 
one, with only the top page revealed. The titles of the rest stick up at 
the top; click one to switch to that page. 
But you may not realize that the same strategy works in most apps— 
both Apple’s and third-party ones. If you haven’t explored app tabs yet, 
they are a great way to keep everything within reach. And if you’ve 
been using tabs in Safari for years, you’re ahead of the game: most of 
the basics remain the same (Figure 36). 

Figure 36: Save space and cut clutter by keeping your app win-
dows—in this case, for Maps—organized in tabs. 

Tabs are particularly useful when you’re in Full Screen or Split View. 
Instead of being forced to leave the view to check another document, 
you can just switch to its tab. 
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Create a New Tab
 

If you find yourself overwhelmed by a bunch of Finder windows or a 
pile of windows within an app, you can convert them into one tidy 
window with tabs. Just choose Window > Merge All Windows. 

To create a new tab in an open window, use one of these techniques: 

•	 To open a tab in the Finder and some apps, press Command-T. The 
Tab Bar—where the different tabs’ names are listed—appears across 
the top of window. 

Tip: You can toggle the Tab Bar on by choosing View > Show Tab 
Bar. 

• If the Tab Bar is already visible, you can click the plus  button at 
its right (Figure 37) to create a new tab. 

Figure 37: Click the plus button (circled) on the Tab Bar to create a 
tab. 

Why Won’t Command-T Work? 
In quite a few apps, the Command-T shortcut brings up the Fonts 
window instead of making a new tab. Use the plus button on the 
Tab Bar (discussed just previously) to create a tab or Customize the 
Way Tabs Work to open new documents in tabs by default. 
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If you are in the Finder, you have a few more options for opening tabs: 

•	 Command-double-click any folder inside a Finder window to open 
it in a tab. Or, Control-click (right-click) a folder in the Finder and 
choose Open in New Tab from the contextual menu. 

•	 Shift-click or Command-click to select a bunch of folders and then 
Command-double-click the selection. The folders all open in the 
same window as multiple tabs. 

Move between Tabs
 

You can switch tabs by clicking or using the keyboard, depending 
where your hands are at the time: 

•	 Click the tab you want in the Tab Bar. 

•	 Press Control-Tab to move to the right through tabs on the Tab Bar; 
press Control-Shift-Tab to move to the left. 

Tip: To rearrange your tabs on the Tab Bar, drag them into the order 
you prefer. 

Move Files between Finder Tabs
 

Just as you can move a file to a different folder by dragging and drop-
ping it between Finder windows, you can drag and drop a file between 
Finder tabs. 

When you drag an item, hover over the target tab until the tab flashes. 
Either drop the item on the tab to put it into that folder or wait a 
moment until the tab’s content appear in the Finder window so you 
can drop the file into a nested folder. 
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Turn Tabs into Windows
 

It’s easy to make a tab become its own window again, a handy feature if 
you need to compare two windows side by side: 

•	 Drag a tab away from the Tab Bar. It becomes its own window. 

•	 Control-click the tab and choose Move Tab to New Window from 
the contextual menu. 

•	 Select a tab and choose Window > Move Tab to New Window. 

Close Your Tabs
 

When you’re done with a tab, try one of these techniques for closing 
them out quickly: 

• Press Command-W to close the tab you’re currently viewing. 

•	 Hover your pointer over a tab you no longer need, and click the 
close icon that appears at the left of the tab. 

• To close all tabs except for one, Option-click the close icon for the 
tab you want and all the other tabs in that window will close. 

Customize the Way Tabs Work 
Love tabs? Not thrilled with them? You can choose how easily and 

how often they appear. Go to System Preferences > Dock to see a
 

pop-up menu called “Prefer tabs when opening documents.” Pick
 

from three options:
 

✦ In Full Screen Only: With this setting chosen, documents open in 
new windows except when you’re working in full screen mode 
(View > Enter Full Screen). 

✦ Always: When Always is selected, most apps will open documents 
in a tab. 

✦ Manually: If you choose manually, most apps will not use tabs 
automatically in any view. (Mail is a notable exception.) However, 
you can open tabs using shortcuts and commands. 
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Command the View 
Most of us use a lot of apps at the same time. Mail, Messages, Safari, 
Calendar, iTunes—the windows can stack up so high that it takes a bit 
to figure out where the one you need has gone. With Mission Control, 
High Sierra provides several ways to bring order to the chaos. 

Mission Control makes it easier to find the window you want by letting 
you see them all at the touch of a button. It also makes it easier to set 
up tidy, predictable Spaces where certain apps live—like separating 
your clothes into different drawers instead of dumping them all into 
one. Its Split View fills your display with the two things you’re working 
on right now, making it easy to compare two documents or keep your 
research to one side while you write notes on the other. We’ll look at all 
the Mission Control features, so you can figure out which ones will 
work best for you. 

Open Mission Control 
Mission Control makes it easier to track down the window you need by 
moving everything else out of the way (Figure 38). 

Figure 38: Invoke Mission Control to get a bird’s-eye view of all 
open windows. 
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There are several ways to activate Mission Control: 

•	 From the keyboard: On an Apple keyboard, press the Mission 
Control button (F3), or on any keyboard, press Control-Up arrow. 

•	 With a multi-touch trackpad: Perform a three-finger upward 
swipe. 

•	 From the Dock: Open the Applications folder and drag the 
Mission Control icon to the Dock for one-click access (Figure 39). 

Figure 39: For easy access, you can drag the Mission Control icon 
from your Applications folder onto the Dock. 

•	 Hover in a hot corner: Revealing Mission Control can be as easy 
as sliding your pointer to the corner of your screen, if you’ve set up a 
hot corner: Go to System Preferences > Mission Control and click 
Hot Corners. You see four pop-up menus that correspond to the 
four corners of your Mac’s display. Pick the one you want and then 
choose Mission Control in the menu (Figure 40). Now, just move 
your pointer to that corner and Mission Control appears. 

Figure 40: Set a hot corner for Mission Control. 
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Once Mission Control is activated, all open windows on your Mac 
shrink so you can see them side by side. Click the one you want to 
jump to it. 

To close Mission Control without making a selection (and return to the 
window you were using), do one of the following: 

•	 From the keyboard: On an Apple keyboard, press the Mission 
Control button (F3), or on any keyboard, press Control-Down 
arrow. You can also press Esc. 

•	 On a multi-touch trackpad: Swipe downward with three fingers. 

Group Windows by App 
Mission Control once grouped windows by app. You can bring back
 

the old days: go to System Preferences > Mission Control and select 

the Group Windows by Applications checkbox.
 

Open Single-app Mission Control 
To see only the windows from the app you’re currently using (a view 
also know as App Exposé), press Control-Down arrow (Figure 41). 

Figure 41: To see only windows from the app you’re in, press 
Control-Down arrow. 
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If you’re already in Mission Control, you’ll need to press Control-
Down arrow twice: once to reveal your regular Desktop; twice to see 
App Exposé. 

Tip: A quick way to see any app and its open windows in App Exposé 
view is to Force Click the app’s Dock icon. 

Revealing the Desktop 
When you need to find a file on the Desktop—and you’re not in Full 
Screen or Split View—press Command-F3 (or F11 on a non-Apple 
keyboard) to sweep away all open windows. Press Command-F3 (or 
F11) again and the windows go back where they were. On a 
trackpad, you can also spread out with your thumb and three fingers 
to reveal the Desktop. 

Put Everything in Its Space
 

Mission Control does more than let you pick a window. Using a subset 
of features called Spaces, it also lets you group windows or apps that 
you commonly use at the same time. You can think of spaces as addi-
tional desktops. 

Let’s take, for example, email. You check it all day. Messages is the 
same—colleagues regularly send you notes and ask questions that way. 
So let’s make a space for these two apps and bring communications 
(some might say distractions) together in one place. 

Making a Space 
Open Mission Control, and then find your main Mail window. Drag it 
quickly up to the top of your screen. The slim bar there expands to 
become the Spaces Bar. When a plus sign appears, drop the Mail 
window on the Spaces Bar (Figure 42). 
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Figure 42: Create a space by dragging a window to the top of your 
screen and then dropping it on the Spaces Bar when a plus sign 
appears. 

Mail automatically appears full screen in a new space, next to your 
desktop (Figure 43). 

Figure 43: High Sierra’s Spaces Bar shows all current spaces. 

You don’t even have to be in Mission Control for this to work. Just grab 
a window and drag it quickly to the top of your screen. The Spaces Bar 
appears. 

Tip: If you are in Mission Control, you can also click the plus sign
 

to the right of the Spaces Bar to create a new space.
 

Now, drag the Messages window onto the Mail space at the top of your 
screen. The space’s name changes to Message & Mail. (These apps will 
appear in Use Split View.) 
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If you see a circle with a line through it when you try to drag a window 
into a space, you can’t group those two things together. 

Tip: You can put an app window in a different space from the rest of 
the app. 

Note: High Sierra automatically creates a space for any app you’ve 
made full screen. (See Full-screen Fundamentals, ahead.) 

Getting to a Space Quickly 
To switch to a space you’ve set up: 

•	 Press Control-Left or -Right arrow 

•	 Swipe left or right on your trackpad using three or four fingers. 

High Sierra lets you skip through spaces only in the order they appear 
on the Spaces Bar. You can change the order of your spaces by opening 
Mission Control and dragging them into place on the Spaces Bar. To 
make them stay that way, in System Preferences > Mission Control, 
deselect Automatically Rearrange Spaces Based on Most Recent Use. 

Note: Another way to quickly jump between open apps is to use the 
Application Switcher (press and hold the Command key while tapping 
Tab to move through open apps). You can also click an app’s icon in 
the Dock to bring it to the front. 

Great Ways to Use Spaces 
✦ Use Split View to group your word-processing app for writing and 

a Google window for research. 

✦	 Keep your calendar full-screen in one space so when you check
 

your schedule you can see everything at a glance (no event titles 

cut off because you’ve squished the window).
 

✦	 Put Mail and Messages together in a space so you can easily
 

switch over to check your messages (and keep both apps out of
 
sight to ward off procrastination).
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Changing a Space’s Desktop 
To make spaces easier to identify, you can give each one that is not a 
full screen a distinct Desktop pattern (Figure 44). Switch to the 
space, Control-click the Desktop and choose Change Desktop Back-
ground. The Desktop & Screen Saver preference pane opens. 

Figure 44: Give spaces different Desktop backgrounds so that 
they’re easier to distinguish and can fulfill different purposes. 

Choose a category at the left and then pick an image at the right. You 
might like the stock High Sierra background when working in the 
Finder, but find it distracting when working with images. Give your 
image-processing app’s space a black or gray background instead. 

Removing a Space 
To nix a space you no longer need, open Mission Control, grab the 
space in question on the Spaces Bar, and drag it off. Or, click the close 

icon that appears at its corner. 

Full-screen Fundamentals 
To make a window fill the screen and enter its own space, click the
 

green
 button in its top-left corner or choose View > Enter Full 
Screen. With Apple’s apps, you can also press Command-Control-F. 

Exit Full Screen (and remove the space) by clicking the green button 
again, choosing View > Exit Full Screen, or pressing Command-
Control-F again. 

If, instead of clicking the green button, you click and hold the green 
button, the Mac switches to Split View, which I explain ahead. 
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Use Split View
 

Split View lets you focus on two things at once—say, the document 
you’re writing in Pages and the Google Docs page that contains your 
research. Or, the book you’re reading in iBooks and the Notes app 
where you’re writing notes about the text. By filling the screen with 
only the things you need to see, you can minimize distractions. 

Note: A few apps, including Bare Bones Software’s BBEdit and 
Apple’s System Preferences, do not support Split View. 

Activating Split View 
Click and hold the green button at the upper-left corner of a 
window. The window shrinks and the left side of your screen fades to 
blue (Figure 45). 

Figure 45: Invoke Split View by clicking and holding a window’s 
green button. Half of the screen fades to blue. 

Move the window to the left or right (the blue background follows) and 
then drop it. It fills that side of your screen; the other side goes into 
Mission Control mode, so you can easily see other open windows 
(Figure 46). Select one of these and it fills the second half of your 
screen. 
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Figure 46: The window or app fills one side of the screen; the other 
shows a Mission Control view of the remaining windows. 

If you’re already working in an app full screen, there’s another easy 
way to enter Split View. Open Mission Control and then drag the 
second app you want onto the first in the Spaces Bar at the top of your 
screen. The two now appear together in Split View. 

Tip: You don’t have to devote the same amount of space to both 
apps. Drag the black divider between the views to make one side 
smaller or larger (within limits). 

Once you’re in Split View, you can do more than just look at one 
document while you’re working in another. Copy and paste informa-
tion back and forth. Drag and drop from one side to the other—for 
instance, you can drag an image from a Finder window to a document, 
or text from Safari to Notes. 

Tip: Mail now uses Split View by default when you compose a new
 

message in fullscreen mode.
 

Leaving Split View 
To exit Split View, move your pointer to the top of the screen to reveal 
the menu bar. Click the green button in the upper-left corner of 
either window. Your Mac exits Split View. 
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Keep Current with 
Notification Center 

Alerts, alarms, reminders, email—chances are you see a steady stream 
every day. Notification Center is High Sierra’s Grand Central Station 
for the information competing for your attention. Its settings control 
which apps can post messages to the upper-right corner of your 
display, as well as how those messages look. The Notification Center 
sidebar, which slides in from the right of your screen, gives you an 
overview of it all. 

Sierra updated Notification Center’s look and integrated it with Siri, 
letting you pin (attach) your most-checked Twitter feeds, sports 
schedules, and more to it. High Sierra adds a new widget, Now Playing 
(Figure 47), which includes playback controls for your media, 
whether it’s playing through iTunes, QuickTime, or Safari. 

Figure 47: Notification Center slides in from the right of your 
screen. In High Sierra it adds a new widget, Now Playing, which can 
control media from more than just iTunes. 
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Control Notifications’ Look
 

Individual notifications appear in the top-right corner of your screen. 
You can tweak how they appear, or whether they appear at all, on an 
app-by-app basis. 

Go to System Preferences > Notifications and select an app from the 
list at the left. Now set up the way that app will notify you at the right 
(Figure 48). 

Figure 48: For each app (Calendar is selected here) you can choose 
from three notification styles—None, Banners, or Alerts. 

You can pick from three notification styles: 

•	 None: Pick None and you won’t see any notifications from that 
app. For instance, if you’re tired of Dropbox telling you every time a 
shared file has been changed, this might be the setting for you. 

•	 Banners: Banners display on your screen for a few seconds and 
then disappear. Select this type of alert when you don’t mind miss-
ing an app’s notifications. For example, you might like to know 
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when Mail messages arrive, but not mind if you miss a notification 
when you walk away from your desk. 

•	 Alerts: Use this style for notifications you can’t miss. Alerts don’t 
go away until you do something. For instance, click Close to dismiss 
a Calendar alert or Snooze to dismiss the alert for 15 minutes (Fig-
ure 49). 

Figure 49: An alert-style notification won’t disappear until you take 
action. 

Reminders’ notifications are even more persistent. You either must 
click Complete or click Later and choose when to be reminded 
again. 

Tip: To change a Calendar alert’s snooze time, click and hold the 
Snooze button to see a menu with choices 

Turn Off Notifications Temporarily
 

If you need to concentrate—for instance, when you’re taking notes 
in class—it can be annoying to see notifications. Option-click the 
Notification Center icon at the far right of the menu bar to mute 
notifications until tomorrow. The menu bar icon goes gray. All notifi-
cations, including calls via your iPhone, are held. 

Option-click again to reactivate Notifications right away. 

Banish the Beep 
Tired of hearing a sound with each notification? In the Notifications 
preference pane, select an app in the list. Deselect the Play Sound for 
Notifications checkbox to get some peace and quiet. 
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You can set certain hours as regular notifications-free time, too. Go to 
System Preferences > Notifications and select Do Not Disturb at the 
top of the left-hand list. At the right, check the box next to the first 
item (From) and specify when you want quiet—say, from 10:00 PM to 
7:00 AM (Figure 50). 

Figure 50: Tweak Notification Center’s Do Not Disturb settings to 
ensure you don’t get bugged during certain times. 

This can be useful if you like to watch movies (distraction-free) on your 
laptop before bed. By default, Notification Center already turns off 
notifications when your display is asleep or when you’re mirroring to 
TVs and projectors. You can adjust these settings, too. 

When Do Not Disturb is activated, High Sierra forbids incoming phone 
calls via your iPhone (see Turn Your Mac into a Speakerphone). 
However, you can turn that feature off, or select Allow Repeated Calls 
to let a caller reach you if they call twice within 3 minutes. 

Explore the Sidebar
 

To reveal the Notification Center sidebar, click its icon in the menu 
bar. Notification Center slides in from the edge of your screen, cover-
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ing part of the Desktop. If you use a trackpad, you can use two fingers 
to swipe from the right side to the left to reveal the sidebar or swipe 
back toward the right to hide it. 

Setting up a Keyboard Shortcut 
To activate Notification Center from the keyboard, go to System 
Preferences > Keyboard > Shortcuts and pick Mission Control in the 
left-hand list. Select the Show Notification Center box and type in 
a keyboard shortcut, such as Command-Option-N. 

The sidebar has two views: Notifications view (next) and Today view 
(flip ahead to Today View). 

Notifications View 
Click the Notifications button to see all notifications that you haven’t 
taken action on (Figure 51). Clicking one will open its app; for exam-
ple, click a notification from Messages and you’ll jump straight to the 
message in the app. 

Figure 51: The Notifications view keeps track of all notifications you 
haven’t taken action on yet. 
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To control what appears where in Notification Center, open System 
Preferences > Notifications. Or, if you’re already in the Notification 
Center sidebar, click the gear icon at the bottom of either view. 

In the Notifications preference pane, you’ll see a list of app names to 
the left. A few settings you may want to investigate: 

Sorting Notifications 
Choose an option in the Notification Center Sort Order pop-up menu 
at the bottom of the Notifications pane (Figure 52). 

Figure 52: It’s up to you how Notification Center sorts your notifica-
tions. 

Your choices are: 

•	 Recents: Only the most recent notifications will appear, sorted by 
the time they arrived. 

•	 Recents by app: Notifications appear in order of most to least 
recent, grouped by app. 

•	 Manually by app: Choose this option to determine the order apps 
will appear in the Notifications sidebar. On the left side of the 
Notifications pane, drag the listed apps into the right order. 

Seeing a Preview 
If you receive a Mail or Messages notification, it’s possible to also see a 
preview (Figure 53). 
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Figure 53: You can choose whether message previews like this one 
appear in your notifications. 

Click the app in the list at the left and then choose one of two options 
in the Show Message Preview pop-up menu: 

•	 When Unlocked: To add a smidge of privacy, previews show only 
when you’re logged in to your user account. 

•	 Always: Privacy, schmivacy. Previews always appear, even if you’re 
logged out of your Mac. (In that case, they appear on the login 
screen.) 

Uncheck the option if you’d rather previews not appear at all. 

Note: To learn how to pin Siri results so they appear in Notifications 
Center, see Pin Results for Later. 

Hide Certain Apps 
Select an app in the list at the left. If you don’t want to see it in the 
Notification Center, deselect the Show in Notification Center checkbox. 

Today View 
Click the Today button at the top of the Notification Center sidebar to 
see an at-a-glance overview of what’s coming up, such as when your 
next meeting is and how many events you’ve scheduled. By default, it 
starts with the date and the Today widget, which includes the current 
weather (Figure 54). 
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Figure 54: Look in Today view for a summary of what’s happening. 
(Here you see only the top portion of the view.) 

Items in this view, called widgets, provide access to information or 
tools. For instance, the Calculator widget lets you perform simple 
calculations. 

Most widgets are self-explanatory, except perhaps Social. It gives you 
a quick way to send status updates to social networking accounts, 
including Facebook, Twitter, and LinkedIn—you can set these accounts 
up in System Preferences > Internet Accounts. It also lets you send 
chat messages via the Messages app. 

The new Now Playing widget offers an alternative to the iTunes widget. 
It provides quick access to playback controls (and sometimes a volume 
slider) for media in iTunes as well as QuickTime and Safari. That 
means you can control your Youtube.com or Netflix.com media from 
Notification Center, too. 

The fun part is that you can customize Today view. Drag and drop 
widgets (click and hold the widget’s header) into the order you prefer 
when you’re looking at Notification Center. 
Or, for more options, click the Edit button at the bottom of Today view 
to switch to Edit mode. 

Adding a Widget 
In Edit mode, a new column appears at the right with a list of available 
widgets, such as Calculator, Find My Friends, Social, and Stocks. Click 
the plus button next to a widget’s name to add it (Figure 55), or 
just drag it into the left-hand column. Click Done to exit Edit mode. 
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Figure 55: Click Today view’s Edit button to reveal an additional 
column with more widgets. Click a plus button to add that widget to 
your view. 

Removing a Widget 
In Edit mode, a minus button appears next to the name of each 
widget already in your view. To remove a widget, click its minus 
button. Click Done to exit Edit mode. 

Configuring Widgets 
Many widgets can be configured (and aren’t worth much until you do). 

Hover over a widget’s name in Today view and click the info button 
if it appears. 

For example, you might want to see the weather not only in your town, 
but also in your favorite vacation spot. (We can all dream.) Or, you 
might want to track the time in your biggest client’s city in addition to 
your own. 
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Update Your Safari 
Smarts 

Few apps get as much use as your web browser, so any time saved 
there really adds up. Apple boasts that High Sierra’s Safari is “the 
world’s fastest desktop browser” and benchmarks back up that claim 
(see this Macworld article for details). In addition, Safari adds features 
intended to make surfing more pleasant, from preventing advertisers 
from tracking you across sites to stopping auto-play videos. Safari also 
lets you customize your surfing experience like never before, setting 
preferences in eight categories on a site-by-site basis. We’ll look at the 
coolest new features. 

Customize Safari Settings Site by Site 

One site uses tiny text you can’t read. Another greets you with a ca-
cophony of sound from its auto-playing videos. Another has pages so 
crowded with ads that you can barely find the Next Page link. Sure, you 
can zoom text, mute videos, and select Safari Reader view, but 
wouldn’t it be nice if you didn’t have to do so every time you visited the 
same sites? 

You can adjust settings for a single site or every site you have open: 

•	 Adjust the topmost site: To quickly set preferences for the site 
you’re viewing, choose Safari > Settings For This Website or 
Control-click the Smart Search bar and choose Settings For This 
Website (Figure 56). 
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Figure 56: It’s easy to set preferences for the site you’re viewing. 

•	 Adjust every open site: To customize settings for more than one 
open site, as well as adjust default settings, choose Safari > Prefer-
ences > Websites. Safari’s new Websites pane is command central 
for site-by-site preferences in eight categories (Figure 57). 

Figure 57: In Safari’s new Websites pane, choose from categories 
(A) to set site-by-site settings for open sites (B) or ones you’ve 
already configured (C). Use the When Visiting Other Websites pop-up 
menu (boxed) to set default preference in the chosen category. 

Let’s take a look at what you can tweak. 
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Reader 
Safari Reader lets you read and print online articles using a simplified 
page view that strips out anything—sidebars, jiggling ads, links, polls— 
that isn’t text, images, or videos (Figure 58). 

Figure 58: An article in its regular layout (top) and in Safari Reader 
(bottom). 
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Another bonus: Even if an article has more than one page, you see the 
entire thing in Reader without having to click multiple links 

Usually, you click the Reader icon to the left of the Smart Search 
bar to invoke Reader, and then click the icon again to leave the view. 
Click Reader in the list to the left of Safari’s Websites preferences 
window. Then, set the On/Off pop-up menu next to each site’s name. 

If you always want to use Reader (when it’s available) with new sites, 
set the When Visiting Other Websites pop-up menu to On. Note that 
Reader view is only available for online articles. To get rid of advertise-
ments all the time, you need a Content Blocker, discussed next. 

Changing Reader’s Look 
What you see isn’t what you get with Reader. To customize your
 

view, click the Reader Appearance Options 
 button to the right of
 
the Smart Search bar. Here, for example, you can size text up by
 

clicking the big A or click a dot to select from four color schemes. A
 

black background with white text, for instance, may be better for
 

reading in dark rooms.
 

Content Blockers 
If pop-up, video, and banner advertisements make Safari slow to a 
crawl or just generally annoy you, you can download an extension to 
block them. A quick trip to the Mac App Store shows some of the 
options, such as Adblock Plus and 1Blocker. 

The new Safari Websites preference pane lets you manage content 
blockers in one place. Click Content Blockers in the list to the left of the 
Websites preferences window. Then, turn content blocking on and off 
for individual sites using the On/Off pop-up menus. 

Note that many sites depend on advertising revenue to keep the lights 
on and might not take kindly to this surfing strategy. If you get a 
warning from a site, saying that you will not be allowed to read its 
articles without disabling content blockers, turn yours off for that site 
in the Websites preference pane (or, just use Reader). 
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In Case You Missed It: Control the Noise 
Here’s how to start and stop audio in your tabs: 

✦	 A Sound icon appears next to the name of any tab with audio. 
Click this to mute the tab. 

✦ Option-click a tab’s Sound icon to quickly mute all tabs except it. 
Click the Sound icon in the Smart Search bar to turn off sound 
from the foremost tab. 

✦ Click and hold the Sound icon in the Smart Search bar to see a 
contextual menu with the options Mute This Tab and Mute Other 
Tabs, as well as a list of all tabs with sound. You can also select 
Auto-Play from this menu to quickly set Auto-Play preferences for 
the site. 

Auto-play 
Way back in the day, when I worked for Macworld, there were few 
topics quite as controversial as auto-playing videos. Readers and 
editors hated them; advertisers and sales people loved them. In OS X 
El Capitan, Apple stepped into the fray by making it easy to mute rogue 
videos (see In Case You Missed It: Control the Noise). Now the compa-
ny has gone one step further, globally preventing videos from starting 
up on their own at all. (Oh, sweet sweet silence.) 

You can adjust auto-play settings on a site-by-site basis. Choose Auto-
Play in the list to the left of Safari’s Websites preferences window and 
then use the pop-up menus to choose one of these settings for each 
listed site: 

•	 Allow All Auto-Play: If you don’t mind videos starting on their 
own on a particular site, change its setting to this. 

•	 Stop Media with Sound: This default setting prevents only 
videos with sound from playing automatically. 

•	 Never Auto-Play: This setting prevents all videos (with or without 
sound on) from starting up until you click Play. 
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Bye-Bye, Safari Shared Links 
If you’ve used Safari’s Shared Links feature to keep track of social 
network or RSS feeds, you’ll receive a rude awakening when you click 
Safari’s sidebar to see what’s going on. As of Safari 11, Shared Links 
are gone (Figure 59). 

Figure 59: Now you see it, now you don’t. As of Safari 11, the
 
Shared Links button (outlined in red) is gone.
 

Although you will need to switch over to a dedicated RSS reader, you 
won’t have to reconstruct your feeds from scratch. Their URLs are 
safely tucked away in a Safari preference file, WebFeedSources.plist. 
Sorting through the code in this file, however, is a pain. Thank 
goodness the ever helpful Dr. Drang wrote us a script and Jason Snell 
wrapped it up in an Automator app to make the extraction process 
quick and easy. Read about the app on this page and download it 
directly here. When you double-click it, a dialog appears telling you 
what the app is about to do. Click OK. A file named converted-sub-
scriptions.opml appears on your Desktop. Import this into an RSS 
reader like Reeder or Feedly and you’re good to go. 

Page Zoom 
In a friendly gesture to those of us with limited vision or aging eyes, 
Safari’s Websites preference pane also includes Page Zoom. Select this 
category in the list to the left to see Currently Open Websites as well as 
Configured Sites. 

If you’ve zoomed in or out of a site at any time (press Command-Equal 
to zoom in and Command-Minus to zoom out), Safari remembers the 
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setting and shows it here. To tweak a setting manually, choose another 
zoom level in the pop-up menu (Figure 60). 

Figure 60: Any time you zoom in or out of a page, Safari records 
the setting. Take a look at, and adjust, any site’s setting here. 

Camera and Microphone 
Want to control which sites can access your Mac’s camera or micro-
phone? Select either the Camera or Microphone category in the list to 
the left of Safari’s Websites preference pane. As with the other cate-
gories, each shows a list of Currently Open Websites and Configured 
Websites (if you’ve configured any websites in the past). Set the pop-
up menus to Ask, Deny, or Allow. (The default setting for both is Ask.) 

Location 
Many people are creeped out by the idea that their apps know where 
they are, but of course we also benefit from this whenever we use GPS 
to find our way or automatically see a list of movies in our area without 
having to plug in our area code. High Sierra’s Safari makes it easy for 
you to set your own boundaries. Choose Location in the list to the left 
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of Safari’s Websites preference pane and then choose Ask, Deny, or 
Allow in the pop-up menu next to each site’s name. 

Note that you must enable Location Services for Safari in order to 
choose anything but the default, Deny. If that’s the case, you’ll see a 
warning (Figure 61). Click the Open Security & Privacy Preferences 
button to go to the right place. 

Figure 61: If you haven’t enabled Location Services for Safari, this 
warning lets you hop to the right System Preferences pane. 

Once System Preferences opens, select the Enable Location Services 
option and then check the box next to Safari.app in the list. 

Notifications 
To turn off annoying notifications from websites, choose Notifications 
to the left of Safari’s Websites preference pane. You see a list of sites 
that have asked for permission to send notifications. 

Pick Allow or Deny for each one; or select one (or more) and click 
Remove. If you don’t want to receive this type of notification again, 
deselect Allow Websites to Ask for Permission to Send Push Notifica-
tions. 

Note that this is the one category you must set in the Websites prefer-
ence pane. It’s not available when you choose Safari > Settings For 
This Website. 
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In Case You Missed It: Better Plug-in Control 
Safari disables proprietary plug-ins like Flash, Java, Silverlight, and 
QuickTime by default, but as of Sierra it also made it easier to use 
the technologies when you want. Now, you’ll find the controls in the 
Safari > Preferences > Websites pane under the Plug-ins header 
(visible only if you’ve downloaded and installed a Safari plug-in). 

If a site offers both a Flash and an HTML5 version of a video, for 
instance, the HTML5 version will play. Otherwise, you’ll be asked 
whether you want to use Flash for this site every time or just this 
once (Figure 62). 

Figure 62: By default, Safari asks if you want to use a plug-in every 
time you visit this site or just once. 

To adjust Safari’s plug-in settings by hand in the Websites preference 
pane, select the plug-in’s name in the list on the left and then click 
the pop-up menu next to a site’s name and choose Off, On, or Ask. 
You can also change Safari’s overall behavior toward a plug-in by 
clicking the When Visiting Other Websites pop-up menu and choosing 
Off, On, or Ask. 

Stop Advertisers from Tracking You
 

If you’re like me, you’ve been mildly surprised, at least once, to see the 
exact pair of Merrell’s Jungle Mocs you were just looking at on Zappos 
appear in a Facebook ad the next day. This is the result of cross-site 
tracking, which is typically done with third-party cookies that let 
advertisers learn about the products you’re shopping around for as you 
move from site to site. (For more info, see this Gizmodo article). 

You can use Safari’s Private Browsing feature (File > New Private 
Window), to avoid being tracked, but when you do, Safari also doesn’t 
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add pages to your history, save information (like your user names and 
passwords) for autofill, or add searches to the pop-up menu of recent 
searches. All that can be overkill if all you really want is to avoid 
sharing your information with advertisers, rather than cover your 
tracks. 

As of High Sierra, though, Apple’s got your back: Safari now limits 
cross-site tracking by default using a new feature called Intelligent 
Tracking Prevention. Companies can still store these cookies in your 
browser, but these are only active for one day. 

Go to Safari > Preferences > Privacy to see the Prevent Cross-site 
Tracking setting, which is selected by default (Figure 63). 

Figure 63: By default, Safari limits advertisers’ ability to track your 
surfing habits across sites. This doesn’t stop ads (like a content 
blocker does); it stops companies from personalizing ads for you. 

Individual sites often track your browsing, but not necessarily for 
nefarious purposes. Doing so can also let them customize what you see 
in a good way. As it did in Sierra, Safari gives you the option to Ask 
Websites Not to Track Me. Be aware, though, that this works on an 
honor system, basically just sending out a request for the site not to 
track you each time your browser loads content from it. 
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In Case You Missed It: Open Recently Closed Tabs 
It’s happened to us all: your attention strays and before you know it 
you’ve pressed Command-W or clicked the close icon at a tab’s 
corner. You’ve closed a tab (or two, or three) by accident and now 
you want it back! Here’s what you can do: 

✦ Click and hold the plus button on the Tab Bar to see, and 
choose from, a list of Recently Closed Tabs. 

✦ Choose History > Recently Closed and choose from the list there. 

✦	 Reopen the last closed tab by choosing History > Reopen Last 
Closed Tab or pressing Command-Shift-T. 

✦ Use the Undo command (Command-Z) multiple times to reopen 
recently closed tabs. Before macOS Sierra, you could do this only 
once. 

Safari Touch Bar Tricks 
If you own the MacBook Pro with Touch Bar, don’t overlook a few 
handy shortcuts the Touch Bar adds for Safari: 

✦	 Favorites (Bookmarks > Show Favorites) appear in the Touch Bar 
for one-touch access. 

✦ Tap the New Tab icon to open a new tab. 

✦	 Scrub backwards or forwards in videos or music you encounter 
online using the Touch Bar’s media controls. 
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Note Your Thoughts 
A photo of a band flyer. The packing list. Books friends recommend. A 
solution that came to you in a dream. Plenty of apps can gather all 
these bits of information together, and plenty do a great job. But, most 
likely, only one is already on your iPhone, iPad, and Mac: Apple’s 
Notes. In High Sierra, Apple continues to beef up this app, this time 
adding tables as well as pinned notes that stay within easy reach. 

iOS 11’s Noteworthy Upgrades 
Don’t use Notes? If you own an iPhone or iPad, the iOS 11 update 
may finally tempt you. Now you can tap an Apple Pencil to your iPad’s 
Lock screen to start taking notes immediately; search handwritten 
notes in iOS; use your iOS device’s camera as a document scanner; 
and more. See Take Control of iOS 11 by Josh Centers. 

Sync Notes with All Your Devices
 

Since Notes syncs through iCloud and is a default app on all iOS 11 and 
High Sierra devices, it can be a great way to move information around. 
Work on your meeting agenda on the bus and then, when you get to 
work, proof it on a bigger screen and print it or paste it into an email 
message. Or, take notes on your MacBook during a meeting and check 
them on your iPhone at the hotel. 

Setting up a Notes Account 
To make sure you can see Notes on all your iOS devices and Macs, go 
to System Preferences > Internet Accounts. Select your iCloud account 
in the list to the left and then make sure that the Notes checkbox is 
selected. 

In Notes, an iCloud header appears in the Folders sidebar—everything 
under the iCloud header syncs through iCloud. 
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As long as your Mac is signed in to iCloud with Notes enabled for 
iCloud, by default, Siri creates your new notes within your iCloud 
account. 

Tip: If you prefer for your notes to live only on your Mac, choose 
Notes > Preferences, select the Enable the On My Mac Account 
checkbox, and then choose On My Mac from the Default Account pop-
up menu. 

Removing a Notes Account 
You may see other types of accounts in the Folders sidebar under their 
own headers—such as Gmail. If you don’t want these on your Mac, Go 
to System Preferences > Internet Accounts. Select the account at the 
left and then make sure the Notes checkbox is not selected. 

Some Features Are iCloud Only 
In our testing, whether we had an On My Mac account or an iCloud 
account, Notes worked pretty much the same way, though obviously 
an On My Mac account doesn’t sync through iCloud. 

However, if you use a non-Apple service, such as Gmail, to store 
notes, those notes will be more limited—you won’t be able to add 
checklists or display an embedded video, and the Attachment Brows-
er won’t show these notes’ attachments, such as photos. 

Stay Organized with Folders
 

Within each account, Notes organizes your notes in folders. For in-
stance, you can create a folder for a trip you’re planning or a project 
you’re working on. (Can’t see any folders? Click the Folders button 
or choose View > Show Folders.)
 

To create a new folder in the currently selected account:
 
1.	 Click the New Folder button at the bottom of the Folders sidebar, 

choose File > New Folder, or press Command-Shift-N. 
2. The new folder appears in the sidebar with its name selected. 
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3. Type a name for the new folder. 

Tip: To move an existing note into a new folder, drag it from the 
Notes list onto the folder’s name in the Folders sidebar. 

Create a Note
 

To start a new note in the currently selected folder, click the New Note 
button, choose File > New Note, or press Command-N. You can also 

start a new note using Siri (Figure 64). (See Say Hello to Siri to learn 
how to activate Apple’s digital assistant on your Mac.) 

Figure 64: Perhaps the easiest way to start a new note is to say 
“Siri, take a note” and begin dictating. To add to a note later, say 
“Siri, add to my note” and Siri will ask you to choose which one. 

A New Note entry appears in the Notes list, and a blank note appears 
at the right. 

Start typing in the blank note. The first paragraph you type appears 
both in the note and in the note’s entry in the Notes list. 

Tip: When you use Siri to create a note, it does so using your default 
Note account (for example, iCloud). If you prefer something else, 
choose Notes > Preferences and choose from the Default Account 
pop-up menu. 
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New! Pin a Note
 

Notes stack up by default in chronological order, with the notes you 
most recently edited rising to the top. If you’re a prolific notetaker, that 
may mean you have to scan or search for that important note you 
regularly need to reference. 

High Sierra lets you pin a note to ensure it stays at the top of the list, 
both in the folder where it lives, and in the All iCloud (or All On My 
Mac) folder. Just select a note in a list and choose File > Pin Note 
(Figure 65). 

Figure 65: Select a note and choose File > Pin Note to make it stay 
at the top of the list for easy reference. 

If you pin multiple notes, they stack up in reverse date order with the 
note you pinned first at the top. Unfortunately, you can’t drag and drop 
them into a different order that makes sense to you. 

To un-pin a note, select it and choose File > Unpin Note. 

Format Text
 

How your thoughts appear is up to you as Notes supports a number of 
formatting options. 
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Choosing a Font 
Choose from any of your Mac’s fonts in the Font palette. To reveal it, 
choose Format > Font > Show Fonts or press Command-T. You can 
specify a font size here, too. 

Making Text Colorful 
Select text, and then choose Format > Font > Show Colors (or press 
Command-Shift-C) to reveal the macOS Color Picker. Click a color in 
the palette to apply it to your text. 

Tip: Here’s an : when words aren’t enough, add an emoji to your 
notes. Choose Edit > Emoji & Symbols (or press Command-Control-
Space) and choose your favorite from the palette that appears. You 
can use this tip in other Apple apps too, including your favorite text 
editor or whenever you encounter a text field. 

Set Up Notes Your Way (Sort of) 
Odds are, you have a particular way you want your notes to look. For 
instance, maybe you prefer a large font that’s easy to see, or a small 
one that packs in a lot of information. Or, perhaps you prefer white 
text on a black background. Notes gives you very limited control over 
your Notes’ default appearance. Your main option is to set the default 
Notes font size, and even that is done somewhat inexactly. Choose 
Notes > Preferences and then adjust the Default Text Size slider 
towards bigger or smaller. (No exact point sizes here.) 

Indenting Text 
Scoot text in from the left margin with an indent: 

•	 Indent: Choose Format > Indentation > Increase (or press 
Command-]). 

•	 Un-indent: Choose Format > Indentation > Decrease (or press 
Command-[) 
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Applying a Style 
Notes comes stocked with predefined paragraph styles, character 
formatting tools, and alignment controls: 

•	 Paragraph style: Click in a paragraph (or select text in it), click 
the Style button, and choose from Title, Heading, Body, Bulleted 
List, Dashed List, Numbered List, or the new Monospaced option 
(Figure 66). 

Figure 66: Apply styles using Notes’ Style button. 

Tip: To change the text style your notes start with, choose Notes > 
Preferences and set the New Notes Start With pop-up menu to Title, 
Heading, or Body. 

•	 Character format: Select the text and choose an option in the 
Format > Font submenu. Common keyboard shortcuts apply: 
Command-B for bold, Command-I for italic, Command-U for 
underline, and so on. 

•	 Alignment: Go to Format > Text and choose from Align Left, 
Center, Justify, or Align Right. 
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Copy and Paste Styles 
If you want just the formatting and not the text, you can copy and 
paste styles from one section of text to another. 

Select some text with the formatting you want to copy and choose 
Format > Font > Copy Style (or press Command-Option-C) to copy 
the styles applied to it, but not the text itself. 

Then, select another section of text and choose Format > Font > 
Paste Style (or press Command-Option-V) and that text will adopt the 
styles. 

Easy-access Formatting Controls 
Wouldn’t it be nice if Notes had a formatting toolbar so you could 
stop wasting time digging through the Format menu? Yep. Most of us 
will continue to wait for this feature with the exception of the lucky 
folks who own the MacBook Pro with Touch Bar (Figure 67). 

Figure 67: By default, the MacBook Pro’s Touch Bar shows context-
sensitive controls in Notes (A); tap the arrow icon to the left of the 
QuickType suggestions to reveal formatting options (B). Or, tap the 
lighter arrow next to the styles button to reveal style controls 
(C). I’m only showing the left side of the Touch Bar here. 

Use these controls to quickly access formatting and style options. 

New! Add a Table
 

Whether you’re keeping track of charitable donations for tax time or 
you want to know who’s bringing what to an event, it’s handy to be able 
to organize everything in a nice, neat table. High Sierra adds this 
feature to Notes. Just choose Format > Table, or press Command-
Option-T, and a four-cell table appears. 
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Tip: You can add a Table button to the Notes toolbar by choosing 
View > Customize Toolbar and dragging the Table button into place. 

To add or delete a column or row, click inside any cell and then click 
the ellipse at the top of the table for column options or to the side of 
the table for row options. Click the arrow and choose an option, for 
example Add Row Below (Figure 68). 

Figure 68: Now you can create tables in your notes to organize your 
information. 

Capture Your Screen 
Want to capture a particular element you see on-screen? Notes 
makes this a snap: Control-click in a note and choose Capture Selec-
tion from Screen. Click and drag over a portion of your screen. A red 
selection box appears; release the button to take a screenshot of that 
area. It’s automatically appended to your note. 

You’ll find this feature throughout High Sierra, for instance in 
TextEdit, Pages, Stickies, and perhaps most helpfully, Mail. That 
makes it easy to send a quick picture of an error you’re experiencing 
or a layout you need feedback on. 
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Make a Checklist
 

It’s easy to make a quick checklist in Notes. Select a list in a note and 
then click the Checklist button, choose Format > Checklist, or press 
Command-Shift-L. 

Round circles appear next to each item. Click one to check it off 
(Figure 69). These checklists just tell you what you need to know: did 
you do this task, or did you not? 

Figure 69: Once you’ve formatted selected items as a list using the 
Checklist button (circled), you can check off completed items. 

Tip: Have you been super productive? Select part or all of your 
checklist and then choose Format > Mark as Checked (or press 
Command-Shift-U) to check off a bunch of items at once. 

Attach Photos and More
 

Notes isn’t limited to plain text and simple attachments. Collect all 
sorts of items that catch your attention. Add sketches, voice memos, 
webpages, photos, videos, documents, and map locations. 

94
 



   
              

            
              

          
    

             

         
        

                
           

 

       
      

  

           
        

Adding a Photo or Video 
Perhaps you like to take a picture of the sunset every night, or you 
frequently snap shots of flyers and other things you want to remember 
later. It’s easy to add images and videos to notes and the app can 
display many different image file formats, including GIF, JPEG, PNG, 
TIFF, MOV, and Photoshop (PSD). 

Here are a few methods for adding a photo or video to a note: 

•	 From your library: Choose Window > Photo Browser to look 
through your Photos and Photo Booth images and videos (Figure 
70). Drag and drop one from the palette to insert it in a note. If the 
image is a video, you can click the palette’s Play button to pre-
view it. 

Figure 70: Use the Photo Browser to look through images and 
videos in your Photos library. Drag and drop images from the palette 
to a note. 

•	 From another window: Drag and drop an image onto a note, say 
from the Finder, an email message, or a document. 
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•	 From the Finder: Choose Edit > Attach File (or press Command-
Shift-A), navigate to one in the Finder, and click Attach. 

•	 From a device: Control-click a note and choose Import Image to 
capture an image from an attached camera or scanner. (Note that 
an iPhone connected to the Mac shows up as a camera, but the 
Mac’s built-in camera does not.) 

•	 From your current app: When you’re in an app—for example, 
Preview or Photos—click the Share button and choose Notes to 
send an image or video to Notes. If you’d rather append it to a note 
you’ve already made, click the Choose Note pop-up menu and select 
the note you want from the list (Figure 71). 

Figure 71: Use the Share button to send an image or video to 
Notes. To add the image to the end of a preexisting note, click the 
Choose Note pop-up menu and select the note from the list. 

Adding a File 
Sometimes it helps to gather the files for a project—PDFs, documents, 
spreadsheets, you name it. Notes can display PDFs and include links to 
most other file types. To add a file: 

•	 From another window: Drag and drop a file on your note. 
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•	 From the Finder: Choose Edit > Attach File (or press Command-
Shift-A), navigate to one in the Finder, and click Attach. 

If the file is a PDF, its first page will preview in your note (Figure 72). 
Otherwise, its name will appear along with its file size and icon. 
Double-click the preview or link to open the file in its parent app. 

Figure 72: When you add a PDF to a note, by default its first page 
previews. 

Tip: After you add a PDF, image, or sketch to a note, Control-click it 
and then choose View as Large Images or View as Small Images to 
get the size right. (This setting applies to all the attachments in that 
note.) 

Tip: Have a bunch of files that are relevant to a note? Add a link to a 
folder. Just drag and drop the folder’s icon from the Finder to your 
note. Double-click the icon in the note to open the folder in a Finder 
window 
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Adding a Web Link 
You can use Notes to keep track of online research, too. Here’s how: 

•	 Type the URL (web address) and press Return. It automatically 
becomes a clickable link. 

• To add a link to a page you see in Safari, click the Share button, 
choose Notes, and click Save. A note appears with a short descrip-
tion, the link, and, in most cases, a thumbnail representing the story 
or website. 

Bringing in Cool Stuff from iOS 
Note-worthy thoughts don’t always come to you while you’re sitting 
politely at your desk. Instead, they often arrive when you’re walking 
the dog, out for morning coffee, or exercising at the gym. Luckily, 
using an iOS device, you can capture your thoughts in different ways: 
✦	 Add a Voice Memo: If you like to talk through your ideas while
 

you walk around the study or while out and about, the iPhone’s 

Voice Memos app makes it easy. Just tap the Voice Memos icon,
 
and tap Record. When you’re done recording, tap the Share
 

button and choose Notes. The audio clip appears in the iCloud 

Notes list on all your devices, including your Mac. In Notes, click
 

the blue Play button to listen to your voice memo.
 

✦ Add a Sketch: On your iOS 9 or later device, sketch an idea in 
Notes using your finger, a stylus, or the Apple Pencil. These 
drawings appear automatically in your iCloud Notes list. High 
Sierra’s Notes app doesn’t have drawing capabilities yet. 

Adding a Map 
Keeping track of dream destinations? Or all of the coffee shops you’ve 
tried in the neighborhood? Include links to their locations: 

1.	 In Maps, pull up the map that location you want to add to a note, 
click the Share button, and choose Notes. 

2.	 In the Save dialog, leave the Choose Note menu set to New Note or 
choose a note to append the map to. 
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3.	 Optionally, enter text. For a new note, the first paragraph of text 
that you enter appears as a title in the Notes list. 

4.	 Click Save. 

In Notes, the map appears as a thumbnail. Double-click this to jump 
back to the directions or location in the Maps app (Figure 73). 

Figure 73: Share a map to Notes and it appears as a thumbnail with 
a brief summary. Double-click this to jump to the location or direc-
tions in the Maps app. 

Lock a Note
 

Whether you use Notes as a diary or simply store tidbits there you’d 
rather keep to yourself, you’ll be happy to hear that Notes lets you lock 
notes for privacy. Use a single password for private notes on all of your 
devices. (Or, if your iOS device has Touch ID, unlock your notes there 
with your fingerprint.) 

Password-protecting a Note 
To lock down a sensitive note: 

1.	 Select a note. As of High Sierra, a password-protected note can’t 
contain video, audio, PDF, or file attachments. 

2. Choose File > Lock Note or click the Lock button on the Notes 
toolbar and choose Lock Note (Figure 74). 

99
 



        
      

              

             
              

          
            
           

  

         
        

     

           

  
           

      

             
            

    

Figure 74: To protect a note against prying eyes, click the Lock 
button on the toolbar and choose Lock This Note. 

If you’ve already set up a Notes password, enter it at the prompt. If 
not, go on to step 3. 

3.	 In the dialog that appears, type a password in the Password field 
and then type it again in the Verify field. (This will be the password 
for all your locked notes on all your iCloud-enabled devices. ) 

4.	 Leave yourself a helpful clue in the Password Hint field. It will 
appear if you mess up your password three times in a row. 

5. Click Set Password. 

Tip: To change your private notes’ password, choose Notes > Prefer-
ences, click the Change Password button, enter your old password, 
repeat Steps 3 and 4, and then click Change Password. 

Locking Your Notes 
To lock all password-protected notes, click the Lock button and choose 
Close All Locked Notes. 

Unlocking Your Notes 
Select any locked note and enter your password. Once you’ve entered 
the password, all notes stay unlocked until: 

•	 You’ve been idle in Notes for a period of time. (Apple says 3 
minutes, but in my testing, notes stayed open as long as 13 
minutes.) 

•	 You close the Notes app. 
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• You lock your notes by clicking the Lock button and choosing 
Close All Locked Notes. 

If you decide you don’t want to lock a particular note any longer, select 
it, click the Lock button, enter your password, and choose Remove 
Lock. 

If You Forget Your Password 
Forget the password for your private notes and you are out of luck! 
Apple can’t help you regain access to your locked notes. 

Until something jogs your memory, your old private notes will remain 
inaccessible, but in the meantime you can create a new password so 
you can create new private notes. To reset your password, choose 
Notes > Preferences, click the Reset Password button, and click 
through the warnings (Figure 75). 

Figure 75: You can’t retrieve a lost password, but you can make a 
new one for all the private notes you create from now on. 

Finally, enter a password for all the new private notes that you’ll 
store in your iCloud account. 

Share Notes with Others
 

Whether you need to coordinate a shopping list or brainstorm a 
project, you can do it in Notes. 

Note: To view notes and collaborate together, all participants must 
use an iCloud account. 
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Sharing a Note 
To give someone else access to a note: 

1. Start a note—or view an existing note. 

2. Click the Add People button on the Notes toolbar. 

In the dialog that appears, choose how to invite people—via Mail, 
Messages, Twitter, Facebook, AirDrop, LinkedIn, or by copying a 
link and pasting it into something else. 

3. Make your choice and click Share. 

You can tell which notes are shared by looking for the Sharing 
symbol next to their names in the Notes list (Figure 76). 

Figure 76: You can tell if a note is shared by looking for a sharing 
symbol next to its name. 

Collaborating in Real-time 
Once the person accepts your invitation, they can open the note on 
their iOS 10, Sierra, or later device and get cracking. You’ll see edits 
highlight briefly as contributors work in the note (Figure 77). 
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Figure 77: As contributors work in the note, edits highlight briefly. 

Stopping Sharing 
Select the note, click the People button, click the More button 
that appears to the right of a contributor’s name when you hover over 
it, and choose Remove Access Figure 78. 

Figure 78: To stop sharing a note with someone, click the View 
Participants button, click the More button (marked with an ellipsis) to 
the right of the person’s name, and then choose Remove Access. 

To stop sharing the note altogether, click the People  button and 
then click Stop Sharing. 
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Search for Notes
 

To find a particular note, type a descriptive term in the search field in 
the upper-right corner. (There’s no natural-language search capability 
in Notes.) 

To limit your search to the account that’s selected in the sidebar, click 
the downward arrow that appears next to the magnifying glass when 
the search field is active and choose Current Account. Choose All 
Accounts (the default) to search all your notes. 

Tip: When you need to see all incidents of a word inside a particular 
note, use a different search technique. Press Command-F when 
you’re looking at the note and a second search field appears below 
the toolbar. Type the term in here and all instances of it will appear 
highlighted in the note. 

Browse Your Attachments
 

The Attachment Browser gives you a visual way to rummage through 
the files you’ve attached to notes, organized by category: Photos & 
Videos, Sketches (from Notes in iOS 9 or later), Maps, Websites, 
Audio, and Documents. 

To open the browser, choose View > Show Attachments Browser, click 
the Attachments Browser button, or press Command-1. 

Click a category name to see the attachments shown there (Figure 
79). 
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Figure 79: Click the Photos & Videos category in the Attachment 
Browser to see all the images in your notes. 

You can’t change or delete an item in the Attachment Browser. But, 
you can double-click a thumbnail to open it in its default application. 
For example, images and sketches will open in Preview, map informa-
tion in Maps, and so on. You can also play a voice memo or video. 

To jump to the note that contains a selected attachment, control-click 
an attachment in the Attachment Browser and choose Show in Note 
from the contextual menu. 

The Quick Look command, also on the contextual menu, can be 
a handy way to see more of an attachment, but you can also trigger 
Quick Look by selecting an attachment and pressing the Space bar. 

To exit the browser, choose View > Hide Attachments Browser, click 
the Attachments Browser button again, or press Command-1 again. 

Export and Share Notes
 

It’s possible to export a note as a PDF. To do so, choose File > Export 
as PDF. 
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Share a note with another app by clicking the Share button and 
choosing the app’s name. For instance, click the Share button 
and then choose Mail to create a new email message that includes 
the contents of your note. 

Delete a Note
 

To remove a note, select it and then press Delete or click the Delete 
button. Notes has got your back: if you delete a note and change your 
mind, chances are that you’ll find it in the Recently Deleted folder (in 
the left-hand Folders sidebar ). Drag it into another folder to restore 
it. 

Notes are permanently deleted after 30 days unless you delete them 
from the Recently Deleted folder first—then, they’re gone. 
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Move Easily between 
Devices 

Many of the improvements Apple has made to macOS in recent years 
have aimed to make it easier to move between (they hope) your many, 
many beloved Apple devices. Yosemite introduced Handoff, which lets 
you start a task on one device and then pick up where you left off on 
another. It also made it possible to answer and place iPhone calls on 
your Mac. Sierra made it possible for Apple Watch users to skip typing 
in their passwords and instead unlock their Macs with an Apple Watch. 
It also added Universal Clipboard, which lets you copy something on 
your iOS device and then paste it to your Mac (or vice versa). 

As of High Sierra, Universal Clipboard now works Mac-to-Mac as well 
as iOS-to-Mac. We’ll take a look at how to use all these features to 
seamlessly stitch together your Apple universe. 

Check the Requirements
 

Now that some incompatible hardware has aged out of the market, 
more people can take advantage of Continuity features like Handoff, 
Universal Clipboard, and iPhone cellular calls on the Mac. 

What You Need to Use Handoff 
According to Apple, you need one of these devices to use Handoff: 

•	 Apple Watch: All models 

•	 iOS: iPhone 5 or newer; iPad Pro; iPad (4th generation); iPad Air 
or newer; iPad mini 2 or newer; iPod touch (6th generation) or 
newer 

•	 MacBook Air: 2012 or newer 

•	 MacBook: 2015 or newer 
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• MacBook Pro: 2012 or newer 

• Mac mini: Late 2012 or newer 

• iMac: Late 2012 or newer 

• Mac Pro: Late 2013 or newer 

To confirm whether your Mac can use Handoff, choose Apple  > 
System Preferences > General and look for the Allow Handoff between 
This Mac and Your iCloud Devices checkbox (Figure 80). If you don’t 
see this box, you’re out of luck. 

Figure 80: Does your Mac support Handoff? Go to System Prefer-
ences > General. You want to see this setting (circled). 

Macs must be running OS X 10.10 Yosemite or later and iOS devices 
must be running iOS 8 or later. 

What You Need to Use Universal Clipboard 
Universal Clipboard has the same hardware requirements as Handoff, 
but doesn’t include the Apple Watch. To access iOS-to-Mac Universal 
Clipboard features, Macs must be running Sierra or newer and iOS 
devices must be running iOS 10 or newer. To use Mac-to-Mac Univer-
sal Clipboard features, both Macs must be running High Sierra. 

What You Need to Make iPhone Cellular 
Calls 
If you want to make and take phone calls on your Mac via your iPhone, 
you must have a Mac (with a microphone) using OS X Yosemite or 
newer and an iPhone running iOS 8.1 or newer. 
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What You Need to Unlock a Mac with a 
Watch 
According to Apple, you must meet these requirements to unlock your 
Mac with your Apple Watch: 

•	 Apple Watch: All models 

•	 MacBook Air: Mid-2013 or newer 

•	 MacBook: 2015 or newer 

•	 MacBook Pro: Late 2013 or newer 

•	 Mac mini: Late 2014 or newer 

•	 iMac: Late 2013 or newer 

•	 Mac Pro: Late 2013 or newer 

The Watch must be running watchOS 3 or newer; the Mac must be 
using macOS Sierra or newer. 

Switch between Devices with Handoff
 

When does Handoff come in handy? Say you start to write an email 
message on your Mac and then have to rush out the door for work. 
With Handoff’s help, you can finish composing the message on your 
iPhone while you wait at the train station. Handoff lets you pick up 
where you left off when using Calendar, Contacts, Keynote, Mail, 
Maps, Messages, Notes, Numbers, Pages, Reminders, Safari, and some 
third-party apps. 

Set Up Handoff 
Before your devices can finish each other’s thoughts, you may need to 
adjust a few settings: 

1.	 On your Mac(s), go to System Preferences > Bluetooth and click the 
Turn Bluetooth On button. (Or, invoke Siri and say “Turn on Blue-
tooth.”) 
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2.	 On your iOS device(s), open the Settings app, tap Bluetooth, and 
turn on the Bluetooth switch. 

3.	 Make sure that your Macs and iOS devices are all signed in to 
iCloud with the same Apple ID. On the Mac, you can check this in 
System Preferences > iCloud. On an iOS device, tap Settings and 
then your name at the top of the screen. 

4.	 Activate Handoff on the Mac by going to System Preferences > 
General and selecting the Allow Handoff between This Mac and 
Your iCloud Devices box. 

5.	 Activate Handoff on an iOS device by tapping Settings > General > 
Handoff and turning on the Handoff switch (Figure 81). If you 
don’t see this switch, the device isn’t compatible with Handoff. 

Figure 81: Turn on the Handoff switch on your iOS device. 

6.	 Make sure both devices are on the same Wi-Fi network: 
‣	 On the Mac, go to System Preferences > Network and, if needed, 

click the Turn Wi-Fi On button. Then check the network name. 
‣	 In iOS, tap Settings > Wi-Fi and, if needed, turn on Wi-Fi. Make 

sure the device is connected to the same network as your Mac. 
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Move Between Devices with Handoff 
When you’re ready to move from one device to another, leave the app 
you’re using in the foreground. Then: 
•	 Check that your Mac and iOS device (or two Macs) are within Blue-

tooth range of each another—no more than 33 feet (roughly 10 
meters) apart. It shouldn’t matter if your iPhone or iPad is inside a 
pocket, purse, or backpack. 

•	 If you’re moving to an iPad, iPhone, or iPod touch, you won’t see an 
activity icon for the app you were working at the bottom-left edge of 
the Lock screen as in the past. Instead, unlock your iOS device and 
double-press the Home button to bring up the App Switcher. You’ll 
see a Handoff icon at the bottom of the screen there. Tap this icon 
to pick up where you left off (Figure 82). 

Figure 82: You won’t find a Handoff icon at the bottom of your 
device’s Lock Screen anymore. Instead, look for one in the iOS App 
Switcher. 

•	 If you’re moving to a Mac, an activity icon for the app (with a tiny 
device icon on it) appears in the Dock. Click this to jump to your 
spot. 

Or, if you like to keep your hands on the keyboard, when the activity 
icon appears in the Dock, press Command-Tab to reveal the Appli-
cation Switcher (Figure 83). Hold the Command key and press 
Tab until the activity icon highlights. Release the keys to jump to 
your spot. 
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Figure 83: Press Command-Tab to access the Application Switcher. 
Hold the Command key and press Tab to move through the icons. 
Once you reach the Handoff icon, release the keys. 

Results Will Vary 
If you’re composing an email message in Mail and switch to another 
device using Handoff, you’ll find your insertion point, and text, 
exactly where you left it. Likewise, Maps jumps to the most recent 
directions. Safari reloads the page you were reading, but data typed 
into forms, as well as your place on the page, is lost. Apple’s iWork 
suite—Pages, Keynote, and Numbers—works with Handoff only if 
you’ve saved the files to iCloud Drive. 

Troubleshoot Handoff 
Handoff works like magic, unless it doesn’t. If nothing happens, here’s 
what to do next: 

•	 Double-check settings: Go back to Set Up Handoff and make 
sure you didn’t miss something. 

•	 Check the app: The app you’re using may not be compatible with 
Handoff. Apple apps that work on both the Mac and iOS include 
Calendar, Contacts, Mail, Maps, Messages, Notes, and Safari. On 
the Mac, you can also use Keynote 6.5 and newer, Numbers 3.5 and 
newer, and Pages 5.5 and newer. In iOS, you can also use Phone, as 
well as Keynote, Numbers, and Pages (versions 2.5 and newer). 
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•	 Sign out and back in to iCloud: On the Mac, go to System 
Preferences > iCloud, and click Sign Out. Once you’ve signed out, go 
back to System Preferences and sign back in. In iOS, go to 
Settings > iCloud, scroll down and then tap Sign Out. Follow the 
instructions, and then enter your password and tap Turn Off. Once 
the process is done, go back to iCloud settings and sign back in. 

Copy and Paste between Devices with 
Universal Clipboard 

For those times when even Handoff seems like a hassle, you can use 
Universal Clipboard to copy and paste between a Handoff-capable Mac 
and iOS device or, as of High Sierra, between two Macs. 

Set Up Universal Clipboard 
Universal Clipboard has the same set up as Handoff. You must have 
Wi-Fi, Bluetooth, and Handoff turned on in System Preferences on 
Macs and in Settings on iOS devices. All devices must be signed into 
the same iCloud account (see Set Up Handoff). 

What Works 
Use Universal Clipboard to copy and paste text; images, including 
JPEG, PNG, TIFF, GIF, and BMP file formats; the contents of a PDF, 
including images and text; and video files in common file formats like 
M4V (Figure 84). 
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Figure 84: You’re likely to see a notification when you paste an 
image (or anything particularly complicated) from one device to 
another. 

Note: In my testing, using Universal Clipboard did not work reliably 
with video. When you need to transfer video from one device to 
another, try another technique instead. See Move Big Files with 
AirDrop (and more). 

You must copy from a file that is open in an app. You can’t select a file 
in the Finder and copy it. (At best, you’ll copy its name instead.) 

What Happens 
The contents of the clipboard transfers when you paste. If you wait 
longer than 2 minutes between copying and pasting, sharing expires 
and, instead of getting the information from the other device, you’ll 
paste in whatever was previously on the target device’s clipboard. 

Tips for Copying and Pasting Images 
Copying text with Universal Clipboard is simple, but copying images 
sometimes requires an extra bit of know-how: 

•	 Avoid copying URLs instead of images (on your Mac): 
When you want to copy an image from a webpage, Control-click the 
image and then choose Copy Image from the contextual menu. 
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•	 Copy an image from a webpage (on your iOS device): Touch 
and hold the image to see options. If you see Copy, tap that. If not, 
tap Share, and then tap Copy. 

•	 Copy an image from Photos (on your iOS device): Select the 
photo you want, tap the Share button, and then tap Copy. 

If you’ve stored your photos in iCloud (see Manage Your Storage), 
your image may already be available on the target device in the 
Photos app. Copying and pasting it from the device you’re on, 
however, may require fewer steps than opening Photos on the target 
device and copying it from there. Use your judgment. 

•	 Paste into Preview (on your Mac): If you’re just trying to get 
an image you’ve copied from here to there, open Preview and 
choose File > New from Clipboard. The image you’ve copied is 
pasted into a new Preview document, which you can now save on 
the target Mac. 

Turn Your Mac into a Speakerphone 

It’s probably happened to you before: You hear your iPhone’s muffled 
ringing, but whether it’s buried deep in a coat pocket or purse, you 
won’t find it in time to answer the call. Your Mac offers a simple fix for 
this daily aggravation: answer the call on your Mac. Need to make a 
call? You can do that from your Mac, too. 

Set Up Calling 
To use High Sierra’s iPhone cellular call features, you must also have 
an iPhone running iOS 8.1 or newer. 

Take these steps: 

1.	 Make sure the Mac and iPhone are on the same Wi-Fi network. 

On your Mac, go to System Preferences > Network, click Wi-Fi, and 
check the network name. On your phone, tap Settings > Wi-Fi to see 
the name of the network. 
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2.	 Double-check that your Mac and iPhone are signed in to FaceTime 
with the same Apple ID. 

On your Mac, go to FaceTime > Preferences to check the ID. On 
your iPhone, tap Settings > FaceTime, make sure that the FaceTime 
switch is on, and then check the ID. 

3.	 If you see a Use Apple ID for FaceTime link on your phone, tap that. 
On your Mac, you will see a dialog asking if you want to add your 
phone number to iMessage and FaceTime. Click Yes. This lets you 
make and receive calls on devices (your Mac or iPad) that are signed 
in to the same iCloud account and on the same Wi-Fi network. 

4.	 In the FaceTime preference pane on your Mac, select Calls from 
iPhone (If this checkbox doesn’t appear initially, try restarting your 
Mac). 

Receive a Call on Your Mac 
When a call comes in for your iPhone, your Mac will chime. A notif-
ication shows the caller’s name (if they are listed in Contacts) or 
number. 

You can: 

•	 Take the call: Click Accept. When you’re connected, the notif-
ication becomes a small window with phone controls (Figure 85). 
Click Video to start a FaceTime session. (This only works if the 
other person is calling from a Mac or iOS device and signed in to 
FaceTime.) Click Mute to mute audio during the call—for instance, 
to discreetly ask someone else in the room a question. Click End to 
hang up. 
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Figure 85: When you answer a call, the notification becomes a small 
window with phone controls. 

•	 Decline the call: Either click Decline or click the arrow next 
to Decline to choose an option, including Remind Me in 5 Minutes. 

•	 Ignore the call: If you miss a call, a notification lingers on your 
screen to let you know when you return. 

Tip: If you get a new call on your Mac when you’re talking to some-
one, an alert appears that gives you the option to put the conversa-
tion on hold to answer the incoming call, just as you can on your
 

iPhone.
 

Make a Call from Your Mac 
To “dial” a number: 

•	 In an app: Click a phone number in an app like Contacts, Maps, 
Spotlight, or FaceTime. You can also select a number on a webpage 
or in an email message, click the triangle that appears to its right, 
and then choose “Call phone number Using iPhone.” 

•	 From a recent call: Open FaceTime, click the Audio button, and 
then click the phone button in the call’s listing. Or, click and hold 
FaceTime’s Dock icon to see a list of recent calls. Choose one to call 
back. 

• Enter a number: Open FaceTime and type the number directly 
into the field under the Video and Audio buttons. 

FaceTime places your call. There’s no video involved. 
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Navigate Automated Phone Systems 
If you hear the fateful words “Press 2 for…” during a call, you don’t 
need to scramble madly for your iPhone. Click the phone call notif-
ication to make sure the focus is on it. Then, use your Mac’s keyboard 
to navigate automated phone systems by pressing the numbers re-
quired. 

Hold All Your Calls 
Big meeting, tight deadline—sometimes you don’t want to be 
disturbed: Option-click the Notification Center icon in the menu 
bar to turn off all notifications, including incoming calls. (Your iPhone 
will still ring, just not your Mac.) When you finish, Option-click the 
icon again. Or, click it to reveal Notification Center and turn off the Do 
Not Disturb switch. 

Tip: If you start a call on your Mac and then realize you need to get 
going, pick up your iPhone and look for a green bar across the top of 
your iPhone’s lock screen. Tap this and enter your passcode. The call 
switches over to your phone so you can keep talking. 

Adjust Where Calls Go 
When you turn on iPhone cellular calls, all devices that share your 
Apple ID will ring when calls come in, as long as they’re on the same 
network. This might not be ideal if your iPad, for instance, is shared by 
all the family and usually in the hands of the kids. 

In that case, on the iOS device where you don’t want to receive calls, 
tap Settings > FaceTime and then turn off the Calls from iPhone 
switch. 

Turn Phone Features Off 
Whether you’ve decided that you don’t like your Mac ringing at all or 
you just want to take a short break from the phone features, but not 
other notifications, you can turn off phone calls on your Mac. 
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Open FaceTime and go to FaceTime > Preferences. Click Settings and 
deselect the Calls from iPhone checkbox. 

Unlock Your Mac with Your Apple 
Watch 

It’s wise to password-protect your Mac whenever you step away from 
it, especially if you lug your laptop around with you everywhere, but 
entering your password repeatedly is a pain. If you have an Apple 
Watch and a Mac (running watchOS 3 and Sierra or newer) you can 
use an extremely cool shortcut: Raise your watch and voilà! Your Mac 
unlocks automatically (Figure 86). 

Figure 86: Your Mac (left) and Watch (right) will show a notification 
as your Mac unlocks. 

Here’s how to set up Auto Unlock on your Mac: 

1.	 Go to System Preferences > Security & Privacy > General and select 
the Allow Your Apple Watch to Unlock Your Mac box. This box 
is visible only if you have a watch. If you see a Disable Automatic 
Login box here, uncheck it. 

2.	 If you aren’t using two-factor authentication (2FA) for your Apple 
ID, you’ll see an error. Turn this security feature on by going to the 

119
 

https://support.apple.com/en-us/HT204915


           
       

           

             
       

              

                
            

    

           
           

             
         

            
              

           
 

Apple ID account page, logging in, clicking Edit next to the Security 
header, and then clicking Turn On Two-Factor Authentication. 

3.	 When prompted, enter the password for your user account on the 
Mac. 

4.	 Close your laptop or put your desktop Mac to sleep. (If you don’t 
want to wait, choose Apple  > Sleep.) 

5.	 Wake your Mac by pressing a key or by opening it if it’s a laptop. 

If your watch is on your wrist and you’re within a foot or so of the Mac, 
you’ll see an unlock notification on the Mac. You’ll also see a notif-
ication on your Apple Watch. 

Note that your watch can unlock only a sleeping Mac; it can’t automati-
cally unlock a Mac that’s been rebooted. Your watch must have a 
passcode, but you don’t need to enter the passcode every time you use 
Auto Unlock. (That wouldn’t save any time!) Also, your watch locks 
automatically whenever you take it off, so it wouldn’t be possible for 
someone to pick your watch up off your desk and use it to access your 
Mac 

Tip: To learn more, see Jeff Carlson’s Apple Watch: A Take Control
 
Crash Course.
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Move Big Files with 
AirDrop (and more) 

Once upon a time, moving electronic files from one computer to 
another required cables, know-how, and a fair dose of determination. 
Nowadays we have options like Dropbox, Messages, Mail, and the 
Universal Clipboard, as well as Apple’s AirDrop. 

Prior to Yosemite, AirDrop simplified transferring files between Macs 
on the same network, and later between iOS devices in close range of 
each other. These days, AirDrop takes on the whole kit-n-caboodle, 
promising instant sharing between Macs, iPhones, and iPads with just 
a few taps or clicks, if you have the right hardware. 

AirDrop Requirements
 

To use AirDrop between a Mac and an iPad, iPhone, or iPod touch, 
your Mac and iOS device must meet Handoff requirements (see What 
You Need to Use Handoff). If you just want to use AirDrop Mac to 
Mac, you can get away with older hardware; see this Apple article for 
details. However, some features covered in this chapter, like limiting 
discoverability to contacts only, won’t work. 

Note: When AirDrop works, it’s great; but for those times when you 
need more ideas for moving files between computers, see When in 
Doubt: Try Other Methods, later in this chapter. 

Turn On Wi-Fi and Bluetooth
 

AirDrop uses Bluetooth to create a peer-to-peer Wi-Fi network be-
tween devices. 
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With that in mind: 

•	 Ensure that all devices have Wi-Fi turned on. (They don’t have to be 
on the same network.) 

To find the settings, on your Mac, go to System Preferences > 
Network, and click Wi-Fi. On an iOS device, tap Settings > Wi-Fi. 

Tip: In the Network preference pane on the Mac, select the Show Wi-
Fi Status in Menu Bar checkbox, near the bottom of the pane, to 
make it possible to turn Wi-Fi off and on from the menu bar. 

•	 Check that Bluetooth is turned on. 

On your Mac, go to System Preferences > Bluetooth. On an iOS 
device, tap Settings > Bluetooth. 

•	 Bring both devices into Bluetooth range—no more than 30 feet 
(roughly 9 meters) away—the closer the better. 

Make Devices Discoverable
 

Are you the type to roll out the welcome mat or would you rather 
connect with just the people you know? You can control who is allowed 
to send files to your device with AirDrop. 

Set Up a Mac 
To set up AirDrop on a Mac: 

1.	 Click AirDrop in a Finder window’s sidebar, or choose Go > AirDrop 
(Command-Shift-R). 

2.	 Click Allow Me to be Discovered By at the bottom of the window 
and choose from three options: 

‣	 No One: Don’t pick this if you want to share via AirDrop. 

‣	 Contacts Only: This limits sharing to people listed in your
 
contacts. You must be signed in to iCloud to use this option
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(Figure 87). Go to System Preferences > iCloud and sign in with 
your Apple ID. 

Figure 87: If you want to limit AirDrop to contacts only, you must 
sign in to iCloud with your Apple ID. 

‣	 Everyone: This broadcasts your location to everyone in range. 
It’s the simplest one to use, if you’re willing to get AirDrop re-
quests from the occasional stranger. 

When You Can’t See Older Macs 
Want to share with an older Mac, but not seeing it in your Mac’s 
AirDrop window? Click the text “Don’t see who you’re looking for?” at 
the window’s bottom, and then click the Search for An Older Mac 
button (Figure 88). 

Figure 88: Click this button to find older Macs. 

Older Macs must have Wi-Fi hardware that supports AirDrop, too. See 
the Apple article Use AirDrop to send content from your Mac. 
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Set up an iOS Device 
To make an iPhone, iPad, or iPod touch discoverable: 

•	 On an iOS 8 or 9 device: Swipe up from the bottom of the screen 
to reveal Control Center and then tap AirDrop to adjust the settings 
for your iOS device; they work basically the same as on your Mac, 
described just previously. 

•	 On an iOS 11 device: Swipe up from the bottom of the screen to 
reveal the Control Center and then touch and hold the Networking 
platter (the area with WiFi button) to reveal the AirDrop button. 
Tap it. 

An icon for the iPhone or iPad should appear now in your Mac’s open 
AirDrop window. 

Empty AirDrop Window? 
If you’ve carefully followed the steps in this chapter, but still don’t 

see another device in your Mac’s AirDrop window:
 

✦ Make sure an iOS device isn’t asleep. If it is, tap the Home button. 

✦ Bring iOS devices or laptop Macs closer to your Mac. 

✦ Turn Bluetooth and Wi-Fi off and then on again on the devices. 

✦	 If you know a receiving Mac is using a firewall, go to System
 

Preferences > Security & Privacy and check to see if the Block All
 
Incoming Connections option is enabled. When this setting is on,
 
the Mac won’t be able to receive AirDrop files.
 

✦ Double-check that all devices meet AirDrop requirements. (See 
AirDrop Requirements, earlier in this chapter.) 

Send a File
 

To begin an AirDrop transfer: 

•	 From the Finder: In the Finder, drag the file to your Mac’s 
AirDrop window and drop it on the iOS device or another Mac’s 
icon (Figure 89). 
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Figure 89: To share a file, drop its icon on the receiving device’s 
icon in your Mac’s AirDrop window. 

•	 From a Mac app: AirDrop is also available in your Mac’s Share 
menus. So, for example, if you want to share a Safari link, click the 
Share button on Safari’s toolbar and choose AirDrop. An AirDrop 
dialog opens. Click the receiving device’s icon to send, and then 
click Done. Send Contacts cards to iOS or another Mac in the same 
way. 

•	 From iOS to a Mac: If you’re sending an image from your iPhone 
to your Mom’s Mac, for example, open the Photos app, choose a 
photo, and then tap the Share button. Under the Tap to Share 
with AirDrop header, tap the icon for the Mac. (If you don’t see the 
Mac’s icon, make sure its AirDrop window is open.) 

If you’re signed in to iCloud on the receiving device with the same 
Apple ID—say, the transfer is between your iPhone and Mac—the file 
downloads automatically. 

If the Mac or device belongs to someone else, the recipient will receive 
a notification saying the sender wants to share a file, complete with the 
filename or a preview. Recipients can decline the transfer if they 
choose (Figure 90). 
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Figure 90: On the receiving device (a Mac is shown here), a notif-
ication appears asking if the recipient wants to accept the file trans-
fer. 

The file typically transfers to the Downloads folder on a Mac, unless 
the recipient selects a different destination by clicking and holding the 
Accept button. In iOS 11, once the file has transferred, the recipient 
sees a menu of options for where the file can go. For example, for a 
PDF, choices may include iBooks, iTunes U, Scrivener, DEVONthink, 
Dropbox, and Slack. 

When in Doubt: Try Other Methods
 

AirDrop is amazing, but it has its limitations: not everyone’s hardware 
meets the requirements and sometimes the technology can be cranky. 
In those cases, consider these easy ways to move files and information: 

•	 Universal Clipboard: Sometimes the fastest way to get text or an 
image from one place to another is to just copy and paste. To share 
among your Macs and iOS devices, see Copy and Paste between 
Devices with Universal Clipboard. 

•	 Email: A tried-and-true method for getting files from one place to 
another is email. Note that as of Yosemite, as long as you’re using 
Mail, you can send files up to 5 GB without worrying about bumping 
into attachment size limits (see this Apple page about Mail Drop 
Limits). The monthly Mail Drop storage limit is 1 TB; each attach-
ment expires after 30 days. 
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Tip: Use Family Sharing to share iTunes purchases, apps, reminders, 
and more with all members of the household. (Family Sharing is 
required for Apple Music family plans.) See Use iCloud Family Sharing 

•	 iCloud Drive: To share files with one of your own devices, use 
iCloud Drive. Note that files can be no larger than 50 GB and you 
can’t exceed your iCloud storage limits. (See Navigate iCloud Drive.) 

Now you can also share and collaborate with someone on the same 
file. See New! Share Files Using iCloud Drive. 

•	 Messages: If Messages is set up on your Mac with an iMessage 
account, as well as on the target Mac or iOS device, it’s a cinch to 
send an attachment (in my testing, files up to 550 MB worked): 

‣ When you’re in an app (such as Photos), click the Share button 
and choose Messages to send the attachment. 

‣	 Start a conversation with someone (or yourself) and then drop 
the attachment onto the message field (Figure 91). Press Return 
to send. 

Figure 91: Drag and drop an attachment into Messages’ message 
field to send it to another person (or yourself on a different device). 

•	 Dropbox: If you’re a Dropbox user, it’s easy to share files with 
others (see this Dropbox page for details on file size limits). 
Control-click any file or folder in your Dropbox folder in the Finder 
and choose Copy Dropbox Link. A link copies to your Clipboard. 
Paste it into an email or text message and send. 

127
 

https://www.dropbox.com
https://www.dropbox.com/en/help/space/upload-limitations


           
             

             
           

               
          

             
           

              
     

        
           

          
            

              
               

 

 
            
   

Navigate iCloud Drive 
When you’re on the move—from home to office, classroom to dorm 
room—it’s not always possible to work on the same device. So how do 
you make sure you always have access to the files you need? Much like 
Dropbox and Google Drive, Apple’s iCloud Drive stores your files in the 
Cloud, making it easy to access them on any of your Apple devices (or a 
Windows PC)—so long as the device has a fast enough internet connec-
tion. Drag files to and from the iCloud Drive folder in your Mac’s 
Finder, and iCloud Drive syncs them across your devices so they’re 
always up to date. 

High Sierra adds a new twist: now you can use iCloud Drive to work on 
a file with others, making collaboration much easier. 

Work with iCloud
 

Use iCloud Drive to store documents, presentations, spreadsheets, 
PDFs, images, you name it, on Apple’s servers. Everything you save 
here is immediately synced and available on other compatible Apple 
devices you’ve set up (as long as you have an internet connection). 
That means you can work on a document on your iPad and then open 
it later on your Mac. In many cases, you can also work with it on the 
iCloud.com website. 

Get Started 
If you bought a Mac that came with Sierra or High Sierra, iCloud Drive 
is turned on automatically. 
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Check the Requirements 
To use iCloud Drive, a device must have an active internet connection 
and you must have an Apple ID. Apple also recommends these 
minimum requirements: 

✦ iPhone, iPad, or iPod touch with Apple’s iOS 8 or newer. 

✦	 Mac with OS X 10.10 Yosemite or newer. 

✦ PC with Windows 7 or later and iCloud for Windows. 

A device that doesn’t meet any of the above requirements could still 
access iCloud Drive through the iCloud website if it is running at least 
Internet Explorer 11, Firefox 45, or Google Chrome 50. 

If you use iWork apps (Pages, Numbers, and Keynote), upgrade them 
to the latest versions. Alternatively, use the web-based iWork for 
iCloud. 

If iCloud Drive isn’t activated on your Mac yet, follow these steps: 

1.	 Go to System Preferences > iCloud and, if you aren’t already signed 
in to iCloud, sign in with your Apple ID. 

2.	 Select the iCloud Drive box (Figure 92). 

Figure 92: To activate iCloud Drive on your Mac, go to System 
Preferences > iCloud and check the iCloud Drive box. 

3.	 Click the Options button to the right to see which apps store files 
and data in iCloud. Uncheck the box next to one to prevent it from 
doing so (Figure 93). Click Done. 
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Figure 93: Uncheck an app here to stop it from storing documents 
and data in iCloud. 

Size Up Your Storage 
The more you store in iCloud—especially if you keep your Desktop and 
Documents folders in the Cloud and use iCloud Photo Library (see 
Manage Your Storage)—the more storage you’ll need. Currently, in the 
United States, you get 5 GB of storage free per Apple ID, and you can 
purchase 50 GB for $0.99/month, 200 GB for $2.99/month, and 2 TB 
for $9.99/month. (See this Apple page for pricing by country.) 

If you need more storage: 

1.	 Go to > System Preferences > iCloud. 

2.	 Click Manage and then click Change Storage Plan. 

3.	 The Upgrade iCloud Storage window appears with your current plan 
highlighted. Click a plan that offers more storage to upgrade and 
then click Next. 
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New! Now you can share an upgraded iCloud storage plan with your 
family, see Use iCloud Family Sharing. 

4. Enter your Apple ID password at the prompt and then click Buy. 

If you decide later that you need less storage, go to the Upgrade iCloud 
Storage window and click the Downgrade Options button. iCloud tells 
you how to delete files, if you choose. 

Save a File to iCloud Drive 
For a new, unsaved document, choose File > Save (Command-S) or 
click the down arrow next to the file’s name in the title bar. Choose 
AppName — iCloud from the Where pop-up menu to save the file in 
the app’s iCloud Drive folder (Keynote, for example). 
Saving into the app’s folder will simplify opening the file from within 
that app. Or, choose iCloud Drive to save it at the root level of iCloud 
Drive. 

Note: iCloud Drive’s app folders (for Pages, iMovie, and so on) are
 

limited to files that the app can open.
 

File Size in iCloud Drive 
You can store any type of file in iCloud Drive, as long as its file size is 
less than 50 GB and you have enough storage. (For perspective, this 
time last year, the file size limit was 15 GB.) 

To check a file’s size, select it in the Finder and choose File > Get 

Info (Command-I). The file size appears in the Get Info window. If
 
you need more room for files, upgrade your iCloud storage plan.
 

Access iCloud Drive Files 
Here are a few techniques. 
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Mac 
To access your cloud-based files: 

•	 Go to iCloud.com in a web browser and click iCloud Drive. A list of 
files and folders appears; upload and download from here. 

•	 Open a new Finder window by choosing File > New Finder Window 
(Command-N). Click iCloud Drive in the Finder window’s sidebar 
(Figure 94). Drag and drop a file to move it to or from here. You’ll 
see a warning if you try to move a file off of iCloud Drive. To copy it 
instead, Option-drag the file. 

Figure 94: Click iCloud Drive in the sidebar to browse files and 
folders stored there. 

•	 In the Finder, choose Go > iCloud Drive (Command-Shift-I). 

Windows 
Use the latest iCloud for Windows app to see your iCloud Drive folder 
in the Windows File Explorer. 

iOS 
Depending on your set up, do one of the following: 

•	 If you’re using iOS 8 through 10, use the iCloud Drive app to browse 
and download files in your iCloud Drive folder. 
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•	 If you’re using iOS 11, launch the new Files app and tap the iCloud 
folder to access your files. 

•	 Open a file from within an iCloud Drive-compatible app—for 
example, Apple’s Keynote, if the file is in the Keynote folder on 
iCloud Drive. 

Turn Off iCloud Drive 
Decide you’d rather not use iCloud Drive? To make sure you can work 
with your documents offline, you will need to save copies of the ones 
you need to your Mac: 

•	 On your Mac, navigate to iCloud Drive in the Finder, select a file, 
and press Command-C to copy. Navigate to the location in the 
Finder where you want to save the copy, and press Command-V to 
paste. 

•	 Alternatively, select multiple files in the Finder by Shift-clicking 
them (for contiguous files) or Command-clicking them (for non-
contiguous files). Then, press Option while dragging and dropping 
them to another location. 

Once that’s done, on your Mac, go to System Preferences > iCloud and 
uncheck the iCloud Drive box. When you do, your Mac apps will no 
longer be able to access documents stored in iCloud. 

Accessing Files in a Pinch 
If you find yourself on a computer that hasn’t been upgraded since 
Mavericks—or that is running Windows—all is not lost. Go to 
iCloud.com, sign in, click iCloud Drive, and then use the web interface 
to upload or download files. (iCloud might ask you to rename 
or compress the file.) 
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New! Share Files Using iCloud Drive 

As of High Sierra, iCloud Drive lets you share files with other iCloud 
users, making it easier to collaborate without having to email different 
versions of a file back and forth. 

Start Sharing 
Share a file either of these ways: 

•	 From the Finder: If you’re in the Finder, Control-click a file in 
iCloud Drive and choose Share > Add People in the contextual 
menu. 

•	 From inside an app: If you have a document stored in iCloud 
Drive open, share by choosing File > Share > Add People. You’ll find 
the Share menu in most Apple apps, such as Text Edit and Preview. 

Then, follow these steps: 

1.	 In the dialog that appears, choose whether you’d like to send an 
invitation via Mail or Messages to collaborate. Although other share 
options, like AirDrop and Facebook, appear here, the Share button 
becomes inactive if you choose one of them. 

2.	 Click Share Options to fine-tune permissions. Your options include: 

‣	 Who Can Access: In this popup menu, choose either Only 
People You Invite or Anyone With the Link. 

‣	 Permission: In this popup menu, choose either Can Make 
Changes or View Only. 

Say, if you have a document you want a team to work on, you might 
choose Only People You Invite and Can Make Changes (Figure 
95). 
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Figure 95: Fine-tune permissions for a shared file by adjusting the 
Share Options popup menus. 

Tip: Permissions are on a per person basis, so you can let some 
people edit and not others. You’ll just need to invite people with 
different settings separately. 

3.	 Click the Share button. In the window that appears—a Mail message 
window or a Messages new message window, for instance—enter 
contact information and a note for the recipient(s). Click Send. 

The recipient receives your note with a link to the file. If they’re using 
High Sierra, when they click the link the file is added to their iCloud 
Drive and opens in its parent app. 

Tip: In our testing, sharing did not work if the intended recipient 
didn’t have an iCloud account. They sometimes got a message saying 
a file had been shared with them, but they encountered errors as 
they try to download it. 

It’s easy to tell which files you’ve shared. You’ll see them marked in the 
Finder (Figure 96). 
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Figure 96: Wondering which files you shared? Look for the words 
“Shared by Me” next to a file’s name in List view (View > As List). 

Make Changes (But Not at the Same Time) 
iCloud file sharing works best when you and another person need to 
work on the same file, but not at exactly the same time. 

If you and another person edit simultaneously, you won’t see changes 
happening in real-time like you would in Google Docs or Notes. In-
stead, the file will update every few moments as the document auto-
saves. You’ll get into trouble if two or more people make lots of 
changes at the same time. Eventually, you’ll see a warning telling you 
that modifications aren’t in sync and asking you to choose a version 
(Figure 97). 

Figure 97: If you try to work on a file simultaneously in an app that 
doesn’t support real-time editing, you will eventually get a warning 
like this and lose work. 

At this point you’re going to lose someone’s work; one choice will keep 
your last changes and the other will keep your partner’s...or other 
changes made by you. Often you won’t be able to tell at a glance from 
the thumbnail which version is which. The options are likely to have 
the same date stamp, too. 
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The moral of this story is: Don’t do that. Think of this feature as a way 
to share files easily, like you can with Dropbox, rather than a way to 
collaborate in real-time, like you can with Google’s Gsuite or Apple’s 
iWork apps. 

Change Sharing Options 
It’s easy to change sharing options after the fact, say when you think 
editing is done and want to change the group’s editing privileges to 
viewing only: 

1.	 Control-click the file in the Finder and choose Share > Show People 
in the contextual menu. Or, from within an app, choose Share > 
Show People. 

2.	 In the dialog that appears, click Share Options and then adjust the 
Who Can Access and Permission pop-up menus as you like. 

Stop Sharing 
To stop sharing a file, follow these steps: 

1.	 Control-click the file in the Finder and choose Share > Show People 
in the contextual menu. Or, from within an app, choose File > 
Share > Show People. 

2. Select the person’s name and then click the More icon that 
appears to the right. Choose Remove Access in the contextual menu. 

3. Click Done. 

People you’re sharing with do not receive a notification when you stop 
sharing, but the file vanishes from their iCloud Drive. 
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Manage Your Storage 
The multiple-terabyte hard drives of today may seem to have solved all 
our storage problems, but that doesn’t mean we can’t find ways to fill 
up every bit of the storage we have. And while desktop Macs have 
bulked up their storage space over the years, laptop Macs actually have 
less storage than models from six or seven years ago, as Apple has 
transitioned from mechanical hard drives to solid-state storage (the 
MacBook Air has at most 512 GB of flash storage). 

High Sierra’s new file system and space-saving improvements to apps 
like Mail will help with this problem. But you can also use built-in tools 
to help you wrangle your bytes. To find them, choose Apple  > About 
this Mac > Storage and click the Manage button (Figure 98). (Make 
sure Recommendations is selected in the list to the left.) 

Figure 98: Short on space? High Sierra comes with built-in tools to 
help you use your storage wisely. 

In this chapter, we’ll look at each of these options, starting with Store 
in iCloud and continuing with Optimize Storage, Empty Trash Auto-
matically, and Reduce Clutter. 
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Store in iCloud
 

Instead of keeping all your files on your drive, this option stores the 
contents of your Desktop, Documents, and Photos library in iCloud 
Drive. If storage is scarce, only recently opened files and low-resolu-
tion photos will stay on your Mac. The result is not only storage sav-
ings, but also the ability to access these items from any of your Macs or 
iOS devices that have iCloud Drive turned on and are signed in with 
the same Apple ID. 

Tip: You will probably need to upgrade your iCloud storage plan if
 
you decide to store your Desktop and Documents folders or your
 

photos in the Cloud.
 

Click the Store in iCloud button to see two checkboxes (Figure 99). I 
recommend that you read about what they do, below, before selecting 
either of them. With that done, you can select one or both and then 
click Store in iCloud. 

Figure 99: High Sierra gives you two options for storing more on 
iCloud and less on your drive. 
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Understanding the Desktop 
Before you turn on the Desktop and Documents option for iCloud 

storage, files stored on your Desktop appear both on the Finder’s 

backdrop and in your Desktop folder, nestled in your user’s Home
 

folder.
 

Desktop and Documents 

Warning! If you use Dropbox to sync items in your Desktop or 
Documents folders, do not add iCloud file syncing to the mix. See this 
Dropbox support article for details. 

Once you’ve turned on this feature, here’s where you can find your 
folders: 

•	 From a Finder window: In the Finder window sidebar, the 
Desktop and Documents folders appear under a new iCloud header 
(Figure 100). 

Figure 100: The Documents and Desktop folders appear under the 
iCloud header in the Finder window sidebar. 

•	 From the Finder: Choose Go > Desktop (Command-Shift-D) or 
Go > Documents (Command-Shift-O) 

•	 From the web: Go to iCloud.com, and sign in with your Apple ID 
and password. Click iCloud Drive. You see the Desktop and 
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Documents folders alongside app folders and any files you’ve stored 
directly in iCloud (Figure 101). 

Figure 101: Access your Desktop and Documents folder on the web 
through iCloud.com. 

•	 From your iOS device: If you’re running iOS 9 or 10, you can 
access your Mac’s Desktop and Documents folders by opening the 
iCloud Drive app on your device and tapping the folder you want. 
On an iOS 11 device, you’ll find the Desktop and Documents folders 
inside the new Files app. 

•	 From another Sierra or High Sierra Mac: According to Apple, 
when you add another Mac’s Desktop and Documents folders to the 
same iCloud account, they will appear as subfolders labeled with the 
Mac’s name. For instance, the second Mac’s Desktop folder will 
appear inside the primary Mac’s Desktop folder in iCloud Drive 
with the name Desktop - Mac Name. Likewise, the second Mac’s 
Documents folder will appear inside the primary Mac’s Documents 
folder in iCloud Drive with the name Documents - Mac Name. 

With that in mind, make sure to turn on this feature for your prima-
ry Mac first to avoid having to root through subfolders more than 
necessary. 

Various Take Control authors and editors saw inconsistent behavior 
from this feature. Sometimes the two Macs’ folders merge—we saw 

141
 



         
             

          

              
           

          
              

   

        

  
      

     
        
   

          
        

 

      
     

      
          

      
  

          
          

         

           
             

the contents of both Documents folders, for instance, when we 
clicked Documents in the Finder window sidebar. The effect is as if 
you have One Mac that you can reach from multiple devices. 

If you like that approach, you can set it up manually if you’ve ended 
up with subfolders for the second Mac. Move the contents of a 
subfolder into its parent Desktop or Documents folder and then 
delete the subfolder. (You can do this for either or both of the 
Desktop and Documents folders.) 

Tip: To learn the basics of using iCloud Drive, see Navigate iCloud 
Drive. 

Use with Caution 
If you’ve turned on Desktop and Documents folder syncing, open
 

System Preferences > iCloud and click Options next to iCloud Drive.
 
At the bottom of the dialog is the Optimize Mac Storage checkbox,
 
which Apple explains by saying:
 

The full contents of iCloud Drive will be stored on this Mac if you have 
enough space. Older Documents will be stored only in iCloud when 
space is needed. 

We haven’t heard about any problems with this since Sierra shipped. 
Still, Take Control cautions against selecting the Optimize Mac Stor-
age checkbox as it’s difficult to know how this setting will interact 
with your backup strategy. We can imagine a situation where you 
would end up with the only copy of an old but important document 
stored in iCloud, but not backed up locally. 

•	 From an older Mac: From a Mac that’s running 10.10 Yosemite 
or 10.11 El Capitan, you can access your High Sierra Mac’s Desktop 
and Documents folders through iCloud Drive (in the Finder window 
sidebar). 

Working with iCloud Files 
With iCloud storage enabled, if you add a file to your Documents 
folder—whether you do so in the Finder on your Mac, from the iCloud 
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website, or on an iOS device—it will appear everywhere in the Docu-
ments folder. 

Likewise, if you delete a file from the Documents folder, it disappears 
from the Documents folder in all views and on all devices—the same is 
true for the Desktop folder. 

If you’re worried about deleting a file from iCloud Drive (and, by 
association, all your devices) by accident, choose Finder > Preferences 
> Advanced and make sure that Show Warning before Removing from 
iCloud Drive is selected. 

If you plan to work on something away from an internet connection— 
say, on an airplane—you’ll want a local copy of the file. To see what’s 
stored where, click the Documents folder in the Finder window sidebar 
and look for a Download icon next to an item’s name. That indi-
cates that the file is located online only. Click the Download icon 
and you’ll see a progress bar as the file copies to your Mac’s drive. 

Turning off Desktop & Documents 
Go to System Preferences > iCloud, click the Options button next to 
iCloud Drive, and deselect the Desktop & Documents Folders 
checkbox. Click the Turn Off button to proceed. 

The contents of your Desktop and Documents folders remain in 
iCloud, so you’ll have to copy them back to your Mac’s normal (local) 
Desktop and Documents folders manually if you want them there. 

Note that if you turn the feature back on later, new folders will be 
created, leaving the old ones in place. For example, “Desktop - High 
Sierra iMac” and “Desktop - High Sierra iMac - 1” both will be in 
iCloud Drive inside the “Desktop” folder. This can get confusing. 
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Where’s That File? 
Unsure about where a file lives? In the Finder, choose View > Show 
Path Bar (or press Command-Option-P). Now, at the bottom of your 
Finder windows you see a visual representation of nested folders 
where the selected file is stored, known as its path (Figure 102). 

Figure 102: The Path Bar (outlined in red) shows you exactly where 
a file is. 

Double-click any part of the path bar—for instance the Pictures folder 
or Users folder—to jump to that location in the Finder. 

Photos 
The other option you see when you click the Store in iCloud button is 
Photos. This box gives you another way to turn on iCloud Photo Li-
brary, a feature that has been available since 2014. When you select it, 
Sierra uploads to iCloud full-resolution versions of all the photos and 
videos in your main (“System”) Photos library, defaulting to the Opti-
mize Mac Storage setting that generally keeps “optimized” (a.k.a. 
lower-resolution) versions on your drive. 

The benefits of this are two-fold: you not only save space on your Mac, 
but also can access your photos from all your Apple devices and from 
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the web. Changes made to a photo on one device reflect across all your
 
devices. 

Here’s where to find your photos: 

•	 From the Photos app on the Mac: When you open this app on 
the Mac, photos should appear as usual. 

•	 From the web: Go to iCloud.com, and sign in with your Apple ID 
and password. Click the Photos icon. You see photos organized by 
Moments and Albums. 

•	 From the Photos app in iOS: On a device running iOS 11, tap 
Settings > Photos, and then turn on the iCloud Photo Library 
switch. Now you should be able to see photos from your High Sierra 
Mac by opening the Photos app on your iOS device. 

•	 From the Apple TV: Sign in to a fourth-generation or newer 
Apple TV with the same iCloud Apple ID and look in the Photos 
app. 

This feature is ideal on a laptop or a secondary Mac where space is at a 
premium. If you have sufficient space, however, consider leaving the 
Optimize Mac Storage setting turned off for better performance. You 
will be able to see images on all your devices, but you will not have to 
wait for originals to download when you need them. 

To disable Optimize Mac Storage so that full-resolution photos appear 
on your Mac, open the Photos app and choose Photos > Preferences > 
iCloud. Select the iCloud Photo Library checkbox and then select the 
Download Originals to This Mac radio button. The Optimize Mac 
Storage button toggles off. 

If you ever decide you don’t want to store your photos in the Cloud at 
all, open the Photos app and choose Photos > Preferences > iCloud and 
deselect iCloud Photo Library (Figure 103). 
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Figure 103: Uncheck the iCloud Photo Library checkbox (outlined in 
red) to stop storing photos and videos in the cloud. 

Be aware that if you decide to turn this setting back on later, uploading 
your photos may take days. 

Ack—I Deleted the Wrong Photo! 
If you delete a photo on one of your devices in iCloud Photo Library, 
the photo is deleted everywhere. But Apple gives you another 
chance: you can recover it for 30 days. Look in the Recently Deleted 
album in Photos’ Albums list (Figure 104). 

Figure 104: Select an image in the Recently Deleted album and click 
the Recover button (circled). 

Every image in the album has an expiration date underneath it. Click 
the photo you want back, and then click the Recover button. 
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Optimize Storage
 

When you choose Apple  > About This Mac > Storage and click the 
Manage button, the second category is Optimize Storage. By default, 
this category has an Optimize button that you can click to see as many 
as two choices (Figure 105). Select one or both and then click Opti-
mize to start. (This category looks somewhat different if you’ve already 
turned on either of these optimization possibilities.) 

Figure 105: The Optimize Storage option gives you up to two
 
choices for saving space on your Mac.
 

Automatically Remove Watched iTunes 
Movies and TV shows 
The first checkbox under Optimize Storage is an easy win—few of us 
need those video files after the fact, and boy, do they take up loads of 
space! Leave this checkbox selected and choose Optimize and High 
Sierra updates your iTunes settings for you. 

To revert your iTunes settings later, open iTunes, choose iTunes > 
Preferences > Advanced, and deselect Automatically Delete Watched 
Movies and TV Shows. 

To download a video you’ve already watched (and that has therefore 
been deleted), go to iTunes and choose Movies or TV Shows from the 
Media Picker pop-up menu near the left of the navigation bar. Click the 
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Library button in the navigation bar and then click the Download 
icon above the show’s name (Figure 106). 

Figure 106: To watch a deleted TV show again, open iTunes, choose 
TV Shows from the Media Picker, click the Library button, and then 
click the Download icon above a show’s title. 

It can be difficult to see the Download icon on top of the video’s 
thumbnail image. To avoid that problem, choose View > View As > 
List. 

Download Only Recent Attachments 
The second choice under Optimize Storage affects your email 
attachments in the Mail app. Click the pop-up menu and choose either 
Download Only Recent Attachments or Don’t Automatically Download 
Attachments. 

You’ve long been able to choose to not download attachments auto-
matically in Mail; the ability to limit downloads to “recent” attach-
ments was new in Sierra. The significance of this Optimize Storage 
option, however, is that it saves you the trouble of choosing this down-
load setting manually for each of your email accounts in the Mail app. 

It’s a cinch to access an email attachment later, no matter what you 
choose (as long as you’re online). Just go to Mail and find the message 
in question. Hover your pointer over the line right below the message 
header to reveal a line of buttons (Figure 107), and then click the 
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arrow next to the Attachments icon. Choose the attachment you 
want and then choose where to save it in the dialog that appears. 

Figure 107: Use the Attachment icon here to download email 
attachments anytime. 

If You Don’t See an Email Option 
If you don’t see the option to optimize your email attachments, it’s 
probably because your email is already set up that way. To find out, 
open the Mail app and choose Mail > Preferences > Accounts > 
account-name > Account Information. 

There’s a pop-up menu for Download Attachments that can be set to 
All, Recent, or None. If that menu doesn’t have All chosen in it for 
any account, then you won’t see mention of Mail attachments in 
Optimize Storage. 

Empty Trash Automatically
 

It’s easy to dump files in the Trash and forgot all about them, but they 
add up, one by one, sometimes taking up loads of drive space. One 
small, but helpful, option for managing your Mac’s storage is the 
ability to automatically empty your Trash after 30 days. 

Choose Apple  > About This Mac > Storage and click the Manage 
button. Next to Empty Trash Automatically, click the Turn On button. 
Read the warning and then click Turn On. 

If you want to turn this setting off later, in the Finder, choose Finder > 
Preferences > Advanced and deselect the “Remove items from the 
Trash after 30 days” checkbox (Figure 108). 
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Figure 108: You can turn automatic Trash emptying off or on by 
choosing Finder > Preferences > Advanced. 

Reduce Clutter 


When running out of drive space, most people’s first impulse is to start 
deleting files. But which files? You can use a built-in feature to take a 
closer look at what’s hogging your disk. 

In the Finder, choose Apple  > About This Mac > Storage and click 
the Manage button. Then next to Reduce Clutter, click the Review Files 
button. 

You can filter the list that appears by clicking Large Files, Downloads, 
or File Browser. By default, each view is displayed with the biggest files 
on top. 

If you see a file you want to delete, in Large Files or Downloads view 
hover your pointer over it to show a Remove icon and a Reveal 
icon. Click the Reveal icon to see the file’s location in the Finder— 
always a good idea if you’re unsure whether this is a duplicate file or an 
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important file. Click the Remove icon and you’ll see a warning. Click 
the Remove button to proceed. In the File Browser view, Control-click 
or right click and choose Show In Finder to double-check a location. 

To delete multiple files at once, Shift-click to select consecutive files, 
Command-click to select non-contiguous files, or just press Command-
A to select them all. When you’ve got what you want, Control-click (or 
right-click) and choose Delete. 

A warning will ask “Remove X items from disk?” (It will also let you 
know how much storage you’ll be freeing, which can be quite 
cheering.) Click Remove to delete them all. They do not appear in the 
Trash—they’re gone. I’ve found this technique to be especially helpful 
in the Downloads view (Figure 109). 

Figure 109: The Reduce Clutter tool makes it easy to browse for 
superfluous big files. Here, I’ve selected most of my downloads. Next 
step, delete! 
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Use iCloud Family Sharing 
Family Sharing, an iCloud feature, makes it easy for up to six family 
members to share App store, iBooks, and iTunes purchases, as well as 
an Apple Music subscription, without having to share an Apple ID. 
Family purchases route through the family organizer, which means 
kids can spend money only when sanctioned (if you choose). As a 
bonus, when you use Family Sharing, a shared family calendar and 
family reminders list are generated automatically, which makes coordi-
nating the family schedule and to-do list extra convenient. You can 
also share a family photo album. 

High Sierra simplifies Family Sharing by organizing its options into a 
revamped Manage Family pane. It also lets family members share one 
upgraded iCloud storage account. 

Note: To use Family Sharing you must be running 10.10 Yosemite or 
later and iOS 8 or newer. You can be part of only one family at a 
time. To see new Family Sharing features, you must be running High 
Sierra. 

Set Up Family Sharing
 

You can set up Family Sharing on either a Mac or iOS device. After you 
do, it’s enabled on all devices that share the same iCloud account. Here 
are the steps to follow on your Mac: 

1.	 Go to System Preferences > iCloud and click Set Up Family. 

2.	 Read the details listed and then click Continue. 

3.	 Make sure that your Apple ID is listed if you want to be the family 
organizer. The organizer is the person in charge of inviting group 
members and paying for purchases. If so, click Continue. 
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4.	 Here’s one more chance to change your mind. If you want to make a 
different account the organizer, click Use a Different Account and 
enter the information. Click Continue. (The Use a Different Account 
button wasn’t working at publication time, but we hope it will be by 
the time you read this.) 

5.	 Choose whether to Share Your Purchases or Not Now and then click 
Continue (Figure 110). 

Figure 110: If you share your purchases, family members will be 
able to download them, too. 

If you do, family members will be able to download everything you 
buy from iTunes, iBooks, and the App Store. 

6.	 On the next screen, confirm your payment method. By default, 
purchases will be charged to the credit card you’ve associated with 
your Apple ID. Click Continue. 

7.	 If you want to share your location with family members, choose 
Share Your Location. This is handy if you’re wondering if a spouse 
has left work yet or you’re trying to pick up a teen at the mall. If you 
don’t want to share your location, choose Not Now. Click Continue. 

Tip: It’s possible to stop sharing your location temporarily—say,
 
when you’re picking up the surprise family pony. See New! Access 

Options in the Manage Family Pane next.
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8. The Manage Family dialog appears with the Family Members tab 
selected. You can now close the preference pane or add family 
members. 

The first time you add a family member, you’ll see an Add Family 
Member button. Click it to begin. To add more family members at any 
time, click the Add button at the bottom of the list. (To remove a 
family member, select their name in the list and click the Remove 
button.) 

How you proceed after that depends on the person’s age. 

Add an Adult Family Member 
To add an adult family member or a teen who already has an Apple ID, 
follow these steps: 

1.	 Select “Enter a family member’s name, email address, or Game 
Center nickname” and type their name or email address in the field. 

2.	 Follow the prompts as you enter your Apple ID password, and verify 
that you are the family organizer by typing in the security code for 
the credit card associated with your Apple account. 

3.	 Once you finish following the prompts, your Mac sends the person 
an invitation (typically in a notification and by email). If they 
accept, they’re added to the group. 

Unaccompanied Minors Not Allowed 
The Children’s Online Privacy Protection Act (COPPA), restricts com-
panies from collecting personal info from children under the age of
 
13. (For details, see this COPPA FAQ.) The upshot is that younger 
kids can only get an Apple ID—and use various Apple services—if 
they’re under parent supervision. In this case, that means they must 
be part of a family group. Unfortunately, this makes it difficult to 
remove a child under 13 from a group. See Transfer a Child to 
Another Family. 
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Add a Child Family Member 
The process is slightly different for kids who don’t have an Apple ID 
(and all children under the age of 13). 

Follow these steps: 

1.	 Fill in a bunch of information, including the child’s birthday, the 
iCloud email address you’d like them to have, whether to share the 
child’s location with family members, and a password you both can 
remember (Figure 111). 

Figure 111: Provide information to create an Apple ID for a child. 

Note: It may take quite a few tries before you find an iCloud user-
name that’s not already in use. When you finally do, you’ll see a 
warning that basically says “No take backs.” Click OK. 

2.	 Click Continue and follow the prompts as you read the Parent Priva-
cy Disclosure, enter your credit card security code, and set up 
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security questions—make the answers relevant to you, not to your 
child—so you can retrieve a lost password later. 

3.	 Agree to two more sets of terms and conditions before you finally 
see a summary of the child’s account. 

4.	 If you want your child to ask your approval for iTunes, App Store, 
and iBooks purchases, choose Ask to Buy. 

5.	 Click Done. Other members receive a notification when a new 
family member is added. 

Share the Responsibility 
If you want someone else to share the responsibility of approving 
purchases, you can set that up. Choose Apple  > System Prefer-
ences > iCloud and click the Manage Family button. Select another 
adult in the list and then select the Parent/Guardian checkbox. 

New! Access Options in the Manage 
Family Pane 

High Sierra makes it easier to adjust your Family Sharing settings by 
gathering and organizing them all in the revamped Manage Family 
pane. 

Choose Apple  > System Preferences > iCloud and click the Manage 
Family button. The resulting pane is organized into two views, Family 
Members and Apps & Services (buttons are at the top). 

Family Members 
The Family Members view is selected by default; here you’ll see a list of 
all people who belong to the group. Each family member’s status is 
summarized under their name, for instance, they might be labeled 
Adult or Organizer. If any are children, their age appears under their 
name. 
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Click a name to see details. These vary according to what role the 
person has in the family group, for instance, organizer (Figure 112). 

Figure 112: Click the Family Members button (A) to view a list of 
people in your family group (B). Select a name to see details and 
options for that person (C). A family organizer is shown here. 

Much of what you see here was available in Sierra’s Manage Family 
pane with the exception of the ability to change your family purchases 
account directly from the organizer’s listing. 

If the family member is child, you’ll see basics like their account name 
and what iCloud address they use to make purchases. Select the Ask to 
Buy checkbox if you want to approve of all purchases before they’re 
made (Figure 113). 
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Figure 113: Select a child’s name in the Family Members list and 
you’ll see their details, including the Ask To Buy option. 

Apps & Services 
Bigger changes live in the Apps & Services view. Click this to gain easy 
access to options previously buried elsewhere in the iCloud System 
Preference pane (or not available at all). Here are your choices: 

Purchase Sharing 
From here you can control aspects of the group’s purchases, if you’re 
the organizer (Figure 114). 
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Figure 114: Click the Apps & Services button and then select 
Purchase Sharing to see a range of options all conveniently gathered 
in one place. 

Click Change Account to use a different Apple ID. (You’ll need the 
password to confirm.) Check or uncheck the Share My Purchases with 
Family checkbox, depending on how altruistic you feel. Update your 
Shared Payment Method by clicking Edit. 

If you want to cut off your family members’ ability to make purchase 
and share past purchases, click the Stop Family Purchase Sharing 
button. You’ll see a warning (Figure 115). 
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Figure 115: High Sierra warns you before you cut off family mem-
bers’ access to shared media and apps. 

Browse Family Purchases 
Family sharing gives you access to purchases other family members 

have made. Here’s how to find and download them to your Mac:
 

✦	 App purchases: In the App Store, choose Store > Purchased.
 
Click the Purchased pop-up menu and select a family member’s 

name. Select an app in the list and click the Download button.
 

✦	 iBooks purchases: In iBooks, choose Store > Store Home and 

then click Purchased in the righthand list. In the pane that 

appears, you’ll see your name next to the word Purchased. Click
 

the arrow
 next to it and then choose a family member’s name. 
Click the Download icon next to one of their purchases to 
download it to your computer. 

✦	 iTunes purchases: To browse family iTunes purchases, choose
 

Account > Family Purchases. You’ll see your name next to the
 

word Purchased, click the arrow
 next to your name and choose 
a family member’s name to see their purchases. Click on any of 
these items to download. 

Apple Music 
Apple’s streaming service for music and video lets subscribers tap into 
a huge catalog of tunes, as well as videos like the Carpool Karaoke 
series. That means you can listen to almost any song you might think 
of on a whim, from Taylor Swift’s “Look What You Made Me Do” to 
“Summertime” by DJ Jazzy Jeff and The Fresh Prince to Dolly Parton’s 
“Jolene.” 
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Tip: At first glance, Apple Music appears to have a limited classical 
music selection, but that’s not the case. See this Macworld article by 
Kirk McElhearn for tips. 

Set Up an Apple Music Family Membership 
When you sign up for a Family Membership, all members of your
 

group get unlimited access to the service. To get started:
 

✦ Join for the first time: To join, open iTunes, select Music in the 
pop-up menu at the top-left corner, and then click For You at the 
top of the window. Click Get Started, and then click the Family 
Membership option. Enter your Apple ID password, if necessary, 
and agree to terms and conditions. Finally you’ll get the opportuni-
ty to choose the types of music you like, from Classical to R&B. 

✦ Change to Family Membership: If you chose an individual or 
student membership when you joined, you can change it to a 
family membership. In iTunes, select Account > View My Account 
and enter your password. Click Manage next to the word Subscrip-
tions and then click Apple Music Membership. Select Family and 
then click Done. 

If you’ve already set up Family Sharing and have an Apple Music 

family membership, add new people simply by inviting them to join
 

your family group.
 

High Sierra makes it easy to check on the status of your family’s Apple 
Music subscription. Click the Apps & Services button and then select 
Apple Music (Figure 116). If you don’t have a family membership, 
click “Start a Free Trial” to get one. Note that you don’t have to be the 
family organizer to share an Apple Music subscription with your 
group. 
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Figure 116: Click the Apps & Services button and then select Apple 
Music to see the status of an Apple Music account. If you have a 
Family Membership, all members can access the service. 

Tip: If you don’t want explicit music to turn up in your playlist, 
choose iTunes > Preferences > Restrictions. Next to Restrict, select 
the Music With Explicit Content checkbox. If the issue is a child’s Mac, 
you can restrict explicit music there using parental controls. See 
Create Managed Accounts for Kids and Novices. 

iCloud Storage 
All iCloud users get 5 GB of storage for free, but if family members 
start using iCloud in earnest to store files and digital media, they might 
find themselves running out of space. Luckily, members can now share 
an upgraded storage plan. 

To upgrade your storage plan, click iCloud Storage in the Apps & 
Services pane and then click the Change Storage Plan button. You’ll see 
your current plan as well as any available plans that offer more storage, 
along with their price. Only the 200 GB and 2 TB plans can be shared. 
Click the one you want and then click Next. Enter your Apple ID 
password and click Buy to finalize the purchase. 

To share a plan, click Start Sharing. You’ll see a list of family members 
next to how much storage they’re using (Figure 117). 
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Figure 117: Click the Apps & Services button and then select iCloud 
Storage to change storage plans or share with family members. 

Location Sharing 
Location sharing makes it easy to see where family members are, for 
example, by asking Siri (see Say Hello to Siri) or using the Find Friends 
widget in Notification Center (see Keep Current with Notification 
Center). It also makes it possible for family members to help find each 
other’s lost devices using Find My iPhone. 

When you create a Family Sharing group, members are asked if they’d 
like to share their location with each other. But what if you don’t want 
the twins to know where you are, say, when you’re out shopping for 
their birthday presents? Previously, if you wanted to adjust this 
setting, you had to go to members’ entries, one by one, in the Manage 
Family pane. Now, High Sierra gathers everyone’s names under 
Location Sharing. Check or uncheck the box by one or more members’ 
names to change settings (Figure 118). 
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Figure 118: Select Location Sharing to view a list of all family 
members and adjust who can see your location. 

Share Family Reminders
 

Family Sharing offers a simple solution to the dilemma of how best to 
share a to-do list with everyone in your household. When you create a 
Family Sharing group, a shared Family reminders list is added auto-
matically to the Reminders app (Figure 119). 

Figure 119: When you create a Family Sharing group, High Sierra 
automatically creates a Family reminders list for the group in the 
Reminders app. 

Everyone in your family can view and update the Family reminder list. 
Click on the list’s name in the Reminders sidebar to select it. (If you 
don’t see the sidebar, choose View > Show Sidebar.) 
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Family members can’t be removed unless they leave (or are kicked out 
of) the family group itself. You can’t delete the Family reminders list, 
but you can rename it. 

Tip: To learn more about using Apple’s Reminders and Calendar
 

apps, read my book Take Control of Calendar and Reminders.
 

Share a Family Calendar
 

It used to be a complicated affair to set up a shared family calendar, 
but Family Sharing makes it easy. When you sign in to Family Sharing, 
a shared Family calendar is added automatically to the Calendar app. 

All family members can add or delete events to this calendar. When 
they do, the family organizer gets a notification on their Mac and iOS 
devices. 

All family members are added to the Family calendar and can’t be 
removed from it while they belong to the family group. You can’t delete 
the Family calendar, but you can rename it. 

Tip: If you see more than one copy of the Family calendar and one
 

doesn’t have the Share Calendar
 button next to its name, hide
 

that one by unchecking the box next to it in the Calendars list.
 

Share a Family Photo Album
 

If your family members all love to take pictures, you might find your-
self emailing and messaging photos back and forth whenever you want 
to make a family photo book. 

Yes, there is an easier way. You can’t share Photos libraries across a 
network, but Family Sharing automatically creates a shared photo 
album in iCloud. Everyone in the group can view and edit the photos 
here, or include them in a project. 
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To see this album, click on Shared Albums in the Photos sidebar and 
then select the Family album. 

Tip: Show your appreciation by “Liking” a shared photo or adding a 
comment. To do this, double-click the image to see it full size in Edit 
mode and then click the speech bubble icon in the bottom-left corner. 
Choose Like or click Add a Comment. 

You can add images to the album in a number of ways. Here are two of 
them: 

•	 When you’re in the shared album: You’ll see the word Family 
in big letters and underneath the words “Add photos and 
videos” (Figure 120). 

Figure 120: To add an additional image to the shared family photo 
album, click “Add photos and videos” (circled). 

Click this, select an image, and click the Add button. Members 
receive a notification on their device(s) that new photos have been 
posted. Photos appear in family members’ Family photo album. 

•	 When you’re browsing photos: If you see an image you want to 
share, select it and click the Share button. Choose iCloud Photo 
Sharing, add a short note if you’d like, and then select your Family 
album (Figure 121). 
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Figure 121: To share an image with the group, select it, click the 
Share button, and then click iCloud Photo Sharing. Make sure to 
select the Family album (outlined in red). 

You can view, edit, and use these images in projects as if they were 
your own. 

Stop Family Sharing
 

The family organizer can stop Family Sharing by removing themselves 
from the group. (Things gets more complicated if there’s a family 
member under the age of 13. See Transfer a Child to Another Family.) 
Choose Apple  > System Preferences > iCloud. Click the Manage 
Family button, select your name in the list, and click the Remove 
button. 

When you stop Family Sharing, members keep anything paid for using 
the shared credit card, but lose access to other items: 

•	 Other family members’ purchases no longer appear in the Pur-
chased section of the iTunes Store, App Store, or iBooks Store. 

•	 Copy-protected music, movies, TV shows, books, and apps pur-
chased by one family member and downloaded by others become 
unavailable to anyone but the original purchaser. 
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•	 If an app was originally purchased by another user, all in-app 
purchases become unavailable. Former family members must 
purchase the app themselves. 

•	 You can no longer use Find My iPhone to find (former) family mem-
bers’ devices. 

Warning! After a group disbands, each member can join a new 
family. However, Apple limits you to joining only two families per 
year (presumably so you don’t hop from group to group just to share 
music). 

Transfer a Child to Another Family
 

If one of your family members is younger than 13, you’ll need to 
transfer them to another family group before you can stop Family 
Sharing (Figure 122). To learn why, see Unaccompanied Minors Not 
Allowed. 

Figure 122: Apple does not condone electronic orphaning. 

To do so, you need to ask another family organizer to invite them to 
their group. When they do, you’ll get a notification. Approve the move, 
and the child switches to the other group. 
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Avoid Problems with User 
Accounts 

One of my siblings (who will remain unnamed) used to come home 
every Christmas and “borrow” my mom’s computer. Without fail, he 
left behind a jumble of changed preferences, randomly installed apps, 
and disconnected cords that took hours to fix before my mom could 
use her computer again. Today, this source of family strife could have 
been easily avoided. The answer? User accounts (Figure 123). 

Figure 123: Use different types of user accounts to solve problems. 

Know Your Accounts
 

User accounts allow multiple people to have a custom experience on 
the same Mac—without altering each other’s settings or mixing up 
files. High Sierra lets you choose from several user account types. 

Separate accounts can keep people out of your stuff, make trou-
bleshooting easier, and (through the use of Parental Controls) help 
kids and novices navigate the computer. 
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Basic Types of User Accounts 
macOS offers the following main types of user accounts: 

✦	 Administrator: An administrator can add and manage users, 
change any of a Mac’s settings, install software for all users, and 
perform system-level tasks. 

✦	 Standard: A standard user can make changes—adding apps, 
adjusting settings—only to their own account. 

✦ Managed with Parental Controls: A managed account is set up 
by an administrator, who determines what apps and content this 
user can access. 

✦ Guest: A guest does not need a login password and gains tempo-
rary access to limited items on the Mac. 

Welcome Visitors to the Guest Account
 

When you first install and boot your Mac into High Sierra, the operat-
ing system automatically configures a guest account. Guests don’t need 
a password to log in, but the account has strict limits on what it allows. 

For example, guests cannot change user settings or computer settings. 
They also can’t log in remotely, even when remote login is turned on in 
the Sharing pane of System Preferences. High Sierra stores guest files 
in a temporary folder and then deletes those files when the person logs 
out. 

Because of this, the guest account is the place to steer visiting friends 
and relatives. It makes it easy for them to check their webmail or finish 
a quick paper in Google Docs—and leave no trace behind. 

iCloud Connections 
iCloud’s Find My Mac feature lets you track and lock down your Mac,
 
and even wipe its data, if it’s lost or stolen. For example, if someone
 

finds your Mac, logs in as a guest, and then uses Safari, iCloud uses 

Location Services to find the Mac.
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If you don’t see a guest account on your login screen, open System 
Preferences > Users & Groups. Click the lock icon and enter your 
administrator’s name and password. 

Click Guest User in the accounts list, and then select the Allow Guests 
to Log In to This Computer box and, if you choose, the Enable Parental 
Controls box (Figure 124). (We’ll talk about that next.) 

Figure 124: The Guest User account lets visitors use your computer 
and leave no trace behind. 

Create Managed Accounts for Kids and 
Novices 
A managed account can make using the computer easier. It can also 
keep users out of trouble by limiting what changes they can make to 
the system or which parts of the web they visit. To set it up: 
1.	 Open System Preferences > Parental Controls. If you’ve logged in 

with an administrator account and don’t yet have any managed 
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accounts, you’ll see a window that asks if you’d like to create one 
(Figure 125). 

Figure 125: Click Continue to start making your first account with 
parental controls. 

Note: If you already have one or more managed accounts, you’ll 
follow a slightly different process to create another account with 
parental controls. Click the lock icon in the lower-left corner of the 
pane, enter your administrator’s name and password, and click 
Unlock. Then, click the plus button to open. After that, the rest of 
your steps are similar to what we describe here. 

2.	 Type in the user’s name as well as a name for the account. (The 
latter becomes the name of the person’s user folder.) 

3.	 Choose the user’s age in the Age pop-up menu. This sets age restric-
tions, including those for the iTunes, iBooks, and App Stores (Fig-
ure 126). (You can tailor these later.) 

172
 



       
          

           
            

          
           
             
        

             
          
             

     

  

         

       

Figure 126: When you choose the user’s age, High Sierra automati-
cally sets up age restrictions, seen here for a user who is 4-years or 
older. 

What’s limited is determined by age—your choices are 4+, 9+, 12+, 
and 17+. For example, if you pick the 12+ setting, High Sierra allows 
music with explicit content, but sets the maximum movie rating to 
PG-13, TV shows to TV-PG, apps to 12+, and restricts books with 
explicit sexual content. It also allows access for this age group to the 
iTunes Store and iBooks Store, and to iTunes U. 

4.	 Enter a password in the Password field. (Click the key icon next to 
the field for suggestions.) Retype the password in the Verify field, 
and type a clue in the Password Hint field for the inevitable moment 
when the user forgets the password. 

5.	 Click Create User. 

6.	 If prompted, enter your administrator password and click Modify 
Configuration. 

The new account appears in the accounts list. 
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Administer from Afar 
Don’t want to leave the cozy spot on the couch you and your Mac-


Book share to change parental controls on the kids’ iMac across the
 

room? You can administer managed accounts from another Mac on
 

the local network. To set this up:
 

1. On the kids’ Mac, go to System Preferences > Parental Controls.
 
Click the lock icon in the lower-left corner. Enter your administra-
tor’s name and password, and click Unlock.
 

2. Click the gear icon and choose Allow Remote Setup. 

Now, on your MacBook: 

1. Go to System Preferences > Parental Controls. Click the lock,
 
enter your administrator’s name and password, and click Unlock.
 

2. Under Other Computers, select the name of the managed account. 
(Your computer and the one you want to manage must be on the 
same network for this feature to work.) 

3. Enter an administrator’s name and password for the kids’ iMac 

that hosts the managed account.
 

Now, you can change any of the account’s Parental Controls settings. 

You are now ready to customize the new managed account. In the 
Parental Controls pane, select the account to customize at the left. As 
of High Sierra, options include: Apps, Web, Stores, Time, Privacy, and 
Other. 

Most tools in the Parental Controls pane are self-explanatory. But here 
are a few you don’t want to overlook: 

•	 The Finder, simplified: Click the Other button to see the Use 
Simple Finder checkbox. This mode substantially reduces what the 
user can do in the Finder. Access to Spotlight disappears, and basic 
Finder actions are disabled. The Dock also changes. It contains only 
Finder, the Trash, and three folders—My Applications, Documents, 
and Shared (Figure 127). Simple Finder is so limited that it’s 
probably only a good choice for young children. 

174
 



         
  

          
          

         
   

          
      

          
       

          
      

      

          
           

            

            
        

         
           

 

            
             

           
         

Figure 127: The Simple Finder winnows down the Dock to only a 
handful of items. 

Tip: If you need to change something when you’re in the Simple 
Finder, choose Finder > Run Full Finder, and then enter your adminis-
trator name and password. When you’re done, choose Finder > 
Return to Simple Finder. 

A Little Less Simple Finder 
When the Simple Finder seems to be too simple, take a less restric-
tive approach. Create a managed account and use parental controls 

to set limits. Then, log in to the account and organize the Dock so
 

that only the apps and folders the user will use the most appear.
 

Log out, log back in to your administrator account, go to System
 

Preferences > Parental Control and select the managed account. In
 

the Other pane, select Prevent the Dock from Being Modified.
 

•	 Application limits: To winnow down the apps that a user can 
explore, click the Apps button and then select Limit Applications on 
this Mac. Specify the apps you want available in the Allowed Apps 
list. 

For instance, you might limit your 4th grader to Safari, Minecraft 
(have a heart), TextEdit, Calendar, Chess, Dictionary, iBooks, 
Preview, Reminders, and FaceTime (to talk with Grandma). To use 
something that’s not on the list, your child will need to ask for an 
administrator’s help. 

•	 Screen-time tools: The Time section is a gem if you want a no-
hassle way to limit screen time (Figure 128). Here you can set total 
time limits for the weekdays and weekends. You can also enforce 
bedtime by preventing access to the Mac between certain hours. 
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Figure 128: You don’t have to be the bad guy. Make the Mac en-
force your child’s screen-time limits. 

Tip: The occasional wily teenager may realize they can get around 
time limits by logging in using a Mac’s Guest account. In that case, 
one option is to go to System Preferences > Users & Groups, click the 
Lock icon and log in with your Administrator password. Then, 
uncheck the Allow Guests to Log In To This Computer box. (Can you 
tell I’ve learned from experience?) 
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Create a Troubleshooting Account
 

When your Mac misbehaves, it can be hard to tell whether the problem 
is specific to your user account or it affects the computer as a whole. 
Having a clean extra account that you use only when troubleshooting 
is a great way to isolate problems. You should create this account now, 
so that it’s ready and waiting if you ever need it. 

Leave this account set to High Sierra’s defaults. The goal here is to see 
whether a problem is related to a specific user’s settings or files (learn 
more at this Apple page). 

Adding the Account 
To create a fresh account: 

1. Go to System Preferences > Users & Groups. Click the lock icon 
and enter your administrator’s password. 

2. Click the plus button. In the dialog that opens, choose Adminis-
trator in the New Account pop-up menu. Type in a full name for the 
account, as well as an account name—say, Troubleshooting Account 
and trouble, respectively. 

3.	 Type a password in the Password field and then repeat it in the 
Verify field. In the Password Hint field, type in something that will 
help you remember the password that day you actually need to use 
this account. 

4. Finally, click Create User. 

The new account appears in the accounts list at the left. When you’re 
done, quit System Preferences. 
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Putting Your Troubleshooting Account to 
Use 
Log in with this account if: 

•	 You keep encountering a problem after you log in to your user 
account. 

•	 You aren’t sure whether a problem is limited to your user account or 
if it affects your whole Mac. 

Once you’ve logged in to the troubleshooting account, see whether you 
can reproduce the problem or not: 

•	 If the problem disappears in your troubleshooting account, then the 
issue is likely a bad preference file or login item in your main user 
account, so you can focus your troubleshooting there. 

•	 If the problem appears even in the troubleshooting account, move 
on with your troubleshooting, since you now know for sure that the 
problem is not limited to just your account—it’s a system-wide 
software or hardware problem. 

Find Your Preferences 
Want to trash a bad preferences file? User-specific preferences are
 

kept in the ~/Library folder (at the root level of your user folder).
 

In the Finder, hold down the Option key and choose Go > Library. 
(Library appears in the Go menu only when you hold down the Option 
Key.) 

Tip: No matter what happens when you try to reproduce the problem 
in your test account, Troubleshooting Your Mac: A Joe On Tech Guide 
has advice about how to further narrow the cause of your problem 
and find a solution. (A High Sierra version of Joe’s book is due out 
this fall.) 
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Troubleshoot Mac 
Problems 

Maybe the heartache begins with errors when you try to save or open a 
file. Or, you find yourself staring at an unchanging gray screen. High 
Sierra comes equipped with the tools you need to face everyday trou-
bleshooting problems. Better yet, the new macOS file system (if you 
have a Mac that’s converted to it) has been designed to make your Mac 
less likely to lose data in the event of a crash. Here’s the least you need 
to know. 

High Sierra Specific Issues 
Forewarned is forearmed: Look out for these issues with High Sierra. 

✦	 Boot Camp: Apple’s Boot Camp—which makes it easy for Mac 

users to install Windows on a separate partition on their hard 

drive—can’t read or write to Mac volumes that use High Sierra’s 

new file system. See this Apple support document.
 

✦ External drives: High Sierra Macs can read and write to USB 
devices formatted with the new file system, but Macs using OS X 
10.11 El Capitan or earlier can’t. High Sierra Macs will be able to 
read and write to external drives formatted with HFS+, the older 
file system. 

✦	 Microsoft Office: Microsoft will provide no support for Office for 
Mac 2011 in High Sierra as the program is being phased out. But 
even users of the more recent Office 2016 for Mac 15.35 are 
warned that Word, Excel, PowerPoint, Outlook, and OneNote may 
quit unexpectedly or lose functionality. Make sure to update to the 
newest version of Office 2016, which should be available soon 
after the final version of High Sierra is released. 
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Zap a Frozen App
 

Is your problem an endlessly spinning beach ball? Try these tricks 
first: 

•	 Force Quit: First see if the problem is limited to one app. Try to 
switch to another by clicking its Dock icon or pressing Command-
Tab to use the Application Switcher. 

If other apps respond, you’ll want to force the offending one to quit. 
Choose Apple  > Force Quit (or press Command-Option-Esc). 
Select the bad app in the list (Figure 129), and then click Force 
Quit. Often, an app behaves once relaunched. 

Figure 129: Stalled app? Press Command-Option-Esc, select the 
offender, and then click Force Quit (or in the case of the Finder, 
Relaunch). 

Another way to quit the currently active app is to press Command-
Shift-Option-Esc to skip the dialog and Force Quit it immediately. 

•	 Restart your Mac: If you can’t force-quit the app, or if the prob-
lem seems to be affecting more than one app, choose Apple  > 
Restart. If the Restart command fails, hold down the Command and 
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Control keys while pressing the Power button to force a restart (with 
a chance that the Mac will let you save unsaved work first). If that 
doesn’t work, press and hold your Mac’s Power button until the Mac 
shuts down (unfortunately, losing any unsaved work), and then 
press it again to start it up again. 

•	 Log in with your troubleshooting account: Still having 
trouble? Log out of your current account, if you are logged in, and 
then log in to your troubleshooting account to find out whether 
the problem is limited to your normal user account. (See Create a 
Troubleshooting Account, in the previous chapter, for details.) If it 
is, something in your user’s folder is likely the culprit, so you can 
start narrowing it down from there. 

When Your Mac Won’t Turn On 
Are you staring blankly at this chapter because you can’t even get 

your Mac to turn on? Try this:
 

✦	 Is your Mac plugged in? No, seriously. 

✦ Does the electrical outlet work? Plug in a lamp to test it. 

✦ Is your power cord damaged? Check for chew marks if you have a 
kitten, puppy, or other teething beastie. (If you have another 
power cable—or, for laptops, power adapter—try that.) 

✦ Did you recently install new RAM? Take it out and see if the Mac 
turns on without it. 

If your Mac still won’t start, take it to the Genius Bar. 

Solve Slowdowns
 

If force-quitting apps and restarting your Mac doesn’t fix a slowdown 
problem, you might need to do more: 

•	 Update your software: If the problem is a software bug, a soft-
ware update may help. Choose Apple  > App Store and click 
Updates to check for, and then install, new versions of software 
from the App Store—this includes any updates to macOS. (If you 
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don’t see an update you expect, select Store > Reload Page (or press 
Command-R) to refresh the view. Check vendor websites for apps 
you got elsewhere. 

•	 Free up disk space: If your disk is nearly full, your Mac may run 
slowly—and apps may even crash. High Sierra’s Reduce Clutter tool 
lets you drill down to find files that are hogging your megabytes 
(Figure 130). 

Figure 130: Short on disk space? Use High Sierra’s storage man-
agement tool to home in on large files you don’t need anymore. 

Warning: Before you use this tool to delete files that aren’t in an 
obvious place like your Downloads folder, check where they are using 
by clicking the Reveal icon. It’s also a good idea to have great 
backups before deleting any files willy-nilly. 

•	 Add RAM: High Sierra and your apps can use a lot of RAM; 
if everything is running slowly, and it’s not due to a full drive, you 
might need more. 

To see how much you have, choose Apple  > About This Mac and 
click Memory (Figure 131). (You won’t see a Memory button if it’s 
impossible to upgrade the Mac’s RAM, which is the case with 
Apple’s recent laptops and the 2014 iMac.) If it’s possible to add 
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more RAM, click Memory Upgrade Instructions. Or, see Crucial’s 
step-by-step guides. 

Figure 131: Choose Apple  > About This Mac and click Memory to 
see how much RAM you have and whether you can add more. 

Tame Troubled Startups
 

For problems at startup—say, your Mac gets stuck on the gray startup 
screen or you hear the boot up chime again and again, but your Mac 
doesn’t boot up—try these tricks first: 

•	 Unplug peripherals: Sometimes peripherals like keyboards, 
trackpads, webcams, or microphones (particularly those with wires) 
are to blame. Unplug everything and restart. 

If your Mac starts up without a problem, test peripherals one by 
one. If the evidence points to a device, check its cables, update its 
software, or contact the manufacturer for help. 

•	 Try Safe Mode: Some problems can be solved with Safe Mode. 
Restart your Mac and immediately press and hold the Shift key until 
you see the grey Apple logo. The startup process may take a while; 
once it’s done, the words “Safe Boot” should appear in red at the 
upper-right corner of the screen. 

High Sierra runs diagnostics and clean-up processes. (It also dis-
ables software that loads at startup and login.) If the problem goes 
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away, restart again normally. The problem is most likely due to 
third-party software (especially things bought outside the App 
Store) that was disabled in Safe Mode. Look for updates on the App 
Store or the company’s website. 

Do You Still Have AppleCare? 
Every Mac comes with a 1-year hardware warranty and 90 days of 
phone support. But you can buy more coverage with an AppleCare 
Protection Plan, which extends both your warranty coverage and 
phone-support eligibility to 3 years from your Mac’s original purchase 
date. 

See whether you still have coverage by choosing Apple  > About 
This Mac, and clicking Service. Click “Check my service and support 
coverage status.” An alert appears, telling you your serial number will 
be sent to Apple. Click Allow. 

Safari opens to a webpage where you must verify your serial number 
and enter a code, do so and you’ll jump to a page with your coverage 
details. 

Coverage or not, you can still take your Mac to your local Genius Bar. 
Just be prepared to pay for repairs if your Mac is out of warranty. 

Try Disk Utility’s First Aid
 

If none of the tricks so far work, turn to Disk Utility’s First Aid. Launch 
Disk Utility (in /Applications/Utilities), select your startup drive in 
the list on the left, click First Aid, and click Run. A dialog appears, 
warning that you will not be able to use your Mac while First Aid is 
running. Click Continue and First Aid gets to work. 

When Disk Utility finishes, select Show Details to see a report of what 
it did and then click Done (Figure 132). 
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Figure 132: Use High Sierra’s Disk Utility to repair your disk even if 
it’s the active startup volume. 

If Disk Utility repairs your drive—or can’t find problems to repair—but 
the problem still occurs, try reinstalling High Sierra using macOS 
Recovery (discussed next) or using a bootable installer disk. 

If Disk Utility can’t repair the drive: 

•	 You might need a better repair utility (see Joe Kissell’s Macworld 
article Do you need a third-party disk utility?). 

•	 You might need to reformat the drive and reinstall High Sierra 
using a bootable installer disk or macOS Recovery. (Make sure 
you’ve backed up your data first, and have a plan for restoring it!). 

•	 You might need to replace the drive and then restore your data from 
a Time Machine backup using macOS Recovery (or from another 
type of backup, during the first startup after reinstalling High 
Sierra). 

•	 It may be time to visit the Genius Bar. 
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Turn to macOS Recovery
 

When you install High Sierra, it creates a hidden partition (or updates 
the existing hidden partition) to help you in times of woe. Hold down 
Command-R at startup until the Apple logo appears to see this emer-
gency mode. 

macOS Recovery gives you four choices; here’s where to start and how 
to proceed. 

Get Help Online 
If you’re not sure what to do after reading the rest of this chapter, start 
here. 

First, make sure you’re connected to the internet. If you’re using 
Ethernet, you’re likely good to go. If you’re using Wi-Fi, make sure 
you’re connected by clicking the Wi-Fi icon in the top-right corner of 
the screen and choosing a network. Enter the network’s password, if 
necessary. 

Next, from the macOS Utilities window, choose Get Help Online and 
click Continue. Safari opens to a description of how to use macOS 
Recovery. For additional help, you can click the link to the Apple 
Support site, click the Mac category, and then browse help topics. 
Or, click the search icon and type a description of your problem to see 
if fixes turn up. You may also want to do a more general Google search. 

Repair with Disk Utility 
If you’re in Recovery mode because of disk problems, Disk Utility is the 
option you’ll choose first. Select it in the macOS Utilities window and 
click Continue. For more on using Disk Utility, flip back a page or so in 
this chapter to Try Disk Utility’s First Aid. 

Reinstall macOS 
If High Sierra itself is the problem, you’ll need to install it anew. You 
can do this without affecting your files and settings. 
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For this to work in macOS Recovery, you must be connected to the 
internet. Click the Wi-Fi icon in the top-right corner of the screen and 
choose a network. Enter the network’s password, if necessary. 

Select Reinstall macOS, and then click the Continue button. The High 
Sierra installer data—roughly 5 GB worth—downloads over the inter-
net from Apple’s servers; once the download is finished, installation 
proceeds. Be prepared for the download to take anywhere from 
20 minutes to several hours, depending on your connection; installa-
tion will then take another 15 to 30 minutes. 

In Case of Emergency: A Bootable Drive 
The High Sierra installer is nearly 5 GB in size, so it makes sense to
 

keep a local copy on an external drive. That way, if you need to
 

reinstall it, you don’t have to download it again. Having a bootable
 

copy can also be helpful in the event that your Mac doesn’t have the
 

invisible Recovery partition. See Roman Loyola’s Macworld article
 

How to make a bootable macOS High Sierra installer drive.
 

Restore from a Time Machine Backup 
Say the worst has happened and you must wipe your drive and start 
fresh (or install a new drive). If you’ve backed up your data using High 
Sierra’s Time Machine feature, you can restore your system—files, 
settings, and all—using the Restore from Time Machine option. 

If you have a complete Time Machine backup (see warning), and you 
want to wipe your drive clean and restore your backup to that drive, 
select Restore from Time Machine Backup and then click Continue. On 
the next screen, select your Time Machine drive, the particular backup 
you want to restore from, and the destination drive. 

Tip: If you have a bootable backup, it might be easier to boot from 
that and then restore your disk. 
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Warning! If you’ve used Time Machine’s exclusion list to leave out 
system files, you can’t restore your system from within macOS 
Recovery. Instead, reinstall macOS and use the Setup Assistant 
(during installation—preferred approach) or Migration Assistant (while 
logged in to an account; it’s in /Applications/Utilities) to transfer 
data from a partial Time Machine backup. 

Backup, Backup, Backup 
What does a good backup entail? Some basic elements include: 

✦ Any backup at all: Just connect an external drive or AirPort Time 
Capsule and turn on Apple’s Time Machine and you’re already 
ahead of most folks. This built-in backup tool makes it easy to 
regularly store multiple versions of your files in case of 
emergency. 

✦ Redundant backups: The next step is to make backup backups, 
so to speak. That way, if one fails or is corrupted, you’re not up a 
creek. 

✦ Offsite backups: One of the best redundant backups is an offsite 
backup, for instance through an online service like Backblaze. That 
way, if your house or office falls prey to natural disaster, you’re 
still covered. 

✦ A bootable backup: If you can’t afford a day of downtime after a 
disk crash, a bootable backup is a good idea, too. This is a com-
plete copy of your Mac’s startup volume, usually kept on an 
external drive. Plug it in, reboot, and get back to work. 

See Backing Up Your Mac: A Joe On Tech Guide to get started making 
your own strategy. Already in a fix? See When You Don’t Have a 
Backup. 

Erase and Reinstall High Sierra
 

If you’re sure that you don’t need a new drive, but you want to start 
from scratch, you can erase the disk and reinstall a fresh copy of High 
Sierra. (Make sure you’ve backed up your data and you know how to 
restore it!) 
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Boot into macOS Recovery, select Disk Utility, and click Continue. 

After the utility launches, select your startup drive’s name in the list on 
the left. Click the Erase button. In the Format pop-up menu, choose 
your file system—for instance, APFS if you have a solid state drive— 
rename your disk if you like, and click…(you’re sure, right?)… Erase. 

Once this process is done, go back to Reinstall macOS, earlier in this 
chapter, and follow the directions there—or, if you have a bootable 
installer disk available, now is the time to use it. 

Note: For more about macOS Recovery, see this support Apple 
article. 

When You Don’t Have a Backup 
Speaking hypothetically—because I know this will never, ever happen 
to you—what do you do if your drive is toast and you don’t have a 
backup? Time for damage control: 

✦ If you can, go to System Preferences > Network and write down 
your network settings. 

✦ Try to back up any of your important, irretrievable files—photos, 
documents, financial or work files—that aren’t already stored on 
iCloud Drive or a cloud-based file-sharing service like Dropbox. 
(You could, in fact, make copies to the Cloud, if you don’t have a 
flash drive or external drive.) 

✦	 If you use iCloud to share passwords, calendars, contacts, and the 
like among various Apple devices, you can now say a prayer of 
thanks to Steve Jobs. You don’t need to worry about this data. 

✦	 If you use Gmail, iCloud, or any other web-based email service, 
you don’t need to worry about your email messages and settings, 
either—unless you’ve chosen to save messages locally and delete 
them from the cloud. 
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About This Book 
Thank you for purchasing this Take Control book. We hope you find it 
both useful and enjoyable to read. We welcome your comments. 

Ebook Extras
 

You can access extras related to this ebook on the web. Once you’re 
on the ebook’s Take Control Extras page, you can: 

•	 Download any available new version of the ebook for free, or buy 
any subsequent edition at a discount. 

•	 Download various formats, including PDF, EPUB, and Mobipocket. 
(Learn about reading on mobile devices on our Device Advice page.) 

•	 Read the ebook’s blog. You may find new tips or information, as 
well as a link to an author interview. 

•	 Find out if we have any update plans for the ebook. 

If you bought this ebook from the Take Control website, it has been 
automatically added to your account, where you can download it in 
other formats and access any future updates. However, if you bought 
this ebook elsewhere, you can add it to your account manually: 

•	 If you already have a Take Control account, log in to your account, 
and then click the “access extras…” link above. 

•	 If you don’t have a Take Control account, first make one by follow-
ing the directions that appear when you click the “access extras…” 
link above. Then, once you are logged in to your new account, add 
your ebook by clicking the “access extras…” link a second time. 

Note: If you try these directions and find that your device is incom-
patible with the Take Control website, contact us. 
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as well as from venues such as Amazon and the iBooks Store. But it’s 
a better user experience and our authors earn more when you buy 
directly from us. Just saying… 

Our ebooks are available in three popular formats: PDF, EPUB, and 

the Kindle’s Mobipocket. All are DRM-free.
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ISBN: 978-1-947282-06-3
 
Copyright © 2017, Sawyer McFarland Editing. All rights reserved.
 

alt concepts inc. 4142 Adams Ave. #103-619, San Diego CA 92116, USA 

Why Take Control? We designed Take Control electronic books to help readers regain 
a measure of control in an oftentimes out-of-control universe. With Take Control, we also 
work to streamline the publication process so that information about quickly changing 
technical topics can be published while it’s still relevant and accurate. 

Our books are DRM-free: This ebook doesn’t use digital rights management in any 
way because DRM makes life harder for everyone. So we ask a favor of our readers. If you 
want to share your copy of this ebook with a friend, please do so as you would a physical 
book, meaning that if your friend uses it regularly, they should buy a copy. Your support 
makes it possible for future Take Control ebooks to hit the internet long before you’d find 
the same information in a printed book. Plus, if you buy the ebook, you’re entitled to any 
free updates that become available. 

Remember the trees! You have our permission to make a single print copy of this 
ebook for personal use, if you must. Please reference this page if a print service refuses 
to print the ebook for copyright reasons. 

Caveat lector: Although the author and alt concepts inc. have made a reasonable effort 
to ensure the accuracy of the information herein, they assume no responsibility for errors 
or omissions. The information in this book is distributed “As Is,” without warranty of any 
kind. Neither alt concepts inc. nor the author shall be liable to any person or entity for any 
special, indirect, incidental, or consequential damages, including without limitation lost 
revenues or lost profits, that may result (or that are alleged to result) from the use of these 
materials. In other words, use this information at your own risk. 

It’s just a name: Many of the designations in this ebook used to distinguish products 
and services are claimed as trademarks or service marks. Any trademarks, service marks, 
product names, or named features that appear in this title are assumed to be the property 
of their respective owners. All product names and services are used in an editorial fashion 
only, with no intention of infringement. No such use, or the use of any trade name, is 
meant to convey endorsement or other affiliation with this title. 

We aren’t Apple: This title is an independent publication and has not been authorized, 
sponsored, or otherwise approved by Apple Inc. Because of the nature of this title, it uses 
terms that are registered trademarks or service marks of Apple Inc. If you’re into that sort 
of thing, you can view a complete list of Apple Inc.’s registered trademarks and service 
marks. 
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