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What's all the fuss about Soundtrack Pro?
Apple's loop-based music composition application expands to become
a sophisticated sound sweetening, design and mixing tool.

By: Mark Spencer

 
When Apple announced Final Cut Studio at NAB earlier this year, the big buzz was all
around Final Cut Pro 5 - most notably its new multicam editing feature and support for
HDV. However, behind the big headlines there has been a growing swell of interest in
Apple's update to Soundtrack, dubbed Soundtrack Pro.

In this article we'll take a look at some of the most compelling new features of
Soundtrack Pro. And we'll discuss some examples of how you as a video editor might
use these new features in your day-to-day workflow.

What is the Soundtrack Pro?
Let's get something straight right up front. If you are familar with the original
Soundtrack application, you need to look at Soundtrack Pro with fresh eyes. This is no
simple upgrade with a few new features. The interface make look quite similar at first,
and it's certainly true that everything you could do in Soundtrack you can do in
Soundtrack Pro - but there is so much more packed into this application that it really
isn't the same animal anymore. Essentially, Apple has taken Soundtrack and added
elements of Logic Pro to create an audio post-production workhorse.

While the original Soundtrack was primarily a loop-based music application for creating
royalty-free soundtracks and original compositions, Soundtrack Pro is a full-featured
professional audio application that has been designed specifically for audio post-
production work on video and film projects. This means that in addition to composing
music and creating sound effects from a huge library of loops and one-shots, you can
use Soundtrack Pro's to clean up and repair problematic audio, apply a vast array of
effects in a non-destructive fashion, and build a sophisticated mix using an external
control surface. Tighly integrated into Final Cut Pro 5, I predict Soundtrack Pro will
become a video editor's best friend when it comes to repairing, sweetening and mixing
audio, composing music, and designing soundscapes and effects. Professional audio
engineers and sound designers should take a good hard look as well.

With that, let's dive in and take a look around.

Summary

Split Personality

New to Soundtrack Pro is the ability to work in two different kinds of projects. The key
is in understanding which type of project is suited to which type of task.
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Multi-track projects are similar to what you may be used to in the original Soundtrack.
You use multitrack projects to synchronize audio and video, build up mixes using loop-
based music, and automate changes to pan, level and effects over time. Multitrack
projects are also where you use Soundtrack Pro's sophsiticated Mixer, which we will
cover a little later.

Figure 1. A multitrack project.

Audio file projects are completely new to Soundtrack Pro. You use audio file projects to
edit the waveform of a specific audio clip, including eliminating pops and clicks or
background noise, adding ambient noise, and changing the nature of the audio by
adding different effects. You can make all these changes destructively or non-
destructively, as we shall see.
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Figure 2. An audio file project.

Multitrack projects and audio file projects have different icons and extensions so that
you can easily tell them apart.

Figure 3. Icons for a multitrack project and an audio file project. Note that I have unchecked the "hide file extension" checkbox in the
Get Info window for these icons so you can see the .stmp ("soundtrack pro multitrack project") and .stap ("soundtrack pro audio
project") extensions.

An Audio Project Example

Let's look at how a video editor might use a Soundtrack Pro audio project to fix some
audio coming from Final Cut Pro 5. This way we can also see one example of how
Soundtrack Pro and Final Cut Pro 5 are integrated to create an easy workflow.

Below is a screenshot of a Final Cut Pro 5 project. We have some audio that we'd like
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to clean up by reducing the background noise. To do so, select the clip and choose File
> Sent To > Soundtrack Pro Audio File Project.

Figure 4. To bring an audio clip from Final Cut Pro 5 into a Soundtrack Pro audio project, you use the new "Send To" command under
the File menu. 

You will be prompted to save the Soundtrack Pro audio project file, then Soundtrack
Pro will launch if it isn't already running, and the Waveform Editor is displayed.
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Figure 5. Soundtrack Pro with the audio project file open. Note the .stap file extension at the top of the window. Note also that the
video has been imported even though we only selected the audio clip in Final Cut Pro. How cool is that?

In this example, the interview was shot with two mics recording the audio: a lavaliere
mic was clipped to the shirt of the subject, and the on-camera mic recorded sound to
a separate channel. The top waveform is from the on-camera mic, which recorded
more background noise than the lavalier mic. Let's say that we'd like to use a mix of
both audio sources, but we'd like to reduce the background noise from the camera-
mounted mic. To do this, we drag the mouse over a section of the background noise
to select it. To select from just the top waveform, move the mouse up towards the top
of the screen until a little "L" appears, then make the selection.
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Figure 6. By moving the mouse to the top of the screen, a little "L" appears, indicating that we can make a selection on just the left
channel of a linked pair.

Now, select Process > Set Noise Print
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Figure 7. Telling Soundtrack Pro what noise sounds like.

Now that you've told Soundtrack Pro what the noise sounds like, you can choose
Reduce Noise from the same Process menu. Press the Play button in the dialog box
and drag the Noise Threshold slider while listening to find the optimal setting. You can
also check the Noise Only checkbox to find the point at which the voice starts to get
included with the noise that you are cutting out - in other words, if you go beyond this
point you are throwing out the baby with the bath water - so find this point and back
off a bit.
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Figure 8. Noise reduction is a trade-off between reducing noise and affecting the remaining sound you want to keep.

When you press Apply, you will see the noise level in the waveform magically shrink.

Figure 9. The waveform after Noise Reduction has been applied. Note the Reduce Noise action in the Actions list.

Save the project and switch back to the Final Cut Pro 5 project - you'll see that the
original audio clip has been replaced with the Soundtrack Pro audio project file
automatically.
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Figure 10. Back in FCP5, our Soundtrack Pro audio project file automatically replaces the original audio clip. Important: this clip no
longer references a media file on your drive - it references the Soundtrack Pro audio project file.

If you want to make further changes to the audio, it is a simple matter of control-
clicking on the new clip and selecting Open in Editor - the Waveform Editor opens in
Soundtrack Pro and you can process further.

Figure 11. To re-edit the audio file, control-click and select Open in Editor - because the clip is now a Soundtrack Pro audio project file,
Soundtrack Pro will launch.

You could use this same workflow to set an Ambient Noise Print rather than a Noise
Print - you could then easily cut out sections of dialog and replace them with ambient
noise.

Analyzing and Fixing Audio Problems

In addition to reducing ambient noise, Soundtrack Pro can fix a wide variety of audio
problems, such as removing clicks and pops, or getting rid of an annoying hum from
an overhead power line. It does this by first analyzing the audio to identify problem
areas, then lets you select what problems you would like to fix. All of this repair work
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is accomplished by first clicking on the Analysis button and selecting the type of
problem you would like Soundtrack Pro to look for.

Figure 12. Clicking the Analysis button brings up all the different types of analyses you can run on your audio. Select an analysis type,
click Analyze, and Soundtrack Pro identifies with red areas it believes are a match. 

Once you select an analysis type and click Analyze, Soundtrack Pro creates a list of
every section it has found and highlights them in the Waveform Editor. You can select
the ones you want to fix (they may not all actually be problem areas), or press Fix All.
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The Power of Actions

In our little example above, you may have noticed that when you applied the Reduce
Noise filter, it appeared in a list called Actions to the left of the waveform. Actions are
one of the most exciting and versatile new features of Soundtrack Pro. They allow you
to stack up various process and and effects applied to your audio in a completely non-
destructive manner. This means that any applied action can be turned off at any time
and you'll get back the audio without the action. In fact, actions can by reorganized,
bypassed, and deleted - and the underlying original audio file is still always available.
You can think of Actions as similar to creating a "pack" of filters on a video clip in
Final Cut Pro - you can add filters, turn them on and off, change their order, and you
never overwrite the original video file - you just create new render files.

Figure 13. As you add processes, they appear as actions in the actions list to the left of the waveform. It's a simple matter to turn them
on and off individually with the checkboxes, reorder them by dragging, or delete them.

Actions include over 50 effects plug-ins from Logic Pro, and their parameters are
controlled with graphical interfaces designed specifically for each action.
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Figure 14. An example of an effect interface. With all effects, you can play the audio clip while making adjustments, and you can bypass
the effect to hear the original audio and compare to the effected version.

When Audio Files get destructive

It is important to note that it is possible to edit your audio file destructively - that is,
once you make changes, the original audio file gets overwritten. You can do this from
directly in Soundtrack Pro or from other Pro applications like Final Cut Pro 5.

When working in a multitrack project, you can open any clip simply by double-clicking
on it. When you do, you are presented with a dialog giving you two options: you can
create a new audio project file, or you can simply edit the original file.

Figure 15. It's safest to choose the first option and create an audio project file to store all your changes - that way the underlying audio
file is always available, and you can change your mind at any time. But if you know you want to overwrite the original file, choose the
second option.

In Final Cut Pro 5, if you control-click on an audio clip (one that has NOT been
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replaced by a Soundtrack Pro audio project file) and select Open in Editor from the
menu, the clip will open in the Waveform Editor in Soundtrack Pro. Once you make
changes and save, the original audio file gets overwritten. To avoid this behavior,
select the clip in Final Cut Pro, and rather than control-clicking on it, select File >
Send To > Soundtrack Pro Audio File Project.

Spectrums and Samples

Two more features of audio projects of note (there are many, many more, but we only
have so much space!). First, in addition to the Waveform view, Soundtrack Pro
provides a Frequency Spectrum view that maps the frequency spectrum of the audio
on a vertical scale.

Figure 16. The default Waveform view. You can see how the audio level changes over time, but that's about it.

Figure 17. The Frequency Spectrum view. White areas indicate audio in that frequency range.
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The Frequence Spectrum view allows you to identify areas of significant frequency
change that aren't visible in a waveform, which only plots audio level changes and
values.

The second feature is the ability to edit all the way down to the individual sample level
by zooming in with the zoom tool and then redrawing the waveform with the sample
edit tool.

Figure 18. Making edits at the sample level.

Multitrack Projects: where it all comes together

Let's shift gears and discuss the features available when working with a multitrack
project in Soundtrack Pro. We'll use a real-world example to step briefly through a
typical workflow. Let's say that in Final Cut Pro 5, you have finished editing a video
that includes on-camera dialogue and some music. You've already cleaned up the
audio using a Soundtrack Pro audio project file as described above. Now, you want
acheive the following:

Add some effects to the dialog as a whole
Add in some more music
Add some sound effects
Create a balanced mix between the dialogue, music and sound effects.
Output separate dialogue, music, and sound effects tracks

Soundtrack Pro is able to handle all these audio post production tasks.

Final Cut Pro integration: multitrack projects

Once you have "picture lock" in Final Cut, simple select all the clips in the sequence
and choose File > Send To > Soundtrack Pro Multitrack Project.
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Figure 19. Sending a completed edit to Soundtrack Pro for sweeting, effects, and final mixing.

After choosing where to save the fiile, Soundtrack Pro launches a new multitrack
project with separate tracks for each track in FCP - and of course, the sync video is
included as well.
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Figure 20. The Final Cut Pro sequence gets imported as a multitrack project in Soundtrack Pro.

Track effects

While you can always double-click on a single clip to launch the Waveform Editor and
apply effects there, sometimes you want to apply an effect to an entire track. For
example, you may want to add some compression and equalization to your dialog. You
do this in a multitrack project by selecting the track(s) and then selecting the effect
you want from the Effects tab. Add the effect, and click the Advanced button to gain
access to the full set of controls.
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Figure 21. Adding effects to an entire track entails selecting the track, and then selecting the effect from the Effects tab.

Music composition

The primary strength of th original Soundtrack application was its ability to allow even
musical dunces like myself to build decent compositions. That feature is alive and well
in Soundtrack Pro. In fact, Soundtrack Pro includes over 5,000 loops to work with, all
tagged with searchable metadata to make it easier to find the instrument, mood, and
tempo you are looking for. Because Soundtrack Pro automatically forces loops to
match key and tempo, it's hard to build something that sounds bad (although I do
have some particular skill in this area :-)).

Figure 22. Building a simple composition - all loops automatically match tempo and key.
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Sound Effects

In addition to the ambient one-shots and other effects that were part of the original
Soundtrack, Soundtrack Pro has an entire new category of professional Foley effects -
no more smashing up your vegetables to get a good bone-breaking sound!

Figure 23. Finding just the right muddy walking sound.
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Creating the mix: using a control surface

One of the more exciting new features of Soundtrack Pro is it's ability to talk to a
physical mixer that supports the Mackie protocol - this means you can mix your tracks
in real time by using physical faders on the control surface rather than dragging the
virtual faders on the on-screen mixer. Not only is this much easier, you can control
multiple faders at the same time - something that you just can't do with one mouse!

Creating the mix: using the Mixer

The mixer allows you, through channel strips, outputs, and busses, to control how
your tracks get mixed, effected, and output. For example, you can send all the
dialogue tracks to one output, the music tracks to a second output, and the effects
tracks to a third output in order to control them separately.

Figure 24. The Soundtrack Pro mixer. Here we have created three outputs and named them "dialogue", "music", and "sfx". We then
mapped all the dialogue tracks (1 and 2) to dialogue, all the music tracks to music, and sound effects to sfx. This way we can duck all
the music tracks down during dialogue at the same time with one fader.

In addition to multiple outputs, you can create multiple busses. Busses are similar to
outputs in that you can map multiple tracks to a single bus and then control all those
track with a single bus fader. But buses can also be used to send effects to all the
tracks that are mapped to a bus. You do this by building an effects chain (a series of
effects), then add a "send" which will send that effects chain to a specific bus.



11/13/2006 09:53 AMWhat's all the fuss about Soundtrack Pro?

Page 20 of 22http://www.kenstone.net/fcp_homepage/soundtrack_pro_new_spencer.html

Figure 25. Buses are extremely flexible - one use is for applying effects to multiple tracks at the same time. Here, we created a new bus
and named it "music". In the Effects tab we've added a GraphicEQ effect and then added the send by clicking the Add Send button. By
choosing music from the drop-down in the Parameter column, the track(s) with this effect applied are sent to that bus.

In addition to multiple outputs (you can create up to 24), you can create multiple
busses. Busses are similar to outputs in that you can map multiple tracks to a single
bus and then control all those track with a single bus fader. But buses can also be
used to send effects to all the tracks that are mapped to a bus. You build build an
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effects chain (a series of effects), then add a "send" which will send that effects chain
to a specific bus.

Output

Note that unlike the roundtrip process for an audio project file, creating a Soundtrack
Pro multitrack project from Final Cut Pro is a one-way process. To bring the final mix
back into Final Cut Pro, you would export a either a mix or export selected tracks,
busses, or outputs. You can then import these files into Final Cut Pro and replace the
original audio.

Figure 26. Exporting a selected output that contains all of the music tracks.

Conclusion

We have just touched on some of the key new features in this article. Soundtrack Pro
is a giant leap forward from the original Soundtrack application. Its ease of use,
powerful feature set, and integration with Final Cut Pro 5 make it a natural extension
of your post-production workflow.

Mark Spencer is a freelance producer/editor, Apple-certified instructor for Final Cut
Pro, Final Cut Pro Advanced, and Motion, and the author of the Motion Visual
Quickstart Guide from Peachpit Press.
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